[Sammelthread] macOS 10.15 Catalina Sammelthread - Final

Barrac

Querina
Mitglied seit
16.12.15
Beiträge
187
Hmm, mein MacBook Pro 13“ aus 2019 zeigt dieses Verhalten nicht.
Der Fehler ist bei mir nicht aufgetreten.
 

Albert Eberli

Granny Smith
Mitglied seit
07.11.16
Beiträge
14
Ich beginne mit einem Clean Install von Catalina in einem separaten Volume und arbeite mich nun Schritt für Schritt durch eine manuelle Migration durch. Ziel: Mojave und Catalina parallel betreiben mit einer möglichst kleinen Redundanz and Daten und Programmen. Die Installation von Catalina in einem separaten Volume lief problemlos und es funktioniert auch nach wie vor alles, inklusive Bootcamp.

APFS Container .jpg

Als erstes ist mir der Automount des zweiten MacOS (Mojav, resp. Catalina) ein Dorn im Auge. Wie kann ich das im jeweiligen MacOS (Mojave ohne Catalina / Catalina ohne Mojave) einstellen. Da der Catalina Volume verschlüsselt ist, konnte ich den Automount unter Mojave verhindern, indem ich die Passworteingabe abgebrochen habe. Aber das ist auch keine Lösung auf Dauer und bei Catalina hab ich keine Ahnung.

In älteren Threads habe ich Hinweise auf /etc/fstab gefunden, dort steht aber drin:

IGNORE THIS FILE.
This file does nothing, contains no useful data, and might go away in
future releases. Do not depend on this file or its contents.
 
Zuletzt bearbeitet:

Marcel Bresink

Nathusius Taubenapfel
Mitglied seit
28.05.04
Beiträge
5.493
Wie kann ich das im jeweiligen MacOS (Mojave ohne Catalina / Catalina ohne Mojave) einstellen. Da der Catalina Volume verschlüsselt ist,
Normalerweise über die /etc/fstab. Bei verschlüsselten Volumes ist keine direkte Lösung möglich, da noch vor dem Mount (den man verhindern könnte) immer die Anfrage zur Entschlüsselung kommt. Man kann aber versuchen, den Schlüssel für die Entschlüsselung im Systemschlüsselbund zu hinterlegen, so dass die Partition automatisch entschlüsselt wird, und dann die entschlüsselten Volumes für den Automount in der /etc/fstab sperren.

In älteren Threads habe ich Hinweise auf /etc/fstab gefunden, dort steht aber drin:
Das ist so nicht gültig. Bist Du sicher, dass Du die Datei nicht mit der /etc/fstab.hd verwechselst?
 

Albert Eberli

Granny Smith
Mitglied seit
07.11.16
Beiträge
14
Normalerweise über die /etc/fstab. Bei verschlüsselten Volumes ist keine direkte Lösung möglich, da noch vor dem Mount (den man verhindern könnte) immer die Anfrage zur Entschlüsselung kommt. Man kann aber versuchen, den Schlüssel für die Entschlüsselung im Systemschlüsselbund zu hinterlegen, so dass die Partition automatisch entschlüsselt wird, und dann die entschlüsselten Volumes für den Automount in der /etc/fstab sperren.



Das ist so nicht gültig. Bist Du sicher, dass Du die Datei nicht mit der /etc/fstab.hd verwechselst?

Ja Du hast recht, das war /etc/fstab.hd

Das mit dem Passwort kann ich eliminieren, wenn ich dieses im Schlüsselbund speichere, dann ist da Ruhe.
Danach habe ich versucht herauszufinden, was denn in die /etc/fstab gehört, allerdings kann ich das nicht nachvollziehen:

2020-02-06_14-50-22.jpg

wenn ich bei mir die Devices Liste, dann sieht das folgendermassen aus:

2020-02-06_14-48-17.jpg

Wie müsste denn nun mein /etc/fstab aussehen ?
 

faraway

Morgenduft
Mitglied seit
14.10.11
Beiträge
169
Nach einiger Zeit habe ich Catalina mal wieder gestartet und den Update 10.15.3 installiert.

Zwei alte Probleme bestehen weiterhin:

1. An- und Ummelden an der Synology DS218 NAS mit unterschiedlichen Benutzern aus dem Finder ist fehlerhaft. Nachdem das System Nachts schlief ist auch der einzige Benutzer nicht mehr zu gebrauchen. Angeblich wird "home" nicht gefunden. Abmelden funktioniert aber auch nicht. Das ist seit 10.15.1 unverändert. Das ist ein Showstopper auf Catalina zu gehen.

2. Mail öffnet sich weiterhin durch gmail ausgelöst ca. alle Stunde. Das "seltsame" Verhalten von gmail ist bekannt und alle anderen Mail Clients können damit umgehen. Ich vermute Apple hat mal wieder ethische Gründe einen Google Server möglichst kundenunfreundlich zu behandeln.

Bin also wieder auf Mojave zurück zu dem die gleiche unbefriedigende Mail App gehört aber wenigstens wird die NAS richtig behandelt. Catalina hat weiterhin keine Funktionen die ich benötige.
 
Zuletzt bearbeitet:
  • Like
Wertungen: richard_it

ottomane

Gelber Richard
Mitglied seit
24.08.12
Beiträge
12.492
Beide Probleme habe ich unter Catalina nicht. Vielleicht hab ich ja Glück ;)
 

Marcel Bresink

Nathusius Taubenapfel
Mitglied seit
28.05.04
Beiträge
5.493
Wie müsste denn nun mein /etc/fstab aussehen ?
Du musst die UUID der einzelnen Volumes z.B. mit

diskutil apfs list

bestimmen. In die /etc/fstab müssen dann Einträge nach dem Muster

UUID=12345678-1234-1234-1234-12345678ABCD none apfs rw,noauto

zeilenweise eingetragen werden.
 

Reemo

Jakob Fischer
Mitglied seit
27.07.09
Beiträge
2.957
Eine kurze Frage für die Experementierfreudigen. Hat schon einer von euch Sidecar mit einem nicht unterstützten Gerät zum laufen gebracht?
Gibt dazu im Internet ja durchaus viele Tutorials, da Apple das ganze ja nur Softwareseitig blockiert. Einen technischen GRund gibts für das nicht-funktionieren kaum bzw. nicht.
 

pinarek

Idared
Mitglied seit
29.10.08
Beiträge
24
Eine kurze Frage für die Experementierfreudigen. Hat schon einer von euch Sidecar mit einem nicht unterstützten Gerät zum laufen gebracht?
Gibt dazu im Internet ja durchaus viele Tutorials, da Apple das ganze ja nur Softwareseitig blockiert. Einen technischen GRund gibts für das nicht-funktionieren kaum bzw. nicht.
Hier lies dir das mal durch: Sidecar auf älteren Mac's
 

Reemo

Jakob Fischer
Mitglied seit
27.07.09
Beiträge
2.957
@pinarek

Diese Möglichkeit wurde von Apple rausgepatcht. Apple verhindert aber die ANzeige von Sidecar bei "inkompatiblen" Geräten relativ simpel über eine Blacklist. Man muss nur diese Liste anpassen und schon kann man Sidecar auch bei älteren Geräten oder älteren iPads nutzen.
 
  • Like
Wertungen: pinarek

pinarek

Idared
Mitglied seit
29.10.08
Beiträge
24
@Reemo danke für die Hinweise. ICH selber nutze das nicht auf meinem alten MBP Baujahr 2021
 
Zuletzt bearbeitet:

Balkenende

Mecklenburger Königsapfel
Mitglied seit
12.06.09
Beiträge
9.822
So, heut wird gerade das Arbeitstier (iMac 2019) im Büro von Mojave auf Catalina gebracht.

Fängt mit der Installation an, zu erwartende Zeit 16 Minuten, schaun mer mal.

Da ich den Zugang auch noch auf dem MB Pro habe, ist unbeschadet von Backups per Server und sonstigem das Risiko gering, bin mal gespannt, was das Firmwareflashen bei mir so gestaltet. Ich tippe mal auf nichts.

Mein Book mit der ganzen Musik hingegen heilig, das bleibt bei Mojave, bis Music App und Mediathek über jeden Zweifel erhaben sind.
 

Balkenende

Mecklenburger Königsapfel
Mitglied seit
12.06.09
Beiträge
9.822
Naja, Du wurdest ja eindeutig als derjenige entlarvt, der nur Bildschirmschoner laufen lässt 🤪

Kannst Du damit inzwischen leben?

Edit

Fertig. Mal durchklicken.

Keine Lüfter gehört, Zeit passte mit knappen 15 Minuten.

Nervig Apple Music, wie erwartet soll ich mir Apple Music mal reinziehen. Das ist aber echt schon nervige Werbung.

Weg und einstellen, dass ich auf der Ebene der eigenen Mediathek bin. Apple Music ist rrrraus.

Sieht alles nicht so viel anders aus, halt nur getrennt.

Ansonsten scheint alles zu laufen.
 
Zuletzt bearbeitet:

marcozingel

deaktivierter Benutzer
Mitglied seit
07.12.05
Beiträge
9.960
Na nen bißchen mehr mache ich damit schon ;)
Oder ist das auch schon Framing ;)

Ich kann nur über unsere Macs im heimischen Umfeld berichten und da gibt es nichts Negatives und viel besser als unter macOS Mojave.
 
  • Like
Wertungen: pinarek

Balkenende

Mecklenburger Königsapfel
Mitglied seit
12.06.09
Beiträge
9.822
Spannend fand ich jetzt mal, Peripherie dazu anzustecken und den Mac im Idle laufen zu lassen.

Das ist ja bei nicht ganz wenigen, wie man beim Apple Forum sieht, der reproduzierbare ärgerliche Bug mit dem sofortigen Kernelchaos samt der obskuren Bad Item Meldung.

Nun ja, da es keine weiteren Monitore sind, habe ich bei Chip-Kartenleser und Diktiergerät nicht so viel erwartet. Aber man sollte solch ein massives Problem schon antesten, ob man betroffen ist.

Als erstes zumindest nicht. Alles unauffällig.

Mails über Exchange alles da.

Nächste Woche Arbeit damit.
 

marcozingel

deaktivierter Benutzer
Mitglied seit
07.12.05
Beiträge
9.960
Ich habe da auch (privat) insgesamt 10 Geräte dranhängen und nichts von den Endgeräten zickt da rum.
 
Zuletzt bearbeitet: