macOS Catalina auf nicht unterstützen Macs installieren

Dieses Thema im Forum "Magazin" wurde erstellt von Michael Reimann, 24.07.19.

  1. Michael Reimann

    Michael Reimann Geschäftsführung
    AT Administration

    Dabei seit:
    18.03.09
    Beiträge:
    5.491
    macOS Catalina auf nicht unterstützen Macs installieren
    [​IMG]


    Noch ist Apples neues Betriebssystem nicht erschienen und schon gibt es eine Möglichkeit, macOS Catalina auf nicht unterstützen Macs zu installieren. Wir zeigen euch, wie es geht.
    Wichtiger Hinweis


    Bitte die Anleitung zuerst vollständig durchlesen. Es gibt derzeit noch ein paar Probleme mit dem Patcher im Zusammenspiel mit der Beta von macOS Catalina. Bitte auch unseren Haftungsausschluss am Ende beachten.
    Nicht alle Geräte geeignet


    Wie auch beim Vorgänger macOS Mojave schneidet Apple alte Zöpfe ab und verhindert offiziell die Installation von macOS Catalina auf älteren Macs. In manchen Fällen sprechen technische Gründe für dieses Vorgehen. Nicht alle alten Geräte sind schnell genug, unterstützen die neuen Sicherheitsfunktionen und einige alte Grafikkarten sind nicht in der Lage mit Metal 2 umzugehen. Apples neuer Grafikschnittstelle.

    Es gibt aber immer noch Macs, die durchaus in der Lage wären, Catalina einigermaßen flüssig laufen zu lassen. Vielleicht nicht mit allen Top-Features aber ganz sicher wird etwas gehen. Auch bei Mojave war dies möglich. So konnten wir in einem Video zeigen, dass macOS Mojave mit wenig Aufwand auf einem 10 Jahre alten weißen MacBook läuft.

    Dieses Video findet ihr hier:


    Upgrade auf macOS Catalina


    Aber auch macOS Catalina macht da keine Ausnahme. Dank des Catalina Patchers von Collin alias Dosdude1 läuft die bereits ladbare Beta Version auf dem weißen Mac Book. Wir zeigen euch wie das Procedere vonstatten geht. Wir nehmen wieder unser 10 Jahre altes Gerät und versuchen damit ein Upgrade von Mojave auf Catalina.

    [​IMG]

    Für das Upgrade brauchen wir wieder einen USB-Stick und das Tool. Außerdem sollten wir wieder überprüfen, ob der Mac auf der Liste der unterstützten Geräte steht. Faustregel: Wenn ein Mac sich für Mojave patchen ließ, wird vermutlich auch Catalina laufen.

    In der Systeminformation findet man die Nummer des Macs.
    Diese Maschinen werden unterstützt:


    Early-2008 oder neuere Mac Pro, iMac, oder MacBook Pro:
    • MacPro3,1
    • MacPro4,1
    • MacPro5,1
    • iMac8,1
    • iMac9,1
    • iMac10,x
    • iMac11,x (Systeme mit AMD Radeon HD 5xxx und 6xxx GPUs werden aber quasi unbenutzbar mit Catalina.)
    • iMac12,x (Systeme mit AMD Radeon HD 5xxx und 6xxx GPUs werden aber quasi unbenutzbar mit Catalina.)
    • MacBookPro4,1
    • MacBookPro5,x
    • MacBookPro6,x
    • MacBookPro7,x
    • MacBookPro8,x

    Late-2008 oder neuere MacBook Airs oder Aluminium Unibody MacBooks:
    • MacBookAir2,1
    • MacBookAir3,x
    • MacBookAir4,x
    • MacBook5,1

    Early-2009 oder neuere Mac Mini oder weiße MacBooks:
    • Macmini3,1
    • Macmini4,1
    • Macmini5,x (Systeme mit AMD Radeon HD 6xxx GPUs werden aber quasi unbenutzbar mit Catalina.)
    • MacBook5,2
    • MacBook6,1
    • MacBook7,1

    Early-2008 oder neuere Xserve:
    • Xserve2,1
    • Xserve3,1

    Diese Maschinen werden NICHT unterstützt:


    2006-2007 Mac Pros, iMacs, MacBook Pros und Mac Minis:
    • MacPro1,1
    • MacPro2,1
    • iMac4,1
    • iMac5,x
    • iMac6,1
    • iMac7,1
    • MacBookPro1,1
    • MacBookPro2,1
    • MacBookPro3,1
    • Macmini1,1
    • Macmini2,1

    2006-2008 MacBooks:
    • MacBook1,1
    • MacBook2,1
    • MacBook3,1
    • MacBook4,1

    2008 MacBook Air (MacBookAir 1,1)

    Steht der Upzugradende Mac auf der Liste der unterstützten Macs kann es weitergehen. Alle anderen Macs sind in der Tat zu alt für macOS Catalina (und auch für den Vorgänger macOS Mojave.)
    Den Patch anwenden


    Nach dem Download des jeweils neuesten Tools von der Webseite von Dosdude1 kann der Stick vorbereitet werden. Die Erfahrung zeigt, dass USB-2.0-Sticks am Besten funktionieren. Bitte vor der Anwendung prüfen, ob der Mac den Stick erkennt. Das kann aber im Rahmen der Formatierung passieren. Wichtig: Der USB-Stick wird während dieser Prozedur gelöscht. Es sollte also am Besten ein neuer oder einer, dessen Inhalt nicht mehr gebraucht wird verwendet werden.

    Im Idealfall hat man für die Prozedur einen weiteren Mac zur Verfügung. Dieser kann auch mit Sierra, High Sierra oder Mojave laufen. Er wird zum Formatieren und Vorbereiten des Sticks und vielleicht auch zum Lesen dieser Anleitung benötigt.
    Bekannte Probleme


    Macs mit Grafikkarten, die nicht kompatibel zu Metal 2 sind, werden die Maps- und die Fotos-App nicht nutzen können.

    Die Kompatibilität der WLAN-Module ist ebenso wie beim Vorgänger. In unserer Anleitung zum Mojave-Patcher findet sich eine Liste.

    Auf Mac Books mit älteren Nvidia-Karten kann es zu Darstellungsfehlern im hellen Modus kommen. Im Darkmode treten diese nicht auf.
    Den Stick formatieren und Catalina laden


    Der Patch wird später über den USB-Stick oder direkt eingespielt. Der USB-Stick muss mit dem Festplattendienstprogramm als OS X Extended (Journaled) formatiert werden. Damit er bootfähig ist, muss er außerdem mit dem GUID Bootschema formatiert sein.

    [​IMG]

    Während oder nach der Formatierung kann durch das Patcher-Tool, das leider nur in englischer Sprache vorliegt, die aktuelle macOS-Catalina-Version geladen werden. Dazu muss das Tool mittels Rechtsklick und "Öffnen" gestartet werden, da es nicht mit einem Entwickler-Zertifikat signiert wurde.

    [​IMG]

    Der Patcher speichert die heruntergeladene Version von macOS standardmäßig im Verzeichnis Downloads. Es kann aber natürlich auch jedes andere Verzeichnis gewählt werden. Der Download kann je nach Verbindungsgeschwindigkeit etwas dauern. Es sollte auch mindestens 8 GB auf der Festplatte frei sein, damit die Installationsdateien geladen werden können.

    [​IMG]

    [​IMG]
    [​IMG]


    Direkt installieren


    In der neusten Version kann der Patcher auch ohne den Umweg über einen USB-Stick direkt auf dem Mac angewendet werden, auf dem er gestartet wurde. Damit spart man einiges an Zeit. Nach dem Download der neuesten macOS Version kann über einen Auswahldialog diese Methode gewählt werden. Wir empfehlen dies, wenn sichergestellt ist, dass der Mac auf der Liste der unterstützten Systeme steht.

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    Mit dem Klick auf "Akzeptieren" und der anschließenden Auswahl des Ziellaufwerkes geht es dann auch schon los.

    [​IMG]

    Auf einem Mac pro 3.1 hat diese Methode auf Anhieb leider nicht funktioniert. Es wurde nach dem Neustart das Symbol für ein nicht unterstütztes System angezeigt, Offenbar hat der Patch nicht oder falsch funktioniert. Hier gilt es also, auf eine neue Version des Patchers und/oder Catalina zu warten.
    Den USB-Stick mit dem Patch-Tool vorbereiten


    Nachdem Catalina herunter geladen wurde, kann alternativ der Stick vorbereitet werden. Das Tool kann den Stick entsprechend bootfähig machen und die nötige Software (Patches) inklusive dem Betriebssystem darauf platzieren. Ein einmal so eingerichteter Stick kann dann für mehrere Macs verwendet werden. Wir empfehlen diese Methode, wenn mehrere oder viele Macs auf macOS Catalina gebracht werden sollen.

    Das Tool erkennt normalerweise den abgeschlossenen Download des Betriebssystems und überprüft ihn anschließend auf Vollständigkeit. Ist alles soweit korrekt gelaufen kann der Stick vorbereitet werden. Dieser Vorgang kann ein paar Minuten (bis zu 20) dauern. Zum Vorbereiten muss im Tool unter "Volume" der vorhin formatierte Stick ausgewählt werden. In unserem Fall "CATPAT".

    [​IMG]

    [​IMG]

    In der neuen Version zeigt das Tool mit einem Balken den Fortschritt des Patchvorganges an. Erst wenn dieser Vorgang beendet ist, kann der Mac vom Stick gebootet werden.
    macOS Catalina Patcher vom Stick starten


    Dazu hält man beim Neustart die Alt/Options-Taste gedrückt und wählt im Bootmenü den Stick aus. Je nach Art des Sticks und des USB-Ports kann der Bootvorgang einige Minuten dauern. Ältere Macs haben noch USB-2.0-Ports von diesen dauert das Booten des Tools ca. zwei Minuten.

    [​IMG]

    Nach dem Booten gibt es die Möglichkeit, ein Update auf dem vorhandenen System durchzuführen. Das Fenster sieht dabei aus, wie bei einer normalen macOS-Installation.



    [​IMG]

    Dabei sollte natürlich die interne Festplatte ausgewählt werden. Nach der Installation startet der Mac automatisch neu. Zunächst von der internen Platte. Es wird also eine normale Installation durchgeführt.

    [​IMG]

    Nach dieser Installation muss der Mac allerdings erneut vom Stick gebootet werden, damit die Patches zum jeweiligen Mac-Modell angewendet werden können.

    Derzeit kommt es bei der Anwendung des Tools immer noch zu Problemen. Wir konnten auf dem weißen Mac Book kein Upgrade machen.

    Das kann einerseits am Tool selber liegen. Es ist aber durchaus auch möglich, dass es noch Probleme mit der Beta von macOS Catalina gibt. Wir empfehlen daher - wenn überhaupt - den Patch nur auf Geräten anzuwenden, die nicht im produktiven Einsatz sind.

    Ein Clean-Install, also eine Variante bei dem erst die interne Festplatte formatiert wurde, ließ sich aber mit der USB-Stick-Methode durchführen.

    [​IMG]
    Disclaimer/Haftungsausschluss


    An dieser Stelle sei noch der Hinweis angebracht, dass wir diese Anleitung ohne Gewähr veröffentlichen. Es ist nicht ausgeschlossen, dass sie Fehler enthält die eure Systeme unbrauchbar machen können. Auch ist nicht ausgeschlossen, dass Apple mit kommenden Versionen neue Sicherheitsmechanismen einführt, die die Nutzung auf diese Weise verhindern. In jeden Fall - wenn ihr plant den Patch auf produktiven Systemen einzusetzen - solltet ihr vor der Installation ein Backup anfertigen. Wir übernehmen keine Haftung für die Richtigkeit der Angaben und für eventuelle Schäden.

    Via: Dosdude1
     
    #1 Michael Reimann, 24.07.19
    Zuletzt bearbeitet: 25.07.19
    m4d-maNu, frostdiver und saw gefällt das.
  2. m4d-maNu

    m4d-maNu Golden Noble

    Dabei seit:
    29.01.10
    Beiträge:
    14.106
    Sehr gut, dann weiß ich nun ja was ich nächsten Sommer installieren kann auf meinen Macs.
     
  3. hakara

    hakara Morgenduft

    Dabei seit:
    20.09.17
    Beiträge:
    168
    Werde das gleich mal mit Mojave auf meinem 2011er MacBook Air probieren. Catalina dann als Final, je nachdem wie Mojave läuft.
     
  4. m4d-maNu

    m4d-maNu Golden Noble

    Dabei seit:
    29.01.10
    Beiträge:
    14.106
    Also ich habe auf meinen Late 10 MBA Mojave laufen und ich merke keine Unterschiede zu High Sierra bzgl. der Performance. Läuft immer noch sehr gut meine in die Jahre gekommenes MBA. Denke mit Catalina würde es ähnlich sein, da ich aber nicht ständig diese Update Prozedere machen will, werde ich mit der Catalina Installation vermutlich auf nächsten Sommer warten, dann wird Catalina sein letztes Minor Update erhalten und es kommt vereinzelt Sicherheitsupdates.
     
    #4 m4d-maNu, 25.07.19
    Zuletzt bearbeitet: 25.07.19
  5. FuAn

    FuAn Weisser Rosenapfel

    Dabei seit:
    18.07.12
    Beiträge:
    795
    Mit der aktuellen Developer Beta was vermutlich die nächste public Beta wird wäre ich vorsichtig. Die hat mein Test MBP total zerlegt und ist unbrauchbar langsam geworden...
     
  6. hakara

    hakara Morgenduft

    Dabei seit:
    20.09.17
    Beiträge:
    168
    Das klingt schon mal sehr gut, vielen Dank für dein Feedback.
     
  7. Thaddäus

    Thaddäus Golden Noble

    Dabei seit:
    27.03.08
    Beiträge:
    15.676
    Ich wäre GENERELL mit jeder Beta vorsichtig, und würde die nur dann installieren, wenn ich sie auch tatsächlich brauche.
     
  8. FuAn

    FuAn Weisser Rosenapfel

    Dabei seit:
    18.07.12
    Beiträge:
    795
    Deshalb isses bei mir auch auf nem Test gerät, manche können allerdings eben einfach nicht warten...
     
    Thaddäus gefällt das.
  9. Fantom53

    Fantom53 Pomme au Mors

    Dabei seit:
    20.02.10
    Beiträge:
    862
    Wenn ich das richtig gelesen habe, wird trotz des Patchers der Mac nicht wirklich benutzbar, da alle Anwendungen, die Metal benötigen nicht laufen werden. Darunter fällt ja Fotos und Karten zum Beispiel. Da ich Fotos für meine Bilder nutze, wird es das wohl gewesen sein mit dem MacBook 2010 und Catalina. Ich werde somit noch etwas länger auf Mojave bleiben.

    Oder gibt es schon Neuigkeiten bezüglich der Umgehung von Metal?
     
    Freddy K. gefällt das.
  10. Michael Reimann

    Michael Reimann Geschäftsführung
    AT Administration

    Dabei seit:
    18.03.09
    Beiträge:
    5.491
    Also auf einem Mac pro 2008 mit GTX 680 Karte geht vieles. Photomator zwei lässt sich nicht mehr installieren. Aber Fotos App und Karten geht.
     
  11. Fantom53

    Fantom53 Pomme au Mors

    Dabei seit:
    20.02.10
    Beiträge:
    862
    Das verstehe ich und finde ich gut, aber wie sieht es mit Grafikkarten at aus, die keine Metal Unterstützung besitzen?
     
  12. Michael Reimann

    Michael Reimann Geschäftsführung
    AT Administration

    Dabei seit:
    18.03.09
    Beiträge:
    5.491
    Da geht es in der Tat nicht. Also beide Apps stürzen ab. Das kann aber auch ein Problem der Beta sein. Ich bleibe dran.
     
  13. der Loeti

    der Loeti Alkmene

    Dabei seit:
    17.10.14
    Beiträge:
    34
    DANKE!

    Auf meinem 8.1 MBP late 2011 hat es problemlos funktioniert. Natürlich nicht ohne ein vorheriges Backup zu machen. Installation lief problemlos und das MBP rennt nach wie vor sehr, sehr geil.
     
  14. clipse

    clipse Weigelts Zinszahler (Rotfranch)

    Dabei seit:
    30.06.09
    Beiträge:
    248
    Hi Leute,
    Ich krieg den USB Stick einfach nicht hin.
    Ich formatiere den Stick entsprechend, lade das Tool und Catalina runter, aber der zeigt mir immer einen Fehler das er disk5 nicht dismounten konnte.
    Egal an welchem Mac ich das mache (auch da wo Catalina läuft).
    Einer ne Idee?

    danke
     
  15. der Loeti

    der Loeti Alkmene

    Dabei seit:
    17.10.14
    Beiträge:
    34
    Schon mal im Festplattendienstprogramm gewesen und dort Darstellung (oben links) auf "Alle Geräte einblenden" gestellt? Dann sollte es klappen. Daran bin ich auch schon einmal fast verzweifelt.