Installation von El Capitan auf dem MacPro 1.1/2.1

Dieses Thema im Forum "macOS & OS X" wurde erstellt von Hendrik Ruoff, 03.10.15.

  1. Hendrik Ruoff

    Hendrik Ruoff Welschisner

    Dabei seit:
    16.03.13
    Beiträge:
    11.677
    Installation OSX 10.11 auf dem MacPro 1.1/2.1 und anderen nicht supporteteten Mac's (MacBook 4.1)

    Dinge, die Sie benötigen!

    1. Einen 10.11 fähigen Mac der am besten über FW800 verfügt (dazu später mehr)
    2. Ein Mac Pro 1,1 oder 2,1 mit einer aktualisierten Grafikkarte (7300GT oder X1900XT gehen nicht)
    4. Das Aktuelle Boot.efi (dazu auch noch mehr)


    Erstellen des USB-Stick Installers

    Leider noch nicht möglich!!!! Anleitung folgt!

    Es gibt wohl einige Bootloader die hab ich selbst aber noch nicht getestet

    Installation über Möglichkeit 2. (zurzeit einzigste Möglichkeit)


    1. MacPro im TargetDisk Mode starten. Alternativ Festplatte ausbauen und Per USB anschließen
    2. Auf einem ElCapitan fähigen Mac das OSX 10.10 des Mac Pro booten und 10.11 über den AppStore Aktualisieren. (OSX 10.10 mit PikeJosefix ist Pflicht)
    3. Nachdem das Update Abschlossen ist muss man Händisch beide Boot.efi's wieder Tauschen!

    Diese befinden sich an folgenden Stellen:

    /usr/standalone/i386
    /System/Library/CoreServices/

    Achtung:

    Das Boot.efi in CoreServices ist auch wie in 10.10 verschlüsselt.... nach dem Tauschen einfach CMD+I Drücken und das Häkchen erneut setzten.

    Selbiges muss seit 10.11 auch auf der Recovery Partition wiederholt werden!!!! (FusionDrives oder RAID's funktionieren NICHT)

    Wie man die Recovery sichtbar macht:

    Code:
    defaults write com.apple.DiskUtility DUDebugMenuEnabled 1
    Wenn man den Code in's Terminal eingeben hat sollte unter dem Menü "Debüt" im Festplatten Dienstprogramm
    "Alle Partitionen Anzeigen" Verfügbar sein! Dort dann ein Haken setzten.

    Hat man dort nun auch die Efi's getauscht Repartiert man am besten noch die Zugriffsrechte!

    Nachdem sollte der MacPro hier gewohnt starten... und alle Daten sollten noch vorhanden sein!

    Weitere Informationen:

    Ich wiederhole mich nochmal!!

    64bit GPU wird benötigt ohne funktioniert es nicht!!! !

    Am besten eine Karte mit EFI kaufen oder bereits geflashte Windowskarten die's in der Bucht für mehr oder weniger kleines Geld gibt.

    Beispiele bereits getesteter Karten:

    ATI:
    HD 4870
    HD 5770
    HD 5850
    HD 5870

    Die HD 6000 Serie geht zwar auch lohnt sich im 1.1 aber nicht da dieser nie die volle Geschwindigkeit ausnutzen kann!!

    NVIDIA:

    GT 120
    GTX 285
    GeForce 8800GT
    GTX 680
    GTX 570


    Außerdem sind 2GB RAM minimum ich rate aber mindestens auf 4GB aufzurüsten!

    Neuere GPU's unterstützen auch das in 10.11 verfügbare Metal!!!



    iMessage und FaceTime Funktionieren wie gewohnt Kleider nicht......

    Bildschirmfoto 2015-10-03 um 00.18.13.png

    Für Fragen stehe ich gern zur Verfügung auch wenn ich nicht viel Zeit dafür habe....
     
    techjunk gefällt das.
  2. macaneon

    macaneon deaktivierter Benutzer

    Dabei seit:
    19.06.07
    Beiträge:
    1.753


    Zählt eine GTX 680 zu den "neueren" GPUs?
     
  3. Hendrik Ruoff

    Hendrik Ruoff Welschisner

    Dabei seit:
    16.03.13
    Beiträge:
    11.677
    Alle Mac Karten die seit 2012 verbaut wurden!!!

    Also müsste die GTX680 laufen.....
     
  4. Fridolin'

    Fridolin' Rheinischer Winterrambour

    Dabei seit:
    25.06.12
    Beiträge:
    924
    Ich gehe stark davon aus oder nicht? Die 600 Serie ist doch maximal 3 Jahre alt?
     
  5. macaneon

    macaneon deaktivierter Benutzer

    Dabei seit:
    19.06.07
    Beiträge:
    1.753

    Kein Grund mich anzuschreien. Die GTX 680 ist von Apple selbst nie im Mac Pro verbaut worden. Vielleicht als Mobil-Version in irgendeinem MacBook Pro oder Mac Mini… Wenn das auch zählt, tut's mir leid, denn das hab ich nicht alles nachgeschaut.

    Release war Anfang 2012, ja. Danke für den Hinweis. Heutzutage ist es eher ungewöhnlich, dass ein dreijähriges Bauteil noch zu den "neueren" gehört. Aber gut: Mir soll es in diesem Fall sehr recht sein.
     
  6. Hendrik Ruoff

    Hendrik Ruoff Welschisner

    Dabei seit:
    16.03.13
    Beiträge:
    11.677
    :D Sorry das sollte eigentlich als Feststellung gemeint sein....
     
  7. techjunk

    techjunk Jonagold

    Dabei seit:
    05.09.15
    Beiträge:
    20
    iMessage und Facetime funktionieren bei mir
    OS X 10.11 beta 8 (15A279b)
     
  8. Hendrik Ruoff

    Hendrik Ruoff Welschisner

    Dabei seit:
    16.03.13
    Beiträge:
    11.677
    Ja dann hast du es aber sicherlich wie früher möglich über den Support "freischalten" lassen oder?
     
  9. techjunk

    techjunk Jonagold

    Dabei seit:
    05.09.15
    Beiträge:
    20
    Ne, hab ich nicht. Ich hab die Installation über mein Yosemite drübergebügelt.

    Als ich vorhin diese Beiträge hier gesehen habe, musste ich es direkt mal ausprobieren und habe "Nachrichten" über spotlight geöffnet.
    brim ersten Versuch wurde die Eingabe meine appleID ignoriert. Ich habe das Program trotzdem öffnen lassen und unter accounts die Daten erneut eingegeben...
    Hat dann umgehend geklappt.
     

    Anhänge:

  10. techjunk

    techjunk Jonagold

    Dabei seit:
    05.09.15
    Beiträge:
    20
    Also ich hab es natürlich auch getestet mit Nachrichten an mich selbst und an meine Frau und es ging problemlos
     
  11. Hendrik Ruoff

    Hendrik Ruoff Welschisner

    Dabei seit:
    16.03.13
    Beiträge:
    11.677
    Na dann ist ja alles gut...
     
  12. techjunk

    techjunk Jonagold

    Dabei seit:
    05.09.15
    Beiträge:
    20
    warum es funktioniert bzw. bri anderen nicht kann ich nicht genau sagen. Ich habe nichts besonderes unternommen damit es klappt -sorry
     
  13. Hendrik Ruoff

    Hendrik Ruoff Welschisner

    Dabei seit:
    16.03.13
    Beiträge:
    11.677
    Ja ich weiß jetzt das es funktioniert.
     
  14. BoscoMac

    BoscoMac Golden Delicious

    Dabei seit:
    17.10.14
    Beiträge:
    9
    Ich habe alles so gemacht wie beschrieben, hätte ich bei den anderen OS X Versionen auch schon gemacht. Nun habe ich das Problem das der MacPro nicht bootet. Hier das Bild mit der Fehlermeldung.
    Habe alles efi's getauscht wie beschreiben. Bin alles mehrfach durchgegangen. Auch habe ich als es nicht klappte noch mal gemacht, leider ohne Erfolg.
    Wo ist der Fehler? ImageUploadedByApfeltalk1443907905.698599.jpg
     
  15. BoscoMac

    BoscoMac Golden Delicious

    Dabei seit:
    17.10.14
    Beiträge:
    9
    Kleine Ergänzung:
    Wenn ich über die alt Taste im recovery Modus boote geht's. Aber das normale System geht nicht.
     
  16. techjunk

    techjunk Jonagold

    Dabei seit:
    05.09.15
    Beiträge:
    20
    Hendrik hat die EFI's gepostet.
    Ich habe nach der Installation von El Capitan die EFI's & Kernel ersetzt....

    Ich weiß nicht ob es daran liegt aber den Fehlerbildschirm hatte ich bei den ersten Versuchen Yosemite zu installieren.

    EDIT: ich hab die Dateien mal zusammengefasst und neu gepackt.
    Versuch mal die Dateien auf dem MP zu überschreiben.
    Ich hab die Dateien mit LTE hochgeladen weil mein DSL streikt.
     

    Anhänge:

    #16 techjunk, 03.10.15
    Zuletzt bearbeitet: 04.10.15
  17. BoscoMac

    BoscoMac Golden Delicious

    Dabei seit:
    17.10.14
    Beiträge:
    9
    Ich kann nichts finden, auf der 6. Seite ist ein Link aber die Daten sind nicht mehr vorhanden.
     
  18. techjunk

    techjunk Jonagold

    Dabei seit:
    05.09.15
    Beiträge:
    20
    .
     
    #18 techjunk, 04.10.15
    Zuletzt bearbeitet: 04.10.15
  19. BoscoMac

    BoscoMac Golden Delicious

    Dabei seit:
    17.10.14
    Beiträge:
    9
    Vielleicht hat Hendrik noch eine Idee?
     
  20. BoscoMac

    BoscoMac Golden Delicious

    Dabei seit:
    17.10.14
    Beiträge:
    9
    Danke für die Dateien, hat leider auch nicht geholfen. Der Fehler kommt immer noch.