1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Ich kann den Papierkorb nicht entleeren (Dateien geschützt)

Dieses Thema im Forum "macOS & OS X" wurde erstellt von JohnnyAppleseed, 21.12.07.

  1. JohnnyAppleseed

    JohnnyAppleseed Schmalzprinz

    Dabei seit:
    11.09.07
    Beiträge:
    3.561
    Hallo,



    ich kann meinen Papierkorb aufgrund geschützter Dateien nicht entleeren und bekomme folgende Meldung:

    Bild 1.png

    Wenn ich nun aber beim entleeren die Wahltaste gedrückt halte, überrascht mich die gleiche Meldung wieder!

    Es befinden sich 3917 Objekte im Papierkorb, insgesamt 647,7 MB. Die vielen Dateien ergeben sich aus einem Windowsprogramm (Delphi).

    Ich hoffe mir kann hier jemand weiterhelfen, wie ich endlich diesen Müll löschen kann o_O



    Schönen Tag noch!
     
    #1 JohnnyAppleseed, 21.12.07
    Zuletzt bearbeitet: 02.05.08
  2. gucadee

    gucadee Strauwalds neue Goldparmäne

    Dabei seit:
    14.08.07
    Beiträge:
    638
    Hatte mal das gleiche Problem. Meine Lösung ist vermutlich nicht die einfachste/logischste,
    hat bei mir aber funktioniert.

    - Das betreffende Objekt aus dem Papierkorb in einen normalen Ordner verschieben
    - Dort über Tasten CMD+i (oder Rechtsklick > "Informationen") den Schutz aufheben
    (das Häkchen bei "geschützt" rausnehmen)
    - Dann wieder löschen
    - Papierkorb leeren
     
  3. apfelbutzen

    apfelbutzen Pferdeapfel

    Dabei seit:
    07.10.06
    Beiträge:
    78
    Hi,

    Löschen des Papierkorbs mit Adminrechten auch unmöglich? Ansonsten im Papierkorb die entsprechende Datei markieren, mit Apfel + i die Informationen anzeigen lassen. Wenn unter "Allgemeines" bei "Geschützt" ein Häkchen ist, selbiges entfernen und nochmals löschen probieren. Geht allerdings auch nur, wenn du Schreib-/Leserechte hast.

    Edit: Da war einer knapp schneller ;)
     
  4. BigB

    BigB Angelner Borsdorfer

    Dabei seit:
    26.08.06
    Beiträge:
    619
    Die Änderungen kann man auch direkt machen, wenn die Dateien schon im Papierkorb liegen.
    Einfach Apfel+i, wie gucadee geschrieben hat.

    Hatte das gleiche Problem vor Kurzem und habe auch keine bessere Lösung gefunden; Ist natürlich ärgerlich bei X-Tausend Objekten.

    Gruß
    Björn
     
  5. proteus

    proteus Langelandapfel

    Dabei seit:
    23.10.05
    Beiträge:
    2.671
    Ich empfehle das Tool mainmenu oder aber butler unseres geschätzten Peter Mauer.
    Damit kann man den Papierkorb zwangsweise entleeren - neben zahlreichen anderen sinnvollen Funktionen.
     
    JohnnyAppleseed gefällt das.
  6. lisemie

    lisemie Riesenboiken

    Dabei seit:
    27.09.06
    Beiträge:
    293
    Vielleicht ist in diesem Thread was für Dich dabei?

    Grüße, lisemie
     
  7. JohnnyAppleseed

    JohnnyAppleseed Schmalzprinz

    Dabei seit:
    11.09.07
    Beiträge:
    3.561
    Ok, die „Schützung“ konnte ich nicht im Papierkorb aufheben, in Butler hab ich die genaue Funktion nicht gefunden. Außerdem kann ich die Dateien nicht verschieben, sondern nur kopieren, das bringt mir ja auch nicht viel, wenn ich die Kopien verändere :(


    EDIT:

    MainMenu hat zwar alles gelöscht, aber nicht den delphi-Ordner. Dadrin sind geschützte Dateien, die ich nicht „entschützen“ kann :(
     
    #7 JohnnyAppleseed, 21.12.07
    Zuletzt bearbeitet: 21.12.07
  8. proteus

    proteus Langelandapfel

    Dabei seit:
    23.10.05
    Beiträge:
    2.671
    Dann nimm MainMenu- Option "Finder" Papierkorb zwangsweise entleeren
     
  9. BigB

    BigB Angelner Borsdorfer

    Dabei seit:
    26.08.06
    Beiträge:
    619
    Ich habs noch mal grad mit MainMenu getestet; Funktioniert bestens.
    Einfach oben auf dem Plus unter "Andere Aufgaben" "Papierkorb sicher entleeren" wählen und das Programm erledigt den Rest.

    Gruß
    Björn
     
  10. JohnnyAppleseed

    JohnnyAppleseed Schmalzprinz

    Dabei seit:
    11.09.07
    Beiträge:
    3.561
    Bewirkt auch nichts :(
     
  11. lisemie

    lisemie Riesenboiken

    Dabei seit:
    27.09.06
    Beiträge:
    293
    Manchmal tuts auch ein simpler Neustart.

    Grüße, lisemie
     
  12. BigB

    BigB Angelner Borsdorfer

    Dabei seit:
    26.08.06
    Beiträge:
    619
    Auch nicht, wenn du den Papierkorb zwangsweise entleeren lässt, wie es proteus geschrieben hat?
    Bei meinen geschützten Windows-Dateien hat das eben nämlich problemlos geklappt.

    Vielleicht sonst mal Rechte reparieren lassen und nen Neustart machen. :) Danach noch mal versuchen.

    Gruß
    Björn
     
    JohnnyAppleseed gefällt das.
  13. JohnnyAppleseed

    JohnnyAppleseed Schmalzprinz

    Dabei seit:
    11.09.07
    Beiträge:
    3.561
    Ne, hilft alles nichts, habe jetzt Papierkorb zwangsweise und sicher in MainMenu geleert, Zugriffsrechte im FPDP repariert und mehrfach neu gestartet und trotzdem macht sich dieser Ordner noch im Papierkorb breit.
     
  14. Giftmischer

    Giftmischer Seidenapfel

    Dabei seit:
    30.03.07
    Beiträge:
    1.341
    Schau doch mal hier.

    Klick!
     
  15. JohnnyAppleseed

    JohnnyAppleseed Schmalzprinz

    Dabei seit:
    11.09.07
    Beiträge:
    3.561
    @Giftmischer:

    Wie soll ich das denn machen?

    1. kann ich den Haken bei „Geschützt“ nicht entfernen
    2. Kann ich die Dateien nur Kopieren, nicht aber verschieben

    Und der Terminal-Tip von Apple funktioniert auch nicht!
     
  16. Cram

    Cram Salvatico di Campascio

    Dabei seit:
    21.12.06
    Beiträge:
    428
    Lad dir Dropnuke herunter und dein Problem ist gelöst. Einfach die Dateien im Papierkorb auf das Dropnuke-Icon (vornehmlich im Dock) - und gut iss'. Keine blöde Gegenfrage, einfach weg.

    Gruss

    C.
     
  17. BigB

    BigB Angelner Borsdorfer

    Dabei seit:
    26.08.06
    Beiträge:
    619
    Naja, das gleiche machen die, weiter oben genannten, Programme wie MainMenu auch.
    Nur scheint der Mac von wildpix anders zu ticken, als z.B. meiner. ;)

    Gruß
    Björn
     
  18. moema

    moema Holländischer Prinz

    Dabei seit:
    23.11.07
    Beiträge:
    1.859
    Ich hatte auch schon mal das selbe Problem!

    Ich konnte mir helfen, indem ich mit Windows nativ hochgefahren bin und auf den alten Speicherort der im Mac-Papierkorb befindlichen Dateien gegangen. Dann habe ich unter den Anzeigeoptionen "Versteckte Dateien und Ordner anzeigen" und "Systemdateien anzeigen" aktiviert. Zum Vorschein kommt daraufhin ein ansonsten versteckter Ordner. Darin (oder auch auf gleicher Ebene - das weiss ich jetzt nicht mehr sicher) findest du einen Ordner ".Trash". Darin befinden sich die unter Mac nicht löschbaren Dateien. Diese nun in den Windowspapierkorb ziehen und diesen entleeren. Eventuell kommt die Zwischenmeldung, ob du wirklich schreibgeschützte Dateien löschen willst. ---> FERTIG!

    So hat es zumindest bei mir geklappt!


    möma
     
  19. JohnnyAppleseed

    JohnnyAppleseed Schmalzprinz

    Dabei seit:
    11.09.07
    Beiträge:
    3.561
    @BigB:

    So ist es, nur dass es diesmal schon viel früher hängt: Das Programm arbeitet nicht mit Dateien, die schon im Papierkorb liegen.


    @moema:

    Die Frage ist nur, wie ich unter Windows auf eine HFS+-Partition zugreife und dann auch noch Schreibrechte bekomme ;)

    Übrigens befindet sich der Ordner unter Mac OS X nicht in dem .Trash-Ordner, unter Windows wird es wohl auch nicht anders aussehen ;)
     
  20. MacBat

    MacBat Murer Reinette

    Dabei seit:
    25.03.06
    Beiträge:
    1.628
    Mir hat mal ein Terminal-Tipp geholfen, der nicht von Apple kam, sondern aus diesem Forum, von Cybo:


    Eintippen: sudo rm -rf (nach dem Leerzeichen hinter -rf alle Dateien, die sich im papierkorb befinden in das Terminalfenster reinziehen, mit Entertaste und passwort bestätigen - fertig)

    Gruß
    cybo
     

Diese Seite empfehlen