1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

.profile Datei Terminal kaputt

Dieses Thema im Forum "macOS & OS X" wurde erstellt von Jens P., 09.03.10.

  1. Jens P.

    Jens P. Bismarckapfel

    Dabei seit:
    22.12.09
    Beiträge:
    77
    Hallo zusammen,
    hab laut einem Tutorial die .profile Datei verändert per Terminal (nano .profile).

    Habe Sie abgespeichert und nun geht kein Terminal-Befehl mehr.
    Wenn ich z.B "ls" eingebe, dann kommt "-bash: ls: command not found".
    Der Befehl "cd" funktioniert jedoch.

    Was mach ich nun? Ich kanns ja auch nicht mehr ändern, da es nano nicht mehr geht!
     
    #1 Jens P., 09.03.10
    Zuletzt bearbeitet: 09.03.10
  2. ImperatoR

    ImperatoR Ananas Reinette

    Dabei seit:
    02.12.06
    Beiträge:
    6.235
    Was hast du denn reingeschrieben? Immer diese Informatinsarmut!
     
  3. Jens P.

    Jens P. Bismarckapfel

    Dabei seit:
    22.12.09
    Beiträge:
    77
    export PATH=~/Applications/XAMPP/htdocs/cake

    EDIT: Was macht denn die ".profile" Datei?

    HELFT MIR BITTE. Ich verzweifle!
     
  4. ImperatoR

    ImperatoR Ananas Reinette

    Dabei seit:
    02.12.06
    Beiträge:
    6.235
    Dort kannst du u.a. die PATH-Variablen setzen, damit, einfach gesagt, das Terminal weiß, wo es nach Programmen suchen soll.
    Für gewöhnlich gibt es aber auch eine systemweite Konfiguration und die Benutzer-.profile wird eigenlich nur eingesetzt, um nach Benutzerwünsch z.B. andere PATH-Variablen oder Farbhervorhebungen etc. zu erweitern.

    Du kannst aber noch auf die Programme zurückgreifen, allerdings musst du jetzt den kompletten Pfad angeben:

    Code:
    /bin/ls
    Verschwindet der Fehler, wenn du .profile löscht? Ist das o.g. der komplette Inhalt der .profile?

    Code:
    /usr/bin/nano .profile
    /bin/rm .profile
     
  5. Jens P.

    Jens P. Bismarckapfel

    Dabei seit:
    22.12.09
    Beiträge:
    77
    Danke dir! Ja nun klappt alles wieder nachdem ich die Datei gelöscht habe.

    Vielen vielen Dank! Ein großes Lob an dich!

    Nun habe ich nur noch das Problem, dass ich die CakePHP Console nicht zum laufen bringen kann..
     
  6. ImperatoR

    ImperatoR Ananas Reinette

    Dabei seit:
    02.12.06
    Beiträge:
    6.235
    Du hast XAMPP in deinen Benutzer-Ordner installiert? Und warum XAMPP? MAMP ist für Mac OS X empfehlenswerter.
     
  7. Jens P.

    Jens P. Bismarckapfel

    Dabei seit:
    22.12.09
    Beiträge:
    77
    Wirklich?

    Das steht nun in der .profile Datei:
    Mit dem Befehl "cake" sollte diese nun eig. aufgerufen werden. Klappen tuts aber nicht.
     
  8. ImperatoR

    ImperatoR Ananas Reinette

    Dabei seit:
    02.12.06
    Beiträge:
    6.235
    Wenn der Ordner /Applications/XAMPP/xamppfiles/htdocs/cake/cake/console/cake auch das Programm cake enthält, solltest du versuchen dies in .profile eintragen:

    Code:
    PATH="$PATH:/Applications/XAMPP/xamppfiles/htdocs/cake/cake/console/cake"
    export PATH
     
  9. Jens P.

    Jens P. Bismarckapfel

    Dabei seit:
    22.12.09
    Beiträge:
    77
    Es klappt nun alles! Vielen vielen Dank! Bist der beste :)

    XAMPP aufjedenfall meiden, oder kann ich es so lassen? Oder sollte ich mal MAMP testen?

    EDIT:
    Du hast dich gewundert warum ich es irgendwo installiert habe. Wo hättest du es denn hin installiert?
     
  10. koksnutte

    koksnutte Ribston Pepping

    Dabei seit:
    13.04.05
    Beiträge:
    299
    warum unnötig am pfad rumpfuschen wenns auch einfacher geht:
    Code:
    sudo ln -s /Applications/XAMPP/xamppfiles/htdocs/cake/cake/console/cake /usr/local/bin/cake
    das kommando erstellt einen symbolischen link (eine art alias) von cake in einem ordner der bereits in deinem pfad ist.

    evtl. musst du vorher die ordner /usr/local/ und /usr/local/bin/ erstellen
    Code:
    sudo mkdir -p /usr/local/bin
     
  11. ImperatoR

    ImperatoR Ananas Reinette

    Dabei seit:
    02.12.06
    Beiträge:
    6.235
    XAMPP ist schon nicht schlecht, aber meiner Meinung nach ist MAMP besser — ein Test kann jedenfalls nicht schaden.
     
  12. Jens P.

    Jens P. Bismarckapfel

    Dabei seit:
    22.12.09
    Beiträge:
    77
    Ich hab jetzt MAMP ein wenig getestet. Finde es bisher schon übersichtlicher! Danke dir!
     
  13. Jens P.

    Jens P. Bismarckapfel

    Dabei seit:
    22.12.09
    Beiträge:
    77
    Bist du dir sicher das es klappt? Weil es läuft grade so schön bis auf, dass "ls" nicht mehr geht ohne den Pfad vorne ran zu setzen.

    Soll ich deins mal ausprobieren?
     
  14. ImperatoR

    ImperatoR Ananas Reinette

    Dabei seit:
    02.12.06
    Beiträge:
    6.235
    Das ist eine weitere Möglichkeit, diese durchaus elegant ist. Dort sieht man wieder die Flexibilität und Mächtigkeit der UNICES.
     
  15. Jens P.

    Jens P. Bismarckapfel

    Dabei seit:
    22.12.09
    Beiträge:
    77
    Fehlermeldung wenn ich "cake" eingebe:
    Als erstes habe ich das gemacht:
    sudo ln -s /Applications/XAMPP/xamppfiles/htdocs/cake/cake/console/cake /usr/local/bin/cake

    Und dann:
    sudo mkdir -p /usr/local/bin

    Und dann:
    sudo mkdir -p /usr/local
     
  16. ImperatoR

    ImperatoR Ananas Reinette

    Dabei seit:
    02.12.06
    Beiträge:
    6.235
    Wenn dann musst du erst /usr/local/bin oder /usr/local erstellen und dann den symbolischen Link erstellen, wobei darauf zu achten ist das Programm dort hin zu verlinken und nicht nur den Ordner.
     
  17. koksnutte

    koksnutte Ribston Pepping

    Dabei seit:
    13.04.05
    Beiträge:
    299
    das ist aber alles andere als schön. wenn 'ls' nicht funktioniert, funktionieren so gut wie alle anderen kommandos auch nicht weil du vermutlich wieder deinen default path zerschossen hast.
    -> terminal beenden, plist wieder löschen (oder besser: deine veränderung rückgängig machen) und terminal wieder starten.


    #1: theoretisch dürfte keines der kommandos funktioniert haben da du ja deinen path zerschossen hast. hast du denn keine fehlermeldung erhalten?

    #2: reihenfolge ist falsch. wie gesagt, das erste kommando erst ausführen nachdem du sichergestellt hast ob das verzeichniss /usr/local/bin vorhanden ist:
    Code:
    ls -l /usr/local/bin
    erhälst du "ls: /usr/local/bin: No such file or directory" dann ist das verzeichniss nicht vorhanden. poste doch bitte die ausgabe hier falls du nicht diese fehlermeldung erhälst.

    #3: zum erstellen dieses verzeichnisses reicht "mkdir -p /usr/local/bin" völlig aus. die option '-p' sorgt nämlich dafür das alle fehlenden zwischenverzeichnisse erstellt werden.
     
  18. karolherbst

    karolherbst Danziger Kant

    Dabei seit:
    11.05.07
    Beiträge:
    3.878
    und ich rate dir von MAMP und XAMPP ab und sage, dass du den Apache Server benutzen sollst, der schon an board ist. MySQL kannste installieren und PHP aktivieren, obwohl ich dir da empfehle, die neuste PHP Version runterzuladen und zu installieren
     
  19. MacMapple

    MacMapple Boskop

    Dabei seit:
    22.12.09
    Beiträge:
    205
    @karolherbst
    Endlich mal jemand, der das erwähnt.
    Kannst Du mir mal Deinen "./configure" für PHP rüberschicken?
    Ich habe schon einige Versuche durch, das PHP selbst zu installieren.

    Patches für iconv, libiconv, openssl und und und....machen mir beim Mac echte Probleme.
    So etwas kenne ich noch bei keinem anderen Linux.

    Heissen Dank im Voraus
     
  20. Jens P.

    Jens P. Bismarckapfel

    Dabei seit:
    22.12.09
    Beiträge:
    77
    Wenn ich mit meinem Eclipse öffne und eine Datei öffnen will, sehe ich ganz viele .profile Dateien.

    Sie heißen:
    .profile
    .profile1
    .profile2
    .profile3
    .......

    Alle gestern erstellt. Wie kann ich diese löschen? Sorry, bin neu auf dem Gebiet!
     

Diese Seite empfehlen