mailserver verweigert gmx und web.de

Dieses Thema im Forum "macOS & OS X Server" wurde erstellt von rainerm, 17.04.16.

Schlagworte:
  1. rainerm

    rainerm Jonagold

    Dabei seit:
    05.01.14
    Beiträge:
    19
    Hallo, ich hätte da gern mal ein Problem. Ähh, das habe ich ja schon und ich weiß nicht weiter.

    Seit ein paar Tagen kann ich über meinen OSX Mavericks Server 3.2.2 keine Mails an gmx.de und web.de senden. Ich bekomme diese Fehlermeldung:

    This is the mail system at host baraba.de.

    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.

    For further assistance, please send mail to postmaster.

    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.

    The mail system

    <onkel1@web.de>: Host or domain name not found. Name service error for
    name=web.de type=AAAA: Host found but no data record of requested type
    Reporting-MTA: dns; baraba.de
    X-Postfix-Queue-ID: 556368570149
    X-Postfix-Sender: rfc822; rainerm@baraba.de
    Arrival-Date: Thu, 14 Apr 2016 10:04:48 +0200 (CEST)

    Final-Recipient: rfc822; onkel1@web.de
    Original-Recipient: rfc822;onkel1@web.de
    Action: failed
    Status: 5.4.4
    Diagnostic-Code: X-Postfix; Host or domain name not found. Name service error
    for name=web.de type=AAAA: Host found but no data record of requested type



    Die Mail und DNS Einstellungen habe ich schon mit Hilfe dieses Forums überprüft. Aber eben leider erfolglos.
    Hat jemand einen Rat für mich?

    Gruß Rainer
     
  2. u0679

    u0679 Moderator Apple-Services + Software
    AT Moderation

    Dabei seit:
    09.11.12
    Beiträge:
    5.387
    Klingt nach einem Problem der Namensauflösung mit DNS. Den DNS Server, bzw. den Router mal neugestartet?
     
  3. rainerm

    rainerm Jonagold

    Dabei seit:
    05.01.14
    Beiträge:
    19

    Danke für den schnellen Rat. Ich werde es testen.
     
  4. ottomane

    ottomane Königlicher Kurzstiel

    Dabei seit:
    24.08.12
    Beiträge:
    10.159
    Warum nutzt du IPv6?

    Hintergrund: Du versuchst, den web.de-Mailserver per IPv6 aufzulösen. Normalerweise muss statt "AAAA" (=IPv6) der MX-Record abgefragt werden.
     
    #4 ottomane, 17.04.16
    Zuletzt bearbeitet: 17.04.16
  5. rainerm

    rainerm Jonagold

    Dabei seit:
    05.01.14
    Beiträge:
    19
    Ist mir garnicht bewußt gewesen. Ich hatte doch überall IPv6 aus, bzw "nur link local". Wie kann ich den MX-Record abfragen?
     
  6. ottomane

    ottomane Königlicher Kurzstiel

    Dabei seit:
    24.08.12
    Beiträge:
    10.159
    Manuell geht das mit
    Code:
    dig web.de MX
    Aber das löst das Problem nicht. Leider weiß ich nicht, wieso postfix web.de nach den AAAA-Records abfragt. Damit kenne ich mich nicht aus.

    Korrekt wäre zuerst die Abfrage nach den MX-Records und dann mit einem dadurch erhaltenen Mailserver erneut eine DNS-Anfrage nach dessen IPv4- oder IPv6-Adresse. Diese Anfrage müsste aber versuchen, z.B. mx-ha03.web.de aufzulösen.
     
  7. rainerm

    rainerm Jonagold

    Dabei seit:
    05.01.14
    Beiträge:
    19
    hier ist das Ergebnis. Aber ich kann da leider nix mit anfangen.


    baraba:~ srainer$ dig web.de MX


    ; <<>> DiG 9.8.3-P1 <<>> web.de MX

    ;; global options: +cmd

    ;; Got answer:

    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 43210

    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 4, ADDITIONAL: 8


    ;; QUESTION SECTION:

    ;web.de. IN MX


    ;; ANSWER SECTION:

    web.de. 341 IN MX 100 mx-ha02.web.de.

    web.de. 341 IN MX 100 mx-ha03.web.de.


    ;; AUTHORITY SECTION:

    web.de. 17339 IN NS ns-webde.ui-dns.de.

    web.de. 17339 IN NS ns-webde.ui-dns.com.

    web.de. 17339 IN NS ns-webde.ui-dns.biz.

    web.de. 17339 IN NS ns-webde.ui-dns.org.


    ;; ADDITIONAL SECTION:

    ns-webde.ui-dns.de. 150941 IN A 217.160.80.198

    ns-webde.ui-dns.de. 150941 IN AAAA 2001:8d8:fe:53::d9a0:50c6:100

    ns-webde.ui-dns.biz. 150941 IN A 217.160.81.198

    ns-webde.ui-dns.biz. 150941 IN AAAA 2001:8d8:fe:53::d9a0:51c6:100

    ns-webde.ui-dns.com. 150941 IN A 217.160.82.198

    ns-webde.ui-dns.com. 150941 IN AAAA 2001:8d8:fe:53::d9a0:52c6:100

    ns-webde.ui-dns.org. 150941 IN A 217.160.83.198

    ns-webde.ui-dns.org. 150941 IN AAAA 2001:8d8:fe:53::d9a0:53c6:100


    ;; Query time: 3 msec

    ;; SERVER: 127.0.0.1#53(127.0.0.1)

    ;; WHEN: Sun Apr 17 22:10:44 2016

    ;; MSG SIZE rcvd: 377
     
  8. ottomane

    ottomane Königlicher Kurzstiel

    Dabei seit:
    24.08.12
    Beiträge:
    10.159
    Da gibt er Dir dir korrekten Mailserver für web.de. Die Antwort sieht hier ähnlich aus. Der DNS scheint also korrekt zu arbeiten. An einen dieser Server wird die Mail normalerweise abgegeben. Dass dein Postfix web.de in eine v6-Adresse auflösen will, ist falsch. Warum das ist ist, weiß ich aber wie gesagt nicht.

    EDIT: Vielleicht kann man dir in einem Postfix- oder Serverforum besser helfen. Das Problem scheint mir nichts direkt mit Apple zu tun zu haben. Aber vielleicht kommt ja noch jemand, der die Antwort kennt.
     
  9. rainerm

    rainerm Jonagold

    Dabei seit:
    05.01.14
    Beiträge:
    19
    Schade, trotzdem danke. Denn nun kann ich ja den DNS Server bei der Fehlersuche schon mal ausschließen.
     
    ottomane gefällt das.
  10. rainerm

    rainerm Jonagold

    Dabei seit:
    05.01.14
    Beiträge:
    19
    Nach dem ich noch die halbe Nacht gesucht habe, fand ich folgendes:

    /Library/Server/Mail/Config/postfix/main.cf is indeed the key; however:
    • inet_interfaces should in fact be set to "all", which probably explains why it keeps getting set back to that value.
    • inet_protocols is the key. It's not set in Server's default main.cf, but can be specified if you choose. inet_protocols = ipv4 will limit mail sending to ipv4 addresses
    Erfolg hatte ich aber nicht.

    Diagnostic-Code: X-Postfix; Host or domain name not found. Name service error
    for name=web.de type=A: Host found but no data record of requested type

    Nun wird der Typ A und nicht mehr AAAA benutzt wird, aber emails kann ich, auch nach neustart von server und router, trotzdem nicht versenden. :(
     
  11. ottomane

    ottomane Königlicher Kurzstiel

    Dabei seit:
    24.08.12
    Beiträge:
    10.159
    Nun ja, immerhin hat es Auswirkungen. Interessant wäre zu sehen, ob davor überhaupt eine MX-Abfrage durchgeführt wird oder ob er direkt mit dem A-Record startet. Das kann man vielleicht im Log des DNS-Servers sehen oder per

    Code:
    tcpdump -n -s 1500 -i eth0 udp port 53
    mithören (ggf. anpassen).

    Postfix nutzt vielleicht
    /var/spool/postfix/etc/resolv.conf
    statt
    /etc/resolv.conf

    Da könnte man auch mal schauen, ob da das Richtige drinsteht.

    Aber das ist von mir schon recht ahnungsloses Stochern im Nebel.
     
    #11 ottomane, 18.04.16
    Zuletzt bearbeitet: 18.04.16
  12. rainerm

    rainerm Jonagold

    Dabei seit:
    05.01.14
    Beiträge:
    19
    Im DNS Protokoll steht:


    18-Apr-2016 08:49:33.385 shutting down
    18-Apr-2016 08:49:33.385 stopping command channel on ::1#54
    18-Apr-2016 08:49:33.386 no longer listening on ::#53
    18-Apr-2016 08:49:33.386 no longer listening on 127.0.0.1#53
    18-Apr-2016 08:49:33.386 no longer listening on 10.0.2.99#53
    18-Apr-2016 08:49:33.396 exiting
    18-Apr-2016 08:49:33.479 managed-keys-zone/com.apple.ServerAdmin.DNS.public: loaded serial 0
    18-Apr-2016 08:49:33.482 zone 99.2.0.10.in-addr.arpa/IN/com.apple.ServerAdmin.DNS.public: loaded serial 2016041803
    18-Apr-2016 08:49:33.482 zone 2.0.10.in-addr.arpa/IN/com.apple.ServerAdmin.DNS.public: loaded serial 2016041803
    18-Apr-2016 08:49:33.485 zone 228.32.101.212.in-addr.arpa/IN/com.apple.ServerAdmin.DNS.public: loaded serial 2016041803
    18-Apr-2016 08:49:33.486 zone 0.0.127.in-addr.arpa/IN/com.apple.ServerAdmin.DNS.public: loaded serial 1997022700
    18-Apr-2016 08:49:33.491 zone localhost/IN/com.apple.ServerAdmin.DNS.public: loaded serial 42
    18-Apr-2016 08:49:33.492 zone 32.101.212.in-addr.arpa/IN/com.apple.ServerAdmin.DNS.public: loaded serial 2016041803
    18-Apr-2016 08:49:33.492 db.baraba.de:10: warning: '10.0.2.99.': MX is an address
    18-Apr-2016 08:49:33.493 zone baraba.de/IN/com.apple.ServerAdmin.DNS.public: loaded serial 2016041803
    18-Apr-2016 08:49:33.495 all zones loaded
    18-Apr-2016 08:49:33.495 running
    18-Apr-2016 08:49:33.496 zone 2.0.10.in-addr.arpa/IN/com.apple.ServerAdmin.DNS.public: sending notifies (serial 2016041803)
    18-Apr-2016 08:49:33.496 zone 228.32.101.212.in-addr.arpa/IN/com.apple.ServerAdmin.DNS.public: sending notifies (serial 2016041803)
    18-Apr-2016 08:49:33.496 zone 99.2.0.10.in-addr.arpa/IN/com.apple.ServerAdmin.DNS.public: sending notifies (serial 2016041803)
    18-Apr-2016 08:49:33.496 zone 32.101.212.in-addr.arpa/IN/com.apple.ServerAdmin.DNS.public: sending notifies (serial 2016041803)
    18-Apr-2016 08:49:33.498 client 212.101.32.228#38135: view com.apple.ServerAdmin.DNS.public: received notify for zone '2.0.10.in-addr.arpa'
    18-Apr-2016 08:49:33.770 client 47.88.1.138#53623 (ms08067.com): view com.apple.ServerAdmin.DNS.public: query (cache) 'ms08067.com/A/IN' denied
    18-Apr-2016 08:49:33.910 client 47.88.1.138#53623 (ms08067.com): view com.apple.ServerAdmin.DNS.public: query (cache) 'ms08067.com/A/IN' denied
    18-Apr-2016 08:49:34.065 client 212.101.32.228#45105: view com.apple.ServerAdmin.DNS.public: received notify for zone '99.2.0.10.in-addr.arpa'
    18-Apr-2016 08:49:34.065 client 212.101.32.228#45105: view com.apple.ServerAdmin.DNS.public: received notify for zone '228.32.101.212.in-addr.arpa'
    18-Apr-2016 08:49:34.156 client 47.88.1.138#53623 (ms08067.com): view com.apple.ServerAdmin.DNS.public: query (cache) 'ms08067.com/A/IN' denied
    18-Apr-2016 08:49:34.607 client 47.88.1.138#53623 (ms08067.com): view com.apple.ServerAdmin.DNS.public: query (cache) 'ms08067.com/A/IN' denied
    18-Apr-2016 08:49:35.310 client 47.88.1.138#53623 (ms08067.com): view com.apple.ServerAdmin.DNS.public: query (cache) 'ms08067.com/A/IN' denied
    18-Apr-2016 08:49:35.749 client 47.88.1.138#53623 (ms08067.com): view com.apple.ServerAdmin.DNS.public: query (cache) 'ms08067.com/A/IN' denied
    18-Apr-2016 08:49:36.077 client 47.88.1.138#53623 (ms08067.com): view com.apple.ServerAdmin.DNS.public: query (cache) 'ms08067.com/A/IN' denied


    Von den letzten Einträgen gibt es jede Menge. Kann ich aber leider nix mit anfangen.......


    sudo tcpdump -n -s 1500 -i en0 udp port 53

    09:14:14.499228 IP 81.90.192.252.53 > 10.0.2.99.53122: 26603 NXDomain 0/1/1 (125)

    09:14:14.524442 IP 81.90.192.252.53 > 10.0.2.99.61029: 46017 NXDomain 0/1/1 (123)

    09:14:14.658612 IP 10.0.2.99.58771 > 81.90.192.253.53: 46335+ [1au] MX? web.de. (35)

    09:14:14.677116 IP 81.90.192.253.53 > 10.0.2.99.58771: 46335 3/4/13 MX mx-ha02.web.de. 100, MX mx-ha03.web.de. 100, RRSIG (1302)

    09:14:14.678187 IP 10.0.2.99.64206 > 81.90.192.253.53: 39669+ [1au] A? mx-ha02.web.de. (43)

    09:14:14.678278 IP 10.0.2.99.50203 > 81.90.192.253.53: 50363+% [1au] A? ns-webde.ui-dns.biz. (48)

    09:14:14.678328 IP 10.0.2.99.53094 > 81.90.192.253.53: 43471+% [1au] A? ns-webde.ui-dns.com. (48)

    09:14:14.678401 IP 10.0.2.99.54748 > 81.90.192.253.53: 52952+% [1au] A? ns-webde.ui-dns.de. (47)

    09:14:14.678725 IP 10.0.2.99.53138 > 81.90.192.253.53: 3513+% [1au] AAAA? ns-webde.ui-dns.biz. (48)

    09:14:14.678795 IP 10.0.2.99.56365 > 81.90.192.253.53: 65521+% [1au] AAAA? ns-webde.ui-dns.com. (48)

    09:14:14.678836 IP 10.0.2.99.64322 > 81.90.192.253.53: 42458+% [1au] AAAA? ns-webde.ui-dns.de. (47)

    09:14:14.678883 IP 10.0.2.99.65094 > 81.90.192.253.53: 40445+% [1au] A? ns-webde.ui-dns.org. (48)

    09:14:14.679028 IP 10.0.2.99.53359 > 81.90.192.253.53: 55544+% [1au] AAAA? ns-webde.ui-dns.org. (48)

    09:14:14.693526 IP 81.90.192.253.53 > 10.0.2.99.50203: 50363 1/6/1 A 217.160.81.198 (165)

    09:14:14.695489 IP 81.90.192.253.53 > 10.0.2.99.53094: 43471 1/4/9 A 217.160.82.198 (353)

    09:14:14.695604 IP 81.90.192.253.53 > 10.0.2.99.64206: 39669 2/4/9 A 212.227.17.8, RRSIG (658)

    09:14:14.696404 IP 10.0.2.99.56746 > 81.90.192.253.53: 1712+ [1au] A? mx-ha03.web.de. (43)

    09:14:14.698153 IP 81.90.192.253.53 > 10.0.2.99.54748: 52952 1/4/8 A 217.160.80.198 (321)

    09:14:14.698552 IP 81.90.192.253.53 > 10.0.2.99.53138: 3513 1/6/1 AAAA 2001:8d8:fe:53::d9a0:51c6:100 (177)

    09:14:14.698554 IP 81.90.192.253.53 > 10.0.2.99.56365: 65521 1/4/9 AAAA 2001:8d8:fe:53::d9a0:52c6:100 (365)

    09:14:14.700483 IP 81.90.192.253.53 > 10.0.2.99.64322: 42458 1/4/8 AAAA 2001:8d8:fe:53::d9a0:50c6:100 (333)

    09:14:14.701898 IP 81.90.192.253.53 > 10.0.2.99.65094: 40445 1/4/7 A 217.160.83.198 (309)

    09:14:14.701901 IP 81.90.192.253.53 > 10.0.2.99.53359: 55544 1/4/7 AAAA 2001:8d8:fe:53::d9a0:53c6:100 (321)

    09:14:14.712572 IP 81.90.192.253.53 > 10.0.2.99.56746: 1712 2/4/9 A 212.227.15.17, RRSIG (658)
     
  13. ottomane

    ottomane Königlicher Kurzstiel

    Dabei seit:
    24.08.12
    Beiträge:
    10.159
    Hm. Soweit ich es verstehen kann, sieht das gut aus. Postfix fragt nach dem MX-Record und bekommt auch die richtige Antwort.

    09:14:14.678187 IP 10.0.2.99.64206 > 81.90.192.253.53: 39669+ [1au] A? mx-ha02.web.de. (43)

    09:14:14.695604 IP 81.90.192.253.53 > 10.0.2.99.64206: 39669 2/4/9 A 212.227.17.8, RRSIG (658)


    Eigentlich dachte ich, dass es auch hieran liegen könnte:
    http://www.postfix.org/postconf.5.html#relayhost

    Was steht denn da bei Dir?
     
  14. rainerm

    rainerm Jonagold

    Dabei seit:
    05.01.14
    Beiträge:
    19
    in der postfix/main.cf steht kein Parameter : relayhost =
     
  15. ottomane

    ottomane Königlicher Kurzstiel

    Dabei seit:
    24.08.12
    Beiträge:
    10.159
    Hm. Dann weiß ich auch nicht wirklich weiter, tut mir leid.
     
  16. rainerm

    rainerm Jonagold

    Dabei seit:
    05.01.14
    Beiträge:
    19
  17. ottomane

    ottomane Königlicher Kurzstiel

    Dabei seit:
    24.08.12
    Beiträge:
    10.159
    Der Reverse-Eintrag deiner Domain lautet
    ip228-32-101-212.aco-connect.de.

    Vielleicht kannst du das bei deinem anbieter ändern in die wirkliche Domain.
     
  18. rainerm

    rainerm Jonagold

    Dabei seit:
    05.01.14
    Beiträge:
    19
    wie bekomme ich denn den Reverse-Eintrag heraus?
     
  19. nomos

    nomos Borowinka

    Dabei seit:
    22.12.03
    Beiträge:
    7.703
    Im Terminal (ohne die Anführungszeichen):

    host "abzufragende_domain.de"

    spuckt deine IP aus

    host "ausgespuckte_IP"

    muss dann wieder "abzufragende_domain.de" ausspucken.


    Ist das nicht der Fall, musst du den PTR-record für deine IP setzen.
    Zum testen solcher Einstellungen auch immer wieder nützlich:

    mxtoolbox.com
     
  20. rainerm

    rainerm Jonagold

    Dabei seit:
    05.01.14
    Beiträge:
    19
    Das sieht bei mir so aus:


    baraba:~ srainer$ host www.baraba.de

    www.baraba.de is an alias for baraba.de.
    baraba.de has address 212.101.32.228
    baraba.de has address 10.0.2.99
    baraba.de mail is handled by 0 10.0.2.99.
    baraba.de mail is handled by 0 baraba.de.

    baraba:~ srainer$ host 212.101.32.228
    228.32.101.212.in-addr.arpa domain name pointer baraba.de.

    baraba:~ srainer$ host 10.0.2.99
    99.2.0.10.in-addr.arpa domain name pointer baraba.de.



    Meinem Provider habe ich auch geschrieben. Der hat den Revers-Eintrag auch schon geändert. Wie kann ich das überprüfen ?