1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Leopard und X11 Problem - Inkscape bzw. Gimp ...

Dieses Thema im Forum "macOS & OS X" wurde erstellt von Havras, 02.11.07.

  1. Havras

    Havras Roter Delicious

    Dabei seit:
    21.12.05
    Beiträge:
    93
    Hallo,

    auch hier frage ich nach ;)

    Saubere Installation des Leoparden, komplett neu - bei Ausführung von Gimp (ob aus Ordner Programme oder aus dmg Datei erfolgt sofortige Beendigung von Gimp und ein Fehlerbericht ... bei Start von Inkscape aus Ordner Programme verlangt der Mac nach X11 ("get X11 for Panther") und beendet gleichfalls, Start aus .dmg-Datei funktioniert (finde das aber sehr umständlich ...).

    Gibt es hier eine Lösung?

    Vielen Dank.

    Gruß

    Havras

    ... der sonst wieder den Tiger aufsetzt und auf Leo 10.5.3 abwartet. ;)
     
  2. nev03

    nev03 Freiherr von Berlepsch

    Dabei seit:
    18.05.07
    Beiträge:
    1.104
    gut das du fragst...jetzt fällt mir auch auf das mein inkscape und gimp nicht mehr funktionieren:(
     
  3. hiker

    hiker Gast

    Wenn man X11.app davor selbst startet gehts bei mir. Die neuste Version von Gimp.app (2.4 rc3) startet X11 auch unter Leopard automatisch.
     
  4. hiker

    hiker Gast

    Inkscape.app kann ich auch zum X11 starten bewegen wenn ich in Inkscape.app/Contents/Resources/script die Zeilen
    open-x11 /tmp/getdisplay.sh || \
    open -a XDarwin /tmp/getdisplay.sh || \

    durch
    open -a X11 /tmp/getdisplay.sh
    ersetze.
     
  5. Havras

    Havras Roter Delicious

    Dabei seit:
    21.12.05
    Beiträge:
    93
    zu hiker ...

    Gimp habe ich soeben neu intalliert - und bei Inkscape (ich bin ein DAU in Sachen Terminal und Co.) - wie mache ich den das ?

    Danke schön

    Havras
     
  6. hiker

    hiker Gast

    Im Finder mit rechts auf Inkscape.app klicken und "Show Package Contents" wählen (oder so ähnlich auf deutsch). Dann in den Contents und dann den Resources Ordner rein. Da ist die Datei script. Diese mit TextEdit öffnen und die Änderungen durchführen.
     
  7. dust123

    dust123 Rhode Island Greening

    Dabei seit:
    13.02.05
    Beiträge:
    483
    Die startet zwar, aber kannst du damit auch arbeiten? Bei mir ist es fast unmöglich eine vernünftige Selektion hinzubekommen, weil alles viel zu träge reagiert.
     
  8. Havras

    Havras Roter Delicious

    Dabei seit:
    21.12.05
    Beiträge:
    93
    Hallo.

    bei Gimp ist die Geschwindigkeit merklich langsamer wie im alten Tiger. Sehr schade ... auch Inkscape ist träger geworden. Gibt es hier irgendwelche Tricks, um das Arbeiten vom "Speed her" wieder auf das gewohnte Maß zu bringen (wobei - ich habe Gimp und Inkscape mal unter einem Linux PC werkeln sehen - von der Ausstattung vergleichbar meinem AluImac 2,4 - da fühlte sich mein Mac wahrlich langsam an). Kann ich X11 irgendwie "Beine" machen?

    Danke und Gruß

    Havras
     
  9. JackDanny75

    JackDanny75 Tokyo Rose

    Dabei seit:
    26.08.07
    Beiträge:
    71
    Habe auch gerade akutelle Version von Gimp installiert und kann die Probleme nur bestätigen.

    Total träge und stürzt auch ab.
     
  10. JackDanny75

    JackDanny75 Tokyo Rose

    Dabei seit:
    26.08.07
    Beiträge:
    71
  11. nev03

    nev03 Freiherr von Berlepsch

    Dabei seit:
    18.05.07
    Beiträge:
    1.104
    tut mir leid aber ich kapier beim besten willen nicht was die auf der Darwin Seite von mir wollen und was ich tun muss :(
     
  12. Hathor38

    Hathor38 Gast

    Hallo Leute,

    habe dasselbe Problem mit Gimp:
    Habe das aktuelle Update von Leopard (10.5.1) installiert, die X11-Bugfixes von Nasendackel....aber was soll ich sagen? Gimp läuft zwar, aber von "stabil" ist das noch meilenweit entfernt. Wenn man z.B. ein zweites Bild öffnet und das am Desktop verschiebt, landet Gimp inkl. X11 mit etwa 80%iger Wahrscheinlichkeit im Datennirvana....

    Irgendwie überlege ich mir schon, zum alten Tiger zurückzukehren, da hat das alles klaglos funktioniert.....

    LG Walter
     
  13. FrankR

    FrankR Johannes Böttner

    Dabei seit:
    15.11.07
    Beiträge:
    1.158
    Ja, X11 unter Leopard ist noch nicht so der Bringer. Apple hat die Codebasis auch von XFree86 nach dem X.org gewechselt ...

    Schaut mal hier: http://www.x.org/wiki/XDarwin

    dort ist eigentlich alles beschrieben. Ich habe in den letzten Tagen auch beinahe täglich einen neuen X-Window-Manager (Xquartz) von dort installiert, langsam bessert es sich ;).

    Im Terminal einfach die Schritte unter "Quick Install" ausführen, macht dann den Download und install der Binaries automatisch.

    Falls gar nichts geht, ist auf der Seite/in der FAQ auch beschrieben, wie man zum Tiger X11 zurückkommt.
     
  14. JackDanny75

    JackDanny75 Tokyo Rose

    Dabei seit:
    26.08.07
    Beiträge:
    71
    Ohje, dann warte ich doch noch mal ab, vielleicht tut sich da in Sachen Update was. Brauche Gimp jetzt nicht so dringend.

    edit: So, habe es doch mal gewagt, aber über diesen Link hier:

    http://www.nasendackel.de/2007/11/11/gimp-241-fur-leopard

    Darunter findet man auch einen Punkt Xorg updaten. Das funktionierte alles wunderbar. Gimp stürzte nach kurzem Test nicht ab und ist performant.
     
    #14 JackDanny75, 16.11.07
    Zuletzt bearbeitet: 16.11.07
  15. nev03

    nev03 Freiherr von Berlepsch

    Dabei seit:
    18.05.07
    Beiträge:
    1.104
    Jetzt läuft es bei mir auch wieder richtig :-D
     
  16. duran777

    duran777 Gast

    Hallo habe auch das problem mit leopard inkscape will einfach nicht starten
    kann mir jemand helfen

    grüße duran
     
  17. fls08

    fls08 Jonagold

    Dabei seit:
    14.01.08
    Beiträge:
    20
    Hey, ich habe auch das Problem mit Inkscape. Ich habe das Update von dem oben angegebenen Link probiert und habe auch das Skript von Inkscape einmal verändert, allerdings tut sich dann noch weniger, nicht mal eine Fehlermeldung. Inkscape öffnet sich zwar, aber nur im Dock und sonst nicht (Arbeitsoberfläche oder Menü).
    Weiß jemand eine Lösung?
    Ich würde auch ohne weiteres auf eine kostenlose Alternative umsteigen.
     
  18. duran777

    duran777 Gast

    habe das heute hin bekommen.
    musste nur X11 instalieren und los geht´s
     
  19. fls08

    fls08 Jonagold

    Dabei seit:
    14.01.08
    Beiträge:
    20
    Du bist lustig ^^Das hab ich schon 3 mal probiert, aber keinen Erfolg erzielt.
     
  20. sars

    sars Gast

Diese Seite empfehlen