1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Latex- Bibliogrphystyle - APAger

Dieses Thema im Forum "LaTeX" wurde erstellt von lockerl_kathi, 15.05.09.

  1. lockerl_kathi

    lockerl_kathi Jonagold

    Dabei seit:
    20.01.09
    Beiträge:
    22
    Hi!

    ich schreib gard Diplomarbeit und sollte die Bibliographie im apa stil machen.
    Ich verwende TeXShop und für die Biblio Daten Bibdesk.

    Habe jetzt gefunden, dass fürs deutsche apager gibt, und hab auch die *.sty und *.bst Datei bereits von
    http://www.uni-salzburg.at/portal/page?_pageid=138,456791&_dad=portal&_schema=PORTAL
    downgeloaded.

    Habe jetzt versucht diese richtig einzufügen, nach dieser Anleitung die ich im Forum gefunden habe:
    - Besser als APA-like ist APAcite für englischsprachige Arbeiten und APAger für deutschsprachige (und das auch nur weil APA-Cite nicht korrekt mit babel zusammenarbeitet)
    - diese Packages können bei dante.de runtergeladen werden
    - falls Du TeX-Shop benutzt: *.sty-Datei in user/Library/TeXmf/TeX/LateX ablegen und *.bst-Datei in user/library/TeXmf/bibTeX/bst/apa

    Die *.sty Datei war kein Problem, aber bei der *.bst gibts tin Texmf kein Unterverzeichnis mehr dass bibTex heißt - auch anlegen dieser Verzeichnisse hat nicht funktioniert.

    habe auch das usepackage{apager} eingebunden

    jetzt kommt immer folgender error:
    !LaTeX Error: File `apager.sty' not found.

    Kann mir jemand weiterhelfen?
    DANKE schon mal im Voraus!!!
     
  2. Jenso

    Jenso Zehendlieber

    Dabei seit:
    02.12.07
    Beiträge:
    4.117
    ganz und gar OT!

    Überschrift und Beitrag selbst machen mir (mal wieder) klar, warum ich mich nicht mit LaTex und Derivaten beschäftigen mag: ich bin viel zu ignorant/bequem/„apple“ig, um solche Mengen von technischem Kram (um nicht zu sagen:Kauderwelsch) in einem bloßen Textverarbeitungsbereich ertragen zu wollen.

    Andererseits trifft das Wort Text„verarbeitung“ hier ja strenggenommen viel mehr zu, als etwa bei Pages: dort bleibt Text eben un„ver“arbeitet, die Inhalte und das Layout werden „be“arbeitet…

    'Tschuldigung, dem thread-Ersteller hilft mein Lamento (leider!, ich bedaure wirklich) nicht weiter. Ich wünsche ihm kompetentere Teilnehmer und Hilfe.

    Jens
     
  3. Terror Apfel

    Terror Apfel Tokyo Rose

    Dabei seit:
    14.06.07
    Beiträge:
    68
    Hi versuche die *.bst Datei doch im Projektordner, in dem du die tex, toc, aux etc. files liegen hast, abzulegen.
    Das hat mir bei einem ähnlichen Zitierproblem mal geholfen.

    @jenso: ich pers. kenne mich jetzt mit Pages nicht vollends aus aber gerade Unmengen an Text (m.E. nach ab ca. 10 Seiten +) lassen sich in einem Textsatzprogramm ala LateX sehr viel besser handeln.
    Eine Einarbeitung für die Standardnutzung ala Diplomarbeit schafft man bestens innerhalb von 2-3 Tagen und dannach verzichtet man völlig freiwillig auf Word, Pages und wie sie nicht alle heißen mögen.
     
    Jenso gefällt das.
  4. lockerl_kathi

    lockerl_kathi Jonagold

    Dabei seit:
    20.01.09
    Beiträge:
    22
    hat leider nicht funktioniert - es kommt immer noch die gleiche fehlermeldung :(
     
  5. Stefan_K

    Stefan_K Morgenduft

    Dabei seit:
    18.05.07
    Beiträge:
    168
    apager

    Hallo,

    aktualisiere nach dem download/Kopieren auch die Paketdatenbank:
    Code:
    sudo texhash
    oder mit mktexlsr
    Code:
    sudo mktexlsr
    Stefan


    --
    TeXblog.net
     
  6. lockerl_kathi

    lockerl_kathi Jonagold

    Dabei seit:
    20.01.09
    Beiträge:
    22
    danke für deine antwort - muss aber leider sagen, dass ich damit nichts anfangen kann.
    bin ein relativer latex neuling :-[
     
  7. Terror Apfel

    Terror Apfel Tokyo Rose

    Dabei seit:
    14.06.07
    Beiträge:
    68
    oder lösche mal die aux datei aus dem projekt ordner, da werden die fehler etc. meines wissens nach protokolliert. ich hatte auch schon nen paar fehler die trotz korrekter syntax resistent geblieben sind und nach dem löschen der aux datei (bzw. aller anderen datei außer der tex und dem literatur sowie bst/ sty file) auf einmal verschwanden.
     
  8. lockerl_kathi

    lockerl_kathi Jonagold

    Dabei seit:
    20.01.09
    Beiträge:
    22
    leider immer noch nicht - irgendwie glaub ich sollt ich vielleicht diese beiden datein noch wo reinkopieren - aber wo?
     
  9. Stefan_K

    Stefan_K Morgenduft

    Dabei seit:
    18.05.07
    Beiträge:
    168
    sudo texhash

    Öffne das Programm "Terminal" und tippe dort einmal eines der von mir obengenannten Befehle ein.

    Stefan
     
  10. lockerl_kathi

    lockerl_kathi Jonagold

    Dabei seit:
    20.01.09
    Beiträge:
    22
    danke!

    habs versucht - bekomme aber leider immer noch die gleiche fehlermeldung.
     
  11. Stefan_K

    Stefan_K Morgenduft

    Dabei seit:
    18.05.07
    Beiträge:
    168
    apager

    Zur Not befolge den Rat aus Beitrag #3 und lege die apager.sty in deinen Projektordner. Dort wird sie auf jeden Fall gefunden.

    Stefan
     
  12. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Die Anleitung ist auch fehlerhaft. Die texmf-Unterordner in ~/Library müssen zwingend kleingeschrieben werden. Also Style-Datei nach /Users/DeinBenutzername/Library/texmf/tex/latex und die *.bst-Datei nach /Users/DeinBenutzername/Library/texmf/bibtex/bst/apa. Danach ein "texhash" oder auch "sudo texhash" im Terminal.
     
  13. VollPfosten

    VollPfosten Roter Delicious

    Dabei seit:
    01.11.05
    Beiträge:
    94
    Du verwendest TeXLive 2008 oder 2009, richtig?
    Hast Du die sty-Datei unterhalb von /Users/<kurzerUserName>/Library/texmf/tex/latex und die bst-Datei unterhalb von /Users/<kurzerUserName>/Library/texmf/bibtex/bst reinkopiert?
     
  14. lockerl_kathi

    lockerl_kathi Jonagold

    Dabei seit:
    20.01.09
    Beiträge:
    22
    ja habs reinkopiert - es funktioniert jetzt auch mal so weit, dass es wieder übersetzt wird, aber das problem ist jetzt dass im pdf rauskommt (?, S. 233) zum Beispiel, d.h. er findet das Buch nicht.

    jetzt kommt die fehlermeldung beim ersten \cite[S. 233]{Kehlmann} ???
    was hab ich falsch gemacht?

    wo könnte der fehler liegen?


    Dokument sieht so aus:
    \documentclass[12pt]{book}
    \usepackage{geometry} % See geometry.pdf to learn the layout options. There are lots.
    \geometry{a4paper} % ... or a4paper or a5paper or ...
    \usepackage{graphicx}
    \usepackage{amssymb}
    \usepackage[ngerman]{babel}
    \usepackage[applemac]{inputenc}
    \usepackage{epstopdf}
    \usepackage{tabularx}
    \usepackage{amsmath}
    \usepackage{floatflt}
    \usepackage{pdfpages} % zum PDF einbinden
    \usepackage{apager} %Zitieren
    \usepackage{paralist} %zusätzlich ein compactitem wo keine vertikalen Abstände mehr sind
    \usepackage{hyperref} %Damit Inhaltsverzeichnis anklickbar wird
    \DeclareGraphicsRule{.tif}{png}{.png}{`convert #1 `dirname #1`/`basename #1 .tif`.png}
    \newcolumntype{C}[1]{>{\arraybackslash}p{#1}}

    \begin{document}

    TEXT

    \bibliographystyle{apager}
    \bibliography{Literaturneu}

    \end{document}
     
  15. Stefan_K

    Stefan_K Morgenduft

    Dabei seit:
    18.05.07
    Beiträge:
    168
    BibTeX

    Rufe das BibTeX Kommando im Texshop Menü auf, falls Du es verwendest, sonst im Terminal bibtex dokumentname.

    Stefan
     
  16. lockerl_kathi

    lockerl_kathi Jonagold

    Dabei seit:
    20.01.09
    Beiträge:
    22
    das hab ich schon öfters versucht - funktionert aber nicht
     
  17. VollPfosten

    VollPfosten Roter Delicious

    Dabei seit:
    01.11.05
    Beiträge:
    94
    Was sagt die Fehlermeldung? Wenn da irgendetwas à la "Warning--I didn't find a database entry for "Kehlmann"" steht, findet BibTex Deine bib-Datei nicht. Falls es eine artikelspezifische Datenbank ist, lege die bib-Datei in das Verzeichnis, in dem auch Deine tex-Datei liegt. Falls Du die Literaturdatenbank in mehreren Aufsätzen nutzt, lege sie unter /Users/<kurzerUserName>/Library/texmf/bibtex/bib ab.
     
  18. lockerl_kathi

    lockerl_kathi Jonagold

    Dabei seit:
    20.01.09
    Beiträge:
    22
    Fehlermeldung:
    !Undefined control sequence.
    \hyper@@link->\let\Hy@reserved.....
    I.139 ... aneinander} \cite[S. 89]{Kehlmann}

    und die bibdesk datei liegt in dem ordner wo die .tex datei ist.
     
  19. VollPfosten

    VollPfosten Roter Delicious

    Dabei seit:
    01.11.05
    Beiträge:
    94
    Das ist eine Inkompatibilität von hyperref und apacite. Lade in Deiner Präambel erst hyperref, dann apager.
     
  20. lockerl_kathi

    lockerl_kathi Jonagold

    Dabei seit:
    20.01.09
    Beiträge:
    22
    DANKE!!!!
    jetzt funktionierts!

    schönen abend noch!
     

Diese Seite empfehlen