1. Mach mit bei unserem Weihnachtsbanner-Wettbewerb 2019 --> klick!
    Information ausblenden
  2. Am Mittwoch, dem 27.11.19 ab ca. 10:00 Uhr werden wir eine größere Server-Wartung vornehmen. Das Forum und das Magazin werden bis Freitag, dem 29.11.19 Mittags (wenn alles gut geht) nicht erreichbar sein.
    Information ausblenden

Homepage online bringen.

Dieses Thema im Forum "Webhosting/DSL-Anbieter" wurde erstellt von VonHaiden, 24.06.07.

  1. Sigur

    Sigur Adams Parmäne

    Dabei seit:
    10.07.06
    Beiträge:
    1.301
    du gehst mit deinem browser einfach in das verzeichniss, in dem die website liegt.

    also bei mir wäre das:

    sigur.si.funpic.de/beispiel/

    sigur.si.funpic.de ist die Adresse des Webspaces und

    /beispiel/ ist das Verzeichnis, in dem die Website liegt.
     
  2. VonHaiden

    VonHaiden Gast

    Ja, ich bedanke mich hier bei Allen für die Hilfe! Es hat alles geklappt

    Viele Grüße
     
  3. Sigur

    Sigur Adams Parmäne

    Dabei seit:
    10.07.06
    Beiträge:
    1.301
    na nun möchten wir das ergebnis doch auch sehen.
     
  4. inglewood14

    inglewood14 Königsapfel

    Dabei seit:
    23.10.06
    Beiträge:
    1.216
    Bei mir funktioniert das mit iWeb nicht.

    Folgendes wird immer angezeigt:

    Parse error: syntax error, unexpected T_STRING in /usr/export/www/vhosts/funnetwork/hosting/*****/website/index.html on line 1

    Was läuft da falsch?
     
  5. Nordapfel

    Nordapfel Pomme Etrangle

    Dabei seit:
    03.09.06
    Beiträge:
    912
    Das ist ein PHP Error. Am besten, du postest mal den Quellcode der Datei.

    Aber ich vermute, dass in der ersten Zeile etwas mit <?xml stehen wird, wahrscheinlich:

    <?xml version="1.0" encoding="utf-8" ?> oder
    <?xml version="1.0" encoding="iso-8859-1" ?>

    Ersetz dann diese Zeile durch
    <?= "<?xml version=\"1.0\" encoding=\"iso-8859-1\" ?>\r\n" ?>
    oder eben utf-8 statt iso-8859-1.

    Wichtig: Die \ vor den " (aber nicht vor allen, siehe oben).
     
  6. inglewood14

    inglewood14 Königsapfel

    Dabei seit:
    23.10.06
    Beiträge:
    1.216
    <?xml version="1.0" encoding="utf-8" ?>

    Das steht schonmal da.

    Mit welchem Programm kann ich das ändern? Textedit funktioniert dabei leider nicht.
     
  7. Nordapfel

    Nordapfel Pomme Etrangle

    Dabei seit:
    03.09.06
    Beiträge:
    912
    Öhm. Öh. Keine Ahnung, hat man in iWeb keinen Zugriff auf den Quellcode? Dann wüsst ichs nicht. Vielleicht mal sowas wie Smultron oder irgendeinen anderen Webeditor probieren.
     
  8. inglewood14

    inglewood14 Königsapfel

    Dabei seit:
    23.10.06
    Beiträge:
    1.216
    Ich sag's mal so, iWeb ist ziemlich simpel. Aber ich verstehe nicht warum die eine Zeile solche Probleme verursacht.
     
  9. Nordapfel

    Nordapfel Pomme Etrangle

    Dabei seit:
    03.09.06
    Beiträge:
    912
    Ganz einfach: Die HTML Datei wird (weil dein Provider/Hoster das so eingestellt hat) auch durch den PHP Parser gejagt. PHP Code kann man z.B. durch <?php einleiten, aber auch durch <? .
    Jetzt denkt der PHP Parser, dass <?xml einen PHP Teil einleitet - tut er ja aber nicht, sondern einen "XML Teil", der vom PHP Parser eigentlich ignoriert werden sollte.

    Die Lösung, die ich gepostet habe, tut einfach folgendes: Mit dem Code wird dieses <?xml ... einfach mit PHP ausgegeben und daher nicht durch den Parser geschickt.
    Klingt vielleicht kompliziert, ist aber so :)
     
  10. inglewood14

    inglewood14 Königsapfel

    Dabei seit:
    23.10.06
    Beiträge:
    1.216
    Ich probier's einfach nochmal. Wenn's nicht klappt ist es mir auch egal. Keine Lust mehr.

    Ich danke dir Nordapfel, durch dich habe ich wieder was gelernt.;)

    Danke für die Hilfe. Wahrscheinlich bin ich einfach zu blöde dazu, oder es liegt an iWeb. Hehe.