GELÖST: High Sierra Bug

Dieses Thema im Forum "macOS & OS X" wurde erstellt von Mr.iPad, 27.09.17.

  1. Mr.iPad

    Mr.iPad Gala

    Dabei seit:
    28.09.12
    Beiträge:
    53
    Hallo zusammen,
    hab gerade eine Bug unter High sierra gefunden auf meinem neuen MacBook Pro 2017er: Wenn man unter Benutzer&Gruppen den Gastaccount deaktiviert, erscheint mein neustart nun statt keinem Gastaccount nun 2 Gastaccounts, wobei das "Profilbild" des einen Gastaccount wie ein Störbild aussieht. Schaltet man den Gastaccount wieder ein, kommt wie gehabt nur ein Account zum vorschein beim Neustart...hatte jemand schon sowas? (Vlt schaffe ich es ja ein bild hier anzuhängen)[​IMG]
    EDIT: Hab das schonmal im High Sierra Sammelthread gepostet, aber irgendwie scheint man da ignoriert zu werden
     

    Anhänge:

  2. froyo52

    froyo52 Galloway Pepping

    Dabei seit:
    11.07.14
    Beiträge:
    1.352
    Kann ich bei mir so nicht nachvollziehen, weder auf dem MacBook Pro noch auf dem iMac 27" 5k
     
  3. ottomane

    ottomane Königlicher Kurzstiel

    Dabei seit:
    24.08.12
    Beiträge:
    10.144
    Das passiert bei mir auch nicht. Wie viele Gästeverzeichnisse siehst du denn unter /Users auf der SSD?
     
    #3 ottomane, 28.09.17
    Zuletzt bearbeitet: 28.09.17
  4. Marcel Bresink

    Marcel Bresink Altgelds Küchenapfel

    Dabei seit:
    28.05.04
    Beiträge:
    4.098
    Es wäre auch interessant zu wissen, ob das Bild den Anmeldeschirm (nach dem Start) oder die FileVault-Freischaltung (vor dem Start) zeigt.
     
    Mr.iPad gefällt das.
  5. Mr.iPad

    Mr.iPad Gala

    Dabei seit:
    28.09.12
    Beiträge:
    53
    Ich vermute auch das es etwas mit FileVault zu tun haben könnte. Es ist der Bildschirm den man nach dem Start des MacBooks bekommt und dann den User auswählt und dann lädt er (mit dem weißen Balken ja mittlerweile unter High Sierra)
    Ich habe nun filevault deaktiviert, hatte es eben bei dem erstmaligen aufsetzen des MacBooks aktiviert (wieso auch immer ich dummkopf), aber die Entschlüsselung dauert eben stunden und ich möchte die Batterie meines neuen MacBooks nicht jetzt stundenlang dauerhaft laden wenn er eig voll ist...
    ich melde mich nochmal nachdem filevault komplett aus ist
     
  6. ottomane

    ottomane Königlicher Kurzstiel

    Dabei seit:
    24.08.12
    Beiträge:
    10.144
    Nochmal die Frage:

    Ob er voll ist oder nicht spielt überhaupt keine Rolle. Benutze ihn einfach. Ich misshandele meinen Akku seit 5 Jahren genau so und er ist immer noch gut.
     
    joe024 gefällt das.
  7. Mr.iPad

    Mr.iPad Gala

    Dabei seit:
    28.09.12
    Beiträge:
    53
    Meinst du einfach im Finder und dann unter "Benutzer"? Also da ist einmal mein account, dann ein Folder "Gast" und noch ein Folder "Geteilt"
     

    Anhänge:

    silver1000 gefällt das.
  8. Marcel Bresink

    Marcel Bresink Altgelds Küchenapfel

    Dabei seit:
    28.05.04
    Beiträge:
    4.098
    Das dauert Stunden und ist unnötig. Es dürfte sich hier um einen üblichen Konflikt zwischen der Benutzerdatenbank von FileVault und der Benutzerdatenbank von macOS handeln. Bei einem klassischen System sind diese Daten auf der Recovery-Partition gespeichert, bei einem APFS-Container im sogenannten "Preboot-Volume". Oft reicht es, diesen Datenbanken neu abzugleichen.

    Das ist auch zu empfehlen, besonders wenn eine SSD zum Einsatz kommt.
     
  9. Mr.iPad

    Mr.iPad Gala

    Dabei seit:
    28.09.12
    Beiträge:
    53
    OK und wie mache ich dieses "abgleichen"? Bzw wie kann ich gerade vergleichen was du erklärt hast
    Danke schonmal
     
  10. Mr.iPad

    Mr.iPad Gala

    Dabei seit:
    28.09.12
    Beiträge:
    53
    UPDATE: Nachdem filevault nun deaktiviert ist und mit dem entschlüsseln fertig ist ist das Problem weg, alles wie gehabt
    nach dem einschalten steht da mein Profil und "Andere" weil ich ja nun den Gastaccount deaktiviert habe

    Jetzt funktioniert auch das automatische anmelden, was vorher auch nicht ging
    Danke für die Hilfe trotzdem
     
  11. Marcel Bresink

    Marcel Bresink Altgelds Küchenapfel

    Dabei seit:
    28.05.04
    Beiträge:
    4.098
    Nein, das Problem ist noch da und ungelöst, Du kannst es jetzt nur nicht mehr sehen, da statt der Eingabe zur Entschlüsselung der Festplatte jetzt die Anmeldung von macOS aufgerufen wird.

    Auch das ist nicht ganz richtig. Wenn FileVault eingeschaltet ist, erfolgt standardmäßig immer eine automatische Anmeldung in macOS. Vor dem Start des Betriebssystems musst Du Dich jedoch bei FileVault identifizieren, um an den Schlüssel zur Entschlüsselung der Systemplatte zu kommen.

    Ein mobiler Rechner mit SSD sollte immer mit FileVault betrieben werden.
     
    froyo52, maddi06 und ottomane gefällt das.
  12. Raschie

    Raschie Cripps Pink

    Dabei seit:
    27.12.15
    Beiträge:
    151
    Warum?
     
  13. Marcel Bresink

    Marcel Bresink Altgelds Küchenapfel

    Dabei seit:
    28.05.04
    Beiträge:
    4.098
    Weil bei einem mobilen Gerät grundsätzlich das Risiko höher ist, dass man es verliert, oder dass es gestohlen wird. Die Verschlüsselung schützt die Daten in diesem Fall. Bei gewerblicher Nutzung kann es sogar als Verletzung der gesetzlichen Sorgfaltspflichten gelten, dies nicht zu tun.

    Zum anderen gibt es bei SSDs das technische Problem, dass diese bei einem späteren Weiterverkauf des Computers nicht ohne Weiteres gelöscht werden können. Ein Neuformatieren mit Wegwerfen des FileVault-Schlüssels löst dieses Problem auf sichere Weise.
     
    Wuchtbrumme und doc_holleday gefällt das.
  14. Raschie

    Raschie Cripps Pink

    Dabei seit:
    27.12.15
    Beiträge:
    151
    @Marcel
    Teil 1 deiner Erklärung ist klar.
    Tei 2 wusste ich nicht. Danke.


    Wie ist das zu verstehen?
     
  15. Marcel Bresink

    Marcel Bresink Altgelds Küchenapfel

    Dabei seit:
    28.05.04
    Beiträge:
    4.098
    Bei einer SSD gibt es aus technischen Gründen keine Möglichkeit, auf sämtliche Blöcke des Flash-Speichers zuzugreifen, mit denen die Sektoren einer herkömmlichen Platte simuliert werden. Deshalb kann man auch nicht alle Blöcke löschen.

    Das geht nur dann, wenn die SSD eine Sonderfunktion namens "Secure Erase" unterstützt und man auch Software hat, diese Funktion aufzurufen. In macOS ist ein solches Programm nicht enthalten, d.h. mit Bordmitteln geht es nicht.

    Ist die SSD dagegen mit FileVault verschlüsselt, wird kein unverschlüsselter Datenblock abgespeichert. Wirft man sozusagen den Schlüssel weg, ist die SSD unlesbar, obwohl sie nicht gelöscht wurde.
     
    ottomane, Wuchtbrumme und ken-wut gefällt das.
  16. Wuchtbrumme

    Wuchtbrumme Prinzessin Louise

    Dabei seit:
    03.05.10
    Beiträge:
    10.767
    Wenn man Zugriff auf das gebootete System hat, sollte es reichen, in die Einstellungen Sicherheit/FileVault zu gehen und die Einstellungen dort (Benutzer aktivieren) vorzunehmen.

    Untenstehend ist dieselbe Prozedur, die ich für das "Disk Password" nach der High Sierra-Installation verwendet habe. Das könnte so gehen:
    1. In die Recovery-Partition booten
    2. Terminal öffnen. "diskutil apfs list" aufrufen und das Bootlaufwerk (z.B. Macintosh HD) finden.
    3. "diskutil apfs unlockvolume <disk>" auf das Bootlaufwerk loslassen, mit dem üblichen Passwort authentifizieren.
    4. Am Ende "diskutil apfs updatePreboot" auf das entsperrte Bootlaufwerk loslassen.
     
  17. iTiger97

    iTiger97 Tokyo Rose

    Dabei seit:
    06.07.17
    Beiträge:
    66
    Moin,
    gibt es hierfür eine richtige Lösung? Habe das selbe Problem und die Lösung ist ja eigentlich nur ein Workaround. FileVault deaktivieren ist ja nicht die perfekte Lösung...
     
  18. bountykiller

    bountykiller Ontario

    Dabei seit:
    26.07.12
    Beiträge:
    351
    Ich muss hier sichtlich einmal nachhaken. Ich habe mein System frisch auf eine Samsung 850 Pro installiert und genau das Problem des Threadstarters. Eine richtige Lösung konnte ich nicht rauslesen. Filefault ist aktiviert.

    Gruß
    Bounty
     
  19. DF0

    DF0 Adams Parmäne

    Dabei seit:
    23.04.11
    Beiträge:
    1.298
    Bei mir habe ich neuerdings, nachdem ich meinem Schwager an meinem iMac gezeigt habe, wie man einen Gastaccount anlegt, auch dieses Problem. Super Sache...nicht.

    Gastaccount-Icon mit hässlichem Grafikglitch und meinen Zugang daneben. Habe den Tipp von @Wuchtbrumme in der RecoveryPartition angewendet und es hat nur bewirkt, dass kein weichgezeichneter High Sierra-Backdrop bei der Anmeldung zu sehen ist, sondern grau. Der Glitch-Gastaccount ist noch immer da.
     
  20. Hendrik Ruoff

    Hendrik Ruoff Welschisner

    Dabei seit:
    16.03.13
    Beiträge:
    11.671
    das ist kein Gastaccount das einfach der Root user, den deaktivieren dann ist es gut....