1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Firewire Festplatte nach/vor Ruhezustand un-/mounten

Dieses Thema im Forum "macOS & OS X" wurde erstellt von Xcode, 25.02.07.

  1. Xcode

    Xcode Empire

    Dabei seit:
    27.08.06
    Beiträge:
    84
    Hi, ich habe mir gestern eine externe Firewire Festplatte gekauft (WD My Book 500 Pro), da der Platz auf meinem iMac (20" Intel Jan '06, OS X 10.4.8) leider langsam zu Neige ging...

    Angeschlossen, HFS+ formatiert, funktioniert alles... bis auf:

    Wenn ich meinen Mac in den Ruhezustand schicke und anschließend wieder aufwecke, wird die Platte nicht mehr gemountet. Noch besser, ich bekomme die (ich denke mal allen bekannte, daher hänge ich jetzt mal keinen Screen an) Meldung, dass das gerät nicht ordnungsgemäß abgemeldet wurde...

    Das lässt sich doch bestimmt richten, oder?
     
  2. Xcode

    Xcode Empire

    Dabei seit:
    27.08.06
    Beiträge:
    84
    Schade, dass mir da keiner weiterhelfen kann :-[

    Ok, dann was "anderes": Ich hab mir gedacht, dass ich die Platte dann nach dem Ruhezustand per Terminal neu mounte. Als ersten test woltle ich sie dann per Terminal unmounten...

    "sudo umount /dev/disk2s3/" oder auch "sudo umount /volumes/My\ Book/" --> "Device busy."

    Ok, ist zwar kein Finder Fenster und nix offen, aber kann ja sein... über'n Finder rausgeworfen und dann im Terminal das Einbinden versucht:

    "sudo mount -t HFS /dev/disk2s3/ /volumes/" --> wieder "Device busy."

    Wie kann letzteres sein? Die ist doch gar nicht eingebunden o_O


    Würde mich über eure Hilfe freuen ;)
     
  3. saarmac

    saarmac Weisser Rosenapfel

    Dabei seit:
    26.12.05
    Beiträge:
    792
    Ja, also ich denke du musst die platte dann wohl immer unmounten vor dem ruhezustand vll bringt das abhilfe.
    Lager auf die Platte doch einfach selten benötigte Daten aus, dann brauchst du sie garnicht so oft. Oder brauchst du alles jeden tag und ständig?
     
  4. jim502

    jim502 Gast

    hi, hab die wd digital pro II (allerdings die 1TB Variante, auch über Firewire angeschlossen) und habe das Problem nicht. Hast du mal auf der WD Seite geschaut? ( http://support.wdc.com/de/download/index.asp ) Bei meiner gabs eine Firewireaktualisierung zum downloaden, ausserdem hab ich noch zusätzlich den Button Manager installiert, aber kann mir nicht vorstellen das es daran liegt, meine hat afaik auch schon vorher problemlos funktioniert.

    lg
    jim
     
  5. Xcode

    Xcode Empire

    Dabei seit:
    27.08.06
    Beiträge:
    84
    Da sind nur Daten drauf an die ich nciht allzu häufig dran muss.

    Nur kann ich meinen Rechner ja nicht mehr in den Ruhezustand schicken ohne beim Aufwachen eine Fehlermeldung zu bekommen. Und ich möchte die Platte schon (wenn auch nur alle paar Tage in Benutzung) dauerhaft dran lassen. ;)

    Das blöde ist ja, ich bekomme sie nach der Ruhezeit nichtmal mehr ohne den Stecker zu ziehen gemountet. o_O

    Ok, ich habe inzwischen gelesen (bin nebenbei selbst am nachforschen), dass ich die Platte vom automatischen mounten ausschließen kann (--> Stichwort diskarbitrationd). Ist aber auch doof, da ich sollte ich an die Daten wollen schon noch direkt dran kommen möchte (und selbst wenn ich sie nciht mit mounten würde... ich kann sie ja dennoch nciht ohne Stecker ziehen einbinden).


    Wie ist das denn bei den anderen? Funktioniert das bei allen anderen Festplatten? Wenn ja/nein wüsste ich ja schonmal wo ich dran bin^
     
  6. Xcode

    Xcode Empire

    Dabei seit:
    27.08.06
    Beiträge:
    84
    Jo, da war ich schon. Für mich gibt's ne ganze Menge Windows Treiber aber kein Update für'n Mac o_O

    Nun gut, will ich den Button Manager einfach mal installieren... schaden kanns ja nicht^
     
  7. jim502

    jim502 Gast

    jap ^^

    wie schauts denn aus wenn du sie über usb anschließt, funktioniert dann mit dem ruhezustand alles problemlos?

    lg
    jim
     
  8. Xcode

    Xcode Empire

    Dabei seit:
    27.08.06
    Beiträge:
    84
    Ja o_O :-D


    Toll, ich wollte eigentlich einen der beiden Firewire Ports benutzen... die USBs sind nämlich für gewöhnlich voll^^

    Ich schnapp mir gleich mal die Platte von nem Kumpel und teste die mit Firewire... vllt. ruf ich auch noch bei WD an (wenn ich denn mal zu deren geschäftszeiten zu Hause wäre) und frage nach.

    @jim502:

    Danke, auf USB bin ich gar nciht gekommen :-D (wahrscheinlich auch deshalb, weil ich die da gar nciht dran hängen haben möchte)

    Wie hast du deine eigentlich angeschlossen? Firewirre 400 oder 800? Die Pro II ist ja bis auf das 2 Platten drin hängen, ja das selbe.
     
  9. jim502

    jim502 Gast

    hab sie über firewire 800 angeschlossen. allerdings war mir das mitgelieferte kabel zu kurz, also habe ich sie die ersten tagen mit firewire 400 betrieben, auch da ist mir nichts aufgefallen
    jap, einmal direkt bei WD nachfragen kann sicher nicht schaden (aber ob sich die so auskennen?!) :)

    lg
    jim
     
  10. feno

    feno Gast

    Hallo,

    ich habe das selbe Problem mit dem My Book Pro 500GB. Es sieht so als als würde dieser Fehler nur auftreten, wenn die Festplatte vor dem Ruhezustand im Standbymodus war. Ist die Platte im normalen Betriebsmodus wacht sie ordnungsgemäß wieder auf. Da dieses Problem bei anderen Firewireplatten nicht auftritt, ist wohl auf einen Bug in der Firmware bzw. Hardware zu schließen.

    Folgende Lösungsmöglichkeiten bieten sich an:
    1.) statt Firewire USB verwenden
    2.) Standby aller Platten abschalten
    3.) Kurz vorm Ruhezustand auf die Platte zugreifen

    Ich habe mich für Möglichkeit 3 entschieden und lasse durch das Programm Sleepwatcher, dass vor dem Ruhezustand das Script .sleep aufruft einen Ordner auf der Platte erstellen, der sofort wieder gelöscht wird. Das geschieht anscheinend auf dem Plattencach, da die Platte nicht mehr anläuft bevor der Mac in den Ruhezustand geht. - Schön ist die Lösung trotzdem nicht. Bleibt nur zu hoffen das WD nachbessert.

    Gruß Feno
     
    1 Person gefällt das.
  11. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.897
    Unter OS X läuft ein BSD Automounter. D.h.: Der manuelle Eingriff mit mount/umount ist für solche Medien tabu.

    man diskutil

    diskutil eject ${Volume}|${Device}
    diskutil unmount ${Volume}
    diskutil mount ${Device}

    (Grundsätzlich ohne sudo)
     
  12. Pluto

    Pluto Roter Delicious

    Dabei seit:
    09.10.06
    Beiträge:
    95
    Hallo zusammen,

    ich habe mir vor kurzem eine MacPower Pleiades Super Combo-S gegönt, bin so weit acuh ganz zufrieden mit dem Gehäuse. Im Gehäuse werkelt eine Samsung Spinpoint T166.
    Nun habe ich aber folgendes Problem beobachten können, sobald die Platte einmal in den Ruhezustand gegangen ist, kann über das gemountete Laufwerk auf dem Desktop nicht mehr auf sie zugegriffen werden. Es wird zwar noch die Übersicht geöffnet, allerdings fährt sie nicht mehr hoch bzw. fährt hoch aber lässt nichts mehr mit sich machen und blockiert da bei das ganze System.
    Ein/Ausschalten des Pleiades Gehäuse bringt sie wieder zurück ins leben.

    Die Platte ist über FW800 mit meinem Macbook Pro verbunden. OS X ist auf dem neusten stand und ein Firmware Update scheint es auch nicht zugeben. Irgendwie scheint es sich um ein ähnliches Problem wie es hier besprochen wird zu handeln.
    Bin um jede Hilfe dankbar.

    Gruss Pluto
     
    #12 Pluto, 13.04.07
    Zuletzt bearbeitet: 13.04.07
  13. QuickMik

    QuickMik Stahls Winterprinz

    Dabei seit:
    30.12.05
    Beiträge:
    5.189
    also von denen hab ich auch einige rödeln.
    auch mit samsung.

    kenne das prob nicht!
    tausch das gehäuse um...
     
    #13 QuickMik, 14.04.07
    Zuletzt bearbeitet: 14.04.07
  14. Stalker

    Stalker Empire

    Dabei seit:
    17.10.06
    Beiträge:
    89
    @quickmik: ich habe hier n taurus-gehäuse von macpower mit ner 400er pladde von samsung drin (ja, die mit 16mb cache ;) ).das gehäuse hängt per firewire 400 am mac (os x 10.4.9). wenn ich die anschalte, dann dauerts ca 20-30 sek bis die pladde im finder steht. dann kann ich sie auch die nächsten 10 min nich unmounten, da anscheinend irgendein dienst drauf zugreift. lesen/schreiben kann ich dann zwar, aber nicht unmounten. ist das normal? finde auch die wartezeit etwas lang. mit den anderen externen gehäusen habe ich diese dinge noch nicht beobachten können. wenn ich die taurus per usb anhänge meldet sie sich auch schneller an (15-20 sek)
    wie ist das bei deiner platte?

    gruß aus bremen

    micha
     
  15. Pluto

    Pluto Roter Delicious

    Dabei seit:
    09.10.06
    Beiträge:
    95
    @QuickMik: Danke erst einmal. Es ist noch zusagen, dass unter Windows der Ruhezustand korrekt funktioniert, von dem her gehe ich nicht zwingend von einem Defekt aus.

    Edit: Ist die Platte über den USB Anschluss verbunden, scheint es auch kein Problem zu sein. Also mal wieder nur über FW400/800 ein Problem!!!
     
    #15 Pluto, 14.04.07
    Zuletzt bearbeitet: 14.04.07
  16. QuickMik

    QuickMik Stahls Winterprinz

    Dabei seit:
    30.12.05
    Beiträge:
    5.189
    also ich kann mir nur vorstellen, das du vielleicht filesharing aktiv hast oder das der spotlight den index erneuern will.

    USB kann ich nicht beantworten.
    platten hänge ich nur an FW. USB (egal ob 1 oder 2) ist bei mir für tastatur und maus "reserviert" ;)
     
  17. Pluto

    Pluto Roter Delicious

    Dabei seit:
    09.10.06
    Beiträge:
    95
    QuickMik eine Frage, wie sind bei dir die Energieeinstellungen?
    Hast du "Wenn möglich Ruhezustand der Festplatte(n) aktivieren" aktiviert oder nicht?
    Und was geschieht bei dir wenn du den ganzen Rechner in den Ruhezustand versezt und dann wieder weckst, mounted er die Platten so dass sie zu gebrauchen sind?
     
  18. QuickMik

    QuickMik Stahls Winterprinz

    Dabei seit:
    30.12.05
    Beiträge:
    5.189
    also ich müsste das alles mal dezitiert prüfen.
    ich hab die dinger meistens am server hängen.
    da ist nix mit ruhezustand.
    nachdem ich aber einen guten kontakt zum macpower disti hab.....

    werde ich das mal mit ihm zusammen prüfen......

    hier was zum schmökern
    http://www.apfeltalk.de/forum/lacie-big-disk-t54009-4.html#post506535
    http://www.apfeltalk.de/forum/lacie-big-disk-t54009-4.html#post523457

    ciao
    mike
     
  19. Pluto

    Pluto Roter Delicious

    Dabei seit:
    09.10.06
    Beiträge:
    95
    Wow, danke dir QuickMik.
    Warte dann mal voller Hoffnung auf deine Auswertung.
    Ich selber werde heute noch versuchen die Platte neu zu formattieren und schauen ob es etwas bringt!! (Habe aber kaum Hoffnung!!)

    Meine Platte wird am MBP wohl nie solch hohe Übertragungsratten hinkreigen--> interne Platte wird sie ausbremsen.

    Gruss
    Pluto

    EDIT: Habe hier noch ein weiteres Topic gefunden, in welchem ein ähnliches Problem behandelt wird.
    http://www.apfeltalk.de/forum/externe-hdd-schlaeft-t77067.html
     
    #19 Pluto, 15.04.07
    Zuletzt bearbeitet: 15.04.07
  20. QuickMik

    QuickMik Stahls Winterprinz

    Dabei seit:
    30.12.05
    Beiträge:
    5.189
    so isses.
    FW ist einfach ein super bussystem.
    USB ist dagegen ein saudummer.
    alleine, weil er den prozessor der kiste belastet.
    wer kann das schon brauchen....
     

Diese Seite empfehlen