1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

Diablo2 Mac OS 10.5

Dieses Thema im Forum "Spiele" wurde erstellt von Ciaokurve, 01.04.08.

  1. Ciaokurve

    Ciaokurve Granny Smith

    Dabei seit:
    01.04.08
    Beiträge:
    13
    Hi,
    ich versuche Diablo2 auf meinem neunen MacBookPro ans laufen zu bekommen. Ich habe dn Installer von Bizzard benutzt und danach das neuste Update aufgespielt.
    Wenn ich das Spiel zu starten versuche, kommt:
    "Das Programm "Diablo II" wurde unerwartet beendet. Mac OS X und andere Programme sind nicht betroffen." Ich kann also gar keien Grafikmodus oder sonst etwas einstellen. Blizzard hat mir auch noch nicht geantwortet
    Ausserdem habe ich in diversen Foren nach einer Lösung gesucht, aber scheinbar hat noch niemand eine reproduzierbare Lösung gefunden. Oder doch?
    Falls ihr Infos über meine Hardware braucht gebt Bescheid.
    Danke
    Christoph
     
  2. arctic camel

    arctic camel Cripps Pink

    Dabei seit:
    28.10.07
    Beiträge:
    154
    Du hast also Diablo2 mit Lord of Destruction. Hast den Carbon installer benutzt und Komplettinstallation ausgewählt? Als nächstes solltest du kein Patch aufspielen sondern Dia starten (im Software Rendermodus) und mit dem Battle-net verbinden dabei wird das aktuelle Update aufgespielt.
     
  3. Ciaokurve

    Ciaokurve Granny Smith

    Dabei seit:
    01.04.08
    Beiträge:
    13
    Ich kann das Spiel ja nicht starten. Weder vor der Patchinstallation, noch danach. Sobald das Programm ausgeführt wird, stürzt es auf die beschriebene Weise ab.

    Ja. Ich habe LOD Komplettinstallation ausgewählt.
     
  4. arctic camel

    arctic camel Cripps Pink

    Dabei seit:
    28.10.07
    Beiträge:
    154
    Also auch mit gedrückter ALT-Taste? Es sollte dann immer erst ein Einstellungsfenser erscheinen bevor Dia richtig startet.
    Wenn ja installier es neu. (Bei mir auf meinen MBP läuft es einwandfrei)
     
  5. Ciaokurve

    Ciaokurve Granny Smith

    Dabei seit:
    01.04.08
    Beiträge:
    13
    Ja, auch dann. Ich habs bestimmt schon vier oder fünf mal neu versucht. Kein Patch, verschiedene Patches... nix geht. Als Ausweg hätte ich nur noch Paralles und Windows XP. Aber das ist ja eigentlich Quatsch. Ausserdem funktioniert es auch nicht.

    Irgendwo habe ich gelesen, dass es daran liegen soll, dass ich alles zusammen gekauft habe (Bestseller Games). Also nicht seperat diablo2 und lod. scheint ne andere version zu sein. Kann das sein?
     
  6. arctic camel

    arctic camel Cripps Pink

    Dabei seit:
    28.10.07
    Beiträge:
    154
    Naja ich kann es mir dann auch nicht erklären. Aber es funktioniert mit jeden Hybrid-CD. Und mit einem Bootcamp Windows (Paralles naja) wirst du dass Problem haben, das das Spiel auf das MBP gestreckt wird also trotz OpenGL komisch aussieht.

    Bin mal gespannt auf die Antwort von Blizzard (hoffe hast auf englisch geschrieben), da sie bei meinen Problem (Defekter Installer link) nach 4 tagen geantwortet haben. (Link auf Blizzard-Homepage wurde korriegiert)
     
  7. Damodar

    Damodar Braeburn

    Dabei seit:
    17.12.07
    Beiträge:
    45
    Habe genau das selbe Problem wie du, hast du mittlerweile eine Lösung gefunden?
     
  8. KoniCami

    KoniCami Gast

    Hallo,

    hier genau das gleiche Problem.
    Habe mir auch die Bestseller Version gekauft.
     
  9. ando-x88

    ando-x88 Celler Dickstiel

    Dabei seit:
    29.03.07
    Beiträge:
    799
    Ich habe auch die Bestseller-Version, aber bei mir läuft alles fehlerfrei oO
    Wisst ihr, welche Version von Diablo 2/LOD auf eurer CD ist? Bei mir ist es 1.0.9 (vielleicht machen ja ältere Versionen ärger)
     
  10. Ysuran

    Ysuran Gala

    Dabei seit:
    12.02.08
    Beiträge:
    49
    Das Problem liegt bei 1.5.3... Seitdem können manche Nutzer (ich glaub nur Macbook und iMac-User) kein Diablo und Starcraft mehr starten.
     
  11. atani

    atani Schöner von Nordhausen

    Dabei seit:
    13.11.07
    Beiträge:
    320
    Ich wäre schon glücklich, wenn beide Spiele unter XP laufen würden. :D
    Stürzen leider beide nach einer kurzen Zeit einfach ab... Trotz neustem Update, dass ich übers Battle.net lade.
     
  12. Skilljoy

    Skilljoy Empire

    Dabei seit:
    21.11.06
    Beiträge:
    87
    Ich hab mit meinem MacBook und 10.5.3 keine Probleme bei Diablo.
     
  13. ando-x88

    ando-x88 Celler Dickstiel

    Dabei seit:
    29.03.07
    Beiträge:
    799
    ich auch nicht, nur halt das berühmte openGL-Problem
     
  14. connystahr

    connystahr Golden Delicious

    Dabei seit:
    18.03.08
    Beiträge:
    11
    Hier ein ähnliches Problem:
    Hab ein MacBook und aktuell 10.5.2 drauf und ich komme mit dem Blizzard Installer bis zum installieren von Lord of Destruction. dann kommt allerdings kurz vor Abschluss der Installation folgende Fehlermeldung: Die Datei "/Volumes/Lord of Destruction/Support/Diablo II Expansion Data" konnte nicht gelesen werden, weil Fehler -36 aufgetreten ist.
    Dann kann ich das Fenster nur noch schließen und es ist ein Diablo Ordner vorhanden, der auch ganz volltändig aussieht, allerdings lässt sich das Spiel auch nciht öffnen.
    Muss ich vielleicht erst nur Diablo installieren und später noch mal bei LoD ansetzten? Wüsste allerdings auch nciht was das helfen sollte, weil LoD sich ja vielleicht trotzdem nicht installieren ließe...
    Vielen Dank schon jetzt für die Hilfe.
    C.
     
  15. Augustus

    Augustus Gast

    also das Problem mit dem Macbook und dem 10.5.3 Update für die Spiele Diablo 2, Starcraft und keine Ahnung welche Spiele noch liegt nur bei den neueren Macbooks (ab Ende 2007?) vor.
    Diese haben als Grafikprozessor einen GMA X3100.
    Die älteren Macbooks die noch über den GMA 950 verfügen haben nach dem Update kein Problem.
     
  16. connystahr

    connystahr Golden Delicious

    Dabei seit:
    18.03.08
    Beiträge:
    11
    kennt denn jetzt irgendeiner eine lösung?
     
  17. NinthShakazuma

    NinthShakazuma Jonagold

    Dabei seit:
    15.06.08
    Beiträge:
    20
    also ich hab das gleiche problem mit meinem neuem macbook (2,1 ghz) und habe einfach mal naheliegenderweise bei blizzard geguckt und bin auf diesen thread im battle.net forum gestoßen:

    http://www.battle.net/forums/thread.aspx?fn=support&t=535843&p=1&#post535843

    für alle, die nicht so gut englisch sprechen, fasse ich mal zusammen:

    der mod, der den thread am 11.3.2008 öffnete schrieb (zusammengefasst und sinngemäß):

    Einige MacBook Pro Nutzer haben Probleme mit Diablo II und Starcraft. Seit doch so nett und postet eure Hardwareübersicht in diesem Thread, so dass wir uns das Problem anschauen können.

    Er schrieb dann kurz darauf, dass das Problem auch an Apple weitergeleitet wurde und an einer Lösung gearbeitet werde.

    Dann kam von Blizzard nichts mehr. Die ersten Nutzer beschweren sich über den Support beider Firmen (das übliche Forenverhalten). Dann kommt zwischendurch das 10.5.3. Update und alle hoffen auf die Lösung.

    JETZT WIRD ES INTERESSANT:

    Denn nach dem Update wird es noch schlimmer, weil auf einmal auch iMac und MacBook Nutzer (alle mit Intel CPUs) das Problem haben.

    Nach dem Update kam auch keine neue Antwort von Blizzard, ich denke/hoffe einfach mal, dass sie daran arbeiten, aber wir werden uns wohl noch gedulden müssen.

    Die einzige Möglichkeit besteht also darin, diesen Thread regelmäßig zu besuchen. Hier wird vermutlich als erstes die Lösung des Problems gepostet. Es gibt natürlich auch kein RSS für das battle.net-Forum...

    Wer einen Account im Forum hat, kann natürlich auch sein Hardwareprofil posten, ich habe keinen, weil mein Diablo II (+ LoD) gar nicht starten kann^^

    so schönen sonntag noch :)
     
  18. AgentCyber

    AgentCyber Gast

    Schade wie das so läuft. Ich warte dann mal ab. Hab auch ein neues MacBook.
     
  19. MiSa

    MiSa Gast

    ich up den mal,

    da ich seit heute auch auf das problem gestoßen bin :(
     
  20. Ashura

    Ashura Hildesheimer Goldrenette

    Dabei seit:
    08.08.07
    Beiträge:
    676
    Hilft zwar zu Lösung kaum, leider, aber in unserem Kreise tritt das Problem nur und ausschließlich unter Leopard auf.
    Mein Book wird nun ein Jahr alt, während das vom Kollegen mit Leopard ist.

    Grüße
     

Diese Seite empfehlen