[ATV 4K] Alle zwei Tage keine Internetverbindung

Dieses Thema im Forum "Apple TV" wurde erstellt von SaschaL, 28.09.18.

  1. SaschaL

    SaschaL Golden Delicious

    Dabei seit:
    28.09.18
    Beiträge:
    8
    Hallo,

    ich habe seit einer Woche einen Apple TV 4K mit 64 GB und das Problem, dass ich alle zwei Tage keine Internetverbindung mehr mit dem Gerät habe. Ich verstehe es einfach nicht und bin mit meinem Latein am Ende!

    Das Gerät ist per Netzwerkkabel mit einer FritzBox 6590 Cable mit Fritz OS 7.00 verbunden.

    - am Netzwerkkabel liegt es nicht
    - es ist egal, ob ich bei den Ethernet-Einstellungen auswähle, dass die IP automatisch ermittelt werden soll, oder ob ich sie manuell hinterlege
    - es ist egal, ob ich die FritzBox dem Gerät irgendeine IP-Adresse gibt, oder immer die gleiche
    - es ist egal, welche IP-Adresse ich vergebe
    - Neustarten hilft nicht
    - vom Strom nehmen hilft auch nicht
    - mein gesamtes Netzwerk funktioniert einwandfrei, sowohl WLAN als auch LAN
    - Ich habe im Haushalt etliche Geräte, wirklich mit keinem Gerät habe ich je ein Netzwerk- oder WLAN-Problem gehabt
    - am exakt selben Kabel funktioniert z.B. ein nVidia Shield TV seit Monaten einwandfrei
    - sowohl mit iOS 12.0 als auch mit 12.0.1 besteht das Problem


    Erst, wenn ich die FritzBox neu starte, funktioniert es wieder. Für exakt zwei Tage.

    Ist Apple TV inkompatibel zur FritzBox??? Das ergibt doch keinen Sinn. An der FritzBox ansich kann es auch nicht liegen, da die mit absolut keinem anderen Gerät ein Problem hat und einwandfrei läuft.

    Ist zufällig mein Apple TV defekt, oder ist es ein bekanntes Problem? Finde dazu leider im Netz nicht wirklich was. Die meisten scheinen sowieso WLAN zu verwenden. Möchte aber, da ich in UHD mit Dolby Vision und Dolby Atmos streame, lieber ein solides Netzwerkkabel verwenden.



    Liebe Grüße
    Sascha
     
  2. trexx

    trexx Beauty of Kent

    Dabei seit:
    01.04.13
    Beiträge:
    2.178
    Was für ein Internet Zugang? Mit IPTV?
     
  3. Wuchtbrumme

    Wuchtbrumme Orleans Reinette

    Dabei seit:
    03.05.10
    Beiträge:
    10.336
    Jetzt hast Du schon soviel geschrieben und dennoch ist der Informationsgehalt für Netzwerker sehr dünn. Woran machst Du fest, dass das ATV Probleme hat? Was genau tust Du? Wie äussert sich die Störung? Woran ist die FB verbunden? Direkt mit dem Kabelprovider? Das Kabel ist CAT5e? Die zwei Tage kommen wo her? Geht die Störung von selbst wieder weg nach 10min? Zur selben Zeit gehen die anderen Geräte an der FB? Das ATV ist nicht an Ports 2-4 angeschlossen bzw. der Eco-Modus an der FB ist für die Ports aus?

    Fragen über Fragen...
     
    #3 Wuchtbrumme, 28.09.18
    Zuletzt bearbeitet: 28.09.18
    trexx gefällt das.
  4. Scotch

    Scotch Wöbers Rambur

    Dabei seit:
    02.12.08
    Beiträge:
    6.499
    Du hast ein mDNS-Problem. Entweder hast du mehr als einen DHCP-Server im LAN (Kandidaten sind irgendwelche falsch konfigurierten Time Capsules, Air Ports oder andere APs die vermeintlich als "Verstärker" betrieben werden), oder du hast irgendeinem Gerät eine feste IP aus dem Adressbereich des DHCP-Pools vergeben.

    Wenn das Problem wieder auftaucht an allen Geräten die IP-Adressen heraussuchen - vmtl. findest du eine Dublette. Wohlgemerkt: Du musst das an allen Geräten (Smartphones, Tablets, Repeater, Switches, Computer, ATVs, Spielekonsolen, Receiver, Webcams... - halt jedes Gerät, dass über LAN und WLAN verbunden ist. Es sollten natürlich auch alle Geräte eingeschaltet (und nicht im Standby) sein) überprüfen und zwar an den Geräten selbst - nicht in der Übersicht der FB, die ist in solchen Fällen unbrauchbar.
     
    #4 Scotch, 29.09.18
    Zuletzt bearbeitet: 29.09.18
    dg2rbf gefällt das.
  5. SaschaL

    SaschaL Golden Delicious

    Dabei seit:
    28.09.18
    Beiträge:
    8
    Verstehe die Frage nicht, da sie nichts mit dem Problem zu tun hat. Da ich eine 6590 Cable habe, logischerweise Kabelanschluss ;)

    Alle Antworten und notwendigen Infos stehen in meinem Beitrag! Apple TV hat einfach nach 2 Tagen keine Internetverbindung mehr. Mehr gibt es dazu nicht zu sagen? Ich kann mit dem Gerät nicht mehr aufs Internet zugreifen und somit kein Netflix, Amazon, iTunes, etc. verwenden um zu Streamen. Der Fehler äußert sich darin, dass keine Internetverbindung steht und exakt dies auch als Fehlermeldung geäußert wird. Wenn ich die IP-Adresse automatisch zuweisen lasse, sind die Felder fürs Gateways und für den DNS Server leer, wenn der Fehler da ist. Wenn alles einwandfrei funktioniert, werden dort die IP-Adresse meiner FritzBox (192.168.178.1) angezeigt. Wenn ich die Daten alle manuell eingebe, stehen sie auch weiterhin alle dort.

    Woher die 2 Tage kommen? Weiß ich nicht. Ist eine Beobachtung, dass es an jedem 2. Tag nicht mehr geht. Und ja, hab gesagt, dass ALLE Geräte IMMER seit EH UND JE funnktionieren. Ausschließlich, und wirklich nur ausschließlich Apple TV hat das Problem. Und nein, natürlich nicht auf ECO-Mode. Ist an Port 1 und alle anderen Ports stehen auch auf 1 Gbit/s und nicht auf ECO (100 Mbit/s).


    Kann ich auch alles ausschließen und ist auch nicht das Problem. Es gibt keine doppelt vergebenen IP-Adressen. Dass es daran nicht liegen kann, steht auch im ersten Beitrag, da ich sagte, dass das Problem bei JEDER IP-Adresse besteht, die ich vergebe und ebenso, wenn die FritzBox dem Gerät beliebige IP-Adressen geben darf, als auch wenn eine feste IP-Adresse von der FritzBox aus vergeben wird. Es existiert nur ein DHCP-Server, nämlich der von der FritzBox. Andere Apple-Geräte, Server, NAS, etc. besitze bzw. betreibe ich nicht.

    Wie gesagt: JEDES Netzwerk-Gerät funktioniert immer einwandfrei und es kommen ständig neue hin zu. Erst vor ein paar Tagen ein neues Smartphone, eine neue Smartwatch, etc. pp. Jedes Gerät bekommt seine neue eigene IP-Adresse und alles läuft.

    Nur und ausschließlich Apple TV zickt alle 2 Tage rum.
     
  6. trexx

    trexx Beauty of Kent

    Dabei seit:
    01.04.13
    Beiträge:
    2.178
  7. Scotch

    Scotch Wöbers Rambur

    Dabei seit:
    02.12.08
    Beiträge:
    6.499
    Ich bin 'raus, ich hab' keine Zeit für deine Renitenz. Wenn du dein Problem nicht gelöst bekommst, die Schritte aus #4 durchführen.

    Bei mir auch. Inklusive ATV. Deiner "Logik" folgend ist der einzig mögliche Schluss, dass du KEIN Problem haben KANNST, denn bei mir funktioniert schließlich JEDES Gerät.

    Ciao.
     
  8. SaschaL

    SaschaL Golden Delicious

    Dabei seit:
    28.09.18
    Beiträge:
    8
    Keine Ahnung, was du für ein Problem hast. Kann man auch freundlich bleiben? Was kann ICH dafür, wenn es nicht daran liegt? Soll ich jetzt extra dafür sorgen, dass es so ist, wie du meinst? Bist du dann zufrieden, oder was ist bitte dein Problem?

    Ich habe alles durchgetestet und JEDE nur erdenkliche Möglichkeit durchprobiert und durchgetestet. Ich bin Software-Entwicklungsleiter und habe Informatik studiert. Ich habe, wie ich nun schon mehrfach gesagt habe, ALLES wissenswertes im ersten Post stehen. Dort steht exakt jede Antwort auf jede bisher gestellte Frage! Natürlich muss man dafür auch in der Lage sein den Beitrag komplett durchzulesen.

    Und wenn ich sage, dass ich das alles ausschießen kann, dann ist es so. Was ist daran so schwer zu verstehen? Es ist ein deutscher Satz, den jeder versteht. Er bedeutet, dass ich die von dir genannten Punkte als Ursache ausschließen kann, da ich das alles bereits überprüft und getestet habe und es nicht daran liegt. Tut mir Leid, dass das von dir genannte Problem nicht die Ursache ist und du nun eingeschnappt bist, dass es nicht daran liegt!
     
  9. Scotch

    Scotch Wöbers Rambur

    Dabei seit:
    02.12.08
    Beiträge:
    6.499
    Na, ich wusste doch nicht, dass hier ein solcher "Experte" unterwegs ist. Gar ein SW-Entwicklungsleiter (dann musst du ja quasi ein Netzwerkexperte sein) - ich erstarre vor Ehrfurcht.

    Da will ich doch mal gleich ganz kleine Brötchen backen und schüchtern fragen: Warum guckst du Crack dir dann nicht einfach die ARP Requests an, wenn du doch dermassen die Weisheit mit Löffeln gefressen hast und dich so gut auskennst?! Das macht man nämlich als "Experte" mit deinem Problem normalerweise so, bevor man eine dermaßen dünne Fehlerbeschreibung wie deinen OP abliefert.

    Und was ich für ein Problem mit dir habe? Du stellst eine Frage und BRÜLLST DANN HIER RUM wenn dir zu helfen versucht wird.

    Realsatire?!

    Und jetzt bin ich wirklich 'raus.
     
    saw, Balkenende und dg2rbf gefällt das.
  10. SaschaL

    SaschaL Golden Delicious

    Dabei seit:
    28.09.18
    Beiträge:
    8
    Wäre schön, wenn du in der Lage wärst sachlich zu bleiben und nicht mit Beleidigungen um dich zu werfen. Ich habe jegliche Hilfe dankend angenommen und zu jedem Vorschlag Feedback gegeben und mitgeteilt, dass es daran nicht lag. Dann fingst du wie ein kleines Kind an rum zu heulen und mich zu beleidigen, anstatt sachlich zu bleiben. Keine Ahnung, was nach wie vor dein Problem ist und wieso du solch eine soziale Inkompetenz an den Tag legst.

    Es wäre schön, wenn man hier sachlich über das Problem diskutieren kann.

    Fakt ist, dass es nicht an dem von dir genannten liegt. Das habe ich mitgeteilt. Wie gesagt, tut es mir Leid, dass deine Welt dadurch nun erschüttert ist, weil du dir soooo sicher warst und am Ende es doch nicht daran lag.

    Es bleiben vermutlich nur zwei Möglichkeiten offen:
    - Mein Apple TV hat wirklich ein Problem und muss ausgetauscht werden, da anscheinend sonst keiner das Problem hat?
    - Es gibt wirklich ernsthaft eine Inkompatibilität mit meiner FritzBox und Apple TV. Ggf. erst seit dem Fritz OS 7.0 (vor hatte ich ja noch kein Apple TV und wie gesagt, habe ich ansonsten keine Apple-Produkte im Haushalt).

    Bei macuser.de haben sich übrigens zwei gemeldet, die das gleiche oder ähnliche Problem haben. Könnte also wirklich an FritzOS 7 oder iOS 12 liegen und nur in bestimmten Konstellationen auftreten. Übrigens, man mag es kaum glauben: Dort hat man mir nett geantwortet und mich nicht wie du gleich so angefeindet ;) Also, geh mal an die frische Luft, amte tief durch und lies dir noch mal alles in Ruhe durch und bleib bitte sachlich, dann führt dieser Thread auch zu einem sinnvollen Ergebnis ohne Beleidigungen ;) Auf so ein Niveau habe ich nämlich wahrlich keine Lust ;)
     
  11. jd68

    jd68 Erdapfel

    Dabei seit:
    01.10.18
    Beiträge:
    3
    Hallo SaschaL,

    für einen neutralen Leser dieses Threads klingt obiges Zitat sehr sarkastisch. In deinen Kommentaren ist kein "Danke" zu finden. Und in deinem Feedback unterstellst du jedem (direkt oder indirekt), dass er nicht lesen kannst. Das ergibt für den Leser einen ziemlich rüden Ton deinerseits.

    Deine Fehlermeldung ist nicht wirklich informativ, auch wenn du viel schreibst. Es fehlen schlicht die Details, die zur Fehlerermittlung notwendig sind. Kein Mensch kann deine Gedanken lesen und weiß, was du alles versuchst hast. Wie man aus deiner Bemerkung, "dass das Problem bei JEDER IP-Adresse besteht, die ich vergebe und ebenso, wenn die FritzBox dem Gerät beliebige IP-Adressen geben darf, als auch wenn eine feste IP-Adresse von der FritzBox aus vergeben wird" schließen soll, dass keine IP-Adresse doppelt vergeben wurde, erschließt sich mir nicht.

    Wenn ich bei der Arbeit eine Fehlermeldung wie die deine bekomme, dann geht die zurück mit der Bitte nach detaillierten Informationen, z.B. Logfiles. Was steht in den Logfiles der FritzBox (eventuell Debugging Mode einschalten)? Sind es exakt 48 Stunden oder nur ungefähr zwei Tage? Stelle Wireshark-Trace im Fehlerfall zur Verfügung (einmal Neustart des AppleTV und dann den Neustart der FritzBox).

    Das gilt auch für dich.

    Ciao,
    Jens
     
    trexx gefällt das.
  12. SaschaL

    SaschaL Golden Delicious

    Dabei seit:
    28.09.18
    Beiträge:
    8
    Nur, weil ich nicht Danke gesagt habe, heißt es doch nicht, dass ich Hilfe nicht dankend annehme. Es geht doch darum, dass Vorschläge gemacht wurden bzw. behauptet wurde, woran es liegt und ich sagte, dass es nicht dran liegt. Was ist daran schlimm? Wieso muss man mich dann angreifen und beleidigend werden und eingeschnappt sein, weil es nicht an dem vermuteten Problem liegt? Da kann ich doch nichts für.

    Ansonsten wurden Fragen gestellt, die im ersten Post beantwortet wurden.

    Ja, die Frage, ob eine IP doppelt vergeben wurde, kann man stellen und die kann ich klar mit Nein beantworten. Ausschließlich auf diese Frage bezogen war meine Antwort nicht gemeint, dass alles im ersten Post steht, aber im Prinzip sagt die Aussage, dass ich jede IP-Adresse getestet habe, sehr wohl aus, dass es nicht an einer doppelten liegen kann, da es gar nicht möglich wäre, dass jede ausprobierte IP-Adresse bereits vergeben wäre, denn dann wäre mein Netzwerk komplett voll ;)

    Ob es genau 48h sind, kann ich nicht sagen. Jetzt, nachdem ich grade die FritzBox neu gestartet habe, funktioniert es nun. Morgen wird es auch noch funktionieren. Übermorgen wieder nicht. Exakt 48h kann ich daher nicht messen, da ich es ja immer nur zu unterschiedlichen Zeiten (Beruf, privates Leben, etc.) testen kann. Ich weiß nur, dass es jetzt die ganze Zeit wieder klappen wird und morgen definitiv auch noch.

    Sobald das Problem wieder auftaucht, werde ich noch mal über die FritzBox mit den Diagnose-Daten und Wireshark wie von dir vorgeschlagen gucken.

    Im Anhang ist ein Foto, wo man sieht, wie Apple TV plötzlich keine Verbindung mehr hat und keine IP-Adresse mehr vom Router erhält und keinen DNS-Server mehr hat. Die Subnetzmaske ist ebenfalls dann falsch. Wenn ich hingegen manuell alle Daten (IP-Adresse, Gateway, DNS-Server, Subnetzmaske) eintrage, bleiben die Werte zwar stehen und werden anzeigt, aber dennoch funktioniert jeglicher Netzwerkzugriff seitens Apple TV nicht mehr.

    In diesem Zustand hilft ausschließlich ein Neustart der FritzBox. Neustarten von Apple TV, Stromstecker vom Apple TV ziehen, andere IP-Adresse eintragen, etc. hilft alles nichts. Es ist auch egal, ob ich in der FritzBox eine andere IP-Adresse für Apple TV dann zuweisen lassen. Egal, was ich mache, ausschließlich ein Neustart der FritzBox hilft.

    Das lässt ja dann eher ein Problem mit der FritzBox vermuten. Merkwürdig ist dann jedoch, dass es absolut ausschließlich nur mit diesem Apple TV auftritt und auch nichts mit einer speziellen IP-Adresse hat, sondern ausschließlich auf dieses Gerät bezogen ist. Auch das Gerät selbst hab ich schon aus der FritzBox entfernt, damit es nicht irgendeine falsche Zuordnung im Cache hat.

    Vielleicht ist es auch nur ein Bug in Fritz OS 7.0. Verstehe dann halt nur nicht, wieso es sich auf ein einziges Gerät immer und immer wieder beschränkt. Da gibt es für mich noch keinen logischen Zusammenhang. Logischer wäre, wenn es vereinzelt bei irgendeinem Gerät auftritt oder bei bestimmten IP-Adressen.
     

    Anhänge:

  13. jsoul

    jsoul Roter Stettiner

    Dabei seit:
    25.08.08
    Beiträge:
    969
    Hast du dein ATV mal komplett zurückgesetzt und neu eingerichtet? Nicht das sich bei den Netzwerkeinstellungen irgendwo ein Bug eingeschlichen hat.
     
  14. SaschaL

    SaschaL Golden Delicious

    Dabei seit:
    28.09.18
    Beiträge:
    8
    Nein, hab ich noch nicht ausprobiert.

    Anbei der Mitschnitt der FritzBox, während Apple TV wieder kein Internetzugriff hat.
     

    Anhänge:

  15. jd68

    jd68 Erdapfel

    Dabei seit:
    01.10.18
    Beiträge:
    3
    Dein AppleTV reagiert nicht auf den DHCP OFFER. Normalerweise müsste ein DHCP REQUEST (oder DHCP DECLINE) kommen. Direkt danach schickt er vier ARP Queries (die von der FritzBox beantwortet werden) und etwas später noch zwei mDNS Queries. Es sieht so aus, als ob AppleTV und FritzBox aneinander vorbeireden.

    Falls die Neueinrichtung des AppleTV nicht hilft, würde ich mich an Netzwerk-Spezialisten (z.B. AVM) wenden.
     
  16. Scotch

    Scotch Wöbers Rambur

    Dabei seit:
    02.12.08
    Beiträge:
    6.499
    Schön zu sehen, dass seine eigenen Logs meine Diagnose aus #4 bestätigen :D
     
    double_d gefällt das.
  17. SaschaL

    SaschaL Golden Delicious

    Dabei seit:
    28.09.18
    Beiträge:
    8
    Ändert nichts daran, dass nicht ich das Problem habe (Fehlkonfiguration, etc. pp., wie vermutet wurde), sondern es ein Fehler der FritzBox oder des Apple TV ist.

    Zurücksetzen hat übrigens auch nichts gebracht. Auch hier war ein Neustart der FritzBox notwendig, damit überhaupt die Einrichtung des Apple TV funktioniert, da er auch hier keine IP-Adresse vom DHCP-Server bekam.

    Werde mich nun an AVM wenden, da offensichtlich ein Fehler in der aktuellen Firmware vorliegt, wobei ich weiterhin nicht verstehe, wieso der Fehler immer und ausschließlich nur mit dem Apple TV auftritt.
     
  18. cosmo58

    cosmo58 Antonowka

    Dabei seit:
    12.03.15
    Beiträge:
    354
    Moin..
    Bei mir war ein ähnliches Problem. Jeden zweiten Tag bekam Madame einen Schreikrampf, wenn sie mit Prime ihre Serien streamte und dann mitten drin nichts mehr ging.
    Konfiguration:
    Fritzbox 7430 (eine 7390 noch als Wlan-Repeater)
    Apple TV4
    (beide bekamen noch einen Tag zuvor ihre Firmware-Updates auf die neueste Version)

    Nachdem ich alle üblichen Verdächtigen ausgeschlossen habe, alle Geräte neu aufgesetzt und selbst die Billig-HDMI-Strippe vom ATV4 zum TV gegen ein hochwertiges ausgetauscht hatte, fiel mir in meiner Blindheit auf, dass in dem Moment der Unterbrechung das ATV4 eine IP-Adresse eingetragen hatte, die überhaupt nicht in meiner Fritzbox-Range (192.168.178.xx) liegt sondern mit 169.254.1.xx begann.
    Wieso diese Zuweisung erfolgte, das weiss ich bis heute nicht. Laut AVM ist 169.254.1.1 eine "Notfall-Adresse" der FB.

    https://avm.de/service/fritzbox/fri...1_Benutzeroberflaeche-der-FRITZ-Box-aufrufen/

    Mein Workaround: dem ATV4 in der Fritzbox eine feste IP zugewiesen, seit ca. zwei Wochen funktioniert es störungsfrei.
     
    SaschaL gefällt das.
  19. SaschaL

    SaschaL Golden Delicious

    Dabei seit:
    28.09.18
    Beiträge:
    8
    Danke fürs Feedback. Leider hat das bei mir nicht funktioniert. Ich habe sowohl ausprobiert, dass ich seitens der FritzBox eine feste IP für den Apple TV vergebe, als auch umgekehrt, dass Apple TV eine feste IP-Adresse eingetragen bekommt. Das Ergebnis war leider immer gleich :(
     
  20. jd68

    jd68 Erdapfel

    Dabei seit:
    01.10.18
    Beiträge:
    3
    Das kannst du so nicht mit Sicherheit sagen. Dagegen spricht, dass es bei mir (und vielen anderen) keine Probleme mit FritzBox (7560) Version 7 und AppleTV mit iOS12 gibt.

    Gegenüber AVM solltest du jedoch etwas demütiger als hier im Forum auftreten. Ansonsten stellen die sich auf die Hinterfüsse und sagen, dass es ein Problem beim AppleTV ist. Und dann stehst du ziemlich alleine da ...

    Ciao,
    Jens
     
    dg2rbf gefällt das.