1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Zu hohe Auslastung durch Safari

Dieses Thema im Forum "macOS & OS X" wurde erstellt von Schniko, 24.08.09.

  1. Schniko

    Schniko Pomme Etrangle

    Dabei seit:
    01.08.08
    Beiträge:
    902
    Hallo,
    ich habe gerade das Problem, dass Safari immer eine zu hohe Auslastung produziert.
    [​IMG]
    Dabei ist es egal, welche Seite offen ist. Auch wenn nur google angezeigt wird, ist die Auslastung derartig hoch. Safari und auch das ganze System habe ich natürlich schon mehrfach neugestartet. Cache und Verlauf sind frisch entleert.
    Alle paar Sekunden bis Minuten friert dann der ganze Rechner ein. Das heißt, dass das Bild für ca. 10 Sekunden still steht, die Musikwiedergabe von iTunes stoppt und man nur noch den Mauszeiger bewegen kann - ohne dass eine Reaktion kommt.

    Woran kann das liegen, ich hoffe, dass jemand Rat hat, denn das ist geradezu zum verrückt werden :( ..

    Vielen Dank im Voraus,
    Nicolai
     
  2. salome

    salome Golden Noble

    Dabei seit:
    20.08.06
    Beiträge:
    23.757
    Was du da an grafischem Muster gepostet hast, ist unleserlich. Wenn du uns etwas zeigen willst, musst es als Screenshot hochlagen.
    du kannst unter Safari einmal zurücksetzen (Menü/Safari/Safri zurücksetzen).
    salome
     
  3. happymac

    happymac Damasonrenette

    Dabei seit:
    17.05.09
    Beiträge:
    486
    da steht:
    Prozess-ID: 11265
    Prozessname: Safari
    Benutzer: nicolai
    % CPU: 148,1
    Threads: 11
    Physikal.: 99,59 MB
    Virt. Speicher: 1,06 GB
    Art: Intel


    ;)
     
  4. Thaddäus

    Thaddäus Golden Noble

    Dabei seit:
    27.03.08
    Beiträge:
    15.163
    Läuft da irgendetwas wie Youtube o.ä.?
     
  5. salome

    salome Golden Noble

    Dabei seit:
    20.08.06
    Beiträge:
    23.757
    Beende einfach den Prozess (im AktivitätsManager, dort wo du nachgeschaut hast) und starte Safari neu - und setze ihn zurück (falls du das noch nicht getan hast).
    salome
     
  6. Marion Habel

    Marion Habel Morgenduft

    Dabei seit:
    11.09.07
    Beiträge:
    166
    Safari rödelt die CPU zu

    Ich habe das selbe Problem:

    Nach ein paar Minuten rödelt Safari die Auslastung der CPU hoch(87%) und friert dann ein.
    Mein Safari: 3
    Mein OSX: 10.4.11
    Meine CPU: G5

    Bis vor Weihnachten lief noch alles paletti und ich habe auch keine Add-Ons oder so installiert.

    Ich habe inzwischen: Den Cache geleert, Safari zurückgesetzt, die Zugriffsrechte geprüft (alles ok), den Virenscanner ClamXav_1.1.1_Universal_e952 in den Programmen, dem System und den Libraries suchen lassen. Erfolglos.

    Was mag da los sein?
     
  7. macaneon

    macaneon Kaiserapfel

    Dabei seit:
    19.06.07
    Beiträge:
    1.727
    Möchtest du nicht ein Update?
     
  8. Marion Habel

    Marion Habel Morgenduft

    Dabei seit:
    11.09.07
    Beiträge:
    166
    Nein, denn im Büro habe ich beide – 3 und 4 – und der 4er fängt nach kurzer Zeit an die Platte voll zu rödeln ohne Ende. Ich habe auch gelesen, dass er sehr viele Dateien irgendwo ablegt und so langsam aber sicher immer mehr Müll auf der Platte produziert. Außerdem ist er deutlich langsamer als der 3er (habe im Büro einen Mac Pro mit 2 DuoCore). Und die Foren, auf denen ich unterwegs bin, funktionieren mit dem 3er eigentlich bestens und sehr schnell.

    Und? eine Idee, was das sein könnte?
     
  9. macaneon

    macaneon Kaiserapfel

    Dabei seit:
    19.06.07
    Beiträge:
    1.727
    Irgendwo in den Tiefen dieses unseren kleinen Weltalls gibt es Hinweise, wie man das abstellt, falls zum Lesen auch die Erfahrung hinzukommt. Dann könnte auch die Performance wieder steigen.
     
  10. Marion Habel

    Marion Habel Morgenduft

    Dabei seit:
    11.09.07
    Beiträge:
    166
    Ja, das mag schon sein. Aber es bringt mich mit meinem eigentlichen Problem nicht weiter: Warum läuft mein Safari3 hier zu Hause urplötzlich nicht mehr?
     
  11. salome

    salome Golden Noble

    Dabei seit:
    20.08.06
    Beiträge:
    23.757
    Was kannst du in der Aktivitätsanzeige sehen?
    Du hast garantiert keine Safari Add-ons installiert? Sieh doch noch mal nach. Vielleicht liegt och ein unaktuelles herum.
    Wenn das Problem wieder auftritt, schau mal in den Log.Files nach, was da steht zum Zeitpunkt des Steckenbleibens (Programme /Dienstprogramme/ Konsole/)
    salome
     
  12. Marion Habel

    Marion Habel Morgenduft

    Dabei seit:
    11.09.07
    Beiträge:
    166
    Also ich bin kein Spezi – ich DENKE aber doch, dass ich nix installiert habe, sowas passiert doch nicht unbemerkt, oder?

    Hier mal nachdem ich das eben getestet habe ein Screen von den beiden Proggis, denn dies Kauderwelsch in der Konsole sagt MIR gar nix. Kannst du damit was anfangen? :

    [​IMG]
     
  13. salome

    salome Golden Noble

    Dabei seit:
    20.08.06
    Beiträge:
    23.757
    Dass irgendwas sich von selber eingschlichen hast, kannst mit an Sicherheit grenzender Wahrscheinlichkeit ausschließen.
    Schau dir mal in der /Library/Internet-Plugins dieses WacomNetscapeplugin an. entferne das mal und strte Safari neu.
    Schau mal Safari im infofenster an - hast du den Browser mit 64 Bit oder 32 (oder wird das bie dir ohnehin noch nicht angezeigt)? Safari 4 läuft auf 10.6.2 automatisch mit 64.
    Außerdem: Hast du Windows auch dabei und daher paragon ntfs installiert? Dann solltest du das löschen und neu installieren (paragon meine ich).
    salome
     
  14. Marion Habel

    Marion Habel Morgenduft

    Dabei seit:
    11.09.07
    Beiträge:
    166
    Öh – Safari läuft auf meinem Rechner in der "universal" Installation, also für PowerMac und Intel geeignet. Von 32 Bit oder 64 steht da nix.

    paragon ntfs: Ich habe kein Windows laufen (geht ja auch gar nicht auf der Schüssel), und ich weiß nicht: Ich habe vor Weihnachten ein Wacom-Tablett gekauft/installiert – kann das damit zu tun haben? Ich wüsste auch nicht, wie ich das loswerden sollte – wenn ich es unter SUCHEN eingebe, erhalte ich nur ein PDF (eine CHIP von 2007 – keine Ahnung, wo DIE wieder her kommt, es lag in DOWNOADS– ich sollte mal ausmisten–, ich habe es mal gelöscht)…

    Meinst du, ich sollte diese WacomNetscapeplugin trotzdem löschen?

    Danke schon mal für deine Hilfe, ich bin da ganz ratlos.
     
  15. MacAlzenau

    MacAlzenau Golden Noble

    Dabei seit:
    26.12.05
    Beiträge:
    19.405
    Safari 4: Top Sites abschalten

    Mit dem Platte-voll-rödeln bei safari 4 meinst du eventuell, daß es diese Topseiten anlegt. Das ist wirklich eine üble und meiner Ansicht nach sinnfreie Neuerung (wozu gibt es Lesezeichen?), und da werden von allen besuchten Seiten Abbildungen gespeichert.
    Das kann man aber abstellen, indem man sich für den Ordner, in dem Safari das Zeugs sammelt, die Schreibberechtigung entzieht (~/Library/Caches/com.apple.Safari/Webpage\ Previews) oder ihn schützt.
    Außerdem fand ich diesen Terminalbefehl zum Abschalten (ungeprüft):
    defaults write com.apple.Safari DebugSafari4IncludeTopSites -bool NO
     
  16. salome

    salome Golden Noble

    Dabei seit:
    20.08.06
    Beiträge:
    23.757
    und der /Library/Internet-Plugins (oberste Ebene) müsste auch ein wacom plugin liegen, das tu auch raus.
    salome
     
  17. MacAlzenau

    MacAlzenau Golden Noble

    Dabei seit:
    26.12.05
    Beiträge:
    19.405
    Läuft der Virenscanner denn permanent mit? Dann würde ich den erst mal killen - die Dinger machen die seltsamsten Sachen.

    Der Wacom-Treiber: Die Spotlightsuche findet in der Grundeinstellung nichts in den Systemdateien (jedenfalls bei 10.5, ich denke, es ist bei 10.4 genauso). Dazu musst du im Finder mit cmd-F die Suche aufrufen und dann bei den Buttons bei Art was anklicken. Beliebige oder vielleicht gibt es auch direkt den Eintrag Systemdateien. Den Pfad zu diesem speziellen Plugin findest du aber leichter direkt auf deinem Screenshot in der Fehlermeldung: /Library/Internet Plug-Ins/
    Ich würde das Plugin - der Name mit dem Netscape dran klingt sowieso, als ob es etwas veraltet sein könnte - nicht löschen, aber mal aus dem Verzeichnis rausziehen (und irgendwo sichern), dann dafari neu starten.
    Falls das Grafiktablett Kernel Extensions installiert haben sollte, die irgendwie inkompatibel sind, kannst du den Mac mal ohne Fremd-Extensions starten (Shifttaste gedrückt halten beim Start) und schauen, ob sich was ändert. Ich sehe zwar keinen Zusammenhang, aber wenn das schon in den Fehlermeldungen verknüpft ist und dir sonst nichts bewußt ist, was du vor dem Problem geändert hast, sollte man es mal testen.
    Wenn es die Lösung ist, müsste man als nächsten Schritt halt mal schauen, wie man das Wacom problemfrei installiert (was aber funktionieren müsste).
     
  18. Marion Habel

    Marion Habel Morgenduft

    Dabei seit:
    11.09.07
    Beiträge:
    166
    :-c
    Es ist zu blöd.
    [​IMG]

    Ich habe alle Libraries durchsucht und habe dort ein
    WacomNetscape
    PandoWebInst
    WacomSafari
    VerifiedDownloadPlugin
    rausgefischt.
    Dieses paragon ntfs habe ich nicht gefunden (ich suche NIE mit Spotlight, immer mit Apfel-f).

    Der Virenscanner läuft nie, ich hatte den (Freeware) gesucht, weil ich dachte, dass es vielleicht an irgendeiner Seuche liegen könnte und wollte hier nicht doof auflaufen, ohne wenigstens schon was versucht zu haben.

    Wenn füher mal ein Proggi gesponnen hatte (vor OSX), hat man doch einfach immer mal die Preferences gekillt – kann/sollte man sowas vielleicht mal machen?

    *seufz* Für heute reicht es mir, ich danke euch und hoffe, ihr könnt mir doch noch helfen. Bis denne.
     
  19. Bananenbieger

    Bananenbieger Golden Noble

    Dabei seit:
    14.08.05
    Beiträge:
    24.567
    Hohe Prozessorlast bei Safari kommt fast immer von Flash. ClickToFlash schafft da deutliche Linderung.
     
  20. Marion Habel

    Marion Habel Morgenduft

    Dabei seit:
    11.09.07
    Beiträge:
    166
    Danke für den Tipp. Schade, es hilft nicht. Safari rödelt sich sogar fest, wenn gar kein Fenster geöffnet ist. Und trotz des frisch installierten Anti-Flash-PlugIn.
     

Diese Seite empfehlen