1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Website kann nicht angezeigt werden - Was mache ich falsch?

Dieses Thema im Forum "Webhosting/DSL-Anbieter" wurde erstellt von Gartenzwerg, 28.03.08.

  1. Gartenzwerg

    Gartenzwerg Leipziger Reinette

    Dabei seit:
    08.01.08
    Beiträge:
    1.778
    Hi, ich habe mir vor kurzem eine kleine Website mit iWeb erstellt. Ich hab mich ein bisschen nach kostenlosem Hosting umgeschaut, nun bin ich bei kilu.de .
    Ich habe dort diese Anleitung gefunden.
    Da es das Programm im Vorwort nicht für den Mac gibt, habe ich Cyberdruck genommen, ich denke, das macht eh keinen Unterschied. In dieser Anleitung steht, dass ich auf dem Server 3 Ordner finden werde: logs, tmp und www. Allerdings war bei mir nur der Ordner 'www'. So, dann steht dort, wenn nicht alle Ordner vorhanden sind, soll ich sie erstellen. Also, auf den Schreibtisch einen Rechtsklick>Neuer Ordner und dann tmp benannt, das andere auch dann mit logs gemacht. Diese 2 Ordner habe ich dann in Cyberdruck gezogen, so sieht es nun aus:
    [​IMG]

    Auf der Website wurde beschrieben, dass sie ein HTML Text-Dokument (oder was weiß ich) erstellt haben, diese als index.txt abgespeichert haben, in das Upload Programm gezogen haben und es dann in index.html umbenannt haben.

    Meine iWeb Website habe ich in einem Ordner abgelegt, indem ich in iWeb>Ablage>in einem Ordner veröffentlichen gegangen bin. Dann habe ich einen neuen Ordner erstellt und auf auswählen geklickt. In Dem Ordner finde ich nun 2 Dinge:
    [​IMG]
    Wenn ich auf index.html klicke, erscheint meine Website so, als würde sie schon im Internet sein, also eine Vorschau - klar. ;) Wenn ich dann auf den Ordner Website klicke, finde ich viele Dateien. Auch ist dort noch einmal index.html. Das heißt: Ich habe zweimal index.html auch findet sich dort eine Datei namens feed.xml, keine Ahnung, wo die herkommt?! Hat das vielleicht etwas mit iWeb zu tun?

    Also, ich bin das erste mal so vorgegangen: Ich habe index.html auf dem ersten Screenshot ignoriert und einfach nacheinander alle Dateien inkl. dieser feed.xml in den Ordner 'www' gezogen. So, nun auf der Seite: www.error.kilu.com : Code 404 / Seite kann nicht angezeigt werden.

    Was habe ich falsch gemacht?
    Dann hab ich das ganze nochmal ohne feed.xml gemacht> gleiches Ergebnis. :(

    Dann hab ich es einmal mit dem index.html aus dem zweiten Screenshot probiert und das index.html aus dem Ordner Webseite ignoriert. feed.xml mit reingezogen. Dann nochmal ohne feed.xml (nur, weil mich diese Datei wegen der Endung irritiert hat)

    Aber es kommt immer die gleiche Meldung. Was ist Code 404? :oops:

    Ich kenne mich eigentlich Null aus, weder mit html noch mit anderen Dingen.

    Könnt ihr mir bitte,bitte helfen? Ich wollte mich an dieser Stelle auch nochmal ganz besonders bei movidre bedanken, er hat sich echt viel Zeit genommen, wir sind aber zu keinem Ergebnis gekommen. Auch nochmal für die Hilfe von zeno und all den anderen in der Shoutbox. Ich hoffe, einer von euch weiß, was ich falsch gemacht habe o_O


    EDIT: Vielen Dank für eure Hile! :) Hier nun meine fertige Website, irgendwann werde ich mir mal eine gescheite Domain zulegen :p www.crazyzwerg.kilu.de
    Und wie gesagt, über Feedbacks würde ich mich freuen.. :D
     
    #1 Gartenzwerg, 28.03.08
    Zuletzt bearbeitet: 15.04.08
  2. rentophil

    rentophil Weisser Rosenapfel

    Dabei seit:
    16.04.07
    Beiträge:
    789
    404? dann wurde die seite nicht gefunden!

    ich hab auch mal kilu.degenommen und cyberduck aber nicht diese anleitung! hab die ordner nie erstellt und bei mir hats funktioniert!
     
  3. Gartenzwerg

    Gartenzwerg Leipziger Reinette

    Dabei seit:
    08.01.08
    Beiträge:
    1.778
    Wirklich? Also sollte ich es vielleicht einfach mal so versuchen: www, logs und tmp löschen und dann einfach dort die Dateien reinziehen?
    Hilfreich wäre auch noch: Welches index.html soll ich nehmen? Das auf dem Screenshot 2 oder das im Ordner Website_2? Weil beides geht nicht, dann muss ich eins überschreiben. Und soll ich feed.xml mitreinziehen?
     
  4. iPhreaky

    iPhreaky Wilstedter Apfel

    Dabei seit:
    28.10.06
    Beiträge:
    1.927
  5. MacBat

    MacBat Murer Reinette

    Dabei seit:
    25.03.06
    Beiträge:
    1.628
    Du musst ALLES aus dem Ordner hochladen, den iWeb erstellt. Also index.html und den Ordner, der den Namen der Website trägt, auch wenn da noch mal ein index.html drin ist!
     
    Gartenzwerg gefällt das.
  6. Gartenzwerg

    Gartenzwerg Leipziger Reinette

    Dabei seit:
    08.01.08
    Beiträge:
    1.778
    Soll ich die Dateien aus dem Ordner alle einzeln reinziehen oder den ganzen Ordner dann auf einmal? weil bei allem einzeln muss eine datei dann überschrieben werden o_O
     
  7. MacBat

    MacBat Murer Reinette

    Dabei seit:
    25.03.06
    Beiträge:
    1.628
    Ich glaube nicht, dass etwas überschrieben wird. Denn das zweite index.html hat einen anderen Pfad, weil es in dem Ordner liegt.

    Leider kann ich das gerade nicht kontrollieren, weil ich hier keinen Zugang zu dem Server habe, auf den ich meine mit iWeb gemachte Seite geladen habe. Aber ich kann mich nicht erinnern, dass es ein Problem gab. Nur den Ordner, in dem index.html und der Website-Ordner liegen, denn solltest du nicht mit hochladen, denn im Rootverzeichnis (in deinem Fall dem www-Ordner) muss ein index.html liegen.

    Soweit ich mich erinnern kann.
     
  8. MacBat

    MacBat Murer Reinette

    Dabei seit:
    25.03.06
    Beiträge:
    1.628
    Aus einer Anleitung für Fetch (ein FTP-Client, wie Cyberduck):

    "Drag the files created by iWeb to the server folder, or click the Put button and you will be prompted to choose which files on your Macintosh to upload. Choose the files created by iWeb. Do not drag or select the folder containing the files; just drag or choose all the files and subfolders inside that folder."

    Der "Server Folder" ist in deinem Fall der www-Ordner. Beachte: all the files and subfolders inside the folder.
     
  9. Gartenzwerg

    Gartenzwerg Leipziger Reinette

    Dabei seit:
    08.01.08
    Beiträge:
    1.778
    ICH HABS! :D Sie ist online. Ihr bekommt auch gleich den Link. ;)
    Aber ich hab ein ziemlich dummes Problem: Alle : ' ä ö ü
    werden falsch angezeigt.. :( mit komischen Zeichen und so, was kann ich da ändern? :(
     
  10. MacBat

    MacBat Murer Reinette

    Dabei seit:
    25.03.06
    Beiträge:
    1.628
    In welchem Browser?
     
  11. dahui

    dahui Carmeliter-Renette

    Dabei seit:
    22.10.06
    Beiträge:
    3.303
    gratuliere !!!

    das mit den umlauten ist ein bekanntes und IMHO noch nicht gelöstes problem.
    du könntest alle seiten manuell im quellcode bearbeiten und dort die umlaute ersetzen, was aber dem gedanken easy-webpublishing widerspricht. oder eben einen .mac account eröffnen, das kostet aber a) geld un b) ist der service IMHO nicht zu empfehlen, da .mac langsam und teuer ist.

    dahui
     
  12. qwert

    qwert Himbeerapfel von Holowaus

    Dabei seit:
    23.08.07
    Beiträge:
    1.258
    Glückwunsch! :)

    Zum ÄÖÜ-Problem: Welchen Zeichensatz hast du im Quelltext verwendet? Mit diesem Zeichensatz sollte das kein Problem sein: charset=iso-8859-1 Diesen Zeichensatz muss im Quelltext deiner Webseite angeben.

    Beispielsweise:
    <meta http-equiv="Content-Type" content="text/html; charset="iso-8859-1" />
     
    Gartenzwerg gefällt das.
  13. Gartenzwerg

    Gartenzwerg Leipziger Reinette

    Dabei seit:
    08.01.08
    Beiträge:
    1.778
    Wie müsste ich die Umlaute dort verändern? Kannst du mir das vielleicht erklären? Quellcode? Das heißt in nem Texteditor wie Smultron bearbeiten?
     
  14. Gartenzwerg

    Gartenzwerg Leipziger Reinette

    Dabei seit:
    08.01.08
    Beiträge:
    1.778
    Wo muss ich das eingeben? *ahnungslos* o_O
    Zu der Frage mit dem Browser: Safari 3.1, also das müsste schon geändert werden ;)
     
  15. iPhreaky

    iPhreaky Wilstedter Apfel

    Dabei seit:
    28.10.06
    Beiträge:
    1.927
    Zu deiner PN, Gartenzwerg:

    Müsste sich doch jetzt alles geklärt haben, oder?;)

    Mehr weiß ich leider auch nicht...
     
    Gartenzwerg gefällt das.
  16. Peter Maurer

    Peter Maurer Carmeliter-Renette

    Dabei seit:
    16.03.04
    Beiträge:
    3.274
    Entweder die richtige Kodierung als Meta-Tag angeben (Was produziert iWeb denn? UTF-8?) oder HTML-Entities verwenden -- z.B. ä ö und ü.

    EDIT: Upsa, ich hab' die zweite Seite uebersehen. Da hat sich die Antwort ja schon beinahe erledigt. :D
     
  17. dahui

    dahui Carmeliter-Renette

    Dabei seit:
    22.10.06
    Beiträge:
    3.303
    sende doch bitte mal einen link zu deiner online seite.

    a) sind wir jetzt alle neugierig ;)
    b) sollte auch der zeichensatz uft-8 das können.

    dahui
     
  18. Gartenzwerg

    Gartenzwerg Leipziger Reinette

    Dabei seit:
    08.01.08
    Beiträge:
    1.778
    Also, iPhreaky> hat sich alles geklärt. ;)
    Zu denen, die mir mit den Umlauten und so helfen wollen: wo und wie muss ich was eingeben? Ich bin als 12Jähriger leider total ahnungslos mit HTML und solchen Sachen.
     
  19. dahui

    dahui Carmeliter-Renette

    Dabei seit:
    22.10.06
    Beiträge:
    3.303
    iWeb hat im header
    Code:
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    zu stehen, und eigentlich sollte das funktioniern IMHO o_O

    das problem wird aber sehr oft im www beschrieben und ich meine es gäbe noch keine lösung.
    ich selbst habe mit iWeb noch nie gearbeitet ;) aber selbst wenn das charset manuell geändert würde, müsste gartenzwerg dass bei jeder änderung manuell nachziehen ... sehr unschön.
     
    Gartenzwerg gefällt das.
  20. Peter Maurer

    Peter Maurer Carmeliter-Renette

    Dabei seit:
    16.03.04
    Beiträge:
    3.274
    Seltsam.

    Dann wohl doch lieber Entities (s.o., Gartenzwerg, die fangen mit & an) verwenden. Ich gestehe hiermit, dass ich das auch bei meinen in TextWrangler handgestrickten HTML-Dokumenten mache, weil ich den Browsern und ihrer Interpretationsfaehigkeit in Bezug auf die Textkodierung einfach nicht traue. :D
     
    Gartenzwerg gefällt das.

Diese Seite empfehlen