1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

TeXShop - deutsche Anführungszeichen

Dieses Thema im Forum "LaTeX" wurde erstellt von Phlip, 05.12.09.

  1. Phlip

    Phlip Kaiser Wilhelm

    Dabei seit:
    25.01.08
    Beiträge:
    174
    Nun habe ich auch mal eine LaTeX-Frage.

    Ich finde es ja ganz praktisch, dass TeXShop immer wenn ich Anführungszeichen setzen möchte (also " drücke) sogleich dieses ``'' ausspuckt und direkt den Cursor in die Mitte der Zeichen setzt.
    Blöderweise handelt es sich dabei aber um englische Anführungszeichen.

    Gibt es keine Möglichkeit, dass TeXShop bei der Eingabe von " die korrekten deutschen Anführungszeichen ausgibt?
    Wenn ja, wo und wie kann ich das einstellen?

    Bin für jede Antwort dankbar.
     
  2. guy_incognito

    guy_incognito Oberdiecks Taubenapfel

    Dabei seit:
    20.09.06
    Beiträge:
    2.751
    Linke Anführungszeichen: \glqq
    Rechte Anführungszeichen: \grqq

    Die Edith meint noch: Bei "halben" Anführungszeichen gilt: \glq und \grq.
     
    #2 guy_incognito, 05.12.09
    Zuletzt bearbeitet: 05.12.09
  3. Phlip

    Phlip Kaiser Wilhelm

    Dabei seit:
    25.01.08
    Beiträge:
    174
    Danke, das mit den halben wusste ich noch nicht!

    Gibt es eigentlich einen Unterschied zwischen "`Text"' und \glqq Text\grqq?

    Ich habe übrigens herausgefunden, wie man die Autovervollständigung von TeXShop ändert. Ich werde das mal schreiben, falls jemand in der Thread stolpert, der ein ähnliches Problem hat.

    Folgendes hat bei mir funktioniert:
    autocompletion.plist öffnen (unter Library/TeXShop/Keyboard).
    Dort diesen Eintrag (steht bei mir an erster Stelle)
    Code:
    <key>"</key>
    <string>``#SEL##INS#''</string>
    durch diesen ersetzen:
    Code:
    <key>"</key>
    <string>\glqq #SEL##INS#\grqq</string>
    .
    Man kann \glqq und \grqq natürlich auch durch "` und "' ersetzen.
    Dann abspeichern und TeXShop neustarten.

    Natürlich auf eigene Gefahr.
     
  4. Sir Isaac

    Sir Isaac Jamba

    Dabei seit:
    18.03.08
    Beiträge:
    56
    Phlip gefällt das.
  5. guy_incognito

    guy_incognito Oberdiecks Taubenapfel

    Dabei seit:
    20.09.06
    Beiträge:
    2.751
    Also der Unterschied liegt darin, dass ersteres bei mir zum Abbruch des Kompiliervorgangs führt und das zweite nicht. :)

    Achja nach dem \grqq ist es evtl. ratsam ein Ausgleich mit \/ herzustellen.
     
    Phlip gefällt das.
  6. Phlip

    Phlip Kaiser Wilhelm

    Dabei seit:
    25.01.08
    Beiträge:
    174
    Hm, dass ersteres bei Dir den Kompiliervorgang abbrechen lässt, verunsichert mich ein wenig. Ich habe diesen Code für die Anführungszeichen aus einer LaTeX-Beschreibung. Sollte das nicht überall funktionieren?
    Bei mir klappt es übrigens mit jedem der mittlerweile drei Vorschläge.
     
  7. Carim

    Carim Fießers Erstling

    Dabei seit:
    18.04.09
    Beiträge:
    126
    Hallo!

    Dass bei Eingabe von " die voreingestellten Anführungszeichen erscheinen und der Cursor in die Mitte gesetzt wird, liegt an einem entsprechenden Eintrag in der Datei: ~/Library/TexShop/Keyboard/autocompletition.plist.
    Um die deutschen Anführungszeichen zu erhalten, muss lediglich der Eintrag korrigiert bzw. hinzugefügt werden. Ich verwende die deutschen Print-Anführungszeichen, daher sieht das bei mir so aus:

    Code:
    <dict>
    <key>[SIZE=4][COLOR=DarkRed][B]"[/B][/COLOR][/SIZE]</key>
    <string>[SIZE=4][COLOR=DarkRed][B]»[/B][/COLOR][/SIZE]#SEL##INS#[SIZE=4][COLOR=DarkRed][B]«[/B][/COLOR][/SIZE] </string>
    
    Für die normalen Anführungszeichen muss es so aussehen:

    Code:
    <dict>
        <key>[B][SIZE=4][COLOR=DarkRed]"[/COLOR][/SIZE][/B]</key>
        <string>[B][SIZE=4][COLOR=DarkRed]„[/COLOR][/SIZE][/B]#SEL##INS#[B][SIZE=4][COLOR=DarkRed]“[/COLOR][/SIZE][/B] </string>
    
    In den Einstellungen muss natürlich die Checkbox "Autom. Vervollständigung" aktiviert sein.

    Die direkte Eingabe dieser Zeichen anstelle von \glqq und so weiter erhöht die Lesbarkeit des Dokuments ernorm, Voraussetzung ist aber, dass Unicode verwendet wird. Dies muss Latex im Vorspann extra mitgeteilt werden, bei mir funktioniert folgende Sequenz sehr gut:

    Code:
    \documentclass[12pt,ngerman]{scrreprt}
    \usepackage[T1]{fontenc}
    \usepackage{ucs}
    \usepackage[utf8x]{inputenc}
    \PrerenderUnicode{ä}
    \usepackage[ngerman]{babel}
    
    LG, Wolfgang
     
    #7 Carim, 13.12.09
    Zuletzt bearbeitet: 13.12.09
    Phlip gefällt das.
  8. Phlip

    Phlip Kaiser Wilhelm

    Dabei seit:
    25.01.08
    Beiträge:
    174
    Ich hätte auch von selber darauf kommen können, dass man gleich diese „“ in die autocompletition.plist einfügen kann.
    Habe mir nun dort auch die Umlaute und das ß eingesetzt.

    Meine Präambel sieht allerdings ein wenig anders aus:
    Code:
    \documentclass[headings=small,headsepline,12pt,a4paper]{scrreprt}
    \usepackage[ngerman]{babel}
    \usepackage[applemac]{inputenc}
    \usepackage[T1]{fontenc}
    Das Kompilieren hat damit (mit editierter autocompletition.plist) testweise einwandfrei funktioniert.

    Wo liegt der Unterschied zu

    Code:
    \usepackage{ucs}
    \usepackage[utf8x]{inputenc}
    \PrerenderUnicode{ä}
    ?
     
  9. iPiet

    iPiet Raisin Rouge

    Dabei seit:
    07.04.08
    Beiträge:
    1.179
    Steht das schließende Anführungszeichen (das Abführungszeichen? :)) nicht vor einem Satzzeichen, so würde ich statt

    \grqq besser \grqq\

    schreiben, damit LaTex einen Abstand zum nächsten Wort etc. einfügt.
     
  10. Carim

    Carim Fießers Erstling

    Dabei seit:
    18.04.09
    Beiträge:
    126

    Die ersten beiden Zeilen sind erforderlich, wenn die *.tex-Datei in der Codierung UTF-8 vorliegt. Da dein Vorspann brauchbare Ergebnisse liefert, sind deine Dateien offesichtlich in MAC-OS-Roman codiert. Wundert mich, dass damit die deutschen Anführungszeichen korrekt übersetzt werden, aber wenn es funktioniert, ist's eh super.

    Die dritte Zeile hat mir Texshop bei einem Latex-Lauf einmal vorgeschlagen, nachdem ein Umlaut in einer Überschrift vorgekommen ist. Seit dem ist sie bei mir drinnen, scheint aber nicht so die überragende Bedeutung zu haben.

    LG, Wolfgang
     
  11. lyn_

    lyn_ Erdapfel

    Dabei seit:
    11.07.14
    Beiträge:
    2
    hi zusammen,
    probiere mich gerade das erste mal an Texshop und wollte wie oben (#2) beschrieben Anführungszeichen setzen (Linke Anführungszeichen: \glqq Rechte Anführungszeichen: \grqq). Als ich mir den text ausgeben ließ, kam allerdings eine Fehlermeldung weiter unten (\maketitle) und die Ausgabe blieb aus.

    Kann mir das jemand erklären bzw. beheben?
     
  12. bezierkurve

    bezierkurve Danziger Kant

    Dabei seit:
    12.06.05
    Beiträge:
    3.861
    Warum schreibst du deine Anführungszeichen nicht direkt in die TeX-Datei (alt+^ und alt+shift+^ zur manuellen Eingabe bzw. über die im System-integrierten automatischen Transformationen; siehe Menü „Bearbeiten“)? Diese Umwege sind Relikte aus der Steinzeit und dank UTF8-Enkodierung nicht mehr notwendig.
     
  13. lyn_

    lyn_ Erdapfel

    Dabei seit:
    11.07.14
    Beiträge:
    2
    weil dann immer fragezeichen statt anführungezeichen in der übersetzung kommen
     
  14. bezierkurve

    bezierkurve Danziger Kant

    Dabei seit:
    12.06.05
    Beiträge:
    3.861
    Dann füge mal die zwei Packages hinzu:
    Code:
    \usepackage[utf8]{inputenc}
    \usepackage[T1]{fontenc}
    
     

Diese Seite empfehlen