1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

System extrem langsam geworden

Dieses Thema im Forum "macOS & OS X" wurde erstellt von Fat_Toni, 16.06.09.

  1. Fat_Toni

    Fat_Toni Pomme au Mors

    Dabei seit:
    15.02.08
    Beiträge:
    856
    Hallo liebe Forengemeinde,

    in letzter Zeit bin ich nichtmehr so zufrieden mit meinem Mac, wie zu Anfang.

    Zur Hardware:

    Habe ein MacBook 3,1 mit 2.2 GHz und 4 GB Ram mit dem aktuellen Leopard 10.5.7, aktuellen iTunes 8.2 und Safari 4. Das System hatte ich mit dem Erscheinen von 10.5.7 neu aufgesetzt, sogar die Platte 7fach überschreiben lassen.

    Zu meinen Problemen:

    Bereits seit 10.5.6 ist das System extrem langsam geworden, wenn ich im iTunes Lieder abspiele dauert das immer ewig, bis es zu spielen beginnt, dann hängt es sich hin und wieder auf und man sieht nurnoch den Runden bunten Knödel der sich stundenlang dreht. Bei Safari 4 genau dasselbe, auch extrem langsam, hängt sich immer wieder auf. Ich habe weder eine Systemoptimierungssoftware wie Onyx installiert, noch sonstige Programme von denen ich wüsste sie würden dem System schaden. Habe lediglich Adobe CS 3, und paar andere Programme wie Better Zip oder Little Snitch installiert.
    Speziell zum iTunes: Habe meine Musikbibliothek (ca. 350GB) alle auf einer externen Festplatte, weil die interne nicht groß genug ist - vielleicht ist dass das Problem ich weiß nicht. Ist eine TrekStor 1 TB Platte auf HFS + formatiert.

    Habe auch die Zugriffsrechte des öfteren repariert, System neu gestartet usw... Hilft aber alles nichts, das System ist und bleibt genauso lahm wie vorher und hängt andauernd. Ich mache ja nichts weltbewegendes, bisschen Internet surfen, nebenbei Musik hören, Filme gucken, und hin und wieder die Bilder meiner Nikon im Photoshop bearbeiten...

    Wär toll wenn mir jemand helfen könnte... :)

    Liebe Grüße
    Alex
     
  2. Lysander99

    Lysander99 Jamba

    Dabei seit:
    05.06.08
    Beiträge:
    56
    Schau mal mit der Aktivitätsanzeige welche Prozesse, welche Ressourcen beanspruchen.
     
  3. Fat_Toni

    Fat_Toni Pomme au Mors

    Dabei seit:
    15.02.08
    Beiträge:
    856
    Also, am meisten benötigt itunes - beim starten (der Startvorgang dauert etwa 3 Minuten weil er immer wieder Lieder analysiert, obwohl garkeine neuen dazugekommen sind) - mit etwa 98% Auslastung, aber das ist beim Startvorgang ja normal.

    Wenn dann mal alles gestartet ist, dann benötigt Firefox etwa 3-4% CPU, und die anderen Prozesse wie Adium usw. auch etwa 2-3% wenn ich damit arbeite. pmtool und kerneltask benötigen etwa 1% CPU. und Ram Auslastung ist auch nicht sehr hoch, habe noch etwa 2,69GB Ram der nicht benötigt wird. Reserviert sind 570MB Ram, Aktiv 686 MB, und Inaktiv 80 MB.

    Habe übrigens mit TechTool alle Hardware Komponenten überprüft - alles in bester Ordnung.
     
  4. landplage

    landplage Admin
    AT Administration

    Dabei seit:
    06.02.05
    Beiträge:
    21.485
    Wie voll ist die Festplatte?
     
  5. Fat_Toni

    Fat_Toni Pomme au Mors

    Dabei seit:
    15.02.08
    Beiträge:
    856
    Also wenn du die interne HDD meinst:

    Kapazität: 111,47 GB
    Verfügbar: 78,49 GB
    Belegt: 32,98 GB

    Platte ist eine FUJITSU MHY2120BH; S-ATA 1,5.
     
  6. MacAlzenau

    MacAlzenau Golden Noble

    Dabei seit:
    26.12.05
    Beiträge:
    19.405
    Die Verzögerungen bei iTunes sind wohl nicht vom System oder sonstwas verschuldet, sondern stammen von iTunes selbst.
    Ich hatte bis vor Kurzem noch iTunes 6 laufen, das lief auch, wie geschmiert. Dann auf iTunes 8 gewechselt, und seitdem sind diese endlosen Wartezeiten an der Tagesordnung. Wenn Podcasts geladen werden, geht fast nichts, und auch sonst hängt es immer beim Scrollen oder beim Wechsel zwischen Wiedergabelisten.
    Es sieht so aus, als ob iTunes 8 seine Daten ständig von der (externen) Platte holt und nicht aus den Library-Dateien im Home-Verzeichnis (ber selbst dafür ist es zu langsam). Genius benutze ich nicht, könnte mir aber vorstellen, daß das dennoch ständig Kapazitäten abzapft.
     
  7. Fat_Toni

    Fat_Toni Pomme au Mors

    Dabei seit:
    15.02.08
    Beiträge:
    856
    Hallo,

    danke schonmal für die gute Antwort. Und woran denkst du liegen dann die anderen Abstürze und dass das System so langsam ist?
     
  8. Lysander99

    Lysander99 Jamba

    Dabei seit:
    05.06.08
    Beiträge:
    56
    Ich würde erstmal alles was Du nicht unbedingt brauchst in Itunes deaktivieren (unter Einstellungen)
    Wie verhält es sich denn wenn Du Cover Flow ausschaltest und in die Listenübersicht gehst?
     
  9. iChrigi

    iChrigi Angelner Borsdorfer

    Dabei seit:
    26.03.08
    Beiträge:
    628
    Mein iTunes und mein Safari lahmen auch hin und wieder herum. Vor allem iTunes dauert etwa dreissig Sekunden, bis es gestartet ist. Ich bekam dann den Rat von einem User hier, ich solle mal im Kontrollfeld Netzwerk eine neue Umgebung erstellen, in dieser alle deaktivieren. Dann neu Starten. Wenn es sich verbessert hat, nur die Dienste, die Du brauchst wieder anschalten.
     
  10. iStefan

    iStefan Riesenboiken

    Dabei seit:
    19.11.07
    Beiträge:
    293
  11. Fat_Toni

    Fat_Toni Pomme au Mors

    Dabei seit:
    15.02.08
    Beiträge:
    856
    Hallo Stefan,

    ich hab dir mal die File mit den Kernel-Extensions und die File mit launchd geladenen Modulen geupped. Ich hoffe das hilft schonmal.

    Habe jetzt Genius deaktiviert, bringt auch keinen merklichen Unterschied. Da ich sowieso immer die Listenansicht verwende, und nicht die Cover Flow, macht das keinen Unterschied ;)

    Ich hoffe das hilft schonmal weiter bei der Fehlersuche.

    Lg
    Alex
     

    Anhänge:

  12. iStefan

    iStefan Riesenboiken

    Dabei seit:
    19.11.07
    Beiträge:
    293
    Schnellanalyse:
    1. Little Snitch hat sowohl sein Kernel-Extensions als auch Startelemente installiert. Falls es von Dir wirklich benötigt wird ist dieses nicht zu vermeiden und kann zu Einbußen führen. Siehe dazu auch folgenden Thread und die Anmerkungen weiter hinten:
    http://www.apfeltalk.de/forum/little-snitch-helper-t230893.html

    2. Weiterhin die Hintergrundprozesse für Adium (Chatten), Skype, Elgato (Fernsehen), LittleSnitch (Netzwerk-Paketfilter), Google-Module, HP (Drucken) und das Apple Sprachmodul geladen (Adobe kann ich nicht finden oder habe es übersehen). Brauchst Du diese ständig?
     
  13. Fat_Toni

    Fat_Toni Pomme au Mors

    Dabei seit:
    15.02.08
    Beiträge:
    856
    Naja, HP, diese google Module (keine Ahnung für was die eigentlich sind), Apple Sprachmodul, Elgato und Skype verwende ich eigentlich nicht sehr oft. Adium und LS brauch ich sogut wie immer.

    Soll ich diese Hintergrundprozesse deaktivieren? Wenn ja wie? ^^
     
  14. iStefan

    iStefan Riesenboiken

    Dabei seit:
    19.11.07
    Beiträge:
    293
    HP, LS, Adium also lassen. Das Starten bei Apple Sprachmodul, Elgato, Skype läßt sich in den Einstellungen der Programme verhindern oder untern den Startprogrammen unter Benutzer.
    Falls es für die Google-Tools keinen Uninstaller gibt die Dateien erst einmal an einen anderen Ort verschieben und das System neu starten. Dann kann weiter analysiert werden.

    By-the-way: Wie voll ist denn die Festplatte?
     
    Fat_Toni gefällt das.
  15. Fat_Toni

    Fat_Toni Pomme au Mors

    Dabei seit:
    15.02.08
    Beiträge:
    856
  16. iStefan

    iStefan Riesenboiken

    Dabei seit:
    19.11.07
    Beiträge:
    293
    Dann würde ich wie oben beschrieben versuchen zu verfahren.

    Stefan
     
  17. matzzz

    matzzz Gloster

    Dabei seit:
    12.05.08
    Beiträge:
    63
    Gerade zufällig beim Stöbern auf dein Problem gestoßen ;)

    Ist eigentlich auch der Bootvorgang merklich langsamer geworden?

    Ansonsten würde ich auch vorschlagen, jeweils eines der Programme die eine Kernel-Erweiterung geschrieben haben bzw. beim hochfahren gestartet werden zu entfernen (natürlich vorher sichern) und dann neu hochzufahren und wieder testen.

    Gruß
    Matzzz
     
  18. waschbär123

    waschbär123 Echter Boikenapfel

    Dabei seit:
    26.04.08
    Beiträge:
    2.353
    probier mal einen neuen benutzer anzulegen und dort ein wenig zu arbeiten. ist es dort auch deutlich langsamer? wenn nicht, dann liegt es an irgendwelchen benutzereinstellungen. wenn er immer noch langsamer ist dann könnte es an den kext liegen.
     
    Fat_Toni gefällt das.
  19. Fat_Toni

    Fat_Toni Pomme au Mors

    Dabei seit:
    15.02.08
    Beiträge:
    856
    Also der Bootvorgang an sich ist nicht langsamer geworden. Habe jetzt mal einen neuen Benutzer angelegt, da rennt alles irgendwie schneller. Jetzt kopier ich einfach die paar Daten die ich hab vom einen auf den anderen Benutzer, und lösch dann den alten. Ich denk das ist das einfachste. Vielen Dank an alle für die Hilfe ;)
     
  20. iStefan

    iStefan Riesenboiken

    Dabei seit:
    19.11.07
    Beiträge:
    293
    Zur technischen Erläuterung, um Dir die Suche zu vereinfachen:

    Unter OS X seit 10.4 gibt es den Daemon launchd (hat im System immer die Prozess-Nr. 1). Dieser ist für das Starten von Systemdiensten und Prozessen verantworlich, insbesondere beim Systemstart und der Anmeldung eines Users. Zwei grundlegende Konzepte sind dabei wichtig:

    1. LaunchAgent
    Ein LaunchAgent ist abhängig von der Anmeldung eines Users und läuft unter dessen Nutzerkennung.

    2. LaunchDaemon
    Ein LaunchDaemon ist nicht abhängig von der Anmeldung eines Benutzers und wird beim Systemstart von launchd aktiviert (unter root).

    Die Einstellungen für Agents und Daemons finden sich in Property-Lists (*.plist).

    Damit folgt:
    1. Alles unter /System/Library/LaunchDaemons wird bei Systemstart gestartet und gehören root.
    2. Alles unter /System/Library/LaunchAgents wird bei Benutzeranmeldung gestartet (gehört aber root) wie z.B. die Zwischenablage (com.apple.pboard.plist).
    3. /Library/LaunchDaemons ermöglicht dem Admin das Starten von Diensten bei Systemstart,
    4. bzw. /Library/LaunchAgents dient dazu vom Admin konfigurierte Agents bei Anmeldung zu starten.
    5. Erste jetzt kommen die Agents, welche von einem Benutzer gestartet werden und unter ~/Library/LaunchAgents liegen.

    D.h. gemäß der gelisteten Programme sollte eigentlich nichts abhängig vom User sein.
    Es scheint also so, als ob sich in den Programm-Voreinstellungen (~/Library/PreferencePanes) etwas verbirgt, weil diese Userabhängig aktiviert werden. Die anderen Ordner sind ja leer bzw. werden bei Systemstart oder jeder Useranmeldung aktiviert.

    Stefan
     

Diese Seite empfehlen