[10.13 High Sierra] Serverwebsite offline

Forces

Angelner Borsdorfer
Mitglied seit
05.11.10
Beiträge
618
Hi,



ich habe vor, aus diversen Gründen, das MDM in der ServerApp zu starten.
Sofern ich das verstanden habe muss dafür, wegen der Konfiguration, den Dienst Website starten.
Nur sollte nach diversen Anleitungen im Netz der Dienst als auch die Websites nun laufen.


Ganz nebenbei die Frage, kann ich wenn der Dienst schon laufen muss, den so konfigurieren das ich nur von daheim oder per VPN aus Zugriff habe?

Danke für Hilfe
 

Anhänge:

Wuchtbrumme

Roter Herbstkalvill
Mitglied seit
03.05.10
Beiträge
13.061
weiss gar nicht, ob „Webseite“ auch aktiviert sein muss, vermute eher nicht. Auf jeden Fall muss Profilmanager an sein.

Dass der Server aus dem Internet nicht erreichbar ist dürfte für 99% aller Nutzer der Standardfall sein (IPv4 mit dynamischer IP und NAT-Router).
 

Forces

Angelner Borsdorfer
Mitglied seit
05.11.10
Beiträge
618
muss leider laufen da darüber die Konfiguration angesteuert wird.
Die ServerWebsite ist aber auf der lokalen Maschine auch nicht verfügbar.
 

Forces

Angelner Borsdorfer
Mitglied seit
05.11.10
Beiträge
618
was nur komisch ist die Website ist grau dargestellt aber der Dienst selbst ist online. Ich weis nur nicht woran das liegen kann.
 

Forces

Angelner Borsdorfer
Mitglied seit
05.11.10
Beiträge
618
ok ich bekomme nun nach etwas herum probieren jetzt die Meldung wenn ich versuche die Website aufzurufen:

Der angeforderte URL konnte auf dem Server nicht gefunden werden. Der Link auf der ">verweisenden Seite scheint falsch oder nicht mehr aktuell zu sein. Bitte informieren Sie den Autor ">dieser Seite über den Fehler. Sofern Sie den URL manuell eingegeben haben, überprüfen Sie bitte die Schreibweise und versuchen Sie es erneut

Klingt als ob der Dienst mit der hinterlegten HTML Datei nichts mehr anfangen kann. Diese ist jedoch an dem vorgegebenen Speicherort.

Ich wüsste aber nicht wie man das Problem nun beheben könnte?
 

Marcel Bresink

̈Öhringer Blutstreifling
Mitglied seit
28.05.04
Beiträge
5.549
Sofern ich das verstanden habe muss dafür, wegen der Konfiguration, den Dienst Website starten.
Nein, das ist nicht nötig. In macOS Server läuft grundsätzlich ein Reverse Proxy Web Server, der die eingehenden Anfragen an die einzelnen Dienste verteilt. Auch wenn der Profilmanager per Webseite konfiguriert wird und seine Konfiguration per HTTPS verteilt wird, muss der Web-Dienst von macOS Server nicht laufen.

Wenn der Profilmanager nicht über URLs nach dem Muster

https://server.example.com/mydevices/ und
https://server.example.com/profilemanager/

erreichbar ist, musst Du die Protokolle überprüfen, was schiefgegangen ist.