1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Schreibgeschützte Dateien aus dem Papierkorb leeren

Dieses Thema im Forum "macOS & OS X" wurde erstellt von AtticMike, 10.04.08.

  1. AtticMike

    AtticMike Tydemans Early Worcester

    Dabei seit:
    23.10.07
    Beiträge:
    393
    Hi Leute,

    habe folgendes Problem, ist ein bisschen komplexer.

    1. Habe eine ext. HDD in FAT, ehemals unter Windows genutzt
    2. Es gibt dort hunderte schreibgeschütze Ordner
    3. Habe sie versucht aus dem Papierkorb zu löschen, geht nicht
    4. Habe die alt bewährte Tastenkombo probiert, geht auch nicht
    5. Problem ist, jedes mal wenn ich die HDD anschließe kommen
    die nicht geleerten Dateien wieder in den Papierkorb.

    Somit kann ich nicht die HDD laufen lassen, sachen aufm Mac löschen und dann leeren, da er ja dann auch versucht die Daten von der externen HDD zu löschen. Würde auch mal gerne die Daten allgemein von der HDD leeren.

    Würde mich über eine Antwort freuen.

    Gruss Michael
     
  2. Egbert

    Egbert Süsser Pfaffenapfel

    Dabei seit:
    14.12.06
    Beiträge:
    672
    Genau das selbe Problem hab ich hier mit nem USB Stick! Ich lösche die Datein und dann sind sie trotzdem noch da! Der Papierkorb entleert sich nicht! :oops:

    Gruß, Egbert

    PS: Mh vielleicht sollte man das Thema in den Breich OS X verschieben oder so, passt glaube ich besser.
     
  3. AtticMike

    AtticMike Tydemans Early Worcester

    Dabei seit:
    23.10.07
    Beiträge:
    393
    Naja bei mir werden sie ja nicht gelöscht, sondern es kommt ja die Fehlermeldung Schreibgeschütze Ordner / Datei und die Leerung war fürn "Eimer" höhö oO

    Stimmt, nen Mod oder nen Admin wird das bestimmt übernehmen. Bedanke mich schonmal.
     
  4. Egbert

    Egbert Süsser Pfaffenapfel

    Dabei seit:
    14.12.06
    Beiträge:
    672
    Ja ich klick mich dann immer wie ein Doofer durch die (bei mir) ca 300 Meldungen weil die Tastenkombi nicht funktioniert. Und danach liegen die Datein immernoch im Papierkorb.
     
  5. AtticMike

    AtticMike Tydemans Early Worcester

    Dabei seit:
    23.10.07
    Beiträge:
    393
    Da ich 11 Jahre ein Windows Krüppel war und erst seit nem Jahr Mac nutze bin ich noch nicht in allen Dingen so bewandert, gebe mir jedoch alle erdenkliche Mühe
     
  6. paulderbademeis

    paulderbademeis Jonagold

    Dabei seit:
    10.04.06
    Beiträge:
    20
    phkl gefällt das.
  7. AtticMike

    AtticMike Tydemans Early Worcester

    Dabei seit:
    23.10.07
    Beiträge:
    393
    Hat nichts gebracht. Der Mist will nicht weg. Trotzdem danke für den Link.
     
    #7 AtticMike, 10.04.08
    Zuletzt bearbeitet: 10.04.08
  8. Egbert

    Egbert Süsser Pfaffenapfel

    Dabei seit:
    14.12.06
    Beiträge:
    672
    Ich habs jetzt so gelöst:

    alles wieder aus dem Papierkorb raus und überall das Häkchen bei "schreibgeschützt" weggemacht! Na klasse, tolle Beschäftigung! o_O Hat aber immerhin zum gewünschten Ergebnis geführt.


    Gruß, Egbert

    PS: Das ist mir schon oft aufgefallen! Wieso sind eigentlich Datein die ich von Windows-Usern bekomme ziemlich oft schreibgeschützt? Ich seh' da irgendwie keinen Sinn drin. Man wird doch eh doppelt und dreifach gefragt, ob man wirklich löschen will. Mh naja.
     
  9. AtticMike

    AtticMike Tydemans Early Worcester

    Dabei seit:
    23.10.07
    Beiträge:
    393
    Hab ne bessere Lösung :D

    Alle Dateien zurück in ein Ordner ziehen auf der HDD. Geht ja innerhalb ner Sekunde und dann folgende Schritte befolgen:

    1. Öffnen Sie das Programm "Terminal" (es befindet sich in "/Applications/Utilities").

    2. Geben Sie Folgendes ein: "chflags -R nouchg"
    Wichtig: Schreiben Sie nach "nouchg" ein Leerzeichen (im Beispiel oben nicht erkennbar), sodass es folgendermaßen aussieht: "nouchg ". Drücken Sie den Zeilenschalter noch nicht.

    3. Öffnen Sie das Symbol des Papierkorbs im Dock durch Doppelklicken, um den Inhalt anzuzeigen. Ordnen Sie ggf. das Finder Fenster so, dass ein Teil des Terminal Fensters noch sichtbar ist.

    4. Drücken Sie die Tastenkombination "Befehlstaste + A", um alle Dateien im Papierkorb auszuwählen.

    5. Bewegen Sie die Dateien aus dem Papierkorb in das Terminal Fenster.
    Hinweis: Dadurch wird automatisch der Pfadname für jede Datei eingegeben. So müssen mehrere Papierkorb-Verzeichnisse nicht mehr einzeln entleert werden, insbesondere, wenn mehrere Volumes vorhanden sind.

    6. Drücken Sie den Zeilenschalter. Es wird keine Meldung angezeigt, dass der Befehl erfolgreich war.

    7. Entleeren Sie den Papierkorb.
     
  10. iphone3g

    iphone3g Idared

    Dabei seit:
    11.07.08
    Beiträge:
    28
    vielen Dank! Die Anleitung war perfekt!
     
  11. Kaaliad

    Kaaliad Golden Delicious

    Dabei seit:
    02.03.09
    Beiträge:
    8
    Hatte dasselbe Problem, prima Anleitung! Danke.

    so long
     
  12. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.903
    Weil das unter vielen Windows-Versionen die Standardvorgabe ist, wenn man Daten von einer CD oder DVD herunterkopiert hat. Dass die Daten dort aus einem ganz anderen Grund "schreibgeschützt" waren, interessiert den Explorer nicht sonderlich, er setzt einfach eigenmächtig dieses Flag.

    Das Problem lässt sich (meist) übrigens recht einfach umgehen:
    Zum Entleeren des Papierkorbs nicht den Menübefehl im Finder, sondern das Kontextmenü des Papierkorbsymbols im Dock benutzen. Das löscht etwas radikaler.
     

Diese Seite empfehlen