1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Safari + Flash Plug-In + CPU Auslastung

Dieses Thema im Forum "Browser" wurde erstellt von lc4-edgar, 20.12.08.

  1. lc4-edgar

    lc4-edgar Jamba

    Dabei seit:
    25.12.05
    Beiträge:
    55
    Hallo Forum, habe folgendes Problem:

    Bei meinem PB G4 (OS X 10.5.6) habe ich die neueste Version von Safari (3.2.1 /5525.27.1) installiert. Nach dem Start habe ich eine CPU-Auslastung von 20-90%, dadurch steigt die Temperatur, sodass ständig die Lüfter laufen. Nur durch ausschalten von "Plug-Ins aktivieren" hab ich einen "normalen Betrieb". Folgendes habe ich schon ausprobiert:
    - Safari Cache leeren
    - Safari zurückgesetzt
    - Von OS X DVD gestartet und Zugriffsrechte repariert
    - Safari gelöscht und wieder neu installiert
    - Inhalte der Ordner MacHD/Library/Internet Plug-Ins, MacHD/Systemordner/Internet Plug-Ins sowie Benutzer/Library/Internet Plug-Ins Verschoben/gelöscht - und fahre nur noch mit dem Flash-PlugIn, welches zum normalen Surfen notwendig ist. Flash-Player10 mit Adobe Uninstall deinstalliert, über TimeMachine Flash9 installiert, immernoch volle CPU auslastung. Flash 9 wieder deinstalliert, Flash 10 wieder installiert, keine Änderung
    - In den Ordnern Input-Managers befinden sich nur Einträge von "smart crash reports" und "IPLM" (dürfte iPhotoLibraryManager sein)
    - zwischendurch 1000 mal Neustart gemacht

    Kann LEIDER nicht sagen, seit wann das Problem besteht, also Update auf Safari 3.2, Update auf 10.5.6 oder evtl Flash9 auf 10. habe wie oben beschrieben sämtliche Möglichkeiten, die das Forum hier zu bieten hat ausgeschöpft, wäre also für ein Geheimtipp ziemlich Dankbar,
    Gruss
     
  2. Aronnax

    Aronnax Châtaigne du Léman

    Dabei seit:
    03.12.04
    Beiträge:
    831
    Also ohne etwas zu machen, gleich eine CPU-Auslastung von 20-90%?

    Ja dann, ist es wohl am wahrscheinlichsten, dass du ein Safari-Erweiterung drin hast, die nicht mehr kompatibel ist.

    Sowas ist gemeint http://pimpmysafari.com/

    schau z.B.mal hier vorbei, wo sich solche Erweiterungen überall breit machen
    http://hetima.com/safari/stand-e.html


    z.B. /Users/YOU/Library/InputManagers/...
    oder /Library/Application Support/SIMBL/Plugins/...
    (hier am besten gleich mal dann den ganzen SIMBL Ordner rausnehmen)

    MfG
     
  3. lc4-edgar

    lc4-edgar Jamba

    Dabei seit:
    25.12.05
    Beiträge:
    55
    Danke für die Antwort,

    bin mit Safari eigentlich sehr zufrieden und habe noch nie eine Erweiterung installiert. Im Ordner Input Managers habe ich nur -wie oben beschrieben- zwei Einträge, welch nichts mit safari zu tun haben dürften.
    -Im den Ordnern "Application support" sind auch keine Einträge mit Safari
    -im Ordner Preferences habe ich am anfang selbstverständlich "com-apple.Safari.plist" gelöscht und nach safari-neustart wird diese datei ja neu angelegt- hatte ich oben vergessen zu schreiben
     
  4. Aronnax

    Aronnax Châtaigne du Léman

    Dabei seit:
    03.12.04
    Beiträge:
    831
    ja dann .. ist es wohl sicher ein PlugIn .. ist es nicht sinnvoll, erstmal alle Internet Plug-Ins vollständig raus zu nehmen .. und nach und nach wieder zurückzuschieben .. um den Übeltäter so einzugrenzen?
     
  5. lc4-edgar

    lc4-edgar Jamba

    Dabei seit:
    25.12.05
    Beiträge:
    55
    Ich hatte ja alle 3 Ordner mit Internet-plugins in einen Ordner auf den Desktop gezogen. Dann Adobe Flash installiert, dieser hat in HD/Library/Inernet-PlugIns (nicht in User) die Datei "flashPlayer.Plugin" und "flashPlayer.xpt" gelegt. Neustart Safari und die CPU-Temp geht von 45 auf über 60grad, bis die Lüfter angehen. Bei Seiten mit viel Werbung-->flash zieht sich Safari so 80% Systemleistung. Denke dass dies der Übeltäter ist. hatte deshalb auf flash 9 "gedowngradet"-ohne Erfolg. Ich hoffe ich suche an der richtigen Stelle!!!
    Ich schaue mal bei der Apple-Seite nach "install flash player 10", nicht dass ich die Version von Adobe aus versehen erwischt habe. Hab irgendwo gelesen, dass Apple den Player "modifiziert" und dann "anbietet"
     
  6. Aronnax

    Aronnax Châtaigne du Léman

    Dabei seit:
    03.12.04
    Beiträge:
    831
    ganz bestimmt nicht
     
  7. Aronnax

    Aronnax Châtaigne du Léman

    Dabei seit:
    03.12.04
    Beiträge:
    831
    Nur so nebenbei,
    bei einem PB G4 .. weiß ja nicht wie schnell genau
    So ungewöhnlich wäre das nicht .. Bei Seiten mit viel Werbung-->flash zieht sich Safari so 80%
    Besorg dir also auf jeden Fall einen Werbeblocker .. oder eben einen schnelleren Rechner .. und beschwer dich gegebenenfalls bei Adobe, dass Flash unter OS X so unoptimiert läuft.
     
  8. lc4-edgar

    lc4-edgar Jamba

    Dabei seit:
    25.12.05
    Beiträge:
    55
    1,25 GHz!!! und immer voll zufrieden gewesen!!
    Will mir demnächst ein neues MPB gönnen, wollte nur noch warten bis SnowLeo-rauskommt.
    Denke auch, dass bei Werbeintensiven seiten, womöglich noch über mehrere Tabs, dies das Problem sein sollte. Ohne Flash werden halt nicht alle Webseiten bzw. Funktionen vollständig angezeigt. Kannst Du vielleicht einen guten Werbeblocker empfehlen???
     
  9. Aronnax

    Aronnax Châtaigne du Léman

    Dabei seit:
    03.12.04
    Beiträge:
    831
    keine Ahnung - benutze immer Firefox und fast nie mit Werbeblocker ;)

    aber einfach hier vorbeischauen:
    http://pimpmysafari.com/plugins/?c=Adblocking
     
  10. lc4-edgar

    lc4-edgar Jamba

    Dabei seit:
    25.12.05
    Beiträge:
    55
    Bin auf der Website nach auf "Glimmer-Blocker" gestossen, werd den mal ausprobieren.
    Dann noch mal Danke für die schnelle Hilf u einen schönen Abend noch, gruss
     
  11. lc4-edgar

    lc4-edgar Jamba

    Dabei seit:
    25.12.05
    Beiträge:
    55
    Prozessorauslastung und CPU-Temp liegen wieder im grünen Bereich,

    mit Werbeblocker wie "Glimmer-Blocker" oder "Pit Helmet" sollte ich das Problem in den Griff bekommen. Werd jetzt wieder die restlichen PlugIns in die Library schieben
     
  12. A-K

    A-K Stechapfel

    Dabei seit:
    12.06.09
    Beiträge:
    163
    Leider habe ich das gleiche Problem mit der hohen CPU-Auslastung in Safari. Ich habe gerade auch schon alle Plugins gelöscht, neu gestartet, aber das hat nicht geholfen! Wenn ich testweise einen neuen Benutzer anlege und exakt die gleichen Internetseiten aufrufe, dann ist die CPU-Auslastung auf normalem Niveau!

    Was kann ich jetzt noch probieren? Hat jemand noch das gleiche Problem?
     

Diese Seite empfehlen