• Es gibt nach dem Softwareupdate eine Reihe von Änderungen und Neuerungen in unserem Forum. Genaueres dazu findet Ihr in dieser Ankündigung. Hinweise, Kritik, Anregungen, Lob und Tadel bitte hier diskutieren.

[10.9 Mavericks] Probleme mit TimeMachine Backup auf NAS

santa_maria

Cox Orange
Mitglied seit
15.01.11
Beiträge
99
Hallo Community,

kann es sein, dass Apple seit OS X 10.9 Mavericks das TimeMachine Backup auf eine externen NAS unterbindet?

Ich habe folgendes Problem:
Habe ein TM Backup von einem MBP auf eine QNAP-NAS konfiguriert. Habe es nicht ständig ON, da immer wieder Fehler und Abstürze kommen und dann das Sparesbundle unbrauchbar wird. Schalte es aber von Zeit zu Zeit ein, damit alle Systemdateien gesichert werden.

Nach dem Update auf 10.9 Mavericks sehe ich in den TM Systemeinstellungen zwar das Laufwerk des NAS, beim Verbinden kommt aber ein Systemfehler. Habe dann am NAS den TMBackup Dienst de- und wieder aktiviert, die neueste FW aufgespielt und Passwort geändert. Ich bekomme jetzt in den Systemeinstellungen nicht einmal mehr das Fenster zur Eingabe der Account Daten (User / Passwort) für das NAS. Bei einem MBAir, bei dem noch 10.8 läuft, klappt alles wie bisher.

Der Support (ProtectionCare) bietet keine Hilfestellung, weil NAS als TM-Laufwerk nicht unterstützt wird.

Jemand ähnliche Beobachtungen oder eine Lösungsidee?

lg Karl


TM1-Auswahl.jpg
Das Volume /TMBackup am NAS-Server //Hermes wird zwar angezeigt, aber ...

TM2-verbinden.jpg
... beim Verbindungsaufbau kommt ein Fehler.

Es gibt keine Möglichkeit, die Account-Daten (Benutzer/Passwort) einzugeben.
 

machmahinda

Grünapfel
Mitglied seit
19.04.13
Beiträge
7.115
santa_maria, Du bist nicht alleine.
Genau denselben Mist habe ich auch.
Es ist frustrierend. Die Einmal-eingerichtet-und-nie-wieder-anfassen-Taktik greift auf meiner Qnap 221 leider auch nicht.
Dabei habe ich sie zusätzlich zur Time Capsule extra deswegen angeschafft...
 

santa_maria

Cox Orange
Mitglied seit
15.01.11
Beiträge
99
Es hat geklappt.

Mit dem Hinweis von nomos bzgl der Protokolle war ich nicht erfolgreich, aber dann der Tipp von Stoekofatz mit dem Bug-Fix auf der QNAP Seite ist gold wert.

Qfix downloaden (nur wenige MB), dann über das neue App-Center im QNAP-Portal (manuelle Installation) den Fix installieren.

Vielen Dank an alle.
lg Karl
 

Baerchen1

Tokyo Rose
Mitglied seit
30.12.09
Beiträge
68
Ich hatte das gleiche Problem.
Geholfen hat bereits ein neues Initial-Backup über Backup erstellen.
Danach hat alles wieder geklappt.

Trotzdem habe ich den Qfix installiert, mal sehen ob es danach alles noch funktioniert...
 

Hoschy

Fuji
Mitglied seit
13.11.06
Beiträge
38
ich habe genau das selbe Problem.
nur das bei mir das MBP auf eine USB-Platte am iMac sichert.
Naja Sicherte...
Beide Rechner haben 10.9 drauf. Mit 10.8 gings noch.
Bei den TM-einstellungen wird die Freigabe auf dem iMac nicht mal mehr angezeigt.
Jemand eine Idee?
 

tomasm

Prinzenapfel
Mitglied seit
24.05.10
Beiträge
546
Hallo,

selbst mit dem QNAP FIX scheint die Funktion TimeMachine nicht 100% zu laufen, Sicherungen brechen nach einiger Zeit einfach ab, eine Initial Sicherung wird nicht komplett durchlaufen.. (nur mit x Abbrüchen).

Diese Arien sind aber mit den QNAP´s bekannt, nach allen OSX Updates gab es Probleme, teilweise auch recht lange bis endlich eine Verbesserung eingetreten ist.:( Das ist fast wie Weihnachten, jedes Jahr Probleme mit NAS und TM..

Ich bin schon fast dazu geneigt mir eine APPLE Lösung zu suchen und die TM - Funktion der NAS Systeme zu meiden, da diese eben nicht zuverlässig funktioniert.


Nachtrag:

mit dem FIX ist es bei mir unmöglich mehr als 20 GB an Daten in einem Rutsch zu sichern, ich habe den FIX wieder durch eine Neuinstallation gelöscht TM Manuell konfiguriert und die Sicherungen laufen aktuell wieder.. mal sehen wie lange..

Manuell hab ich das Laufwerk wie folgt angegeben:

sudo tmutil setdestination -ap afp://TimeMachine@NAS.local/TMBackup
 
Zuletzt bearbeitet:

santa_maria

Cox Orange
Mitglied seit
15.01.11
Beiträge
99
Kann tomasm nur beipflichten: TM in Kombination mit einem NAS - zumindest mit meinem QNAP TS 419p+ - funktioniert nicht zufriedenstellend. Ich habe ja im Beitrag #6 geschrieben, dass der Fix bei mir geholfen hat. Habe wieder Verbindung, TM sichert einige Tage, dann kommt allerdings immer noch der Fehler " ... um die Zuverlässigkeit zu verbessern ... neues Backup ..."

TimeMachineError.jpg

Das hatte ich vor Mavericks und jetzt noch immer. Für mich ist diese Sicherungsmethode (TM) nicht brauchbar, wenn die Historie immer nach einigen Tagen gelöscht wird.

Habe in diesem Forum an anderer Stelle bereits darüber berichtet und dass ich lieber FreeFileSync einsetzen würde - wenn es sich nur zeitsteuern liese. Wurde da von Wissenden ziemlich belächelt.

Habe leider keine Lösung.
 
  • Like
Wertungen: tomasm

tomasm

Prinzenapfel
Mitglied seit
24.05.10
Beiträge
546
Hallo,

falls es möglich ist dann schmeiss den FIX wieder raus ! Zumindest mit der QNAP 4.0.3 Version klappt die TM ohne den FIX.
Einfach die QNAP Version drüber installieren, alle Einstellungen bleiben ja erhalten nur der FIX ist weg.

Problem ist "ohne FIX" das man kein neues Laufwerk in TM über die GUI einstellen kann, hier kommt immer ein Fehler, man kann aber mit dem Befehl:
sudo tmutil setdestination -ap afp://TimeMachine@NAS.local/TMBackup

Das Laufwerk manuell setzen. Danach sollte TM funktionieren (tut es jedenfalls bei mir.. OSX 10.9 und 10.8).

Dabei ist:
TimeMachine = Username (TM User im QNAP)
NAS.local = NAS (vorher mal mit ping NAS.local probieren, Du kannst hier aber euch eine IP Adresse vom NAS eingeben.)

Er fragt dich dann ggf. 2x nach einem Passwort (einmal wegen sudo = Root PW und ein zweites mal wegen dem TimeMachine User im QNAP)..

Normal sollte aber das TM gleich funktionieren da Du das Laufwerk ja schon konfiguriert hast.. Nach 1 Tag Ärger mit dem FIX (ich Idiot hab es eingespielt) ist es bei mir draussen und alles funkt..

p.s. ein Ticket habe ich bei QNAP über den Fehler eingestellt, mal schauen was die antworten..

Falls der Eintrag für euch hilfreich ist, so würde ich mich über eine Portion "Karma" freuen... ;)


Tomas
 
Zuletzt bearbeitet:

harlekin12

Boskop
Mitglied seit
16.08.10
Beiträge
208
Moin,

die aktuellste Fw für das TS-419P+ ist die Version 4.0.2 (laut Website von QNAP)


Gruß, Roland
 

tomasm

Prinzenapfel
Mitglied seit
24.05.10
Beiträge
546
Hi,

dennoch ggf. ein Versuch wert... Allerdings hat die 4.0.3 eine AFP Änderung die anscheinend die 4.0.2 nicht hat:

[Version]

4.0.3 build0912 for x86 NAS

[Change log]
Enhancement
- App Center GUI minor enhancement.
- User/group/share creation wizards are simplified.
- AFP component is upgraded.
- [TS-269] Smart FAN enhancement for TS-269 series.
- [TS-x69] Updated the TS-x69 Pro/L BIOS. So, the fan does not operate at a high speed as the NAS boots up.
 

santa_maria

Cox Orange
Mitglied seit
15.01.11
Beiträge
99
Tomas danke, habe deinen sudo Befehl versucht. Jetzt habe ich gleich zwei Laufwerke eingetragen
TimeMachineError2.jpg
Sichern funktioniert, werde sehen wie lange. Er hat auf der bestehenden Datei aufgesetzt.

Das mit der QNAP-FW 4.0.3, die eigentlich nicht für meinen Typ freigegeben ist, möchte ich eigentlich nicht ausprobieren.
Gibt es einen tapferen Freiwilligen, der die neue Version austesten möchte. TS-419p+ ist gefragt ;)

Danke


Nachtrag:

der tmutil Befehl hat bei mir bewirkt, dass ...
1. bei mir in den TM-Systemeinstellungen zwei Ziel-Laufwerke angezeigt wurden
2. ich keine Rechte mehr in den TM-Systemeinstellungen hatte (keine Optionen, keine LW löschen, kein aktivieren / deaktivieren von TM

Habe mit sudo tmutil removedestination ID ihn wieder rückgängig gemacht.
https://developer.apple.com/library/mac/documentation/Darwin/Reference/Manpages/man8/tmutil.8.html

Das QNAP NAS Update 4.0.3 ist dzt nur für x86 Prozessoren verfügbar; ich - besser gesagt - mein TS419p+ hat einen ARM Prozessor, also Achtung!! und geduldig warten :)
 
Zuletzt bearbeitet:

tomasm

Prinzenapfel
Mitglied seit
24.05.10
Beiträge
546
Hi,

ja man kann mit removedestination sowas einfach zurücksetzen:

>sudo tmutil destinationinfo # Zeigt alle Laufwerke an die eingetragen sind (mit ID)
>sudo tmutil removedestination <ID> # Löscht ein Volume

was mich wundert ist, das Du keine Rechte mehr in der GUI hattest, das ist nicht normal.. Man kann in den TM Einstellungen auf Volumes gehen und normalerweise diese auch da löschen. Ggf. erstmal TM Ausschalten.. ging zumindest bei mir.. Bist Du sicher das Du einen ADMIN User hattest ?

Grüsse
Tomas
 

santa_maria

Cox Orange
Mitglied seit
15.01.11
Beiträge
99
Hallo Tomas,

Admin-User ja, da ich der einzige User auf meinem privaten MBP bin und in der Benutzerverwaltung unter meinem Namen und Foto auch ADMIN steht. Aber man sollte nichts für bare Münze nehmen ;)
 

OneCent

Becks Apfel (Emstaler Champagner)
Mitglied seit
28.03.11
Beiträge
333
kann es sein, dass Apple seit OS X 10.9 Mavericks das TimeMachine Backup auf eine externen NAS unterbindet?
Einfach noch der Vollständigkeit halber.

Nein, Apple hat NAS fremder Hersteller nie unterstützt und daher nehmen sie auch keine Rücksicht.

Beim nächsten update von OS X würde ich daher zuerst abwarten, ob Apple an TM was geändert hat, und ob QNAP ihr OS schon angepasst hat.
 

ImpCaligula

deaktivierter Benutzer
Mitglied seit
05.04.10
Beiträge
13.859
Zudem... Mavericks + Synology geht ja NAS ohne Probleme. Ist ja "nur" aktuell bei QNAP so. Dummerweise habe ich auch ein QNAP NAS.... aber seit wenigen Tagen auch eine TimeCapsule ^^