1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Problem mit name-based vhost

Dieses Thema im Forum "Webhosting/DSL-Anbieter" wurde erstellt von TaTonka, 12.08.08.

  1. TaTonka

    TaTonka Neuer Berner Rosenapfel

    Dabei seit:
    19.03.06
    Beiträge:
    1.961
    Guten Abend!

    Ich habe momentan ein problem mit einem Name-Based vHost. Wenn ich die URL aufrufe, scheint die Direktive nicht zu greifen, und ich lande auf dem default-vHost.
    Ich habe absolut keine Ahnung, wie ich das fixen könnte...die Config habe ich von nem anderen, funktionierenden vHost kopiert, und bloß die Werte angepasst.

    Schauts euch mal an:

    Code:
    <VirtualHost * >
    ServerAdmin mail@tatonka.info
    ServerName blog.tatonka.info
    ServerAlias *.blog.tatonka.info
    DocumentRoot /home/tatonka/public_html/wordpress
    <Directory /home/tatonka/public_html/wordpress>
    Order Deny,Allow
    Allow from all
    # Don't show indexes for directories
    Options -Indexes
    </Directory>
    </VirtualHost>
    
    Natürlich existiert der Pfad auch, und ist dank mod_userdir auch umständlich zu erreichen.

    Wenn mir irgendwer sagen könnte, was ich falsch mache...ich verzweifel hier grad.
     
  2. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Du hast dem Apache schon zumindest ein graceful gegeben nachdem Du die Konfiguration geändert hast?
    Gruß Pepi
     
  3. TaTonka

    TaTonka Neuer Berner Rosenapfel

    Dabei seit:
    19.03.06
    Beiträge:
    1.961
    Was ist ein graceful? Ich hab ihn zumindest mal reloaden lassen.
    Weiteres Phänomen: Ich habe einen default-vhost. Wenn ich den jetzt aber abschalte, und obige URL aufrufe, werde ich zwar immer noch auf meine default-Domain weitergeleitet, aber es lädt ebenjene gewünschte Seite.

    Ich habe mal gegooglet, und dort stand, dass es was damit zu tun haben könnte, in welcher Reihenfolge der Apache die vHost-Configs lädt. Bei mir sind sie alle nach den URLs benannt und liegen in /etc/apache2/sites-available, bzw. enabled.

    Mein default vHost heißt allerdings 000-default. Standardmäßig halt.

    Ich hab jetzt mal die Zeile <VirtualHost * > in <VirtualHost blog.tatonka.info > geändert. Ohne Erfolg.

    Ich hab mal bei nem Kumpel auf seinem Server nachgesehen, der verwendet IP-Based vHosts, allerdings nur auf einem einzigen Rechner mit einer IP. Also:

    <VirtualHost 1.2.3.4 >
    ServerName bla
    ...

    sodass der Apache anhand des ServerNames Bescheid weiß, welche Direktive er für welche URL aufrufen muss.

    Würde das bei mir auch was bringen?
     
  4. Appleboy

    Appleboy Neuer Berner Rosenapfel

    Dabei seit:
    04.12.05
    Beiträge:
    1.976
    Hi,

    auf unseren Webservern wird das auch über IP-based vHosts gelöst.
    Sollte bei dir auch funktionieren.
     
  5. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    graceful Siehe man apachectl(8). Dort wirst Du auch über Die Option configtest stolpern.

    hat übrigens nichts mit IP based Hosts zu tun, sondern bindet den httpd auf ein bestimmtes Interface auf dem Server. Beispielsweise wenn man mehrere Netzwerkkarten im Server hat und möchte, daß die Intranetseite nur auf einem bestimmten Interface anliegt. Wenn dort also <VirtualHost *> steht, dann reagiert der Apache auf allen Interfaces mit diesem vHost.

    Wirf doch noch einen Blick in die Apache Dokumentation dort wird das alles wunderbar erklärt. Du kannst Dir auch Webmin ansehen wo Du Apache mit einem Webinterface konfigurieren kannst. Das ist manchmal recht hilfreiche weil man sich nachher ansehen kann was alles in ein entsprechendes Konfig File geschrieben wurde.
    Gruß Pepi
     
  6. TaTonka

    TaTonka Neuer Berner Rosenapfel

    Dabei seit:
    19.03.06
    Beiträge:
    1.961
    Ich habe weitestgehend nach der Apache-Dokumentation gearbeitet, und im Webmin wird es imho auch korrekt angezeigt...aber wie gesagt, nicht ausgeführt.

    Ich muss dazu sagen, dass ich auf einem Debian-Server arbeite. Und ich muss zu meinem Bedauern berichten, dass ich den Befehl "apachectl", sowie die zugehörigen man-Pages nicht finden kann, und im APT scheint es dazu auch keine packages zu geben.
     
  7. Toddy

    Toddy Wohlschmecker aus Vierlanden

    Dabei seit:
    10.05.04
    Beiträge:
    240
    Hast du denn in der httpd.conf auch einen

    Code:
    NameVirtualHost 123.123.1.1
    definiert? Wobei du die IP Adresse natürlich an die Echte des Servers anpassen musst. (Und das ganze am besten oberhalb der ersten <VirtualHost *> V-Host Definition setzen.

    LG T.
     
  8. TaTonka

    TaTonka Neuer Berner Rosenapfel

    Dabei seit:
    19.03.06
    Beiträge:
    1.961
    Ich habe es momentan stehen in der vHost-Config von dem vHost, der vom Namen her am ehesten im Alphabet vorkommt. ich habe nämlich immer noch keine ahnung, in welcher Reihenfolge der Apache die vHost-Configs einliest.

    Edit sagt mir, dass es bei mir nicht apachectl sondern apache2ctl heißt. Ausgeführt, ohne Probleme durchgelaufen.

    Problem besteht weiterhin :(

    Ich hab jetzt mal alle anderen vHosts deaktiviert, jetzt wird die Seite korrekt geöffnet, allerdings mit der falschen URL. Wenn ich blog.tatonka.info eingebe, wird der Inhalt geladen, allerdings irgendwie mit nem redirect auf www.harvo.de (das ist der Hostname vom Server).

    Okay, ich habe das Problem jetzt mal soweit zurückverfolgt, als dass da immer diese Weiterleitung auf harvo.de greift. Die aber in meinen vHost-Configs nicht mehr existiert. Die default-Direktive kann da ja auch nicht greifen, da ja sonst die Seite nicht laden würde.

    So langsam blick ich da echt nicht mehr durch.

    So, langsam werd ich echt bekloppt. Man muss im Wordpress, das da drin liegt, noch die Installations-URL einstellen, mit der quasi nen mod_rewrite erfolgt. Da lag natürlich noch die alte Adresse drin, mit mod_userdir und allem.

    Jetzt scheints zu gehen, aber ich hab nicht übel lust, den Wordpress-Leuten deswegen aufs Maul zu hauen.
     
    #8 TaTonka, 13.08.08
    Zuletzt bearbeitet: 13.08.08
  9. Toddy

    Toddy Wohlschmecker aus Vierlanden

    Dabei seit:
    10.05.04
    Beiträge:
    240
    Wäre es möglich, dass du die gesamt httpd.conf und die vhost.conf hier postest?
     
  10. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Was sagt apache2ctl configtest? Irgendwelche verwertbaren Meldungen? Was passiert im httpd.log und error.log des vHosts und des Default Hosts wenn Du versuchst die Seite aufzurufen?
    Gruß Pepi
     
  11. TaTonka

    TaTonka Neuer Berner Rosenapfel

    Dabei seit:
    19.03.06
    Beiträge:
    1.961
    Öh, falls das nicht aus meinem letzten Post ersichtlich war: Es läuft jetzt. Lag an Wordpress.
     

Diese Seite empfehlen