1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Problem mit LaTeX auf unterschiedlichen Betriebssystemen

Dieses Thema im Forum "LaTeX" wurde erstellt von Minthorias, 04.11.08.

  1. Minthorias

    Minthorias Meraner

    Dabei seit:
    24.11.07
    Beiträge:
    224
    Moinsen,

    habe heute eine kleine Einführung in der Uni zu LaTeX gehabt und dort unter OpenSuse mit Kile folgendes erstellt.


    Hat auch alles geklappt dort mit dem kompilieren und umwandeln in eine PDF etc.
    Hab den reinen Text denn Mail gespeichert (an mich selbst geschickt) um dann hier bei mir mit TeXShop weiter zu experimentieren.

    Nur erscheinen immer Fehlermeldungen beim setzen.


    Was mache ich falsch?
    Habe ich einen simplen Schritt übersehen?

    Christoph
     
  2. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Ist Dein Editor auch auf UTF-8 eingestellt?
     
    Minthorias gefällt das.
  3. S3B

    S3B Antonowka

    Dabei seit:
    08.12.05
    Beiträge:
    357
    Ohne genauen Angaben was für Fehlermeldungen du bekommst, ist es schwierig dir weiterzuhelfen;)
     
  4. Stefan_K

    Stefan_K Morgenduft

    Dabei seit:
    18.05.07
    Beiträge:
    168
    Eingabecodierung

    Hallo Christoph,

    auch bei mir ist dieses Beispieldokument fehlerfrei übersetzbar.

    Du solltest uns schon deren Wortlaut mitteilen, damit wir helfen können. ;)
    Vielleicht ist bei Dir in TeXShop nicht die passende Eingabecodierung eingestellt, hier sollte sie UTF-8 sein.

    Viele Grüße,

    Stefan
     
  5. Minthorias

    Minthorias Meraner

    Dabei seit:
    24.11.07
    Beiträge:
    224
    Habe jetzt bei der Kodierung Unicode (UTF-8) eingestellt.

    Und dann den "Code" in ein neues Fenster kopiert.

    Beim Setzen kommt folgende Fehlermeldung.

    Vll könnt ihr mir ja beim Lesen und Interpretieren eben dieser helfen.
     

    Anhänge:

  6. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Bei mir keine Probleme, habe den Code von weiter oben in Emacs reinkopiert, als UTF-8 abgespeichert und getext. Du bist wirklich sicher, das Kile in UTF-8 abgespeichert hat? Stell den TeX-Code doch mal als Attachment hinein, ggf. gezippt.
     
  7. Minthorias

    Minthorias Meraner

    Dabei seit:
    24.11.07
    Beiträge:
    224
    keine Ahnung ob das wirklich UTF-8 war.
    Wusste nicht, das man unter verschiedenen Kodierungen abspeichern kann.
    Aber so wie es da steht hat es funktioniert, und der Text benutzt doch UTF-8 ?

    Würde es denn etwas bringen anstatt copy-paste zu benutzen alles neu zu tippen?


    Wie stell ich denn einen Tex-Code denn als Attachement rein?
     
  8. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Beitrag ändern, Tex-Datei als Anhang hochladen. Da musst Du allerdings ein ZIP-Archiv erstellen, reiner Text geht als Anhang glaube ich nicht bei Apfeltalk.
     
  9. Minthorias

    Minthorias Meraner

    Dabei seit:
    24.11.07
    Beiträge:
    224
    so hier ist die Datei
     

    Anhänge:

    • Uni.zip
      Dateigröße:
      893 Bytes
      Aufrufe:
      56
  10. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Wie ein Hexdump (hexdump -C Uni.tex) verrät, ist das definitiv kein UTF-8. Z.B. wird der Umlaut ü durch ein Byte 0x9F codiert, das entspricht der MacRoman-Codierung. Du müsstest entweder \usepackage[applemac]{inputenc} schreiben oder das Dokument nach UTF-8 codieren. Letzteres könnte z.B. Aquamacs Emacs. Mit anderen Editoren, z.B. TexShop oder auch kile, geht die Umkodierung sicher auch.


    Edit: Und Du solltest auch \usepackage[utf8]{inputenc} schreiben (das {inputenc} fehlt), sonst klappt das Übersetzen nicht. ;)
     
    #10 quarx, 05.11.08
    Zuletzt bearbeitet: 05.11.08
  11. Minthorias

    Minthorias Meraner

    Dabei seit:
    24.11.07
    Beiträge:
    224
    Denn scheint die Linux-Variante ja toleranter zu sein.

    TeXShop habe ich ja eigentlich umkodiert aber das klappt net so wie ich das denke.

    Werde es ancher einmal mit
    probieren.

    Danke für die Hilfe.
     
  12. Stefan_K

    Stefan_K Morgenduft

    Dabei seit:
    18.05.07
    Beiträge:
    168
    Umwandlung der Zeichencodierung

    Hallo,

    ergänzend zu quarx Tipp, so kann man die Umwandlung auf der Kommandozeile vornehmen:
    Code:
    recode MacRoman..utf8 <Uni.tex >Uniutf8.tex
    oder
    Code:
    iconv -f macroman -t utf8 Uni.tex >Uniutf8.tex
    Vielleicht ist zumindest eines der beiden Tools auf Deinem System installiert. Sie sind nützlich, wenn man z.B. mit Windows-Nutzern Dateien austauschen möchte.

    Viele Grüße,

    Stefan
     
    Minthorias gefällt das.
  13. Minthorias

    Minthorias Meraner

    Dabei seit:
    24.11.07
    Beiträge:
    224
    Danke Quarx, dein Tipp hat geholfen.

    Super =)


    Wo finde ich denn die Kommandozeile?
     
  14. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Möglicherweise hattest Du bereits vor Erstellen des Threads korrekt auf UTF-8 umkodiert (und wir haben es nur gemutmaßt), aber in der Zeile \usepackage[utf8]{inputenc} das {inputenc} vergessen. Dann solltest Du nicht nochmal mit recode oder iconv rangehen.

    Mit "Kommandozeile" ist das Programme->Dienstprogramme->Terminal gemeint.
     
    #14 quarx, 06.11.08
    Zuletzt bearbeitet: 06.11.08
  15. Minthorias

    Minthorias Meraner

    Dabei seit:
    24.11.07
    Beiträge:
    224
    Das mim Terminal hab ich mir fast gedacht.

    Nun stell ich mir aber die Frage, warum Kile auf dem Linux-Rechner auch ohne das inputenc auskam?

    Sind die verschiedenen TeXeditoren unterschiedlich tolerant? (bzw die compiler?!)
     
  16. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Wie, die Zeile
    Code:
    \usepackage[utf8]
    wurde unter Linux korrekt übersetzt? Das kann ich nicht glauben, das ist ja gar kein gültiges LaTeX. Oder meinst Du, komplett ohne diese Zeile gearbeitet zu haben? Welche Zeichencodierung verwendet Kile denn per Default?
     
  17. Stefan_K

    Stefan_K Morgenduft

    Dabei seit:
    18.05.07
    Beiträge:
    168
    Eingabecodierung

    Hallo,

    hier steht inputenc ja noch drin, weshalb es geklappt hat. utf8 ist bei den meisten Linux-Versionen, die ich kenne, voreingestellt, daher vmtl. auch bei Kile.

    Hier würde ich übrigens besser ngerman nehmen für die neue deutsche Rechtschreibung. Noch besser stattdessen ist babel mit ngerman-Option:
    Code:
    \usepackage[ngerman]{babel}
    
    Stefan
     
  18. Minthorias

    Minthorias Meraner

    Dabei seit:
    24.11.07
    Beiträge:
    224
    Welche Kodierung da Kile verwendet weiß ich nicht, da ich dies nur einmal die Woche an der Uni nutze.
    Aber er hat alles richtig übersetzt.


    Danke für den Tip mit babel und ngerman.

    Werde es denn mal einbauen =)

    Christoph
     
  19. Minthorias

    Minthorias Meraner

    Dabei seit:
    24.11.07
    Beiträge:
    224
    Huhu, ich bins noch einmal.

    Wenn ich diesen Code zu setzen versuche, zeigt er mir in Zeile 76 nach dem Figurebefehl imm einen Fehler an.
    Hier also stimmt irgend etwas mit center nicht.

    Siehe Anhang.

    Wenn ich den figure-Tag aber nicht setze, na gut ich weiß noch nicht wie es mit dem Tag aussieht^^, dann erscheint die Tabelle aber sonst wo.

    Weiß da jmd Rat?

     

    Anhänge:

  20. Stefan_K

    Stefan_K Morgenduft

    Dabei seit:
    18.05.07
    Beiträge:
    168
    Hallo Minthorias,

    verwende nicht die table-Umgebung innerhalb der figure-Umgebung. Die äußere figure-Umgebung kannst Du an jener Stelle weglassen.
    Die center-Umgebung würde ich auch nicht innerhalb figure oder table verwenden, siehe center vs. \centering.

    Viele Grüße,

    Stefan
     

Diese Seite empfehlen