1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Problem mit hosts Datei

Dieses Thema im Forum "macOS & OS X" wurde erstellt von TobiBuff, 07.03.09.

  1. TobiBuff

    TobiBuff Fuji

    Dabei seit:
    02.05.08
    Beiträge:
    37
    Ich kann auf einmal keine sicheren Verbindungen ins Internett mehr herstellen, d.h. wenn ich z.B. in den iTunes Store will kommt die Fehlermeldung "iTunes kann keine sichere Verbindung zum iTunes Store gewährleisten (-9815). Auf Web.de und alle anderen SSL geschützten Seiten kann ich nicht mehr zugreifen.
    Ich vermute, dass es an der hosts Datei liegt, da ich da vor kurzem etwas verändert hab. Leider hab ich keine Ahnung, wie ich diese Änderungen wieder zurücksetzten kann.

    Meine Hosts Datei sieht so aus:
    Code:
    ##
    # Host Database
    #
    # localhost is used to configure the loopback interface
    # when the system is booting.  Do not change this entry.
    ##
    127.0.0.1       localhost
    255.255.255.255 broadcasthost
    ::1             localhost
    fe80::1%lo0     localhost
    
    Ich hab die Datei auch nochmals angehängt.

    Danke im Vorraus
     

    Anhänge:

    • hosts.zip
      Dateigröße:
      307 Bytes
      Aufrufe:
      274
  2. IceHouse

    IceHouse Ribston Pepping

    Dabei seit:
    30.09.04
    Beiträge:
    297
    Deine hosts Datei ist voellig in Ordnung, was den Inhalt angeht. Wenn sie nun noch den richtigen Eigentuemer und die richtige Rechte hat ist der Teil schon mal in trockenen Tuechern.

    Versuche mal im Terminal folgendes abzusetzen und fuege dann mal den Output hier ein:

    Code:
    curl [url]https://store.apple.com[/url] -v
    Gruss von Mike

    Edit: Typo
     
    #2 IceHouse, 07.03.09
    Zuletzt bearbeitet: 07.03.09
  3. TobiBuff

    TobiBuff Fuji

    Dabei seit:
    02.05.08
    Beiträge:
    37
    Code:
    * About to connect() to store.apple.com port 443 (#0)
    *   Trying 17.149.156.10... connected
    * Connected to store.apple.com (17.149.156.10) port 443 (#0)
    * successfully set certificate verify locations:
    *   CAfile: /usr/share/curl/curl-ca-bundle.crt
      CApath: none
    * SSLv2, Client hello (1):
    * SSLv3, TLS handshake, Server hello (2):
    * SSLv3, TLS handshake, CERT (11):
    * SSLv3, TLS alert, Server hello (2):
    * SSL certificate problem, verify that the CA cert is OK. Details:
    error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
    * Closing connection #0
    curl: (60) SSL certificate problem, verify that the CA cert is OK. Details:
    error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
    More details here: http://curl.haxx.se/docs/sslcerts.html
    
    curl performs SSL certificate verification by default, using a "bundle"
     of Certificate Authority (CA) public keys (CA certs). The default
     bundle is named curl-ca-bundle.crt; you can specify an alternate file
     using the --cacert option.
    If this HTTPS server uses a certificate signed by a CA represented in
     the bundle, the certificate verification probably failed due to a
     problem with the certificate (it might be expired, or the name might
     not match the domain name in the URL).
    If you'd like to turn off curl's verification of the certificate, use
     the -k (or --insecure) option.
    tobis-macbook-pro:~ Tobi$ 
    
     
  4. TobiBuff

    TobiBuff Fuji

    Dabei seit:
    02.05.08
    Beiträge:
    37
    Ahh, mein Datum war auf 2007 gestellt ^^
    Da warn die Zertifikate noch nich gültig, jetzt klappts wieder
    Trotzdem danke
     
  5. wolfsbein

    wolfsbein Jerseymac

    Dabei seit:
    29.06.05
    Beiträge:
    448
    Das hatte ich mal bei einer die Probleme mit dem VPN-Client hatte (unter Windows). Hat Stunden gedauert bis ich das gemerkt habe, weil Datum und Uhrzeit ja korrekt waren. Und die Jahreszahl nicht direkt angezeigt wird.
     

Diese Seite empfehlen