• Apfeltalk ändert einen Teil seiner Allgemeinen Geschäftsbedingungen (AGB), das Löschen von Useraccounts betreffend.
    Näheres könnt Ihr hier nachlesen: AGB-Änderung
  • Viele hassen ihn, manche schwören auf ihn, wir aber möchten unbedingt sehen, welche Bilder Ihr vor Eurem geistigen Auge bzw. vor der Linse Eures iPhone oder iPad sehen könnt, wenn Ihr dieses Wort hört oder lest. Macht mit und beteiligt Euch an unserem Frühjahrsputz ---> Klick

[PHP] PHP-Update - keine Datenbankverbindung mehr

Wuchtbrumme

Golden Noble
Registriert
03.05.10
Beiträge
21.466
Hallo,
fürchte, die Frage ist so banal, dass sie in einem Pro-Forum nichts verloren hat und es tut mir wirklich leid, aber ich stelle mich beim Suchen auch ein wenig blöd an bzw. es ist wie immer, die Suchbegriffe werden so oft in anderen Zusammenhängen gefragt, dass die Ergebnisse total verschmutzt sind.

Ich habe ein ältliches debian8 (Jessie)-System mit php5.6 auf php7 updaten wollen (nein, wegen Virtuozzo muss es leider auf Jessie bleiben). Dazu bin ich der Anleitung hier gefolgt, habe die php5.6-Pakete deinstalliert, dotdeb hinzugefügt und habe dann bis auf php7.0-gd und php7.0-pear alles installiert bekommen. Die Module für Apache2 habe ich installiert und für Apache2 nutzbar gemacht/aktiviert, der Test ist erfolgreich.

Allerdings hatte ich ein Wordpress5.4 auf dem Server. Das mosert jetzt wegen "Error establishing a database connection" rum, dabei stimmen die Credentials- und DB-Informationen in wp-config.php. Einloggen in mysql (5.5.62-0+deb8u1) klappt auch mit den Credentials.

Bin jetzt also etwas ratlos. Gefühlsmäßig hätte ich gesagt, da klappt was mit php7 nicht :)
Wenn ich nur wüsste, was :)

BTW: ist php7.0 eigentlich richtig? Wordpress hat irgendwas von php7.4 gemunkelt, aber dafür finde ich für Jessie gar nichts...
 

Wuchtbrumme

Golden Noble
Registriert
03.05.10
Beiträge
21.466
hm, das scheint ja ein ganz trauriges Thema zu sein. Da dürfte wohl besser sein, ich migriere auf ein neues System.
Das ist dann zumindest aktuell.
 
  • Like
Reaktionen: ottomane

cryptosteve

Süssreinette (Aargauer Herrenapfel)
Registriert
16.04.17
Beiträge
408
Moin,

und das passende php-mysql-Paket ist auch installiert?
 
  • Like
Reaktionen: ottomane

ottomane

Golden Noble
Registriert
24.08.12
Beiträge
16.383
Es ging mir kürzlich ähnlich. Nach diversen Basteleien und dann dem verzweifelten Versuch, Jessie upzugraden, war die VM nicht mehr bootfähig. Tja, hätte ich auch besser gleich alles neu gemacht.

Zum Glück hat man ja Backups :D
 

torben1

Celler Dickstiel
Registriert
05.08.08
Beiträge
796
Wordpress selber mag gerne Version 7.3 Aufwärts. Es klappt aber auch mit Version 7.
Was gibt denn phpinfo aus?