1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

Octave mit fink

Dieses Thema im Forum "Andere Software" wurde erstellt von daniel.macbook, 03.09.08.

  1. daniel.macbook

    daniel.macbook Transparent von Croncels

    Dabei seit:
    09.01.07
    Beiträge:
    313
    Hallo zusammen,

    ich versuche schon seit gestern verzweifelt Octave mit fink zu installieren, aber das klappt nicht. X11 und gnuplot sind drauf, aber ich kriege immer folgende Fehlermeldung:

    WARNING: The package gcc43 Depends on xcode,
    but xcode only allows things to BuildDepend on it.

    Reading dependency for gcc43-4.3.2-1000...
    Reading build dependency for gcc43-4.3.2-1000...
    Reading dependency for gcc43-shlibs-4.3.2-1000...
    Can't resolve dependency "xcode (>= 2.5)" for package "gcc43-4.3.2-1000" (no
    matching packages/versions found)
    Exiting with failure.

    Kann mir jemand weiterhelfen?

    Gruß,
    daniel
     
  2. bezierkurve

    bezierkurve Danziger Kant

    Dabei seit:
    12.06.05
    Beiträge:
    3.861
    Und XCode ist installiert?
     
  3. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Oder einfach das Binary installieren:
    Code:
    sudo apt-get install octave
     
  4. daniel.macbook

    daniel.macbook Transparent von Croncels

    Dabei seit:
    09.01.07
    Beiträge:
    313
    Das Binary findet fink komischerweise nicht, XCode habe ich installiert, auch wenn ich meistens im iTerm mit nedit programmiere. Ich versuche es gerade mit darwinports und es sieht vielversprechend aus ....
     
  5. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
  6. daniel.macbook

    daniel.macbook Transparent von Croncels

    Dabei seit:
    09.01.07
    Beiträge:
    313
    Hmm es ist mal wieder wie verhext. Fink gibt die Fehlermeldung, dass gcc43 nicht auflösen kann und darwinports will texlive_base nicht installieren. Jetzt komme ich nicht weiter
     
  7. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Du hast einen Intel-Mac, gell? Dann behaupte ich mal, Du musst auf Fink unstable umstellen, weil der Quellcode der Pakete octave und gcc43 nicht im stable-i386-Zweig verfügbar ist (klick, klack). Wie man auf unstable umstellt, steht hier. Ist aber seltsam, dass das im PowerPC-Zweig keine Probleme macht.
     
  8. daniel.macbook

    daniel.macbook Transparent von Croncels

    Dabei seit:
    09.01.07
    Beiträge:
    313
    Ich habe fink schon auf unstable stehen
     
  9. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Welche Xcode-Version hast Du installiert?
     
  10. daniel.macbook

    daniel.macbook Transparent von Croncels

    Dabei seit:
    09.01.07
    Beiträge:
    313
    und ja, ich habe ein Intel MacBook, aber im Fink kann ich nur ein octave Packet auswählen 3.0.1-2. Ich vermute mal, dass er mir nur das Intel Packet anzeigt. Des Weiteren kriege ich ein Warning, dass meine X11 Installation unvollständig ist, aber ich habe das Apple Packet installiert und dieses Warning scheint ihn nicht weiter zu interessieren.
     
  11. daniel.macbook

    daniel.macbook Transparent von Croncels

    Dabei seit:
    09.01.07
    Beiträge:
    313
    XCode 2.4.1
     
  12. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Aha! Da steht wohl ein Download an... ;)
     
  13. daniel.macbook

    daniel.macbook Transparent von Croncels

    Dabei seit:
    09.01.07
    Beiträge:
    313
    Vielen Dank, das habe ich natürlich nicht geblickt, dass ich XCode 2.5 haben muss. Ich installiere das mal und schaue ob es funktioniert. XCode 3.0 ist nur für Leopard oder? Nochals vielen Dank und ich werde hier mal über meine Misserfolge oder Erfolge weiter berichten ;)
     
  14. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Ja, Xcode 3.0 ist nur für Leopard, 2.5 auch für Tiger.
     
  15. daniel.macbook

    daniel.macbook Transparent von Croncels

    Dabei seit:
    09.01.07
    Beiträge:
    313
    Super, mit der neuen XCode Version hat es nun geklappt, nachdem ich auch aquaterm und X11 von Apple neu installiert habe! Vielen Dank!
     
  16. stegi

    stegi Fießers Erstling

    Dabei seit:
    30.11.07
    Beiträge:
    127
    Hmm... habe dasselbe Problem:

    Code:
    [~]$ sudo fink install octave
    Information about 7153 packages read in 1 seconds.
    Can't resolve dependency "xcode (>= 2.5)" for package "gcc43-4.3.2-1000" (no matching
    packages/versions found)
    Exiting with failure.
    Allerdings ist Xcode 3.1 installiert. (?)
     
  17. daniel.macbook

    daniel.macbook Transparent von Croncels

    Dabei seit:
    09.01.07
    Beiträge:
    313
    Hast du XCode 2.5 installiert ?
     
  18. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Mit Xcode 3.x müsste es eigentlich auch gehen. o_O
     
  19. stegi

    stegi Fießers Erstling

    Dabei seit:
    30.11.07
    Beiträge:
    127
    Nein, wieso?
     
  20. daniel.macbook

    daniel.macbook Transparent von Croncels

    Dabei seit:
    09.01.07
    Beiträge:
    313
    Lies dir doch mal den gesamten Thread durch. Du musst XCode 2.5 oder 3.0 installieren, um octave entsprechend kompilieren zu können.
     

Diese Seite empfehlen