• Das kreative Thema des Monats Oktober wird vor allem diejenigen unter Euch besonders ansprechen, denen Do-it-yourself quasi im Blut liegt. Zeigt uns Eure Improvisationskünste oder fotografiert, was andere Leute sich so im Alltag zusammengestrickt haben. --> Zum Mitmachen bitte hier klicken

NFSv4 und Sonoma als Client

minimike

Empire
Registriert
07.06.12
Beiträge
84
Hi

Ich suche eine Möglichkeit einen NFS v4 Share unter MacOS Sonoma zu Mounten. NFS v4 weil auf dem Server ist NFS v3 deaktiviert. Einen Thread habe ich diesbezüglich hier im Forum schon gefunden. Der ist aber über 15 Jahre alt und voll mit kaputten Links und für mich letztendlich ohne Lösung.
Mitr Linux-Clients läuft alles einwandfrei. Fehlt nur noch mein Freund auf dem Schreibtisch :)
 
Zuletzt bearbeitet:
Terminal ->
Code:
man nfs
->
MacOS supports
version two, NFSv2 (RFC 1094), version three, NFSv3 (RFC 1813), and in
addition for the client, version four, NFSv4 (RFC 3530).
Funktioniert doch out of the box?
 
  • Like
Reaktionen: Wuchtbrumme
Ich bin nicht mit dem Hersteller verbunden und profitiere nicht von diesem Hinweis. Die gleich genannte Software stammt von einem bekannten Mac-Entwickler, der hier im Forum aktiv ist und den Hinweis wegen Vermeidung von Werbung wahrscheinlich nicht selber machen würde: NFS Manager.

Das ist eigentlich nur ein Hilfsmittel, um NFS-Verbindungen zu konfigurieren; Support selbst ist bereits im OS.

Die letzte Version ist derzeit vom August und führt macOS Sonoma als kompatibel auf. Ausserdem finde ich gerade keine aktuellen Hinweise (die aber sowieso eigentlich eher als Bugs von macOS zu laufen scheinen). Es kann nicht schaden, diese Details zu lesen.

Bitte daran denken, dass nfs4!=nfs3.
 
Terminal ->
Code:
man nfs
->

Funktioniert doch out of the box?
Nun denn

Code:
dhojnik@birne ~ % nmap -P0 troonedier
Starting Nmap 7.94 ( https://nmap.org ) at 2023-10-25 02:08 CEST
Nmap scan report for troonedier (172.23.228.8)
Host is up (0.0045s latency).
Not shown: 992 closed tcp ports (conn-refused)
PORT     STATE SERVICE
22/tcp   open  ssh
631/tcp  open  ipp
2049/tcp open  nfs
5432/tcp open  postgresql
8080/tcp open  http-proxy
9102/tcp open  jetdirect
9103/tcp open  jetdirect

Nmap done: 1 IP address (1 host up) scanned in 997.18 seconds
dhojnik@birne ~ % sudo mount -t nfs troonedier:/netzarchiv /private/nfs
Password:
mount_nfs: can't mount /netzarchiv from troonedier onto /private/nfs: Connection refused
mount: /private/nfs failed with 61
 
Die wahrscheinlichsten Fehlerquellen sind:
1) Du hast die Anfrage von einem unprivilegierten Port aus gesendet, was für manche Server als Sicherheitsproblem gilt. Falls der Server diese Sicherheitsvorgabe macht, musst Du die Mount-Anfrage ändern:

sudo mount -t nfs -o resvport,vers=4 troonedier:/netzarchiv /private/nfs

2) Der Server verwendet eine Liste zulässiger Clients oder höherwertige Identifikationsmethoden, wie Kerberos. In dem Fall muss der Client erst berechtigt, bzw. kerberisiert werden.

3) Es handelt sich gar nicht um NFSv4, sondern um NFSv4.1. Das ist mit macOS nicht kompatibel.
 
Zuletzt bearbeitet:
  • Like
Reaktionen: doc_holleday
sudo mount -t nfs -o resvport,vers=4 troonedier:/netzarchiv /private/nfs

Hey Danke das hat schon mal ordentlich geholfen. Kann man das direkt auch für Finder machen? Ich habe mal das hier in die /etc/nfs.conf eingetragen
Code:
nfs.client.mount.options = resvport,vers=4
Muss man dafür irgendetwas neu Starten? Oder den ganzen Rechner?
 
Wenn ein Wert, der vom Standard abweicht, neu eingetragen wird, wird er in der Regel sofort wirksam.

Wenn ein solcher Eintrag wieder entfernt wird, fällt er erst bei einem Neustart des Betriebssystems wieder auf den Standard zurück.
 
Hmm irgenwas fehlt noch. Ich habe inzwischen doch den Mac neu gestartet. Wenn ich die url nfs://troonedier.webterrorist.lan:/netzarchiv eingebe findet Finder den Server/Share nicht
 
Diese URL verstößt gegen die Syntaxregeln. Richtig wäre

nfs://troonedier.webterrorist.lan/netzarchiv/
 
Ne das klappt so nicht. Der FQDN ist richtig geschrieben. Gib es vielleicht doch noch einen Schlechtschreibfehler? Doppelpunkt habe ich erfolglos probiert...

Im Finder als URL ohne Doppelpunkt.
Ich würde es weiter mit dem Mount Befehl im Terminal versuchen bis es klappt.

Ist die nfs Domain gesetzt? In nfs.conf eingetragen? Wenn der nfs server default den dns suffix nimmt stimmt der mit dem Client überein? Ohne Fehlermeldungen ist’s über Forum etwas schwierig.

Was sagt denn showmount -e troonedier.webterrorist.lan
 
Im Finder als URL ohne Doppelpunkt.
Ich würde es weiter mit dem Mount Befehl im Terminal versuchen bis es klappt.

Ist die nfs Domain gesetzt? In nfs.conf eingetragen? Wenn der nfs server default den dns suffix nimmt stimmt der mit dem Client überein? Ohne Fehlermeldungen ist’s über Forum etwas schwierig.

Was sagt denn showmount -e troonedier.webterrorist.lan
Auf der Shell klappt das schon. Ich hätte es noch gerne im Finder wegen WAF...
showmount wird nicht Funktionieren weil das die Firewall blockt. eine nfs Domain habe ich nicht eingetragen. Kerberos und LDAP sind serverseitig noch nicht implementiert.
 
Auf der Shell klappt das schon. Ich hätte es noch gerne im Finder wegen WAF...
showmount wird nicht Funktionieren weil das die Firewall blockt. eine nfs Domain habe ich nicht eingetragen. Kerberos und LDAP sind serverseitig noch nicht implementiert.

Ah ok das hatte ich überlesen. Dann auf dem Server einen User erstellen mit der selben uid und gid und user / gruppennamen wie auf deinem mac. Bei nfsv4 reicht uid mapping nicht. Oder halt jetzt Kerberos einrichten.