1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

NAS Laufwerk automatisch mounten (Systemstart)

Dieses Thema im Forum "WLAN, Airport & TimeCapsule" wurde erstellt von Marino, 02.09.09.

  1. Marino

    Marino Antonowka

    Dabei seit:
    08.01.09
    Beiträge:
    362
    Ich habe es nun gestern endlich hinbekommen, dass mein NAS das Timemachinebackup akzeptiert.

    Ich habe nun in meinem WLAN-Netzwerk ein NAS (Synologie DS-108...).

    FritzBox 3050: Basisstation (USB-Drucker, 1 PC)
    FritzBox 3270: Repeater (LAN-Drucker, Scanner, NAS)

    Der Repeater ist zum Einbinden der Peripherie, die an ihm angeschlossen ist und zum Erweitern der Reichweite. Somit habe ich meistens zum Repeater eine 300MBit-Verbindung zum MBP. Dadurch dauern die Updates nicht allzu lange.

    Jedoch besteht das kleine Problem, dass ich nach dem Systemstart immer zum Server verbinden muss, was ein wenig nervt. Macht man es nicht, macht TM keine Sicherung. Mit externer HDD habe ich es auch immer aufgeschoben. Ich kenne mich und so nützt es mir wenig :)


    Man kann ja Scripte erstellen, allerdings kenne ich mich da nicht aus. Kann mir dabei jemand helfen?
    Das Script sollte, im Autostart sein und minimiert starten.
    Da ich das ganze mit 2 MacBook's machen möchte, sind diese natürlich nicht stationär. Wäre also doof, wenn man unterwegs ist und es kommen beim Starten Fehlermeldungen, dass der Server nicht erreichbar ist.
    Vielleicht kann man ja einen Ping an die IP der NAS schicken und nur, wenn der erfolgreich war, zum NAS verbinden.

    Den Befehl nutze ich momentan, um zu verbinden. Die NAS kann auch afp. In der Anleitung stand allerdings, dass einige damit Fehlermeldung bekämen und immer smb benutzen, daher...
    smb://Benutzername:Kennwort@IP/Backupordner

    Könnte mir damit bitte jemand helfen? Wäre super. Ich habe schon so lange gebraucht, bis es überhaupt klappte...
     
  2. wellknownasmax

    wellknownasmax Friedberger Bohnapfel

    Dabei seit:
    08.01.08
    Beiträge:
    539
    Mach es wie folgt:
    1. Mounte das NAS
    2. Systemeinstellungen -> Benutzer auswählen -> Startobjekte -> Laufwerk auswählen

    Dann fügst du einfach das entsprechende Laufwerk hinzu und es wird beim Start gemountet
     
  3. Marino

    Marino Antonowka

    Dabei seit:
    08.01.09
    Beiträge:
    362
    Das habe ich nun mal versucht, aber klappt nicht.
     
  4. wellknownasmax

    wellknownasmax Friedberger Bohnapfel

    Dabei seit:
    08.01.08
    Beiträge:
    539
    #4 wellknownasmax, 03.09.09
    Zuletzt bearbeitet: 03.09.09
  5. Marino

    Marino Antonowka

    Dabei seit:
    08.01.09
    Beiträge:
    362
    Muss ich mir mal anschauen.

    NAS wird mit IP, Benutzername und Passwort verbunden.

    EDIT:
    Das Programm startet zwar, aber zum Einstellungen speichern fragt er nach dem Root-Passwort. Nach der Eingabe wird es unerwartet beendet. Vielleicht ja inkompatibel mit SL.
     
    #5 Marino, 04.09.09
    Zuletzt bearbeitet: 04.09.09
  6. Rosi-janni

    Rosi-janni Rheinischer Winterrambour

    Dabei seit:
    27.02.07
    Beiträge:
    926
    Also AppleScript ist dazu doch genial einfach:
    Script Editor öffnen, Code einkopieren und als Programm speichern! Dann fragt er nur einmal, beim ersten Start nach dem Kram ;)
    Ich werde hoffentlich bald mal ein Entwurf für ein Profi Mountsystem auf http://eusers.eu.funpic.de/ online stellen ;)
    Code:
    tell application "Finder"
    	set server_ip to text returned of (display dialog "IP für Server angeben (Das SMB Protokoll wird genutzt!)" default answer "")
    	set user_name to text returned of (display dialog "Username für Server " & server_ip & " angeben" default answer "" with hidden answer)
    	set user_password to text returned of (display dialog "Password von " & user_name & " für Server " & server_ip & "  angeben" default answer "" with hidden answer)
    	try
    		mount volume server_ip as user name text user_name with password text user_password
    	on error
    		display dialog "Mount schlug fehl"
    	end try
    end tell
    
     
  7. Marino

    Marino Antonowka

    Dabei seit:
    08.01.09
    Beiträge:
    362
    Danke für das Script. Doch leider half es mir noch nicht so weiter.

    Zudem bekomme ich die Fehlermeldung, dass es fehlgeschlagen ist. Mit "Gehe zu >>> mit Server Verbinden" klappt es. Was mache ich falsch?

    Ist es möglich, auch vorher zu pingen und nur zu verbinden, wenn das NAS online ist? Wenn ich unterwegs bin, ist das NAS ja nicht da?
    Und ist es auch möglich einen Ordner zu öffnen? Dann könnte ich direkt in den Ordner, wo das Backup liegt.

    smb://username:password@NAS_IP/Time_Nils
    Time_Nils ist der Ordner, in dem das Backup liegt.

    Ich habe irgendwie keine Ahnung, wie ich es anstellen soll?!?
     
    #7 Marino, 05.09.09
    Zuletzt bearbeitet: 05.09.09
  8. deloco

    deloco Carmeliter-Renette

    Dabei seit:
    14.11.07
    Beiträge:
    3.304
    Mach dir ein Mount-Programm mit Automator.
    Neuen Ablauf erstellen, dann "Server abfragen" hinzufügen und die Adresse deiner NAS eintragen, inklusive der Freigabe die du mounten willst, also Beispielsweise "afp://192.168.1.10/Share".
    Danach die Aktion "Mit Servern verbinden" hinzufügen.
    Das ganze testen und wenn's läuft als Programm speichern.
    Danach kannst du das Programm einfach zu den Startobjekten (Systemeinstellungen -> Benutzer -> Startobjekte) hinzufügen.

    Geht bei mir einwandfrei...
     
    alexi77 gefällt das.
  9. Marino

    Marino Antonowka

    Dabei seit:
    08.01.09
    Beiträge:
    362
    Danke nochmal für eure Tipps, habe es nun hinbekommen.

    Code:
    try
    	set t to do shell script "ping -c 1 NAS_IP"
    	if t contains "0% packet loss" then
    		mount volume "smb://Benutzername:Passwort@NAS_IP/Ordner/"
    	end if
    end try
    
    So klappt es. Wenn ich möchte, auch noch mit Sprachausgabe oder Fehlermeldung. Aber ich denke das nervt auf Dauer. :cool:
     
    ImperatoR gefällt das.
  10. Rosi-janni

    Rosi-janni Rheinischer Winterrambour

    Dabei seit:
    27.02.07
    Beiträge:
    926
    Also ich will demnächst auch noch ein großes Netzwerk Server/Clientsystem aufbasteln, dazu hatte ich schon mal so das ein oder Andere geschrieben...
    Ich brauche dann z.b. auch ein vernüntiges Mountprogramm mit AS und das ganze dann im Hintergrund und dann macht das Backups von Ordnern und und und... :D

    Mehr dazu sollte es demnächst auf http://eusers.eu.funpic.de/ geben (Der AS Teil momentan im Umbau, deshalb komische Darstellung)


    EDIT:
    Ja ich war mal wieder blöd und habe was im Code vergessen o0:

    Code:
    tell application "Finder"
    	set server_ip to text returned of (display dialog "IP für Server angeben (Das SMB Protokoll wird genutzt!)" default answer "")
    	set user_name to text returned of (display dialog "Username für Server " & server_ip & " angeben" default answer "" with hidden answer)
    	set user_password to text returned of (display dialog "Password von " & user_name & " für Server " & server_ip & "  angeben" default answer "" with hidden answer)
    	try
    		[B]mount volume "smb://"&user_name:user_password@server_ip&"/"[/B]
    	on error
    		display dialog "Mount schlug fehl"
    	end try
    end tell
    
     
  11. Marino

    Marino Antonowka

    Dabei seit:
    08.01.09
    Beiträge:
    362
    Na, dann konnte das ja auch nicht klappen :)

    So habe ich mich ein wenig mehr damit beschäftigt, schadet auch nicht.

    Danke für die Hilfe.

    EDIT:
    Ich hatte mich immer gewundert, was du hiermit meinst:
    ...Das SMB Protokoll wird genutzt!...
    Ich wunderte mich immer, woher er das weiß und warum er standartmäßig, wenn man gar nichts angibt, nicht eher afp nehmen würde :)
     
  12. olihaeg

    olihaeg Pferdeapfel

    Dabei seit:
    20.08.08
    Beiträge:
    78
    Hallo,

    nochmal zum ursprünglichen Problem: Synology bietet in der aktuellen Beta die Möglichkeit des TimeMachine Supports. In Kürze kommt auch die Final raus.
    Mach einfach das Update deiner Syno. Dann einfach den Haken bei TimeMachine setzen und der Mac findet eine simulierte TimeCapsule auf die per AFP gesichert wird. Dazu muss auch kein Laufwerk gemountet werden. Läuft bei mir bisher problemlos.

    Grüße

    Oli
     
  13. asamooo

    asamooo Empire

    Dabei seit:
    17.02.09
    Beiträge:
    86
    Hast du die möglichkeit die gewünschte Partition auf dem NAS als iSCSI Target zu nutzen?
    Ich weiß es nur von Qnap aber das sollte mit Synology auch gehen.

    Dann diese Sorftware installieren: klick.
    Damit dann das iSCSI Target einbinden (mit den richtigen Einstellungen geschieht dies automatisch beim Start) und du kannst die Platte mit dem Festplattendienstprogramm formatieren und ganz normal wie eine interne Platte als TM Volume nutzen, ohne irgendwelchen Tricks.

    Bei weiteren Fragen helfe ich gerne weiter.
     
  14. Marino

    Marino Antonowka

    Dabei seit:
    08.01.09
    Beiträge:
    362
    @ olihaeg
    Muss man dann noch per Terminal ne sparsebundle-Datei erstellen und konfigurieren?

    Ich habe mir eines erstellt. Somit ist das Backup auf 230GB begrenzt, da die NAS ja auch noch für andere Zwecke da ist. Backups von Fotos z.B.

    Oder kann man einfach TM-Support anschalten und kann sie dann sofort nutzen? Gibt es dann eine Möglichkeit der Speicherbegrenzung? Vor allem auch für 2 MacBooks? Meine Freundin soll ja auch Backups erstellen können.


    @ asomooo
    Wüsste ich nun nicht. Aber würde das nicht bedeuten, sie wird dann nur für TM benutzt? Oder bleiben die übrigen Funktionen weiterhin aktiv? Sie soll ja nur zusätzlich für TM-Backups sein.
    EDIT: Laut Firmware-Changelog sollte das auch möglich sein. MOMENT, bei meiner Box anscheinend doch nicht.
     
    #14 Marino, 07.09.09
    Zuletzt bearbeitet: 07.09.09
  15. olihaeg

    olihaeg Pferdeapfel

    Dabei seit:
    20.08.08
    Beiträge:
    78
    Hi,

    das sparsebundle wird automatisch erstellt. Da musst du gar nichts mehr machen.
    Im Verzeichnis des Sparsebundles liegt auch die Info.plist. In dieser ist die maximale Größe angegeben. Du kannst einfach die max. Größe editieren und voila.
    Ich mache Backups von meinem iMac und dem Air. Beiden habe ich unterschiedliche Größen zugewiesen.

    Grüße

    Oli
     
  16. asamooo

    asamooo Empire

    Dabei seit:
    17.02.09
    Beiträge:
    86
    @marino: du kannst die Platte ja in mehrere Volumes aufteilen und eins davon dann wie beschrieben für TM nutzen.
    Die anderen sind davon nicht betroffen.
     
  17. Marino

    Marino Antonowka

    Dabei seit:
    08.01.09
    Beiträge:
    362
    Ich habe die neue Software nun auf dem NAS drauf. Allerdings finde ich keinerlei Einstellungen bzgl. TM. TM findet auch kein Laufwerk. Ist das irgendwie ein wenig versteckt?
     
  18. olihaeg

    olihaeg Pferdeapfel

    Dabei seit:
    20.08.08
    Beiträge:
    78
    Hi,

    schau ml unter "Gemeinsame Dateien" -> "Win/Mac OS" und dort im unteren Bereich.
    Apple Talk muss aktiviert sein, danach kannst du den Share in der KomboBox "TimeMachine" auswählen. Danach erscheint eine TimeCapsule in den TimeMachine Einstellungen.

    Grüße

    Oli
     
  19. Marino

    Marino Antonowka

    Dabei seit:
    08.01.09
    Beiträge:
    362
    Danke, die Einstellung habe ich einfach nicht gefunden. Trotz alledem mag TM es anscheinend nicht, denn angezeigt wird da nichts neues und eine TimeCapsule erkennt er auch nicht. Vielleicht kämpft das System noch mit Bugs...
     
  20. asamooo

    asamooo Empire

    Dabei seit:
    17.02.09
    Beiträge:
    86
    Hast meinen Vorschlag mal probiert?
    Laut Synologyforum läuft das auch auf einer DS107+, das müsste der Vorgänger von deinem sein, oder?

    Beitrag
    Anleitung
     

Diese Seite empfehlen