1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

mod_rewrite Apache2 Probleme

Dieses Thema im Forum "OS X-Developer" wurde erstellt von gzs, 14.07.08.

  1. gzs

    gzs Roter Delicious

    Dabei seit:
    14.07.08
    Beiträge:
    92
    Hallo zusammen,

    ich mache jetzt schon eine ganze Weile rum und komm einfach nicht drauf.

    Ich habe den im Mac OS X 10.5.4 enthaltenen lokalen Apace2 aktiviert und php ebenfalls. Funktioniert auch perfekt nur mod_rewrite bekomme ich nicht zum Laufen. Meine htaccess-Dateien werden vollkommen ignoriert.

    Gibt es irgendwo eine Schritt für Schritt-Anleitung für Dumme die erklärt wie ich Mod_Rewrite zum Laufen bekomme?

    Gerhard
     
  2. zeno

    zeno Lane's Prinz Albert

    Dabei seit:
    05.11.05
    Beiträge:
    4.898
    Werden die .htaccess Dateien total ignoriert, also auch bei Passwortabfragen oder ähnlichem?
    Eventuell ist in der /etc/apache2/httpd.conf das Laden des rewrite Moduls auskommentiert.
     
  3. gzs

    gzs Roter Delicious

    Dabei seit:
    14.07.08
    Beiträge:
    92
    Hallo,

    ich habe einige meiner .htacess-Dateien mit unterschiedlichsten Inhalten probiert, allerdings keine mit Passwortabfrage. Eigentlich brauche ich lokal nur die Umwandlung von .html in .php

    In der /etc/apache2/httpd.conf ist rewrite Modul nicht auskommentiert, von daher sollte es eigentlich klappen. Tut es aber nicht.
     
  4. dahui

    dahui Carmeliter-Renette

    Dabei seit:
    22.10.06
    Beiträge:
    3.303
    test ... starte mal deine htacces mit den zeilen

    RewriteEngine On
    Options all
     
  5. gzs

    gzs Roter Delicious

    Dabei seit:
    14.07.08
    Beiträge:
    92
    Da hat sich jetzt nichts geändert
     
  6. zeno

    zeno Lane's Prinz Albert

    Dabei seit:
    05.11.05
    Beiträge:
    4.898
    Ist in der httpd.conf überhaupt erlaubt das du aus nem Verzeichnis die Einstellungen überschreibst?
     
  7. dahui

    dahui Carmeliter-Renette

    Dabei seit:
    22.10.06
    Beiträge:
    3.303
    guter einwand!

    an den TO ... schau mal wie deine /etc/apache2/users/<username>.conf ausschaut

    beispiel:

    <username> natürlich mit dem echten username ersetzen.
     
  8. gzs

    gzs Roter Delicious

    Dabei seit:
    14.07.08
    Beiträge:
    92
    Meine sieht folgendermaßen aus:

    liegt hier das Problem und wie kann ich sie ändern ohne dass er mich schimpft ich hätte die Rechte nicht?
     
  9. Samsas Traum

    Samsas Traum Pommerscher Krummstiel

    Dabei seit:
    24.04.08
    Beiträge:
    3.030
    eigentlich musste dir nur das vorher genannte beispiel ansehen ...

    "AllowOverride all"
     
  10. Sid.TUX

    Sid.TUX Tydemans Early Worcester

    Dabei seit:
    20.08.05
    Beiträge:
    397
    Ja das ist das Problem

    Z.B. sudo nano datei

    ctrl-x ist beenden.
     
  11. zeno

    zeno Lane's Prinz Albert

    Dabei seit:
    05.11.05
    Beiträge:
    4.898
    Genau da liegt der Hase im Pfeffer (Woher kommt eigentlich das Sprichwort?).
    Wenn du mit dem Finder über Gehe zu Ordner nach /etc/apache2 wechselst und die .conf dann öffnest sollte er beim speichern schon nach dem Passwort fragen
     
  12. gzs

    gzs Roter Delicious

    Dabei seit:
    14.07.08
    Beiträge:
    92
    OK, wenn man sich nicht so dumm anstellt wie ich, kann man die Datei tatsächlich ändern :)

    Nun habe ich es geändert, es tut sich aber immer noch nichts.
     
  13. Sid.TUX

    Sid.TUX Tydemans Early Worcester

    Dabei seit:
    20.08.05
    Beiträge:
    397
    Service natürlich neu laden ;)
    Bin leider grad nicht an einer Mac... aber die grobe Tour, also Reboot hilft auf alle Fälle.
     
  14. gzs

    gzs Roter Delicious

    Dabei seit:
    14.07.08
    Beiträge:
    92
    Reboot ist das einzige was ich wirklich kann :) hab ich also schon gemacht.
     
  15. kauan

    kauan Stina Lohmann

    Dabei seit:
    31.12.05
    Beiträge:
    1.043
    Wo genau definierst du deine Rule (htaccess? Wo liegt die?) und wie sieht sie aus?
     
  16. supernova

    supernova Erdapfel

    Dabei seit:
    05.09.08
    Beiträge:
    1
    mod_rewrite

    Hallo,

    Ich habe auch Mac OS X 10.5.4 mit lokalen Apace2 aktiviert und php ebenfalls. Funktioniert auch perfekt nur mod_rewrite geht nicht. Meine htaccess-Dateien funktionieren nicht. Hat schon jemand von euch mod_rewrite unter 10.5.4 zum laufen bekommen?

    meine /etc/apache2/users/<username>.conf
    Code:
    <Directory "/Users/xxxx/Sites/">
       Options +FollowSymLinks +SymLinksIfOwnerMatch
       Options +Indexes All
       AllowOverride All
       Order allow,deny
       Allow from all
    </Directory>
    und in /etc/apache2/httpd.conf hab ich folgendes stehen:
    hat jemand Idee?!

    Danke
     
  17. Sid.TUX

    Sid.TUX Tydemans Early Worcester

    Dabei seit:
    20.08.05
    Beiträge:
    397
    Die htaccess heißt ".htaccess" und ist damit im Finder versteckt?
     
  18. dahui

    dahui Carmeliter-Renette

    Dabei seit:
    22.10.06
    Beiträge:
    3.303
    bei mir funktioniert es auf dem leo ( und auch auf 10.4.x ging es schon) mit

    Code:
    <Directory "/Users/<username>/Sites/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride all 
        Order allow,deny
        Allow from all
    </Directory>
    und in der .htaccess in der rewritebase den user mit angeben, also

    Code:
    RewriteBase /~<username>/path_to_folder_in_sites
     
  19. Toddy

    Toddy Wohlschmecker aus Vierlanden

    Dabei seit:
    10.05.04
    Beiträge:
    240
    Bitte sehr: Gesellschaft für deutsche Sprache
     
  20. TeeGee

    TeeGee Jonagold

    Dabei seit:
    14.12.08
    Beiträge:
    20
    Hallo,

    ich habe leider ebenfalls Probleme mit mod_rewrite in Verbindung mit .htaccess. :(

    Zu Testzwecken habe ich Wordpress in der aktuellen Version auf meinem Macbook unter 10.5.5 installiert.
    Ohne mod_rewrite und ohne ein .htaccess-File klappt auch alles bestens.
    In Wordpress kann man sich eine .htaccess-Datei erstellen lassen und Wordpress bzgl. der Permalinks ansprechender einzurichten.
    Bei mir wurde z.B. folgendes .htaccess erzeugt:
    Code:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /~thomas/wordpress/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /~thomas/wordpress/index.php [L]
    </IfModule>
    
    # END WordPress
    
    Meine thomas.conf in /private/etc/apache2/users/ sieht so aus:
    Code:
    <Directory "/Users/thomas/Sites/">
        Options Indexes MultiViews
        AllowOverride all
        Order allow,deny
        Allow from all
    </Directory>
    Mod_rewrite habe ich in der httpd.conf durch Entfernen des Kommentars aktiviert:
    Code:
    LoadModule rewrite_module libexec/apache2/mod_rewrite.so
    
    Sobald die .htaccess von Wordpress erzeugt wurde, kann ich keine Seite mehr aufrufen!
    Code:
    [B]Forbidden[/B]
    
     You don't have permission to access /~thomas/wordpress/ on this server.
    
    Was mache ich falsch?
     

Diese Seite empfehlen