1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

Linux und glibc

Dieses Thema im Forum "Linux auf dem Mac" wurde erstellt von daniel.macbook, 26.01.07.

  1. daniel.macbook

    daniel.macbook Transparent von Croncels

    Dabei seit:
    09.01.07
    Beiträge:
    313
    Hallo zusammen,

    ich möchte mittels Parallels Linux auf meinem Intel MacBook installieren, da ich zwei ausführbare Dateien zum Arbeiten brauche und diese unter MacOS X nicht gestartet kriege. Als Voraussetzung wurde mir folgendes mitgeteilt:

    The current distribution only includes executables for Linux glibc version 6.3 or later.

    Des Weiteren wurden die Exec. auf Fedora (core 1 system) erschaffen. Nun meine Fragen:

    Welche Version des glibc hat die aktuelle Ubuntu Version 6.10? Ich denke mal, es wird kein Problem sein, executables ,welche unter Fedora kompiliert wurden, auch unter Ubuntu zu starten, aber sicherheitshalber frage ich hier mal nach?

    Vielen Dank und schönes Wochenende!
     
  2. PatrickB

    PatrickB Rhode Island Greening

    Dabei seit:
    29.10.05
    Beiträge:
    478
    Wenn es zusätzlich zu den Binaries noch den Quellcode gibt irgendwoe dann Mut zum selberkompilieren.

    Gerade wenn es um irgendwelche Kommandozeilen Applications geht sind die meistens in Handumdrehen und ohne Probleme für den Mac kompiliert.
     
  3. daniel.macbook

    daniel.macbook Transparent von Croncels

    Dabei seit:
    09.01.07
    Beiträge:
    313
    Vielen Dan für die Antwort. Ich komme leider nicht an den Quellcode ran bzw mir fehlen auch die Mittel(ein Mathe-Programm), diesen umzusetzen. Des Wegen war meine Frage eher:

    Wenn die executables unter Fedora kompiliert wurden, werden sie mit der entsprechenden Library (glibc ) auch unter Ubuntu Linux laufen?

    Danke.....
     

Diese Seite empfehlen