1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

LaTeX

Dieses Thema im Forum "LaTeX" wurde erstellt von [Dirk], 12.03.09.

  1. [Dirk]

    [Dirk] James Grieve

    Dabei seit:
    26.10.08
    Beiträge:
    136
    Hallo

    ich bin gerade dabei meine Diplomarbeit zu schreiben. Allerdings bisher nur auf einem Windows Rechner. Da ich oft unterwegs bin, wollte ich sie auch auf meinem MB schreiben. Ich habe MacTex und TextMate. Funktioniert soweit ganz gut. Nur: Die Zeichen {} [] sind nicht auf der Tastatur und für mich umständlich zu erreichen. Gerade der Backslash \ ist sehr umständlich zu erreichen. Aber evtl ist das alles auch nur eine Sache der Gewöhnung...

    Jetzt habe bei jemandem gesehen, dass er als Editor TextMate benutzte (mit welchem Programm er das pdf betrachtete weiß ich nicht mehr). Jedenfalls konnte er im gesetzten pdf (oder dvi...) in das Dokument klicken und war genau an "der" Stelle in der .tex Datei. Also sehr praktisch :)

    Wie geht das, bzw. welche Programme brauche ich?
     
  2. bezierkurve

    bezierkurve Danziger Kant

    Dabei seit:
    12.06.05
    Beiträge:
    3.861
    Dafür brauchst du nicht mal unbedingt TextMate. Nutzt du momentan TeXShop? Dort kannst du per Apfel+Klick in den Code zur entsprechenden Stelle im PDF springen und umgekehrt.
     
  3. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Aber nur mit eingebundenem pdfsync. Und dann dürfte das auch mit TextMate (+Skim), Emacs (+Skim) & Co gehen.
     
  4. Zettt

    Zettt Doppelter Melonenapfel

    Dabei seit:
    16.10.05
    Beiträge:
    3.374
    Damit Skim als PDF Viewer hergenommen wird musst du erst in den LaTeX Preferences festlegen. Geh mal in TextMate unter Bundles >> LaTeX. Dort gibt es irgendwo LaTeX Preferences oder so...In dem Menü, dass dann nach einer gewissen Zeit erscheint, kannst du Skim als PDF Viewer einstellen.

    Und Skim kann pdfsync oder eben synctex.

    (BTW: Tach, Thorsten! ;) )
     
  5. Casi

    Casi Spartan

    Dabei seit:
    21.12.07
    Beiträge:
    1.601
    Warum umständlich?
    Alt 5 = [
    Alt 6 = ]
    Alt Shift 7 = \

    Gewöhnt man sich leicht dran. Ich texe auch mit meinem Mac :)
     
  6. Zettt

    Zettt Doppelter Melonenapfel

    Dabei seit:
    16.10.05
    Beiträge:
    3.374
    Achso...zwecks umständlich. Ich habe meinen Rechner auf englische Sprache und Tastatur umgestellt. Das finde ich vieeel angenehmer zu tippen.
    Dran gewöhnen kann man sich, wenn man sich die Tastaturübersicht (unter der Deutschlandflagge im Menü) mal ein bis zwei Stunden einblenden lässt.

    Um ä, ö, und ü zu schreiben, habe ich mir in TextMate drei Snippets angelegt die aktivier "u, "o und "a ausgeben. Damit bekommt man dann die deutschen Umlauts.
     
  7. skuZz

    skuZz Rheinischer Krummstiel

    Dabei seit:
    30.12.07
    Beiträge:
    377
    siehe signatur - alles was du brauchst. ich empfehle dir lyx, das ist ein wysiwyg editor, ähnlich wie office, also von der bedinung einfach und leicht verständlich. Zudem musste du den lästigen syntax nicht immer wissen... In der hinsicht ist das Programm eine echte arbeitserleichterung und auf jedenfall ein blick wert!

    gruß
     
  8. Irgendein Held

    Irgendein Held Oberösterreichischer Brünerling

    Dabei seit:
    17.06.07
    Beiträge:
    714
    Oder Ami-Keyboard drin haben - aber das Layout ist echt leicht und schnell gelernt. ;)

    Alternativ <alt> + <U> und dann gewuenschten Buchstaben auswaehlen!
     
  9. Zettt

    Zettt Doppelter Melonenapfel

    Dabei seit:
    16.10.05
    Beiträge:
    3.374
    Wobei man damit doch auch Setzschwierigkeiten hat oder? Also wenn man ein UTF8 Dokument hat und dort illegaler Weise einen Latin-1 Charakter (falls das ueberhaupt geht) einfuegt.
     
  10. Irgendein Held

    Irgendein Held Oberösterreichischer Brünerling

    Dabei seit:
    17.06.07
    Beiträge:
    714
    Wenn es ein UTF-8 Dokument ist, dann ist es unproblematisch.
    Zumindest nach meiner Erfahrung.
     
  11. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Dann setzt man am Anfang einfach ein
    Code:
    \usepackage[utf8]{inputenc}
    rein und fertig ist die Laube. Plus entsprechende Einstellung im Editor vielleicht noch.
     
  12. Irgendein Held

    Irgendein Held Oberösterreichischer Brünerling

    Dabei seit:
    17.06.07
    Beiträge:
    714
    "Fertig ist die Laube" erst, wenn auch das Dokument als solches UTF-8 kodiert ist.
     
  13. Macholino

    Macholino Adams Parmäne

    Dabei seit:
    02.08.04
    Beiträge:
    1.303
    Warum gehen meine XeLaTeX-Dateien mit MacTex 2007 problemlos und mit Version 2008 überhaupt nicht. Ich habe ein umfangreiches Masterdokument, das ich immer wieder nutze und in dem ich nur herauskommentiere, was ich nicht brauche. Zettts synctex habe ich in den TextMate-Preferences für LaTeX nicht gefunden, nur XeLaTeX, das bringt aber auch nichts. Es wird keine pdf produziert, der Fehler soll an der Zeile \author{icke} liegen. Halte ich erstmal für Quatsch.

    Ich nutze meine otf-Schriften, die mit der alten Version 2007 prima funktioniert haben. Mein Vorspann sieht so aus:

    Code:
    %!TEX TS-program = xelatex
    %!TEX encoding = UTF-8 Unicode
    \documentclass[paper=a4]{scrreprt}
    
    %% Schriften fuer XeLaTeX
    \usepackage{fontspec,xltxtra,xunicode}
    \setromanfont[Mapping=tex-text]{Linux Libertine O}
    \setsansfont[Mapping=tex-text]{Delicious}
    \setmonofont[Mapping=tex-text]{TheSansMono}
    
    %% Zeichensatz fuer Sonderzeichen definieren
    \newfontfamily{\FontLucidaGrande}[Scale=0.9]{Lucida Grande}
    
    \usepackage [ngerman]{babel}
    \usepackage{color}
    \usepackage{tocloft}
    \renewcommand*{\cftchapfont}{\sffamily\bfseries\color{blue}}
    \renewcommand*{\cftchappagefont}{\sffamily\bfseries\color{blue}}
    
    \renewcommand{\labelitemi}{---}
    
    % Setup for fullpage use
    \usepackage{fullpage}
    
    \usepackage{makeidx}
    
    
    % Surround parts of graphics with box
    \usepackage{boxedminipage}
    
    
    \title{Titel}
    \author{Heinz G. Konsalik}
    
    \date{Stand: \today}
    
    
    \makeindex
    
    % \usepackage[colorlinks=false, pdfborder={0 0 0}]{hyperref}
    
    \begin{document}
    
    \maketitle
    
    \tableofcontents
    
    \chapter{Kapitelname}\label{cha:kapitelname} % (fold)
    Dummes Zeug\index{Quatsch} wird immer erzählt.
    
    
    \textbf{Ein Hinweis:} Stromberg sagt: Ich bin ein geselliger Typ, aber eben nicht immer mit anderen Leuten.
    		
    \end{document}
    Auch wenn ich das hyperref-Paket weglasse, heilt das nicht mein Dokument. Irgendwas stimmt hier nicht ... :-[
     
    Der_Apfel gefällt das.
  14. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Was bedeutet denn "geht überhaupt nicht"? Erhältst Du irgendwelche Fehlermeldungen? In TeX Live 2008 (und damit MacTeX) sind z.B. manche Pakete aus TeX Live 2007 nicht mehr enthalten.
     
  15. Macholino

    Macholino Adams Parmäne

    Dabei seit:
    02.08.04
    Beiträge:
    1.303
    In TextMate bekomme ich die Meldung, dass Skim die pdf nicht öffnen kann, weil sie nicht existiert. Und tatsächlich wird keine pdf erzeugt.

    Kannst Du denn meine Datei sauber in eine pdf wandeln?
     
  16. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Ja, zumindest auf die Schnelle mit xelatex im Terminal. Aber erst, nachdem ich in der Präambel die drei Fonts Linux Libertine O, Delicious und TheSansMono rauskommentiert habe.
     
  17. Macholino

    Macholino Adams Parmäne

    Dabei seit:
    02.08.04
    Beiträge:
    1.303
    ja, und leider kommt es mir genau darauf an. Ich will meine eigenen Schriften nutzen, die unter ~/Library/Fonts liegen...
     
  18. Der_Apfel

    Der_Apfel Transparent von Croncels

    Dabei seit:
    03.12.07
    Beiträge:
    305
    Ich bin gerade total baff, dass es mit xelatex so einfach ist, Schriften einzubauen ... Das ist mit "normalem" Latex ja nicht so simpel.

    Na ja, ich habe gerade mal deine Datei getext und mir vorher die ersten beiden Schriften nach ~/Library/Fonts kopiert. Die dritte ist nicht frei verfügbar (wenn ich das richtig sehe?), deshalb habe ich die Zeile auskommentiert. Mit den anderen beiden scheints zu klappen. Ich habe aber noch MacTex2007. Jetzt lade ich mir 2008 runter, ich sage dir morgen Bescheid, wie es da aussieht.

    Was bekommst du überhaupt für eine Fehlermeldung (da sollte eigentlich mehr stehen als nur, dass der Fehler in der Zeile \autor{...} ist)? Falls dein Programm die Logs nicht automatisch anzeigt, gibt's ja noch die .log-Datei, die xelatex erzeugen sollte. Was steht da drin?

    Ich gehe bis jetzt davon aus, dass dir irgendein Paket fehlt. Werden wir morgen sehen. :)


    EDIT am Samstag: Ich muss dich leider enttäuschen. Bei mir läuft es auch mit MacTeX2008. :( Wie gesagt, nur die Zeile
    Code:
    \setmonofont[Mapping=tex-text]{TheSansMono}
    habe ich auskommentiert, weil ich die Schrift nicht habe.
    Jetzt bräuchte ich deine .log-Datei um dir weiterzuhelfen.
     
    #18 Der_Apfel, 20.03.09
    Zuletzt bearbeitet: 21.03.09
  19. Macholino

    Macholino Adams Parmäne

    Dabei seit:
    02.08.04
    Beiträge:
    1.303
    Ich habe meinen Code jetzt auch nochmal in ein leeres Dokument gepackt und TheSansMono auskommentiert (diese Schrift ist tatsächlich gekauft). Log und zwei Screenshots anbei. Ich werde nicht schlau daraus.

    Die .log habe ich in .txt umbenannt, damit ich sie hochladen kann.
     

    Anhänge:

  20. Der_Apfel

    Der_Apfel Transparent von Croncels

    Dabei seit:
    03.12.07
    Beiträge:
    305
    Mh. Er sagt, er könne deine Schriften nicht finden:

    Code:
    Package fontspec Info: Defining font family for 'Linux Libertine O' with option
    s [Mapping=tex-text] on input line 7.
    \c@zf@famc@Delicious=\count99
    Package fontspec Info: Defining font family for 'Delicious' with options [Mappi
    ng=tex-text] on input line 8.
    Package fontspec Info: Could not resolve font Delicious/B (it might not exist) 
    on input line 8.
    Package fontspec Info: Could not resolve font Delicious/I (it might not exist) 
    on input line 8.
    Package fontspec Info: Could not resolve font Delicious/BI (it might not exist)
     on input line 8.
    \c@zf@famc@Lucida Grande=\count100
    Package fontspec Info: Defining font family for 'Lucida Grande' with options [S
    cale=0.9] on input line 12.
    Package fontspec Info: Could not resolve font Lucida Grande/I (it might not exi
    st) on input line 12.
    
    Vielleicht haben deine otf-Dateien irgendein falsches Format? Probier doch mal meine Dateien, habe ich gerade hochgeladen nach http://veltrus.de/fonts.zip. Diesen Ordner einfach nach ~/Library/Fonts/ entpacken. Dann entstehen zwei Unterordner für die beiden Schriften mit den (bei mir passenden) otf-Dateien.
     
    Macholino gefällt das.

Diese Seite empfehlen