1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

[LaTeX] Lebende Kolumnentitel in der Kopfzeile

Dieses Thema im Forum "LaTeX" wurde erstellt von Macholino, 17.05.07.

  1. Macholino

    Macholino Adams Parmäne

    Dabei seit:
    02.08.04
    Beiträge:
    1.303
    Wenn ich meine Kopfzeilen so einrichte...

    Code:
    % Running Headers and footers
    \usepackage{fancyhdr}
    \pagestyle{fancy} \fancyhf{}
    \fancyheadoffset[RO,LE]{30pt}
    \fancyhead[RO,LE]{1-Ak-31}
    \fancyhead[LO]{\rightmark}
    \fancyhead[RE]{\leftmark}
    \fancyfoot[C]{\thepage}
    \renewcommand\headrule
    {{\color{blue}%
    	\hrule height 2pt
    		width\headwidth
    	\vspace{1pt}%
    	\hrule height 1pt
    		width\headwidth
    	\vspace{-4pt}}}
    ... überlagert mein Text die Kopfzeile. Ich bin leider noch zu unbedarft, um den Fehler auszumachen. Die Kopfzeilen sind 1:1 aus dem LaTeX-Begleiter abgekupfert. Das Ergebnis lässt zu wünschen übrig. Was mache ich falsch?
     

    Anhänge:

  2. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Da muss in der Präambel noch ein anderer Fehler schlummern, poste die doch mal komplett. Bei Dir werden anscheinend noch ein paar Fonts geladen. Dein Schnipsel - um ein Minimaldokument ergänzt - funktioniert bei mir zunächst einwandfrei:

    [​IMG]
     
  3. Macholino

    Macholino Adams Parmäne

    Dabei seit:
    02.08.04
    Beiträge:
    1.303
    So sieht die Präambel aus (lach bitte nicht, dass ich den Titel entfernt habe, das Dokument ist klassifiziert).
    Code:
    \documentclass[9pt]{scrreprt}
    
    \usepackage[avantgarde]{quotchap}
    \renewcommand\chapterheadstartvskip{\vspace*{-5\baselineskip}}
    
    \usepackage{helvet}
    \renewcommand\sectfont{\sffamily\bfseries}
    
    \usepackage{utopia}
    \renewcommand{\rmdefault}{put}
    
    % Use utf-8 encoding for foreign characters
    \usepackage[utf8]{inputenc}
    
    \usepackage [ngerman]{babel}
    % neu von AT
    \usepackage{color} % f. Farbe
    \usepackage{tocloft}
    \renewcommand*{\cftchapfont}{\sffamily\bfseries\color{blue}}
    \renewcommand*{\cftchappagefont}{\sffamily\bfseries\color{blue}}
    % Ende von AT
    
    \renewcommand{\labelitemi}{---}
    
    % Setup for fullpage use
    \usepackage{fullpage}
    
    \usepackage{makeidx}
    
    % Uncomment some of the following if you use the features
    %
    % Running Headers and footers
    \usepackage{fancyhdr}
    \pagestyle{fancy} \fancyhf{}
    \fancyheadoffset[RO,LE]{30pt}
    \fancyhead[RO,LE]{1-Ak-31}
    \fancyhead[LO]{\rightmark}
    \fancyhead[RE]{\leftmark}
    \fancyfoot[C]{\thepage}
    \renewcommand\headrule
    {{\color{blue}%
    	\hrule height 2pt
    		width\headwidth
    	\vspace{1pt}%
    	\hrule height 1pt
    		width\headwidth
    	\vspace{-4pt}}}
    
    
    % Multipart figures
    %\usepackage{subfigure}
    
    % More symbols
    %\usepackage{amsmath}
    %\usepackage{amssymb}
    %\usepackage{latexsym}
    
    % Surround parts of graphics with box
    \usepackage{boxedminipage}
    
    % Package for including code in the document
    \usepackage{listings}
    
    % If you want to generate a toc for each chapter (use with book)
    \usepackage{minitoc}
    
    % This is now the recommended way for checking for PDFLaTeX:
    \usepackage{ifpdf}
    
    %\newif\ifpdf
    %\ifx\pdfoutput\undefined
    %\pdffalse % we are not running PDFLaTeX
    %\else
    %\pdfoutput=1 % we are running PDFLaTeX
    %\pdftrue
    %\fi
    
    \ifpdf
    \usepackage[pdftex]{graphicx}
    \else
    \usepackage{graphicx}
    \fi
    \title{weggelassen}
    \author{\color{blue}weggelassen}
    
    \date{Stand: \today}
    
    \makeindex
    
    \begin{document}
    
    \ifpdf
    \DeclareGraphicsExtensions{.pdf, .jpg, .tif}
    \else
    \DeclareGraphicsExtensions{.eps, .jpg}
    \fi
    
    
    \maketitle
    
    %\begin{abstract}
    
    %\end{abstract}
    
    \dominitoc
    \tableofcontents
    
    Beim Minitoc habe ich noch das Problem, dass im Text das englische Wort Contents steht, obwohl ich gerne ein deutsches Wort hätte, wie zum Beispiel „Das steht in diesem Kapitel“. Aber das können wir später klären.

    Das war mein 1000. Beitrag. Mal so nebenbei.
     
  4. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Lass mich raten, in die LaTeX-Warnungen hast Du nicht reingeschaut? ;)
    Da steht z.B. Folgendes:
    Also füge mal so was wie
    Code:
    \setlength{\headheight}{15pt}
    (oder noch einen größeren Wert) dazu. Und das
    Code:
    \vspace{-4pt}
    am Ende vom \renewcommand\headrule würde ich komplett rausnehmen, das schiebt den Text über die Überschrift.

    Edit: ohne sieht's so aus, ganz OK oder?
    [​IMG]

    ... neuer Thread? :cool:
    Hab ich gesehen, Glückwunsch! Hier auch das Beweisfoto:
    [​IMG]
     
    #4 quarx, 17.05.07
    Zuletzt bearbeitet: 17.05.07
    Macholino gefällt das.
  5. Macholino

    Macholino Adams Parmäne

    Dabei seit:
    02.08.04
    Beiträge:
    1.303
    Bestens, vielen Dank! Ob ich allerdings 15 pt eingebe oder 75, wirkt sich nicht auf den Abstand zwischen Kopfzeile und Text aus. Damit will ich erst einmal leben, es rückt jedenfalls alles auseinander und wird lesbar.

    Zum minitoc-Problem hast Du mich auch auf die richtige Spur gebracht: Die Fehlermeldungen. So wird aus
    \usepackage{minitoc} kurzerhand ein \usepackage[german]{minitoc}, und aus Contents wird die Inhaltsangabe. Aber sicher weißt Du auch, wo welches renewcommand hin muss, damit aus „Inhaltsangabe“ ein „In diesem Kapitel steht dieser Stuss drin“ wird :innocent: ...
     
  6. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Du hast einige Zeilen drüber ja schon das ngerman-Paket eingebunden. Das sollte an sich die "german"-Option bei minitoc überflüssig machen. Schadet aber ooch nichts.
    Ein kurzer Blick in die Datei german.sty verrät, dass man dafür ein
    Code:
    \renewcommand{\contentsname}{In diesem Kapitel steht dieser Stuss drin}
    in die Präambel (oder direkt vor den \dominitoc bzw. \minitoc-Befehl) einfügen müsste. Auf jeden Fall aber hinter das Einbinden von ngerman und minitoc. :)
    [​IMG]
     

Diese Seite empfehlen