1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

IE 7 macht Probleme

Dieses Thema im Forum "Web-Programmierung" wurde erstellt von raid89, 28.08.09.

  1. raid89

    raid89 Carola

    Dabei seit:
    06.01.08
    Beiträge:
    113
    Hallo, der IE7 macht mir Probleme mit meiner seite.

    http://job.rockmartin.de/webby/

    Der Header wird mit komplett zerissen! Ich weiß absolut nicht warum! kann mir da einer weiter helfen?

    Ach und vom IE6 will ich erst gar nicht reden! Aber der wird noch ausgespert :p
     
  2. creative7even

    creative7even Jerseymac

    Dabei seit:
    23.02.05
    Beiträge:
    454
    Ich hab zwar keinen IE bei mir - aber ich würde folgendes machen:
    Header-Elemente (navi + logo) in ein eigenes div-Element geben. Positioning des header-wrappers und der inneren Elemente auf "relative" setzen, ggf. das Logo mit position "absolute" positionieren (ansonsten mit margin/padding -> trial&error).
    Dem Header-div eine fixe Höhe geben...
     
  3. raid89

    raid89 Carola

    Dabei seit:
    06.01.08
    Beiträge:
    113
    Ich arbeite das mal ab und dann melde ich mich nochmal :D

    Edit:// So hat alles nicht hingehauen! Ich weiß es nicht mehr weiter... und irgendwie habe ich jetzt noch mehr kaputt gemacht.
     
    #3 raid89, 28.08.09
    Zuletzt bearbeitet: 28.08.09
  4. creative7even

    creative7even Jerseymac

    Dabei seit:
    23.02.05
    Beiträge:
    454
    könntest du screenshots bzw die umsetzung online stellen?

    EDIT: habs mir gerade im IE7 angesehen - kein Unterschied zur Darstellung im FF festzustellen
     
  5. raid89

    raid89 Carola

    Dabei seit:
    06.01.08
    Beiträge:
    113
    Ja klar... Also Online ist die Version ja unter der oben stehenden Adresse.

    Hier ein Screen vom IE7
    [​IMG]

    Hier vom Firefox
    [​IMG] [​IMG]
     
  6. raid89

    raid89 Carola

    Dabei seit:
    06.01.08
    Beiträge:
    113
    BItte was???? :-c
     
  7. Balkenende

    Balkenende Seestermüher Zitronenapfel

    Dabei seit:
    12.06.09
    Beiträge:
    6.124
    Gerade im Büro gestetet. Funzt alles mit IE7!

    Hast Du nur ein individuelles Problem am Rechner?
     
  8. creative7even

    creative7even Jerseymac

    Dabei seit:
    23.02.05
    Beiträge:
    454
    Cache im IE geleert? Mein IE7 zeigt die Seite korrekt an (Annahme: Darstellung im FF = "korrekt")
     
  9. Balkenende

    Balkenende Seestermüher Zitronenapfel

    Dabei seit:
    12.06.09
    Beiträge:
    6.124
    1. Cache leeren versuchen
    2. Flash Player löschen & neu installieren (akt. Version)
     
  10. raid89

    raid89 Carola

    Dabei seit:
    06.01.08
    Beiträge:
    113
    Ey Leute!!! Was habt ihr an eurem IE 7 Rumgeschraubt?? :D

    Und wer schickt mir hier immer zu mails :D Ja das Kontaktformular geht!

    Kann einer von euch mal einen screen machen, ich kann euch das nicht so ganz glauben.
     
  11. Balkenende

    Balkenende Seestermüher Zitronenapfel

    Dabei seit:
    12.06.09
    Beiträge:
    6.124
    Immerzu nicht, aber testweise 1 mal, um Dir zu zeigen, dass bei Dir alles funzt :-D

    Glückwunsch.
     
  12. creative7even

    creative7even Jerseymac

    Dabei seit:
    23.02.05
    Beiträge:
    454
    bitte sehr - IE7 screenshot
     

    Anhänge:

    • webby.jpg
      webby.jpg
      Dateigröße:
      138,3 KB
      Aufrufe:
      74
  13. raid89

    raid89 Carola

    Dabei seit:
    06.01.08
    Beiträge:
    113
    Das doch der 8
     
  14. creative7even

    creative7even Jerseymac

    Dabei seit:
    23.02.05
    Beiträge:
    454
    oops - stimmt :eek:
     
  15. creative7even

    creative7even Jerseymac

    Dabei seit:
    23.02.05
    Beiträge:
    454
    ich würde aber dennoch den ersten Ansatz aufgreifen:

    Code:
    ...
    <style type="text/css">
     ...
     #header {
       width: 745px;
       margin: 0 auto 0 auto;
       position: relative;
       height: ??px; /* height of logo + navi */  
     }
    #navi {
      position: relative;
    }
    #logo {
      position: relative;
      width: 745px;
      height: 97px;
      background-position: center;
      background-repeat: no-repeat;
    }
      ...
    </style>
    </head>
    <body>
    <div id="page">
      <div id="header">
        <div id="navi">...</div>
        <div id="logo">...</div>
      </div>
    
      ...
    
    </div>
    
    bin mir zu 99% sicher dass diese Lösung (oder der Ansatz) funktioniert...
     
  16. raid89

    raid89 Carola

    Dabei seit:
    06.01.08
    Beiträge:
    113
    Jetzt geht gar nichts mehr. o_O
     
  17. creative7even

    creative7even Jerseymac

    Dabei seit:
    23.02.05
    Beiträge:
    454
    präziser? :)
     
  18. raid89

    raid89 Carola

    Dabei seit:
    06.01.08
    Beiträge:
    113
    Naja guck dir doch mal die seite an.
     
  19. creative7even

    creative7even Jerseymac

    Dabei seit:
    23.02.05
    Beiträge:
    454
    Mein Beispiel sollte nur eine Idee dafür geben, wie man den IE7 dazu bringen kann, das gewünschte Layout richtig zu rendern. Ich hätte nicht damit gerechnet, dass der Vorschlag unreflektiert übernommen wird.

    -> das div-Element, welches die Navi beinhaltet sollte die id "menu" haben (dann greift auch das CSS für die Hautnavi wieder). Die Navi benötigt eventuell - um eine korrekte Darstellung aufrecht zu erhalten - Höhe und Breite. Selbes gilt für das Logo -> pixel addieren und ein wenig trial & error - wäre in diesem Fall der richtige Weg.
     

Diese Seite empfehlen