1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Hilfe! Programmfenster ist auf (nicht angeschlossenem) zweiten Monitor :(

Dieses Thema im Forum "Mobil-Macs" wurde erstellt von jofarmer, 08.08.07.

  1. jofarmer

    jofarmer Gast

    Hallo!

    das Programmfenster eines für mich wichtigen Programms (Bookends) kriege ich nur durch F9 zu sehen, kann aber nicht damit arbeiten. Das preference file dieses Programms möchte ich unter gar keinen Umständen löschen, dafür war es zu aufwendig, all die Einstellungen vorzunehmen.

    Kann mir da jemand einen guten Tipp geben, bevor ich morgen wieder mein Powerbook (12") an meinen TFT anschliessen kann? Vielen vielen Dank!

    (Und ja, ich hab nach der Antwort gegoogelt und gesucht, aber nix gefunden, tut mir leid wenn ich den Wald nicht gesehen hab :()
     
  2. zeno

    zeno Lane's Prinz Albert

    Dabei seit:
    05.11.05
    Beiträge:
    4.898
    Versucht mal Systemeinstellungen -> Monitore -> Monitore erkennen. Mit Glück hüpft dann das Fenster rüber auf dein PB Display.
     
  3. jofarmer

    jofarmer Gast

    Danke, hab ich schon, bringt nüx :(
     
  4. Witti

    Witti Eifeler Rambour

    Dabei seit:
    02.06.06
    Beiträge:
    591
    Hab das selbe Problem beim DivX Converter
     
  5. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Probier eventuell mal, Folgendes im Applescript-Editor (unter Programme->Dienstprogramme) einzutippen und auszuführen:
    Code:
    tell application "Bookends"
    	activate
    	set bounds of front window to {20, 20, 800, 600}
    end tell
    (bei ähnlichen Problemen halt den Appliikationsnamen austauschen ;) )

    Klappt's so?
     
  6. jofarmer

    jofarmer Gast

    Code:
    „Bookends“ hat einen Fehler erhalten: 
    „bounds of window 1“ kann nicht als 
    „{20, 20, 800, 600}“ gesetzt werden.
    
    :(

    Habe inzwischen sogar das Bookends pref file gelöscht (nach vorherigem zippen), hilft aber au nix.

    Das is doch verhext!
     
  7. creative7even

    creative7even Jerseymac

    Dabei seit:
    23.02.05
    Beiträge:
    454
    hatte selbiges problem schon einmal - konnte auch keine lösung finden - scheint ein bug in osx zu sein.
     
  8. jofarmer

    jofarmer Gast

    Neineineineineineinein :( :(

    Bitte nich
     
  9. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Dann ist Bookends nicht Applescript-fähig. Da gibt's aber eventuell nen Trick: GUI-Scripting. Bin mal eben was raussuchen...
     
  10. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Nach kurzem Nachdenken glaube ich nicht, dass es mit GUI-Scripting geht. Meine Idee wäre gewesen, Mausbewegungen und -klicks zu simulieren, um das Fenster auf den primären Bildschirm zurück zu ziehen. Das ginge hiermit. Aber wenn der externe Monitor nicht angeschlossen ist, ist die Maus ja im primären "gefangen". Aber vielleicht hat noch jemand eine andere Lösung. o_O
     
  11. jofarmer

    jofarmer Gast

    Hab grad mein Glück mit virtueDesktops probiert - klappt aber auch nicht. Ich war es von BeOS und Linux eigentlich gewöhnt, dass man Programmfenster verschieben kann auf verschiedene virtuelle Desktops, aber VirtueDesktop kann das anscheinend nicht.
     
  12. jofarmer

    jofarmer Gast

    VirtueDesktops, DesktopManager und ein booten in die OpenFirmware und ein
    Code:
    reset-all
    haben auch nicht geholfen.

    Wie kann ich nur OS X beibringen zu vergessen, daß es jemals einen zweiten Monitor gesehen hat?
     
  13. jofarmer

    jofarmer Gast

    Die Lösung kam gerade aus dem englisch-sprachigen Macrumors-Forum:
    Well. Sorry I didn't suggest this the first time, but... can you bring up any OTHER window in Bookends? For instance, can you get the "Bibliography" window to show up? If you can cause any OTHER window to show up, hold down the "ALT" or "OPTION" key on your keyboard, and click the Green "Plus" or "Zoom" button on the title.

    It will maximize ALL windows in the application, and make them viewable in the current screen.
    Problem erkannt, Problem gebannt ;)

    :cool:
     
  14. commander

    commander Baldwins roter Pepping

    Dabei seit:
    25.02.04
    Beiträge:
    3.210
    Schön, dass Du eine Lösung gefunden hast.

    Bei mir liegt gelegentlich Mail scheinbar auf einem nicht angeschlossenen Monitor.

    Wenn man es jedoch in den Vordergrund birngt, sieht man zumindest ein Pixel breit rechts oder links das Fenster (so ists bei mir zumindest).

    Mit Hilfe der Lupenfunktion ist es dann einfach, das Fenster zu schnappen und in die gewünschte Position zu ziehen.

    Aber vielleicht funktioniert das nur in meinem Fall. Nervig ists in jedem Falle,

    Gruß,

    .commander
     
  15. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Anscheinend ist das Problem ja gelöst. Aber mir ist gerade dieses AppleScript zum Maximieren eines Fensters über den Weg gelaufen. Vielleicht hätte dann das hier auch geholfen (hab's gerade mit Bookends getestet):
    Code:
    tell application "System Events"
      if UI elements enabled then
        tell process "Bookends"
          click button 1 of window 1
        end tell
      end if
    end tell
    Vorher muss man Systemeinstellungen->Bedienungshilfen->Zugriff für Hilfsgeräte aktivieren.
     

Diese Seite empfehlen