1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Ghostscript unter Mac OS X installieren

Dieses Thema im Forum "macOS & OS X" wurde erstellt von _seppel_, 24.11.08.

  1. _seppel_

    _seppel_ Goldparmäne

    Dabei seit:
    04.08.06
    Beiträge:
    557
    Schönen guten Tag liebes Forum.

    Ich habe die obenstehende Frage vor mir und komme nicht weiter.
    Nach der Suche in Google und hier im Fourm weiß ich nur, dass ich die Datei runterladen muss und danach compilen.
    Da ich aber die ReadMe nicht verstehe, habe ich damit ein Problem.
    Normalerweise sollte da dann irgendwo eine .framework Datei erscheinen, die dann in die Library geschmissen wird –*ich finde sie nicht, auch wenn ich per Spotlight danach suche.
    Deswegen wollte ich fragen ob mir einer der Mitglieder Tipps geben kann oder sogar eventuell eine Anleitung kennt, die mir hilft Ghostscript zu installieren.
    Ich brauche es übrigens zur Einbindung von EPS-Daten in ein zweitklassiges Layoutprogramm.
    Und da sag nochmal wer, Open Source sei eine gute Alternative! ;)
     
  2. gKar

    gKar Maunzenapfel

    Dabei seit:
    25.06.08
    Beiträge:
    5.362
    Sollte nicht der i-Installer (neben LaTeX) auch Ghostscript automatisch downloaden und installieren können?
     
  3. stegi

    stegi Fießers Erstling

    Dabei seit:
    30.11.07
    Beiträge:
    127
    _seppel_ gefällt das.
  4. _seppel_

    _seppel_ Goldparmäne

    Dabei seit:
    04.08.06
    Beiträge:
    557
    Ich habe jetzt noch eine Frage:
    Ich habe Ghostscript indtalliert.
    Kann mir jemand sagen, wo es sich jetzt befindet, da ich den Pfad angeben muss?
     
  5. gKar

    gKar Maunzenapfel

    Dabei seit:
    25.06.08
    Beiträge:
    5.362
    Das dürfte von der gewählten Installation abhängen und sollte auch dokumentiert sein.
    Ansonsten würde ich einfach mal unter /usr/local suchen.
     
  6. Walli

    Walli Blutapfel

    Dabei seit:
    06.01.06
    Beiträge:
    2.594
    Gib mal "which gs" in die Konsole ein.
     
  7. gKar

    gKar Maunzenapfel

    Dabei seit:
    25.06.08
    Beiträge:
    5.362
    Gute Idee.
    (Ich kannte bisher nur den "whereis"-Befehl, aber der scheint nach einer ersten Recherche fast mit which (mit -a-Option) identisch zu sein.)
     
  8. MacAlzenau

    MacAlzenau Golden Noble

    Dabei seit:
    26.12.05
    Beiträge:
    19.405
    Die Konsole zeigt unter OS X nur die Fehler-Logs an.
    An die UNIX-Shell kommst du mit dem Terminal.
    Der richtige Gebrauch der Begriffe hilft bei der Suche, z.B. hier im Forum, enorm, auch denen, die sich später mal über alte Tipps freuen.
     
  9. _seppel_

    _seppel_ Goldparmäne

    Dabei seit:
    04.08.06
    Beiträge:
    557
    Alles klar, dass hab ich auch gemacht.
    Dann zeigt er mir als Ort /usr/local/bin/gs an.
    Aber wo auf meiner Festplatte liegt das jetzt eigentlich?
    Irgendwie kann ich den Ordner (?) nicht öffnen. Auch nicht über „Gehe zum Ordner…“ im Finder.
     
  10. gKar

    gKar Maunzenapfel

    Dabei seit:
    25.06.08
    Beiträge:
    5.362
    Der Finder hat auch standardmäßig keinen Zugriff auf „Unix-/Nicht-Mac-OS-Verzeichnisse“ wie insb. /usr (sie werden vom Finder als "versteckt" interpretiert). Im Terminal z.B. kann man aber alle Inhalte der Platte sehen, einschließlich /usr. Natürlich tun es auch andere Filemanager wie z.B. muCommander, ForkLift etc. Oder man aktiviert (z.B. mittels TinkerTool) das Anzeigen versteckter Dateien im Finder.
     
  11. _seppel_

    _seppel_ Goldparmäne

    Dabei seit:
    04.08.06
    Beiträge:
    557
    Das ist natürlich ärgerlich, weil ich die Datei in dem Layoutprogramm angeben muss.
    Aber vielen Dank nochmal für eure Tipps!
     
  12. MacAlzenau

    MacAlzenau Golden Noble

    Dabei seit:
    26.12.05
    Beiträge:
    19.405
    Das sollte aber funktionieren. Allerdings ist das wohl eine Datei, kein Ordner, weswegen du im Findermenü "Gehe zu /usr/local/bin" angeben musst, dann wird der Ordner und sein Inhalt regulär angezeigt. Alternativ reicht es auch, zu /usr zu gehen und sich dort ganz normal weiterzuklicken.
     
    _seppel_ gefällt das.
  13. _seppel_

    _seppel_ Goldparmäne

    Dabei seit:
    04.08.06
    Beiträge:
    557
    Ich konnte das Problem umgehen indem ich mir die Datei aus dem Verzeichnis kopiert und in meinem Benutzerordner in einem allgemeinen Verzeichnis wieder eingefügt habe.
    Denn ich habe bei der Angabe des Pfades nicht den Pfad selbst eingeben können sondern habe ein Fenster bekommen, in dem ich mich durch die Ordner klicken musste.
    NATÜRLICH wurde dort der Ordner /usr nicht angezeigt.
    Deswegen musste ich die Datei eben verschieben.
     

Diese Seite empfehlen