1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

ffmpegX: kein sound beim convertieren von imovie *.mov in avi

Dieses Thema im Forum "Videosoftware" wurde erstellt von onkelolf, 30.01.07.

  1. onkelolf

    onkelolf Braeburn

    Dabei seit:
    18.03.05
    Beiträge:
    42
    Moin,

    folgendes Problem: habe mit imovie nen video gebaut, allerdings hab ich es nicht geschaft es in einer ansprechenden qualität in ein avi zu bekommen, deshalb hab ich es als mov-file "bereitgestellt" und wollte dieses dann nachher im ffmpegx in eine avi umwandeln, ABER: ich bekomme eine avi ohne sound, wobei die mov sound hat.

    so erkennt ffmpegx das file:

    [​IMG]

    hier noch der log:

     
  2. thrillseeker

    thrillseeker Lord Grosvenor

    Dabei seit:
    06.10.04
    Beiträge:
    3.497
    ffmpeg erkennt den Audio-Stream (der in Deine mov-Datei eingebettet ist) nicht. Welches Audio-Format hast Du denn beim Erstellen der mov-Datei gewählt? Ich empfehle ein unkomprimiertes Format. Oder aber gleich eine mp3 oder AAC-Spur, denn dann könntest Du in ffmpeg unter "Audio" die Option "passthrough" wählen.
     
  3. Dante101

    Dante101 Ralls Genet

    Dabei seit:
    11.10.05
    Beiträge:
    5.052
    Falsches Forum - Bitte hierhin verschieben.

    LG
    Daniel

    EDIT: Danke.
     
    #3 Dante101, 30.01.07
    Zuletzt bearbeitet: 30.01.07
  4. thrillseeker

    thrillseeker Lord Grosvenor

    Dabei seit:
    06.10.04
    Beiträge:
    3.497
    Soweit ich es am Screenshot sehen kann, hast Du Audio mit 48000 Hz (sind das nicht eigentlich kHz?) kodiert. Du könntest mal den weiter verbreiteten Wert von 44100 kHz nehmen - der wird vermutlich besser erkannt.
     
  5. crossinger

    crossinger Doppelter Melonenapfel

    Dabei seit:
    30.07.06
    Beiträge:
    3.369
    Öhm, heute Morgen das falsche Mathematik-Müsli gefrühstückt?

    48000 Hz = 48 kHz
    44100 Hz = 44,1 kHZ

    So und nicht anders! ;)

    *J*
     
  6. onkelolf

    onkelolf Braeburn

    Dabei seit:
    18.03.05
    Beiträge:
    42
    so, habe bis jetzt das folgende versucht:

    1. Audio mit 44100hz kodiert im imovie -> gleiches problem
    2. Audio als ACC im imovie und im ffmpegx auf "überspringen" im soundmenü -> gleiches problem
     
  7. thrillseeker

    thrillseeker Lord Grosvenor

    Dabei seit:
    06.10.04
    Beiträge:
    3.497
    Da hast Du mich falsch verstanden :)

    Ich wollte nur darauf hinweisen, dass ffmpegX ein "k" unterschlägt. Statt 48000 Hz sollten da eigentlich 48000 kHz stehen. Quicktime zeigt es richtig an (siehe Screenshots).

    -Stefan
     

    Anhänge:

  8. crossinger

    crossinger Doppelter Melonenapfel

    Dabei seit:
    30.07.06
    Beiträge:
    3.369
    Nein, im Gegenteil: Du hast mit Deinen Screenshots den Beweis für Deinen Irrtum bewiesen! :-D

    Wofür steht denn das "k"? Für "kilo" = 1000!

    Also sind 44 Kilohertz = 44000 Hertz (44 kHz = 44000 Hz)

    ffmpegx zeigt Hertz an, also korrekt 48000

    QT zeigt Kilohertz an, also 44,1 (die beiden Nullen kannst Du ignorieren)

    Beide Anzeigen sind jeweils in ihrer Angabe korrekt!

    Sorry! :p

    *J*
     
    thrillseeker gefällt das.
  9. thrillseeker

    thrillseeker Lord Grosvenor

    Dabei seit:
    06.10.04
    Beiträge:
    3.497
    Offtopic

    Sorry für den kleinen Offtopic-Ausflug! Aber offenbar ist die Angabe in Quicktime falsch: Bei den AIFF-Tracks einer Audio-CD wird in Quicktime eine Abtastrate von 44100 kHz angezeigt, obwohl es eigentlich 44,1 kHz (also 44100 Hz) sind.

    @onkelolf:

    Möglicherweise sind bei Dir nicht alle Module in ffmpegX up-to-date? Beim Programmstart müssen die jeweils aktuellen Versionen von mpeg2enc, mplayer und mencoder installiert werden.

    -Stefan
     
  10. thrillseeker

    thrillseeker Lord Grosvenor

    Dabei seit:
    06.10.04
    Beiträge:
    3.497
    Sorry :innocent: Das kommt davon, dass ich viel mit einem gewissen Statistik-Programm arbeite, in dem die Zahlen US-amerikanisch formatiert sind. Ein Komma markiert dort nämlich 1000er-Kolonnen (44,100 bedeutet also 44100 und 44.1 bedeutet 44 Komma 1). Danke für Deine Geduld :)
     
  11. crossinger

    crossinger Doppelter Melonenapfel

    Dabei seit:
    30.07.06
    Beiträge:
    3.369
    Aber erkannt werden diese Änderungen in ffmpegx? D.h., Du siehst die entsprechenden Einträge für Audio links?

    *J*

    P.S.: @thrillseeker: OK, dann sind wir uns ja jetzt einig! ;)
     
  12. onkelolf

    onkelolf Braeburn

    Dabei seit:
    18.03.05
    Beiträge:
    42
    sollte, hab es vorgestern erst installiert

    japp, er erkennt es schon nur er mag es nicht umwandeln
     
  13. crossinger

    crossinger Doppelter Melonenapfel

    Dabei seit:
    30.07.06
    Beiträge:
    3.369
    hmmm... o_O

    Jetzt ist die Frage: liegt's am Input (aber das Audioformat wird ja offenbar erkannt) oder am Output.

    Nächster Versuch: mov in irgendein anderes Format? Z.B. mpeg1?

    Es geht mir jetzt darum: Kommt der Ton im Zielformat generell nicht an, oder liegt's speziell an AVI/DivX als Zielformat.

    *J*
     
  14. onkelolf

    onkelolf Braeburn

    Dabei seit:
    18.03.05
    Beiträge:
    42
    grade nochmal geteste:

    bekomme den sound auch bei ausgabe als mp3 nicht aus der datei und: wenn ich versuche die imovie-datei im ffmpegx abzuspielen (per playbutton oben rechts) bekomm ich auch keinen sound und der mplayer stürzt beim beenden ab.
     
  15. crossinger

    crossinger Doppelter Melonenapfel

    Dabei seit:
    30.07.06
    Beiträge:
    3.369
    Ich glaube, dann muss ich passen! Das ist dann letztlich kein Problem mehr von ffmpegx, sondern liegt offenbar eher am Output von iMovie. Und da habe ich nicht genug Erfahrung für qualifizierte Antworten. :(

    Höchstens noch folgenden Vorschlag: Nimm beim Erstellen des Films in iMovie doch mal DV als Format und lass das Ergebnis auf ffmpegx los. Auch wenn mir nicht klar ist, warum ausgerechnet iMovie nicht-konformes .mov schreiben sollte.

    *J*
     
  16. onkelolf

    onkelolf Braeburn

    Dabei seit:
    18.03.05
    Beiträge:
    42
    hmm, anscheinend kann man aus imovie nur als mov exportieren, habe jetzt mal "DV" als kodierung versucht, bringt auch nix... aber man muß doch irgendwie ein avi mit ansprechender qualität aus imovie bekommen
     
  17. crossinger

    crossinger Doppelter Melonenapfel

    Dabei seit:
    30.07.06
    Beiträge:
    3.369
    Ich hab's jetzt mal ausprobiert: iMovie 6 --> DV Output, danach Versuchsweise mit VisualHub nach DivX konvertiert. Ergebnis: VisualHub bricht mit Fehlermeldung ab! :mad:

    OK, ich habe sonst mit DivX nix am Hut, aber irgendwas ist da wohl quer...

    *J*
     
  18. onkelolf

    onkelolf Braeburn

    Dabei seit:
    18.03.05
    Beiträge:
    42
    so, hab das ganze jetzt so gelöst:

    1. export aus imovie als mov
    2. mit MPEG Streamclip ne *dv datei ruas gemacht
    3. mit ffmpegx nen xvid draus gemacht

    zwar umständlich aber wenigstens gehts...
     

Diese Seite empfehlen