[Boot Camp] Festplatte nach Boot Camp defekt/korrupt?

Dieses Thema im Forum "Windows auf dem Mac" wurde erstellt von frestler, 19.09.16.

  1. frestler

    frestler Granny Smith

    Dabei seit:
    10.12.14
    Beiträge:
    13
    Guten Abend zusammen,

    ich habe seit letzter Woche Freitag 2 iMacs von einen Kollegen hier rum stehen, auf denen ich für Ihn per Boot Camp Windows 8.1 (auf den iMac 27" Mid 2011) sowie Windows 10 (auf den iMac 27" Late 2012) installieren soll.
    Boot Camp Installationen habe ich schon so oft gemacht, den Prozess kannte ich also was alles zu tun ist - leider aber bisher immer nur auf neuere Mac Modelle und vor allem nur auf den MacBooks durchgeführt. Nun bei den iMac hatte bzw. habe ich noch ein paar Probleme.
    Nachdem ich mir hier etwas eingelesen habe, habe ich dank diesen Beitrags das eine Problem vom iMac 27" Mid 2011 behoben und somit Windows 8.1 sauber installieren können. Soweit alles ok.

    Nun zu meinen jetzigen Problem mit dem iMac 27" Late 2012, wo ich schon am verzweifeln bin, weil ich nirgends im Internet so ein Phänomen gefunden habe. Kurz zur Vorgeschichte:
    Auf dem iMac war vorher Yosemite installiert mit 2 Partitionen: 1x "MacOSX10.10" und 1x "Daten". Mit Hilfe eines El Captian USB Sticks (siehe Anleitung hier) habe ich dem iMac gebootet und das Festplattendienstprogramm des Installationssticks aufgerufen, um anschließend beide Partitionen zu löschen und eine große "Macintosh HD" Partition zu erstellen. Soweit alles noch OK, danach auch mittels dem USB Stick El Captian sauber installiert.
    Nun also Boot Camp geöffnet, die Schritte befolgt und den Stick erstellt. Mac startet neu und will Windows 10 versuchen zu installieren. Kurz darauf kam ein Fehler bzw. er konnte die Boot Camp Partition nicht finden und nutzen. Also wieder neugestartet in Mac OS X und versucht Boot Camp nochmal komplett neu zu machen: Festplattendienstprogramm -> Boot Camp Partion löschen und den freien Speicherplatz der Partition "Macintosh HD" zuweisen. Und genau hier hat das komische Phänomen schon angefangen:
    Beim Löschen bzw. Formatieren der Partition kam der Fehler "Exit-Code für Dateisystemprüfung lautet 0". Kurz gegoogelt was das heißt und auch direkt auf den Beitrag hier im Forum gestoßen. Bin aber nicht wirklich schlauer daraus geworden. Hab wo anders auch gelesen, dass das ein Zeichen ist, dass die Festplatte wohl ein Schaden weg hat.
    Naja, hab mir dann gedacht (aus Zeitdruck, da der Kollege die iMac eigentlich gestern schon holen wollte). ich ignoriere das mal und erstelle einfach mittels Boot Camp eine neue Partition. Gesagt getan, iMac startet neu oder wieder kam der Fehler wie vorher, dass ich Windows 10 nicht installieren konnte, weil mit der Boot Camp Partition etwas nicht stimmte. Wieder in OS X gestartet und das Festplattendienstprogramm aufgerufen. Wieder das gleiche Spiel: Versucht die zweite Boot Camp Partition zu löschen, aber wieder abgebrochen mit den Fehler "Exit-Code für Dateisystemprüfung lautet 0". Und jetzt kommt das von mir angesprochenen Phänomen: Ich hatte das nur nebenbei bemerkt, da ich alle anderen Partitionen verglichen habe:
    Nachdem ich beide Boot Camp Partitionen (waren beide so um die 400 GB groß) ja versucht habe zu löschen, es aber schief ging, hat Mac daraus eine Partition mit "Ohne Titel" erstellt. Dieser hat eigentlich eine Kapazität von 120 GB (das ist schonmal komisch...), aber "Verfügbar" zeigt er an über 850 GB ?!?! Wie geht das? Und das aller beste, bei "Belegt" zeigt er -730 GB an - genau MINUS ?!?! Sowas habe ich noch nie gesehen:
    Bildschirmfoto 2016-09-19 um 14.49.09.png
    Gehe ich auf die Festplatten Ansicht von "Über diesen Mac", dann sieht das ganze so aus:
    Bildschirmfoto 2016-09-19 um 14.49.06.png

    Ich hab jetzt 2 Probleme:
    1. Das mit der Festplatte und den verschwundenen 730 GB Speicherplatz
    2. Eine gescheite Boot Camp Partition erstellen, damit ich Windows 10 auf dem iMac installieren kann

    Ich bin mittlerweile echt am verzweifeln und jetzt zur später Stunde fällt mir leider auch nichts mehr ein, was ich machen könnte.
    Habt ihr eine Idee? Ich hoffe ihr könnt mir helfen!

    Danke!
     
  2. redbull-kalli

    redbull-kalli Schweizer Glockenapfel

    Dabei seit:
    21.04.15
    Beiträge:
    1.379
    @frestler,

    soweit ich das verstanden habe, war es ein Fehler im 1. Schritt per Festplattendienstprogramm (des Sticks) beide Partitionen zu löschen. Die "Daten"-Partition hätte genügt um daraus wieder "1" Laufwerk zu machen (...was es ja nicht ist, weil Fusion Drive). Aus dem dann fertig installierten El Capitan hätte man dann per Boot Camp Assistenten (BCA) eine Windowspartition erstellen und es anschliessend installieren können. Und zwar erstellt der BCA bei einem Fusion Drive (120 SSD + 1TB HDD) die Partiton immer auf der langsameren HDD. - Warum ursprünglich eine extra Datenpartition erstellt wurde, bleibt wohl das Geheimnis eigentlichen Besitzers.

    Wichtig ist, das nun entweder wieder ein Fusion Drive (aus beiden Festplatten), oder zwei getrennte Laufwerke eingerichtet sind. Wobei ich das Fusion Drive empfehle.

    Ich habe vor einiger Zeit mit Fusion Drives "experimentiert". Das heißt vereinfacht diese erstellt bzw. getrennt. Das geht nur über das Terminalprogramm. Wie das funktioniert kann man "googlen". - Wenn Dein USB-Stick mit El Capitan in Ordnung ist, dann kannst Du das Fusion Drive wieder einrichten. El Capitan installieren und dann per BCA eine Windowspartition einrichten. Suche nach "Fusion Drive selbst erstellen". Hierzu gibt es zahlreiche Anleitungen. Ein Versuch ist es...;)
     
    frestler gefällt das.
  3. frestler

    frestler Granny Smith

    Dabei seit:
    10.12.14
    Beiträge:
    13
    @redbull-kalli danke für den Hinweis mit dem Fusion Drive. Leider habe ich den El Capitan USB Stick nicht mehr bzw. auf den Stick ist El Capitan nicht mehr drauf, den müsste ich nochmal neu erstellen (hatte gestern und heute aber leider die Zeit dazu nicht).
    Habe hierzu auch 2 schöne Anleitungen gefunden:
    - http://www.maclife.de/ratgeber/do-it-yourself-baust-dir-dein-eigenes-fusion-drive-10076765.html
    - http://hardwrk.com/blog/fusion-drive-hardwrk-kit-mac-os-x/

    Bei beiden Anleitungen (bedingt durch keinen Boot Stick den ich aktuell habe) scheitere ich aber schon an den Punkt, wenn ich das Terminal öffnen und die Befehle eingeben soll (bei der zweiten Anleitung Schritt 3). Ich habe den iMac im Recovery Modus mitt cmd + R gebootet aber ich finde nirgends unter Dienstprogramm oder sonst wo eine Option das Terminal zu starten.
    Bin ich blind und blöd oder ist das, weil der iMac Late 2012 ist? Die Recovery Partition ist aber OS X El Captian, zumindest erscheint das wenn ich auf OS X erneut installieren gehe.

    Wie komme ich nun also das Terminal im Recovery Mode gestartet? Jemand eine Idee?
    Oder werde ich nicht drum herum kommen einen neuen Installationsstick zu erstellen?
     
  4. redbull-kalli

    redbull-kalli Schweizer Glockenapfel

    Dabei seit:
    21.04.15
    Beiträge:
    1.379
    frestler gefällt das.
  5. frestler

    frestler Granny Smith

    Dabei seit:
    10.12.14
    Beiträge:
    13
    Danke dir, aber leider wie in der Anleitung von Hardwrk beschrieben (obwohl der iMac Late 2012 ist) erhalte ich bei der Benutzung des Terminals im Wiederherstellungsmodus die Fehlermeldung "Error -69888: Couldn’t unmount disk".
    Gut dachte ich mir, versuchste das Ganze nochmal über einen Installationsstick. Hab also einen Stick mit Mac OS Sierra erstellt und die ganze Prozedur nochmal gemacht. Bekomm aber wieder die gleiche Fehlermeldung: Error -69888: Couldn’t unmount disk

    Was mich auch wundert, ich hab nicht nur 2 disks (wie in der Anleitung von Hardwrk beschrieben) sondern 20 Stück?!?
    20160924_123851671_iOS.jpg
    20160924_123855138_iOS.jpg
    20160924_123901300_iOS.jpg

    Hab alle möglichen Varianten versucht, aber nichts hilft
    20160924_123928940_iOS.jpg
    20160924_123959662_iOS.jpg

    Bin langsam ratlos...
     
    #5 frestler, 24.09.16
    Zuletzt bearbeitet: 24.09.16
  6. redbull-kalli

    redbull-kalli Schweizer Glockenapfel

    Dabei seit:
    21.04.15
    Beiträge:
    1.379
    @Frank,
    ..ich würde einen USB-Stick mit einem MacOS X Mavericks oder Yosemite) nehmen und zunächst das Festplattendienstprogramm starten. Dann beide Festplatten (HDD u SSD) so vorbereiten, als wollte man auf jede das Betriebssystem installieren. Wie hier beschrieben: http://praxistipps.chip.de/mac-os-x-neu-installieren-so-gehts_13473

    Erst dann das Fusion Drive per Terminal einrichten. Hier noch einmal eine anderes Howto: https://www.datenreise.de/macbook-pro-fusion-drive-selbst-erstellen-anleitung/
     
  7. frestler

    frestler Granny Smith

    Dabei seit:
    10.12.14
    Beiträge:
    13
    Danke dir, aber das hat leider auch nicht viel geholfen. Bin ja schon im Festplattendienstprogramm daran gescheitert, dass die beiden Festplatten ja nicht angezeigt werden sondern nur die eine Partition wo noch aktiv ca. 250GB Speicherplatz hat.

    ABER, ich hab es selbst geschafft! :cool::D
    Nach etwas intensiveren Recherchen heute morgen bin ich auf folgendes Thema gestoßen:
    http://apple.stackexchange.com/ques...the-fusion-drive-on-my-1tb-imac-with-bootcamp
    Hab mich dort etwas eingelesen und versucht A das Problem zu verstehen (was in etwas das gleiche war wie bei mir) und B die Lösung zu verstehen, damit ich diese an meinen iMac übernehmen und durchführen kann.

    Was habe ich also gemacht, sodass mein iMac wieder "repariert" wurde und die FusionDrive wieder einwandfrei lief:
    1. iMac im Internet Recovery Modus mittels alt + cmd + R gestartet (dauerte ca. 5 Min)
    2. Terminal aufgerufen
    3. Mit "diskutil cs list" die Liste des CoreStorage anzeigen lassen
    4. Die UUID des Logical Volume (ist die letzte verschachtelte UUID in der Liste) kopiert
    5. Das Logical Volume mittels "diskutil cs deleteVolume UUID" gelöscht
    6. Die UUID der Logical Volume Group (ist die erste UUID in der Liste) kopiert
    7. Die Logical Volume Group mittels "diskutil cs delete UUID" gelöscht
    8. Terminal geschlossen
    9. Festplattendienstprogramm gestartet
    10. Hier dann auf die einer der Festplatten geklickt und die Meldung, das etwas mit den Treibern nicht stimmt nicht (wie in der Anleitung beschrieben) ignoriert, sondern auf "Fix/Beheben" geklickt, sodass das Festplattendienstprogramm die Fehler automatisch behebt
    11. Gesagt getan, das Ganze hatte ca. 2-3 Minuten gedauert. Volumen Prüfung war erfolgreich/grün und ich hatte links im Festplattendienstprogramm wieder "Internal Drive -> Macintosh HD" stehen
    12. Festplattendiensprogramm geschlossen
    13. Terminal wieder gestartet
    14. Mit "diskutil cs list" die Liste des neuen/behobenen CoreStorage anzeigen lassen
      1. Hier stand die unter "Logical Volume Group" 1.1 TB (vorher waren hier nur die besagten 250GB oder was das waren)
      2. Und ganz unten unter "Logical Volume" stand auch 1.1 TB bei "Macintosh HD" (vorher waren hier nur die besagten 250GB oder was das waren)
    15. FusionDrive war somit behoben und wieder aktiv
    16. Nun das Internet Recovery Mode beendet
    17. iMac neugestartet und vom MacOS Sierra Installations Stick gestartet
    18. MacOS Installation gestartet, FusionDrive (Macintosh HD) Partition ausgewählt und nach 20 Minuten hatte ich wieder einen funktionsfähigen iMac mit MacOS Sierra und vollen 1.1 TB FusionDrive
    Ja und alles weitere danach war ja dann easy:
    BCA gestaret, Windows 10 Installations Stick erstellen lassen, BC Partition anlegen lassen, iMac neustarten und Windows installieren. Fertig.

    Das hat mich heute zwar den kompletten Sonntag gekostet, aber der iMac läuft jetzt sauber mit allen nötigen Programmen und Updates unter MacOS Sierra und Windows 10 Pro.

    Trotzdem danke dir für die Hilfe! Hast mich ja zumindest auf den Lösungsweg gebracht ;)
    Vielleicht hilft ja meine Anleitung nun jemand Anderen, der das gleiche Problem hat.

    So und nun aber Feierabend.
    Schönen Abend und ein guten Start morgen in die neue Woche.
     
    redbull-kalli gefällt das.

Diese Seite empfehlen