1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Excel - Vor den Inhalt der Zelle eine "0" - Aber nicht immer!?

Dieses Thema im Forum "Office:Mac" wurde erstellt von birneone, 23.08.09.

  1. birneone

    birneone Schöner von Nordhausen

    Dabei seit:
    24.07.06
    Beiträge:
    323
    Hallo Leute,

    habe eine Spalte in der stehen einige Tausend Postleizahlen. Nun sind irgendwo auf dem Weg bis die PLZ in der Spalte wahren alle Postleitzahlen bei denen vorne eine "0" steht um diese "0" verkürzt, also die fehlt schlichtweg. Wie bekomme ich es hin, dass diese "0" wieder da ist. Einfach überall eine "0" davor setzten geht nicht, da es ja auch in der Spalte PLZ gibt die schon 5stellig sind, weil sie vorne keine "0" haben.

    Hoffe mein Problem ist klar geworden..

    Danke im Voraus.
     
  2. Guenni14

    Guenni14 Braeburn

    Dabei seit:
    04.12.08
    Beiträge:
    44
    Das ganze in der Zelleninfo (Cmd-1) als Text deklarieren sollte reichen.
     
  3. birneone

    birneone Schöner von Nordhausen

    Dabei seit:
    24.07.06
    Beiträge:
    323
    Nein, leider nicht. Man hätte das vorher machen müssen, bevor die Zahlen reinkopiert wurden. Aber im Nachhinein geht das nicht mehr.

    Leider bin ich nicht so firm in Excel aber folgendes müsste doch realisierbar sein.

    Eine Hilfsspalte anlegen und dann in etwa:
    WENN(Zelle XY Vier Zeichen hat; Dann schreibe eine "0" vor die Zeichen; Sonst mache nichts)

    Nur finde ich keine Funktion die die Anzahl der Zeichen zählt, gibt es die nicht?
     
  4. Guenni14

    Guenni14 Braeburn

    Dabei seit:
    04.12.08
    Beiträge:
    44
    Du hast in sofern recht als das die Nullen im Nachhinein nicht mehr automatisch hinzugefügt werden. Aber mit der Umformatierung in Text können sie nachträglich eingefügt werden.

    Kenne auch keine Zählfunktion. Denke es wird wohl per Hand gemacht werden müssen
     
  5. bezierkurve

    bezierkurve Danziger Kant

    Dabei seit:
    12.06.05
    Beiträge:
    3.861
    Um Zeichen zu zählen: LÄNGE(A1)

    Das ließe sich dann sicherlich irgendwie mit der "bedingten Formatierung" verknüpfen.
     
  6. birneone

    birneone Schöner von Nordhausen

    Dabei seit:
    24.07.06
    Beiträge:
    323
    Na das glaube ich nicht. Zehntausend Nullen per Hand kann ja nicht die Lösung sein. Bin aber fast am Ziel. Muss nur noch rauskriegen wie man ein Zeichen vor den Inhalt einer Zelle schreibt.

    =WENN(Länge(A1)=4;schreibe Null vor Inhalt)


    LÖSUNG: Zelle als Sonderformat Postleitzahl formatieren :)
     
  7. Guenni14

    Guenni14 Braeburn

    Dabei seit:
    04.12.08
    Beiträge:
    44
    Es geht viel einfacher. Einfach Formatierung einer leeren Zelle aufrufen und unter Benutzerdefinierte Formate 00000 eingeben. Eine Postleitzahl wird dann immer mit 5 Stellen angezeigt.

    LG

    Edith: Unter Sonderformate gibt es ja sogar Postleitzahlen
     
  8. svierer

    svierer Cripps Pink

    Dabei seit:
    07.02.08
    Beiträge:
    155
    =WENN(Länge(A1)=4;"0"&A1;A1)

    lg
    Christian
     

Diese Seite empfehlen