DNS Probleme / kein Internet trotz aktiver Verbindung

Applinator

Idared
Mitglied seit
24.08.20
Beiträge
25
Guten Abend allerseits,

seit ein paar Tagen habe ich das Phänomen, dass bei meinem iMac von 2013 plötzlich das Internet nicht mehr funktioniert, obwohl ich nach wie vor mit dem WLan verbunden bin. Auf meinen anderen Geräten funktioniert alles reibungslos.
Ich habe bereits in den WLan Einstellungen den DHCP Lease erneutet, ohne Verbesserung.

Ich denke ich habe Probleme mit DNS / Namensauflösung. Ich kann mich selber anpingen und ebenfalls den Router, und bekomme keine verlorenen Packete im Terminal.

ping 127.0.0.1:
64 bytes from 127.0.0.1: imcp_seq=0 tt1=64 time=0.038ms
64 bytes from 127.0.0.1: imcp_seq=1 tt1=64 time=0.064ms
usw.

Beim Router dann:
... time=2.460 ms, 2.650 ms, usw.

Wenn ich nun z.B. ping 8.8.8.8 eingebe, bekomme ich folgendes:
64 bytes from 8.8.8.8 imcp_seq=0 tt1=115 time=20.541ms, time=20.005ms, time=19.929ms, usw.

Pinge ich nun aber z.B. ping www.facebook.com an, dann bekomme ich folgendes:
ping: cannot resolve www.facebook.com: Unknown host.


Bei Google Chrome erscheint folgende Meldung:
DIe Website ist nicht erreichbar
Die Server-IP wurde von ... nicht gefunden.
Versuchen Sie Folgendes:
Proxy, Firewall und DNS Konfiguration prüfen
DNS_PROBE_FINISHED_BAD_CONFIG.


Als DNS Server ist wie bei meinem Macbook die IP Adresse vom Router eingeben, auch ein ändern auf einen anderen DNS Server zeigte keine WIrkung.

Würde mich sehr über Hilfe freuen, bei fehlenden Infos reiche ich diese gerne nach.
Neustarten vom Router zeigte auch keine Verbesserung (fritzbox 7490)
 

m4d-maNu

Fauliger Sekai Ichi
Mitglied seit
29.01.10
Beiträge
17.548
Also selber anpingen ist leider logisch, denn du hast dich als Lokal Host (127.0.0.1) selber angepingt. Interessant wäre es ob du dich von einen anderen Gerät aus anpingen kannst.

Da dein MacBook eigentlich keine Probleme hat, können wir eigentlich den Router als Problem ausschließen. Du schreibst, dass es Plötzlich nicht mehr geht, heißt dass es mittendrin wieder funktioniert?
 
  • Like
Wertungen: Applinator

Applinator

Idared
Mitglied seit
24.08.20
Beiträge
25
Also selber anpingen ist leider logisch, denn du hast dich als Lokal Host (127.0.0.1) selber angepingt. Interessant wäre es ob du dich von einen anderen Gerät aus anpingen kannst.

Da dein MacBook eigentlich keine Probleme hat, können wir eigentlich den Router als Problem ausschließen. Du schreibst, dass es Plötzlich nicht mehr geht, heißt dass es mittendrin wieder funktioniert?
Danke für deinen Beitrag. Also ich habe soeben getestet und ich kann von meinem Laptop meinen iMac anpingen:
64 bytes from 192.1**.1**.98: icmp_seq=0 ttl=64 time=99.594 ms, time=18.330 ms, time=40.797 ms, time=189.054 ms,
time=5.368 ms, time=35.334 ms, time=43.135 ms, time=3.082 ms, usw..

Mit plötzlich meinte ich eher, dass ich keine Software, Updates etc. installiert habe, sondern von heute auf morgen keine Verbindung mehr möglich ist. Der DNS Server ist logischerweise der gleiche wie auf dem Laptop (Fritzbox IP Adresse).

Mit freundlichen Grüßen
Apllinator
 

m4d-maNu

Fauliger Sekai Ichi
Mitglied seit
29.01.10
Beiträge
17.548
Okay, dass Pingen geht zwar ist auch nicht wirklich schnell. Hier mal wenn ich von meinen MacBook Air meinen Mac mini anpinge.
Code:
PING 192.168.1.20 (192.168.1.20): 56 data bytes
64 bytes from 192.168.1.20: icmp_seq=0 ttl=64 time=3.657 ms
64 bytes from 192.168.1.20: icmp_seq=1 ttl=64 time=1.975 ms
64 bytes from 192.168.1.20: icmp_seq=2 ttl=64 time=1.491 ms

Steht am iMac bei DNS nur die FritzBox IP? Oder noch was anderes?
 
  • Like
Wertungen: Applinator

Applinator

Idared
Mitglied seit
24.08.20
Beiträge
25
Okay, dass Pingen geht zwar ist auch nicht wirklich schnell. Hier mal wenn ich von meinen MacBook Air meinen Mac mini anpinge.
Code:
PING 192.168.1.20 (192.168.1.20): 56 data bytes
64 bytes from 192.168.1.20: icmp_seq=0 ttl=64 time=3.657 ms
64 bytes from 192.168.1.20: icmp_seq=1 ttl=64 time=1.975 ms
64 bytes from 192.168.1.20: icmp_seq=2 ttl=64 time=1.491 ms

Steht am iMac bei DNS nur die FritzBox IP? Oder noch was anderes?
Ja bei dir schaut das schon deutlich schneller aus!
Da steht nur die Ip Adresse und nochmal als Mac Adresse oder Hexadezimale IP Adresse^^
 

m4d-maNu

Fauliger Sekai Ichi
Mitglied seit
29.01.10
Beiträge
17.548
Das andere müsste die IPv6 sein 😉 Vielleicht bringt aber genau die da was durch einander. Trage zum test mal selber die IPv4 des Routers dort ein, dann verschwindet die IPv6.

Kommst du über den iMac eigentlich auf das Webinterface vom Router drauf oder geht das auch nicht?
 
  • Like
Wertungen: Applinator

Applinator

Idared
Mitglied seit
24.08.20
Beiträge
25
Habe die DNS vom Router manuell eingetragen, ohne Änderung.
Auf die Oberfläche von dem Router komme ich nicht drauf wenn ich Fritz.box eingebe. Gebe ich aber die IP Adresse vom Router ein, dann erscheint die Oberfläche.
Ich kann auch andere Geräte vom iMAc anpingen.
Es sind irgendwelche DNS Probleme ...
 

ottomane

Signe Tillisch
Mitglied seit
24.08.12
Beiträge
13.921
Was wird angezeigt, wenn du mit alt-Klick auf das WLAN-Symbol klickst? Die technischen Parameter wäre interessant.

Da auch der Ping auffällig hohe Latenzen aufweist, denke ich, dass es sich nicht um ein DNS-Problem, sondern um ein generelles Verbindungsproblem handelt. Die DNS-Probleme könnten nur Symptom und nicht Ursache sein.
 

Applinator

Idared
Mitglied seit
24.08.20
Beiträge
25
Lösch (über das -) am Mac mal das WLAN Profil und erstelle es neu (über das +).
Habe ich gemacht, habe auch mal den Router zurückgesetzt (stand sowieso an) und dann erneut angemeldet, gleiches Problem.
Was wird angezeigt, wenn du mit alt-Klick auf das WLAN-Symbol klickst? Die technischen Parameter wäre interessant.

Da auch der Ping auffällig hohe Latenzen aufweist, denke ich, dass es sich nicht um ein DNS-Problem, sondern um ein generelles Verbindungsproblem handelt. Die DNS-Probleme könnten nur Symptom und nicht Ursache sein.
Abgesehen von IP Adressen, Sicherheit und BSSID folgendes:
Kanal 36 (5Ghz, 80MhZ)
Ländererkennung DE
RSSI -54dBm
Störsignal -96dBm
Tx Rate 878 MBit/s
PHY Modus 802.11ac
MCS Index 7
NSS 3
 

m4d-maNu

Fauliger Sekai Ichi
Mitglied seit
29.01.10
Beiträge
17.548
Habe ich gemacht, habe auch mal den Router zurückgesetzt (stand sowieso an) und dann erneut angemeldet, gleiches Problem.
Also dass ist auf jeden Fall schon mal nicht gut, denn ein löschen des WLAN Profil und neu erstellten, würde eigentlich auch ein DNS Problem im Profil korrigieren. Das Router zurücksetzten, hättest du eigentlich nicht machen brauchen, denn die anderen Geräte haben ja diese Probleme nicht, so dass es auf den Mac eingegrenzt werden kann.

Was du noch probieren könntest, einen neuen Benutzer erstellen und schauen ob es da geht (den alten aber nicht löschen, denn wir testen ja nur ob es dann geht oder ob es dann auch nicht geht). Denn unter einen neuen Benutzer hast du dann ja keine andere Programm etc. laufen, die könnten (warum auch immer) auch mal aus den Ruderlaufen und Probleme bei Dingen wie WLAN etc. hervorrufen.
 

Marcel Bresink

Tiefenblüte
Mitglied seit
28.05.04
Beiträge
6.354
Es gibt keine Netzwerkfunktion, die benutzerbezogen wäre, deshalb wird das nichts bringen.

Alles deutet in der Tat auf ein Problem mit dem DNS-Client hin. Oder war auf diesem Rechner mal ein Web-Filter oder Proxy installiert?

Was liefert ein

dig www.facebook.com

? Eine normale Antwort von einer Fritzbox sieht etwa wie folgt aus:

Code:
; <<>> DiG 9.10.6 <<>> www.facebook.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 9870
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;www.facebook.com.        IN    A

;; ANSWER SECTION:
www.facebook.com.    2308    IN    CNAME    star-mini.c10r.facebook.com.
star-mini.c10r.facebook.com. 41    IN    A    69.171.250.35

;; Query time: 2 msec
;; SERVER: 192.168.178.1#53(192.168.178.1)
;; WHEN: Tue Aug 25 12:30:56 CEST 2020
;; MSG SIZE  rcvd: 102
 

Applinator

Idared
Mitglied seit
24.08.20
Beiträge
25
Also dass ist auf jeden Fall schon mal nicht gut, denn ein löschen des WLAN Profil und neu erstellten, würde eigentlich auch ein DNS Problem im Profil korrigieren. Das Router zurücksetzten, hättest du eigentlich nicht machen brauchen, denn die anderen Geräte haben ja diese Probleme nicht, so dass es auf den Mac eingegrenzt werden kann.

Was du noch probieren könntest, einen neuen Benutzer erstellen und schauen ob es da geht (den alten aber nicht löschen, denn wir testen ja nur ob es dann geht oder ob es dann auch nicht geht). Denn unter einen neuen Benutzer hast du dann ja keine andere Programm etc. laufen, die könnten (warum auch immer) auch mal aus den Ruderlaufen und Probleme bei Dingen wie WLAN etc. hervorrufen.
Das klingt ja nicht so gut. Wie gesagt den Router musste ich sowieso mal zurücksetzen, da ich das Passwort von der Anmeldung zur Router Oberfläche nicht mehr wusste.
Ein neuer Benutzer hat das gleiche Problem, habe ich gerade neu angelegt und getestet. Ebenfalls sind dort die Websites nicht erreichbar.
 

m4d-maNu

Fauliger Sekai Ichi
Mitglied seit
29.01.10
Beiträge
17.548
@hillepille, ich glaube den Router können wir außen vorlassen, er ist zurückgesetzt und andere Geräte haben keine Probleme. Es ist nur der Mac der Probleme bereit.
 
  • Like
Wertungen: Applinator

Applinator

Idared
Mitglied seit
24.08.20
Beiträge
25
Sieht soweit sehr gut aus. Hm.

Was sagt denn z.B.

traceroute 8.8.8.8
Folgendes kam hier raus:
image.jpg
Es gibt keine Netzwerkfunktion, die benutzerbezogen wäre, deshalb wird das nichts bringen.

Alles deutet in der Tat auf ein Problem mit dem DNS-Client hin. Oder war auf diesem Rechner mal ein Web-Filter oder Proxy installiert?

Was liefert ein

dig www.facebook.com

? Eine normale Antwort von einer Fritzbox sieht etwa wie folgt aus:

Code:
; <<>> DiG 9.10.6 <<>> www.facebook.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 9870
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;www.facebook.com.        IN    A

;; ANSWER SECTION:
www.facebook.com.    2308    IN    CNAME    star-mini.c10r.facebook.com.
star-mini.c10r.facebook.com. 41    IN    A    69.171.250.35

;; Query time: 2 msec
;; SERVER: 192.168.178.1#53(192.168.178.1)
;; WHEN: Tue Aug 25 12:30:56 CEST 2020
;; MSG SIZE  rcvd: 102
folgendes kam hier raus:
global connections: +cmd
connection timed out, no servers could be reached
 
  • Like
Wertungen: ottomane

Marcel Bresink

Tiefenblüte
Mitglied seit
28.05.04
Beiträge
6.354
Die Meldung "no servers could be reached" deutet darauf hin, dass entweder der Eintrag für den DNS-Server von einer Software (Malware?) wirkungslos geschaltet wurde, oder dass auf diesem Rechner etwas die ausgehende Kommunikation für Port 53, bzw. deren Rückantworten blockiert.

Was liefert ein

cat /etc/hosts

? Die normale Antwort muss etwa wie folgt aussehen:

Code:
##
# Host Database
#
# localhost is used to configure the loopback interface
# when the system is booting.  Do not change this entry.
##
127.0.0.1    localhost
255.255.255.255    broadcasthost
::1             localhost
 

Applinator

Idared
Mitglied seit
24.08.20
Beiträge
25
Vielleicht ist auch Malware der Grund. Bin gespannt auf die Antworten.
Hmm, wie kann ich das herausfinden ? Ich habe letztens festgestellt, dass bei den Sicherheitseinstellungen die Firewall deaktiviert war, fragt bitte nicht wieso und wie lange. Habe die nun mal wieder aktiviert.
Die Meldung "no servers could be reached" deutet darauf hin, dass entweder der Eintrag für den DNS-Server von einer Software (Malware?) wirkungslos geschaltet wurde, oder dass auf diesem Rechner etwas die ausgehende Kommunikation für Port 53 blockiert.

Was liefert ein

cat /etc/hosts

? Die normale Antwort muss etwa wie folgt aussehen:

Code:
##
# Host Database
#
# localhost is used to configure the loopback interface
# when the system is booting.  Do not change this entry.
##
127.0.0.1    localhost
255.255.255.255    broadcasthost
::1             localhost
Ich bekomme das gleiche Ergebnis.