• Es gibt nach dem Softwareupdate eine Reihe von Änderungen und Neuerungen in unserem Forum. Genaueres dazu findet Ihr in dieser Ankündigung. Hinweise, Kritik, Anregungen, Lob und Tadel bitte hier diskutieren.

Debian auf QNAP mit MBP als Terminal - Tastaturproblem

peters1

Lambertine
Mitglied seit
15.07.09
Beiträge
691
Hallo,
vielleicht hat hier jemand eine Idee:
Ich habe auf meinem QNAP-System eine VM installiert mit Debian. Da das QNAP-NAS weder Bildschirm noch Tastatur hat, konfiguriere ich das über mein MBP. Die Installation war kein Problem, die ist über Web geführt. Nach dem Booten und Verbinden mit der Console erscheint nur ein blinkender Cursor, der mich zum Einloggen auffordert. Das geht noch, da ich keine Sonderzeichen im Benutzernamen noch im Passwort habe.
Aber nun möchte ich die Tastaturbelegung entsprechend meiner Mac-Tastatur umstellen. Ich bekomme nämlich keine Sonderzeichen, keinen Bindestrich und viele andere fehlen auch.
Ich habe schon gegoogelt und auch den Hinweis auf die Datei "/etc/default/keyboard" bekommen. Dort habe ich wie beschrieben auch "macintosh" und "de" hineingeschrieben. Es ändert sich aber nichts an der Funktion, selbst nach dem Neustart. Muss ich vielleicht woanders schrauben, weil die Tastatur ja nicht am Gerät hängt, sondern Remote erfolgt?
Schon mal vielen Dank im Voraus
Dirk
 

dg2rbf

Akerö
Mitglied seit
07.03.10
Beiträge
1.817
Hi,
ich vermute mal, dass du in einem QNAP Forum, mit dieser Frage schneller an deine Infos gelangst.

Gruß Franz
 

peters1

Lambertine
Mitglied seit
15.07.09
Beiträge
691
Ich habe es gefunden. Zur Info: In der QNAP-Weboberfläche gibt es unter Einstellungen/Konsole die Möglichkeit das Tastaturlayout zu bestimmten. Dann klappt es auch mit sonstigen Zeichen.
 

peters1

Lambertine
Mitglied seit
15.07.09
Beiträge
691
@Wuchtbrumme: Mit der Weboberfläche wurde alles installiert, da brauche ich nur klicken. Erst nach der Installation bin ich auf dem neuen, jungfräulichen System mit Konsole. Und dort war das Problem mit der Tastatur.