debian 10.0 Buster auf MacBook4,1 lahmt extrem

helge

Murer Reinette
Mitglied seit
17.10.06
Beiträge
1.619
Hallo,

jetzt komme ich mal wirklich nicht mehr weiter:

Ich habe so eben debian Buster auf meinem MacBook4,1 installiert, da Mac OS X 10.7.5 nun bald endgültig - aber ein für alle male - auf's Altengleis gehört.

Entschieden habe ich mich für das neueste Debian - Version 10.0 - passt auch gut zum Mac.

Nun hab ich mich dazu durchgekämpft, dass debian endlich von Festplatte startet - allerdings lahmt es ohne Ende.

Ist der Desktop einmal da, dann läuft es eigentlich ganz gut. Nur bis dahin dauert es ewig.

Was funktioniert:
Auf meinem Acer Aspire One rennt debian 10.0 einwandfrei (naja, was der 1,6 GHz Atom von 2010 noch bringt).
WLAN geht (dank b43-Firmware nonfree), Intel Microcode ist installiert, firmware-nonfree ist installiert.
Auf meinem MacBook1,1 läuft debian 9.9 angenehm schnell.
Auf meinem MacBook3,1 läuft debian 8.11 angenehm schnell.

Was nicht geht:
Der Start zieht sich hin trotz SSD.
Sogar vom Login bis hin zum Desktop dauert es mehrere Minuten.
Auch solche Spielereien wie von marco auf compiz umschalten (wo MacBook3,1 und 1,1 nur kurz blinken) dauern auf dem 4,1 nun etliche Sekunden.

Frage:
Weiß jemand, woran das liegt? Hat jemand solch eine Erfahrung bereits gemacht?
 

Turkey1976

Johannes Böttner
Mitglied seit
03.07.07
Beiträge
1.162
Wie hast du das Problem mit dem Booten gelöst?
 

helge

Murer Reinette
Mitglied seit
17.10.06
Beiträge
1.619
Kleine Info: scheinbar betrifft dies auch das MacBook3,1 - eigentlich(!) zu erwarten, beide haben die gleiche Grafikkarte. Eine Installation von elementary OS ist nur mit dieser Zeile möglich. Mit Debian 8 hatte ich dieses Verhalten gar nicht beobachtet (wobei ich Debian 8 installiert hatte, als diese Platte noch in einem MacBook2,1 verbaut war).