1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Bank X und MacGiro erkennen Cyberjack nicht unter OS X 10.5.6

Dieses Thema im Forum "Finanzsoftware" wurde erstellt von geoff, 17.03.09.

  1. geoff

    geoff Golden Delicious

    Dabei seit:
    17.03.09
    Beiträge:
    7
    Hallo,

    bin neu hier und brauche jetzt mal Euren Rat. Habe Bank X Standard als Kaufversion und MacGiro in einer Demoversion, beide erkennen den Cyberjack Secoder nicht.
    Im System-Profiler wird der Chipkartenleser jedoch am USB-Anschluss (im übrigen kein Hub) richtig erkannt. Ebenso habe ich den Tip

    Offenbar "übernimmt" der zu Mac OS X 10.5.6 gehörende CCID-Kartenleser
    Treiber neuerdings den cyberJack von Reiner-SCT. Der Apple-Treiber hat keine
    Klasse 2 Funktionalität.
    Bitte gehen Sie so vor: Rufen Sie im Finder "Gehe zum Ordner..." auf. Geben
    Sie dort diesen Pfad ein:
    /usr/libexec/SmartcardServices/drivers
    Löschen Sie in dem Ordner "drivers" dann die Datei "ifd-ccid.bundle".
    Starten Sie Ihren Mac nun neu.

    Bitte beachten Sie, dass Sie bei zukünftigen Systemupdates auf Versionen
    10.5.7 etc. evtl. wieder die Datei Datei "ifd-ccid.bundle" löschen müssten,
    falls diese in so einem Update wieder enthalten sein sollte.


    befolgt, keine Besserung... Auch die neuesten Cyberjack Treiber sind aufgespielt.

    Ich betreibe die Installation auf einem neuen iMac, die "Gegenprobe" auf meinem MB Pro bringt das gleiche negative Ergebnis. Was ist da los, woran kann das liegen? Hat einer einen Tip? Ich denke mal, daß ich nicht der einzige mit diesem Problem sein kann, und vor allem betrifft das ja auch auf Mac-Basis eine wohl sehr übliche Kombination (Bank X & Cyberjack, MacGiro & Cyberjack, die ja auch allesamt als kompatibel miteinander beworben werden.)

    Danke für Eure Antworten

    geoff
     
  2. Mocsew

    Mocsew Moderator Hardware/Netzwerk
    AT Moderation

    Dabei seit:
    28.01.07
    Beiträge:
    3.564
    Das ist seltsam. Ich habe auch einen CyberJack Klasse 2 am iMac und er läuft bestens mit Bank X Standard. Der Reader hing zeitweise auch mal an einem aktiven Hub - ebenfalls ohne Probleme. Meine Frau werkelt mit einem MacBook und hat dort ebenfalls einen CyberJack Klasse 2 und Bank X -> auch ohne Probleme. Ich habe lediglich beim Installieren damals den Treiber von Reiner SCT draufgeschmissen und dann Bank X installiert.
     
  3. geoff

    geoff Golden Delicious

    Dabei seit:
    17.03.09
    Beiträge:
    7
    die schnelle Antwort freut mich. Wenn Du schreibst "damals", welche aktuelle Betriebssystemversion habt Ihr?

    Ich habe das Gefühl, daß es irgendwie mit dem Update auf 10.5.6 zu tun hat, ob nun auf Reiner SCT-, Bank X, MacGiro oder Apple-Seite. Kann mir nicht vorstellen, daß es an meinem spezifischem Rechner liegt. Habe den iMac vorkonfiguriert und nagelneu erhalten, ebenso vor Monaten das MB Pro (da ist natürlich jetzt auch schon so einiges andere drauf).

    Sonst fällt mir evtl. noch ein, daß es bei Windows unbedingt diese Reihenfolge sein musste: erst die Reiner-Treiber, dann Cyberjack anstöpseln...
    Kann es auch hier an der Reihenfolge der Installation liegen? Habe nämlich zuerst Bank X installiert und im Nachgang dann die Cyberjack-Treiber.
     
  4. Mocsew

    Mocsew Moderator Hardware/Netzwerk
    AT Moderation

    Dabei seit:
    28.01.07
    Beiträge:
    3.564
    Mittlerweile nutzen wir auch komplett 10.5.6 - die "damalige" Installation war noch auf 10.4.x

    Das Updaten auf Leo sowie alle zwischenzeitlichen 10.5.x-Updates hat das Setup gut überstanden. Probleme gibts nur hin und wieder mit dem Ruhezustand - der Kartenleser wird dann teilweise nicht mehr erkannt. Da hilft dann nur ein Reboot und fertig. Die Bank X-Version ist bei uns die 3.3.0 (meines Wissens nach up2date).

    Die Installationsreihenfolge ist unter Win auch nicht entscheidend. Wenn ich per Bootcamp Win neu installiere, hängt der Kartenleser meist gleich dran. Ich breche dann die Hardwareerkennung ab, installiere die Treiber von Reiner SCT und lasse die Hardwareerkennung neu laufen - der Leser wird gefunden und eingerichtet.

    Die Reihenfolge sollte unter OSX auch gleichgültig sein, da man ja bei einem installierten Bank X auch von PIN/TAN später auf HBCI wechseln kann. Wäre sicher nicht so toll, im gleichen Zug Bank X neu installieren zu müssen.

    Ich habe auch zwischenzeitlich die Treiber von Reiner SCT mal neu geladen und drüberinstalliert in der Hoffnung, dass es eine neuere Version gibt. Hat sich später als die gleiche Version herausgestellt, wie bereits vorhanden war, aber es funktionierte auf Anhieb ohne Probleme.

    Die Demo von MacGiro kam auch auf Anhieb mit dem Leser klar.

    Unter Win (leider gehts unter OSX wohl nicht) führe ich hin und wieder ein Firmwareupdate des CyberJack aus. Vielleicht liegts daran?
     
  5. geoff

    geoff Golden Delicious

    Dabei seit:
    17.03.09
    Beiträge:
    7
    Ja, da bin ich mal gespannt, was es sonst noch so an Kommentaren dazu gibt. Ich habe mir ja auch schon den Kopf zerbrochen, ob es an mir, meiner Hardware, meiner Vorgehensweise liegt, sprich: ein individueller Fehler ist.

    Aber wie ich es drehe und wende: im System-Profiler ist der Cyberjack eingetragen, beim Booten blinkt auch die LED und im Display erscheint: "Cyberjack OS Version 3.0" und dann springt es um auf "Secoder", alles bis dahin alles gut.
    Wenn ich dann aber nur die Chipkarte als "Test" mal stecke, leuchtet oder blinkt keine LED (was sie meines Wissens nach eigentlich müsste).
    Und ein weiteres Indiz dafür, daß gernerell irgendetwas nicht stimmt, ist, daß der Tip oben mit dem Löschen der Datei von ASH (Bank X) kam. Schien mir nicht, als ob das ein unbekannter Fehler ist.

    Wenn hier im Forum nicht noch der eine oder andere wertvolle Hinweis eintrifft, werde ich mir bei der Bank wohl mal einen Kartenleser ausleihen, um zumindest Hardwarefehler auszuschließen (so wirklich glaube ich aber nicht an einen solchen Fehler, da mein Gerät ja noch vor wenigen Tagen an meinem jetzt verkauften PC funktionierte).
     
  6. Mocsew

    Mocsew Moderator Hardware/Netzwerk
    AT Moderation

    Dabei seit:
    28.01.07
    Beiträge:
    3.564
    Beim Einlegen der Karte blinkt bei meinem die grüne linke LED kurz und bleibt dann dauerhaft an. Ob die Bank allerdings Kartenleser verleiht ... mmmh ... weiss nicht.
     
  7. Mocsew

    Mocsew Moderator Hardware/Netzwerk
    AT Moderation

    Dabei seit:
    28.01.07
    Beiträge:
    3.564
    btw. Hast eine PN ;)
     
  8. geoff

    geoff Golden Delicious

    Dabei seit:
    17.03.09
    Beiträge:
    7
    Hallo Mocsew,

    Deine Antworten und Schilderungen, was Du mit dem Chipkartenleser und dem Banking-Programm machst und was alles funktioniert, haben mir tatsächlich die Lösung meines Problems gebracht!

    Entscheidend war die Aussage über die hin und wieder unter Windows genutzte Firmwar-Update-Möglichkeit! So naheliegend - und doch so fern, wenn man den Wald vor lauter Bäumen nicht mehr sieht.
    Ich bin prompt an den PC meiner Tochter und siehe da, es gab tatsächlich eine neuere Firmware, die ich dann aufgespielt habe. Und was soll ich sagen - tatsächlich funktionierte anschl. am Mac alles. Ich bin happy!!!

    Also an alle, die ähnliche Probleme haben: denkt auch bei einem wenige Wochen alten Chipkartenleser an ein evtl. Firmware-Update. Beim Reiner-SCT Cyberjack geht das wie beschrieben über Windows.

    Ganz herzlichen Dank Mocsew und Gruß an alle!
     
  9. Mocsew

    Mocsew Moderator Hardware/Netzwerk
    AT Moderation

    Dabei seit:
    28.01.07
    Beiträge:
    3.564
    Tja, manchmal liegt die Lösung so nahe :-D Beruflich bedingt schaue ich ca. jede Woche nach einem Firmwareupdate für den CyberJack - von daher wäre mir das hier beinahe untergegangen. Ich hab zwar bei Reiner SCT mal angefragt, wann endlich eine Software für OSX herauskommt, um die Updates nicht nur unter Windows durchführen zu können - auf die Antwort warte ich jedoch seit ein paar Monaten (scheinbar vergeblich).

    Viel Spaß beim Onlinebanking :-D
     
  10. zahnriemen

    zahnriemen Cripps Pink

    Dabei seit:
    29.10.08
    Beiträge:
    153
    Hi

    gehört vielleicht nur indirekt zum Thema.

    Bei MacGiro gab´s vor ein paar Tagen ein Update.

    Aktuell ist die 6.0.5 u.a. wegen "neuer PIN/TAN-Verfahren für HBCI"
     
  11. Kangar00

    Kangar00 Erdapfel

    Dabei seit:
    25.03.09
    Beiträge:
    3
    Ich habe genau das gleiche Problem und frage mich nun, wo genau ich diese Firmware finde. Ich habe auf der Webseite von Reiner SCT unter Support & Download nur Treiber gefunden, aber kein Firmware Update. Ich habe noch einen "Gerätemanager" gefunden - das scheint aber nicht das zu sein, was ich suche, oder doch? Kann mir hier bitte jemand weiter helfen? Vielen Dank schon mal!

    Viele Grüsse,
    Kangar00
     
  12. Mocsew

    Mocsew Moderator Hardware/Netzwerk
    AT Moderation

    Dabei seit:
    28.01.07
    Beiträge:
    3.564
    Das Firmwareupdate machst Du unter Windows unter Systemsteuerung -> cyberJack (ein gelbes Symbol eines Chips). Dann auf den Reiter "Aktualisierung" und dort auf "Prüfe auf neue Version" unten klicken
     
  13. Kangar00

    Kangar00 Erdapfel

    Dabei seit:
    25.03.09
    Beiträge:
    3

    Hallo Mocsew,

    vielen Dank für den Hinweis. Ich habe nun die Treiber für Windows installiert und sehe dann diesen gelben Chip etc. Wenn ich allerdings auf 'Updates' gehe und aktualisiere, erhalte ich die Nachricht, dass keine Updates verfügbar sind.

    Es scheint bei mir wohl an etwas anderem zu liegen. Schade.

    Viele Grüsse,
    Kangar00
     
  14. geoff

    geoff Golden Delicious

    Dabei seit:
    17.03.09
    Beiträge:
    7
    Hallo,

    ich habe bei meinen Problemen eben dieses Firmware-Update über diesen Gerätemanager des Cyberjack gemacht und es hat geholfen. Hier bleibt der Wunsch, daß es den Gerätemanager nicht nur für Windows-PC´s gibt, sondern demnächst auch mal für Mac OS X.
    Vielleicht hilft Dir dann folgender Vorschlag:
    "Offenbar "übernimmt" der zu Mac OS X 10.5.6 gehörende CCiD-Kartenleser-Treiber neuerdings den cyberJack von Reiner-SCT. Der Apple-Treiber hat keine Klasse 2 Funktionalität.
    Bitte gehen Sie so vor: Rufen Die im Finder "Gehe zum Ordner ..." auf. Gegen Sie dort diesen Pfad ein:
    /usr/libexec/SmartcardServices/drivers
    Löschen Sie in dem Ordner "/drivers"dann die Datei "ifd-ccid.bundle". Starten Sie den Mac neu.
    Bitte beachten Sie: bei zukünfitgen Systemupdates auf Versionen 10.5.7 etc muss die Datei "ifd-ccid.bundle" erneut gelöscht werden."

    Diesen Vorschlag hatte ich von ASH (Bank X) und dem dort sehr bemühten und schnell reagierenden Support erhalten.

    Viele Grüsse
    geoff
     
  15. Mocsew

    Mocsew Moderator Hardware/Netzwerk
    AT Moderation

    Dabei seit:
    28.01.07
    Beiträge:
    3.564
    Ich hab vorgestern zum zweiten Mal den Support von Reiner SCT kontaktiert, ob geplant ist, ein Tool für OSX rauszubringen, mit welchem man die Firmware upgraden kann. Schauen wir mal, ob und wann da geantwortet wird. Meine erste Anfrage von vor ein paar Monaten wurde mit eisigem Schweigen ignoriert. Wenn es bei der jetzigen Anfrage wieder so sein sollte, dann hat Reiner SCT es wohl nicht nötig, Anfragen von OSX-Usern zu beantworten - dann gibts auch noch andere Hersteller ;)
     
  16. Kangar00

    Kangar00 Erdapfel

    Dabei seit:
    25.03.09
    Beiträge:
    3
    Hallo Geoff,

    vielen Dank für Deinen Beitrag, aber das hatte ich schon probiert bevor ich meine Frage gestellt habe.

    Da für meinen Kartenleser kein Firmware-Update verfügbar ist, vermute ich, dass ich vielleicht ein älteres Modell habe. Mein Modell ist rot und nicht schwarz oder grau, wie die auf der Webseite abgebildeten Modelle. Ich habe meins vor zwei Jahren von meiner Sparkasse bekommen.

    Gleichzeitig mit meinem ersten Post hier, schrieb ich eine eMail and SCT-Reiner mit genauen Angaben zu meinem Problem und meinem Kartenleser Modell. Ich habe keine Antwort erhalten.

    Vielen Dank nochmal für Eure Mühe.

    Viele Grüsse,
    Kangar00
     
  17. Mocsew

    Mocsew Moderator Hardware/Netzwerk
    AT Moderation

    Dabei seit:
    28.01.07
    Beiträge:
    3.564
    Die Farbe des Kartenlesers spielt keine so grosse Rolle. Meiner ist z.B. blau, hat aber exakt die gleichen Funktionen wie ein roter (Sparkasse) oder ein schwarzer (Reiner SCT direkt). Ist wohl nur ein (Farb-)Branding
     
  18. geoff

    geoff Golden Delicious

    Dabei seit:
    17.03.09
    Beiträge:
    7
    Hallo Kangar00, hallo Mocsew,

    Euren (Negativ-)Erfahrungen mit Reiner SCT kann ich mich nur anschließen, auch bei mir zeichnete sich der Support durch eisiges Schweigen (auf zweimalige höfliche Anfrage) aus, ganz im Gegenteil zu ASH (Bank X).

    Man sollte meinen, daß die Firmenangehörigen regelmäßig Forenbeiträge "scouten", um auch ein Feedback für Ihre Arbeit zu erhalten und daraus entspr. Konsequenzen ziehen. Das scheint bei Reiner SCT aber nur ein frommer Wunsch zu sein (s. oben).
    Für mich absolut unverständlich, daß auch schon im Rahmen einer gewissen Qualtitätssicherung hier nichts passiert.
    Hoffentlich liest dies auch der eine oder andere Banker wie Mocsew, der dann vielleicht auch von dieser Seite mal etwas Druck bei Reiner SCT macht.
    Aber Vorsicht: als ich mal wegen einer ähnlichen Angelegenheit (SAT-Digitalreceiver) als Privatmensch sehr neutral und nicht polemisch einer namhaften deutschen Firma schrieb, daß ich zumindest in Diskussionsforen und Kundenbewertungen (A....n) aus meinen Erfahrungen keinen Hehl mehr machen würde, da erhielt ich sofort ein Schreiben der Geschäftsführung mit der Androhung einer Klage wegen geschäftsschädigenden Verhaltens.

    Also, liebe Fa. Reiner SCT, verbessert mal Eure Arbeitsabläufe auch i. S. eines guten Supports! Gerade die Erfahrungen von Mitgliedern eines solchen Forums wie diesem hier sollten Euch Einiges an fruchtbaren Erkenntnissen bringen, Hier diskutieren durchaus User mit einigem Hintergrundwissen und nicht der technikentrückte Esoteriker, für den "Computer" bisher ein Fremdwort war!

    geoff
     
  19. Mocsew

    Mocsew Moderator Hardware/Netzwerk
    AT Moderation

    Dabei seit:
    28.01.07
    Beiträge:
    3.564
    Und auch eine kurz nach dem o.a. Posting geschickte Support-Anfrage blieb und bleibt wohl auch zukünftig ignoriert. Irgendwie machen mich solche Arten von "Support" stinksauer, da ich selbst im Bereich Dienstleistungen arbeite und nicht verstehen kann, wie man so verstockt und ignorant sein kann. Fazit: Es gibt auch andere Hersteller, die Leser (meist) günstiger (und auch optisch attraktiv) anbieten. Mein nächster Leser (Klasse 3) wird sicher nicht mehr aus dem Hause Reiner SCT stammen. Manchen steigt der Erfolg scheinbar zu Kopf und der kleine Privatkunde darf außen vor bleiben.

    Erneut bin ich mal den Weg der Kontaktaufnahme gegangen. Nicht übers Formular sondern über die im Impressum angezeigte Mailadresse:

    Sehr geehrte Damen und Herren,

    bislang habe ich mich 2x an den Support gewandt, um eine Anfrage loszuwerden. Beide Anfragen waren inhaltlich identisch und mit einem Zwischenraum von ein paar Monaten gesendet. Auf keine der Anfragen kam eine Reaktion - nicht mal eine Bestätigung, dass man sich melden würde.

    Meine Frage wäre, ob man als Privatkunde überhaupt das Recht hat, sich Ihrem Support zu nähern oder ob dies nur für Kunden gedacht ist, die eine entsprechend große Stückzahl an Geräten über Sie beziehen und auf diese Art evtl. eine Support-Anfrage "erkaufen" können.

    Vielleicht erhalte ich auf diese Frage eine Antwort, damit ich abwägen kann, meinen nächsten Leser (Klasse 3) vielleicht bei einem Mitbewerber zu kaufen.

    Meine Anfrage bezog sich lediglich auf die Information, ob in naher Zukunft ein Tool geplant ist, mit welchem man die Kartenleser unter OSX konfigurieren sowie mit Firmware-Updates versorgen kann. Eine Frage, die eigentlich mit "ja" oder "nein" schnell beantwortet wäre.

    Gruß
    xxxxx


    Ich bin gespannt ...
     
  20. RalfSt

    RalfSt Jamba

    Dabei seit:
    22.12.07
    Beiträge:
    57
    Hallo,

    leider wird bei mir auch der Cyberjack e-com 3.0 (ID 401) nicht von den Treibern erkannt. Die Version 3.3 von Reiner-SCT ist vom Datum her auch relativ alt, dort sind nur die IDs 100, 300 und 400 drin enthalten.

    Ändere ich von Hand eine ID in den jeweiligen Bundels ab, wird der entsprechende Treiber auch versucht zu laden, das geht allerdings in die Hose:

    Code:
    src/PCSC/debuglog.c:240:DebugLogSetLevel() debug level=debug
    src/PCSC/pcscdaemon.c:572:main() pcsc-lite 1.4.0 daemon ready.
    src/PCSC/readerfactory.c:762:RFInitializeReader() Attempting startup of cyberJack 00 00 using /usr/libexec/SmartCardServices/drivers/ifd-cyberJack.bundle
    src/PCSC/readerfactory.c:488:RFBindFunctions() Binding driver functions
    src/PCSC/readerfactory.c:590:RFBindFunctions() Loading IFD Handler 2.0
    src/PCSC/readerfactory.c:801:RFInitializeReader() Open Port 3D300000 Failed (cyberJack)
    src/PCSC/readerfactory.c:656:RFUnBindFunctions() Unbinding driver functions
    src/PCSC/readerfactory.c:668:RFUnloadReader() Unloading reader driver.
    src/PCSC/readerfactory.c:671:RFUnloadReader() --- closing dynamic library
    src/PCSC/readerfactory.c:242:RFAddReader() RFAddReader: cyberJack init failed: -2146435067
    
    Weiß noch jemand Rat, wie ich den Kartenleser zum Laufen bekomme ?
     

Diese Seite empfehlen