1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Apache2 zurücksetzten

Dieses Thema im Forum "PHP & Co." wurde erstellt von WannaBeApple, 28.04.09.

  1. WannaBeApple

    WannaBeApple Alkmene

    Dabei seit:
    25.04.09
    Beiträge:
    33
    Hallo!
    Ich habe versucht, PHP für OS X 10.5.6 manuell zu installieren, da ich nicht mit XAMPP arbeiten will wenn schon Apache2 integriert ist.
    Habs zuerst versucht, PHP 5.2.9 manuell zu installieren, ging aber nicht und hab dann ein fertiges .pkg benützt mit PHP doch wenn ich nun auf 192.168.x.x zugreifen will, kommt überhaupt nichts mehr. Das gleiche ist dann bei meinem persönlichen Website Ordner.

    Wie kann ich da den Fehler wieder beheben bzw. wie kann ich PHP entfernen und Apache2 zurücksetzten?

    Habe gd2 library usw per frink commander installiert, da in der Anleitung libpng usw stand..hoffe doch das es nichts damit zutun hat.

    Danke und Grüße!
     
  2. bezierkurve

    bezierkurve Danziger Kant

    Dabei seit:
    12.06.05
    Beiträge:
    3.861
    Was für ein Package hast du denn installiert? Generell ist seit PHP 5 bei Leopard schon dabei, du musst es nur in der /etc/apache2/httpd.conf freischalten, indem du den Kommentar vor der Zeile
    Code:
    #LoadModule php5_module        libexec/apache2/libphp5.so
    entfernst.
     
  3. WannaBeApple

    WannaBeApple Alkmene

    Dabei seit:
    25.04.09
    Beiträge:
    33
  4. bezierkurve

    bezierkurve Danziger Kant

    Dabei seit:
    12.06.05
    Beiträge:
    3.861
    … dort steht aber auch, wie du es wieder entfernen kannst:

     
  5. WannaBeApple

    WannaBeApple Alkmene

    Dabei seit:
    25.04.09
    Beiträge:
    33
    Naja schon klar, ich habe die +entropy-php.conf entfernt aber es tut sich noch immer nichts.
    Welchen Ordner muss ich denn da entfernen, da gibts keinen der irgendwie mit PHP oder Entropy etc anfängt.

    Danke
     
  6. bezierkurve

    bezierkurve Danziger Kant

    Dabei seit:
    12.06.05
    Beiträge:
    3.861
    Den Webserver hast du danach neugestartet? Und /usr/local/php5 existiert nicht bei dir?

    Ansonsten muss ich mich an der Stelle ausklinken, da ich die Entropy-Packages mittlerweile nicht mehr nutze.
     
  7. WannaBeApple

    WannaBeApple Alkmene

    Dabei seit:
    25.04.09
    Beiträge:
    33
    Achso, doch der existiert noch.
    Also die +entropy-php.conf löschen, den Ordner php5 in /usr/local/ löschen und Apache2 neustarten mit /usr/local/apache2/bin/apachectl -k restart ?
     
  8. bezierkurve

    bezierkurve Danziger Kant

    Dabei seit:
    12.06.05
    Beiträge:
    3.861
    An der Stelle liegt bei mir nichts, was mit Apache zu tun hätte. Hast du den Apache auch noch separat installiert? Falls nicht, reicht es, einfach das Web-Sharing in den Systemeinstellungen einmal aus- und wieder einzuschalten.
     
  9. WannaBeApple

    WannaBeApple Alkmene

    Dabei seit:
    25.04.09
    Beiträge:
    33
    Also ich hab die Datei gelöscht und auch den Ordner php5 und per Systemeinstellungen neu gestartet, doch es tut sich trotzdem nichts.
    Apache2 wollt ich mal updaten aber da ging das kompilieren eh nicht, daran kanns also nicht liegen.

    in der usr/local/lib muss ich da nicht php löschen oder?
     
  10. WannaBeApple

    WannaBeApple Alkmene

    Dabei seit:
    25.04.09
    Beiträge:
    33
    Ich hab den Extra Ordner neu reingeladen und die httpd.conf und nun funktioniert Apache2 wieder. Waren noch ein paar Sachen falsch in den Dateien.

    Wegen PHP trotzdem: Die Zeile #LoadModule php5_module libexec/apache2/libphp5.so gibt es gar nicht in meiner httpd.
    Und wenn ich sie hinzufüge funktioniert PHP noch immer nicht.
    Mache ich was falsch?

    Grüße

    PS: Editieren ging leider nicht, vl kann sich ein Mod oder etc das mal anschauen wieso (;
     

Diese Seite empfehlen