1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Anleitung für localhost -> extern Websharing!

Dieses Thema im Forum "Browser" wurde erstellt von MACRASSI, 16.11.05.

  1. MACRASSI

    MACRASSI Gelbe Schleswiger Reinette

    Dabei seit:
    21.11.04
    Beiträge:
    1.754
    So ich habe beschlossen jetzt mal eine Anleitung zu schreiben wie man ganz einfach seine Webseite, die auf localhost liegt, zu sharen...

    1. In den Systemeinstallungen -> Sharing -> PersonalWebsharing aktivieren!

    2. Dann die Webseite unter: /Library/WebServer/Documents/ die Webseite ablegen.

    3. In den Router gehen (auf ihn zugreifen ;) ) und dort die Portumleitung von Port 80 zu der IP Adresse eures Rechners auf Port 80 umleiten.

    4. Da ihr ja nicht immer eure neue IP den Leuten geben wollt:
    Geht man auf DynDns.com .

    5. Dort erstellen wir dann eine Dynamische IP.

    6. Um zu testen gehen wir dann auf die Webadresse die wir bei DynDns erstellt haben...

    7. Wenn dann die HomePage zu sehen ist -> Super... | Wenn nicht ->

    1. Hab ich nen Fehler gemacht.
    2. Wirklich alles so gemacht wie oben beschrieben?


    Ich hoffe das es euch was nützt...
    Hatte schon oft von Problemen gehört... Und dem wollte ich jetzt endlich mal ein Ende setzen.

    Gruß Rasmus
     
    iKnow, LiviaCH, smb und einer weiteren Person gefällt das.
  2. smb

    smb Raisin Rouge

    Dabei seit:
    27.08.05
    Beiträge:
    1.171
    klappt, gute Anleitung - Karma ;)

    kannte ich zwar schon vorher, aber sehr gut…!
     
  3. MACRASSI

    MACRASSI Gelbe Schleswiger Reinette

    Dabei seit:
    21.11.04
    Beiträge:
    1.754
    *hochschieb*
    Will ja nich das die Anleitung in den Unendlichenweiten des Apfeltalks untergeht...
    Gruß Rasmus
     
  4. natsuki

    natsuki Boskop

    Dabei seit:
    24.06.05
    Beiträge:
    205
    Hab da mal ne Frage:
    Also, wenn sich jetzt jemand die HP, die ich auf dem Mac gespeichert habe, ansieht, greift der direkt auf den Mac zu oder?

    Wird das dann nicht ein Kinderspiel für jeden X-beliebigen Hacker, meinen Mac zu hacken?

    Gruß
    natsuki
     
  5. MACRASSI

    MACRASSI Gelbe Schleswiger Reinette

    Dabei seit:
    21.11.04
    Beiträge:
    1.754
    Nich so ganz.
    Denn du kannst ja auch den FTP Account aktivieren, etc.
    Und wenn das nich gemacht is dann kommt er nich drauf.
    Und so wie "wir" das dann gemacht haben geht es ja nur über den Port 80. Und ich bin mir ganz sicher das man über den nix hacken kann...

    Gruß Rasmus

    Ps. für Tippfehler entschuldige ich mich, aber ich bin gerade Fahrrad gefahren und jetzt sind meine Finger noch "eingefrohren"... ;)
     
  6. mullzk

    mullzk Linsenhofener Sämling

    Dabei seit:
    04.01.04
    Beiträge:
    2.529
    tatsächlich ist es so, dass damit ein aussenstehender über den port 80 direkt auf deinen mac zugreift. damit ist prinzipiell ein angriff denkbar

    auf os x liegt hinter port 80 ein apache-server. dieser gilt jedoch als sehr sicher, vor allem wenn (wie bei os x der fall) nur wenige module aktiviert sind. apache hat mit abstand den grössten marktanteil von web-servern im internet - wenn es so einfach wäre, von apache aus den server anzugreifen, würde dies wohl nicht so sein.
    allerdings muss man fairerweise schon auch sagen, dass es in der vergangenheit auch beim apache immer wieder sicherheitslücken gab, die zwar schnell gestopft wurden (allerdings gibt es dann immer wieder eine verzögerung, bis die updates auch über das os x-update da sind).

    auch wenn es gute gründe gibt, apache zu vertrauen: 100%-sicherheit gibt es bei einem system nie, und wer keine webpage betreibt, sollte das web-sharing deaktiviert lassen...
     
  7. MACRASSI

    MACRASSI Gelbe Schleswiger Reinette

    Dabei seit:
    21.11.04
    Beiträge:
    1.754
    *hochschieb*
    Mist, ich kanns einfach nicht lassen...
    Ich weiß zwar das Leute beim durchstöbern hier drauf stoßen werden aber...
    Gruß Rasmus
     
  8. Hab alles gemacht! Jetzt ist nur noch das problem mit der weiterleitung vom router auf meinen compi. Wie mach ich das??
    P.S. Hab nen Zyxel Prestige 600 Series
     
  9. mullzk

    mullzk Linsenhofener Sämling

    Dabei seit:
    04.01.04
    Beiträge:
    2.529
    ich habe eine prestige 652, nehme mal an, dass das dasselbe sein wird...

    was du brauchst: die lokale ip-adresse deines router sowie deines macs.

    nun verbindest du dich mit dem router (in safari einfach die ip-adresse eingeben und gut ist), das standardpasswort bei zyxel ist wenn ich mich richtig erinnere admin | 1234, steht sonst aber in deinem router-manual

    nun auf adavanced setup->nat
    dort SUA only aktivieren und edit details anklicken

    als start und als endport die 80 eingeben, als ip-adresse diejenige deines macs

    normalerweise ist nun gut - zumindest von aussen her solltest du drauf kommen. viele zyxel-router haben aber die bekloppte standard-einstellung, dass nur pakete aus dem wan genattet werden, und pakete aus dem lan, welche an die wan-ip adressiert sind einfach verschluckt werden. diese konfiguration ist relativ mühsam und nicht immer genau gleich.
    schau doch mal ob es soweit funktioniert (frag allenfalls noch jemanden, ob er/sie von aussen her drauf zugreifen kann), falls nicht, poste doch mal die genaue bezeichnung deines routers...
     
  10. Danke mullzk!
    Aber es klappt nicht! :oops: Es kommt nur wieder die Kennworteingabe des Routers. Dort gibt er sich als "Prestige 650H/HW-33" aus. Was muss ich tun, dass auch dies funzt??
    Gruss MD
     
  11. mullzk

    mullzk Linsenhofener Sämling

    Dabei seit:
    04.01.04
    Beiträge:
    2.529
    hi mathisdedial
    ok, die 650H sollte gleich funktionieren wie meiner.

    - öffne das terminal
    - gibt ein: telnet [ip-adresse des routers] , gefolgt vom admin-passwort

    im telnet musst du irgendwie in die command line kommen. bei meinem router geschieht dies innerhalb des menüs mit den punkten: 24. System Maintenance -> 8. Command Interpreter Mode. Wenn du kein Menü siehst, bist du vermutlich schon am richtigen Ort.

    - Gib ein:
    sys view autoexec.net
    wenn da ein paar kryptische konfigurationsbefehle auftauchen ist gut, wenn nicht, dann nicht. in diesem fall ist die 650H anders geartet als meine 652HW, das sinnvollste wäre in diesem Fall, wenn du dem Zyxel-Generalimporteur (in der Schweiz studerus.ch) ein Mail schreibst, wie dies genau gemacht werden soll.
    wenn irgendwo die zeile "ip nat loopback on" vorhanden ist, hast du nicht das problem, mit dem ich gerechnet habe, auch dann abbrechen und mit zyxel kontakt aufnehmen.

    jetzt wird es ein wenig heikler, weil der telnet-modus der prestige nicht wirklich sehr angenehm ist und es weder backspace-taste noch ein notknopf gibt. also aufpassen und immer nur die richtige taste drücken.

    - gib ein
    sys edit autoexec.net
    nun kommst du in einen vi-ähnlichen editor, allerdings wird dir der aktuelle inhalt der datei nicht angezeigt, oder höchstens die erste zeile.

    - nun drücke die taste i
    - gib ein
    ip nat loopback on
    - drücke enter
    - drücke die taste x
    - starte den router erneut und bete...


    ah ja, das ganze macht nur dann sinn, wenn das problem aus dem LAN-zugriff geht. wenn auch von aussen her alle nur die kennworteingabe oder gar nix sehen, liegt das problem nicht da. in diesem falle hätte ich dich missverstanden und man müsste mal noch sonstwie schauen wo das problem liegen könnte.
    alle grüsse in den weiten osten
    mullzk
     
  12. Danke für diese ausführliche antwort! doch ich bekomme als antwort nur, nachdem ich die erste Zeile eingegeben habe:

    Usage: telnet [-4] [-6] [-8] [-E] [-K] [-L] [-N] [-S tos] [-X atype] [-c] [-d]
    [-e char] [-k realm] [-l user] [-f/-F] [-n tracefile] [-r] [-s src_addr] [-u] [-P policy] [-y] [host-name [port]]

    Was hat das zu bedeuten??
    Gruss mathisdedial
     
  13. Ich glaube ich gebe auf! Jetzt habe ich auch noch bemerkt, dass mein Router die IP-Adresse immer wieder ändert. Nochmals danke für alles
    mathisdedial
     
  14. mullzk

    mullzk Linsenhofener Sämling

    Dabei seit:
    04.01.04
    Beiträge:
    2.529
    äh, nicht die eckigen klammern eingeben, die sollen nur darstellen, dass das drin eine option sein soll. sorry, unklar

    also der befehl muss irgendwie so lauten
    telnet 192.168.1.1
     
  15. MACRASSI

    MACRASSI Gelbe Schleswiger Reinette

    Dabei seit:
    21.11.04
    Beiträge:
    1.754
    Kann ein Mod die Anleitung ins Tutorial Board schieben?
    Danke

    Gruß Rasmus
     
  16. wapplegraph

    wapplegraph Normande

    Dabei seit:
    12.04.06
    Beiträge:
    571
    Was muss ich bei http://www.dyndns.com/ eingeben für so eine dynamische IP?

    Klappt noch nicht.

    Merci wapplegraph
     
  17. MACRASSI

    MACRASSI Gelbe Schleswiger Reinette

    Dabei seit:
    21.11.04
    Beiträge:
    1.754
  18. wapplegraph

    wapplegraph Normande

    Dabei seit:
    12.04.06
    Beiträge:
    571
    So danke!
    Könnte jetzt noch jemand dies Testen?
    Merci Hier der Link:



    Bitte Hier melde!

    wapplegraph
     
  19. MACRASSI

    MACRASSI Gelbe Schleswiger Reinette

    Dabei seit:
    21.11.04
    Beiträge:
    1.754
    Gehen tut es im Moment leider nicht.
    Liegt vielleicht auch daran das du nicht online bist bzw. dein Rechner nicht.

    Gruß Rasmus
     
  20. wapplegraph

    wapplegraph Normande

    Dabei seit:
    12.04.06
    Beiträge:
    571

Diese Seite empfehlen