Admin gelöscht - keine Authentifizierung möglich

Dieses Thema im Forum "macOS & OS X" wurde erstellt von outlat, 14.12.17.

  1. outlat

    outlat Erdapfel

    Dabei seit:
    14.12.17
    Beiträge:
    5
    Ich möchte mich kurz vorstellen, ich bin Dominik und befinde mich gerade auf Weltreise- aktuell in Thailand

    ich habe einen großen scheiß mit meinem Mac gebaut und hoffe, dass ihr euch die Zeit nimmt, diesen Text zu lesen und mir vielleicht zu helfen.

    folgendes ist passiert:

    Ich wollte meinen Adminbenutzername ändern und bin über die Benutzer & Gruppen auf meinen Namen gegangen. Hier bin ich auf das Schloss gegangen und habe meine Admindaten eingeben. Anschließend habe ich den Namen auf Steve umgeschrieben. Jetzt habe ich das Problem, dass mein Benutzername immer noch Dominik ist,
    und ich keine Adminrechte mehr habe. Wenn ich mich jetzt authentizieren möchte, funktioniert das nicht mehr. Weder mit Steve und meinem alten Kennwort noch mit Dominik....

    Auch wird mir kein Admin mehr angezeigt. Ich hab zwar noch all meine Dateien, kann aber nichts mehr instalieren und keine Einstellungen ändern...

    Ich weiß jetzt nicht mehr weiter! Könnt ihr mir vielleicht helfen?

    Herzliche grüße Dominik
     

    Anhänge:

  2. MACaerer

    MACaerer Manks Küchenapfel

    Dabei seit:
    23.05.11
    Beiträge:
    11.239
    Über den SingleUser-Modus kannst du den Mac in den Einrichtungsmodus bringen und dann einen neuen Benutzer mit Adminrechten einrichten.
    https://blog.netways.de/2012/01/21/neuen-admin-account-am-mac-erstellen/
    Den Benutzernamen so mir nichts dir nichts zu ändern ist eine der Todsünden am Mac, da in den Verzeichnis- und Dateinamen nicht nur der sichtbare Namen sondern der gesamte Zugriffspfad inclusive dem Kurznamen des Benutzerkontos enthalten ist. Wenn man letzteren ändert stimmt der Zugriffspfad nicht mehr und es tritt genau das ein was dir passiert ist.

    MACaerer
     
  3. outlat

    outlat Erdapfel

    Dabei seit:
    14.12.17
    Beiträge:
    5
    ich probiere das gleich mal aus! Danke für die schnelle Antwort. Mir fehlt leider das Grundverständnis zu diesem Thema...

    Herzlichen Dank schon einmal!
     
  4. MACaerer

    MACaerer Manks Küchenapfel

    Dabei seit:
    23.05.11
    Beiträge:
    11.239
    Den Benutzernamen zu ändern ist natürlich grundsätzlich möglich, aber man muss dabei einiges beachten. Eine zwar etwas umständliche aber sichere Methode wäre ganz einfach einen neuen Benutzer mit dem gewünschten Namen einzurichten und die Daten aus dem alten Benutzer in die Verzeichnisse des neuen Benutzerkontos zu schieben. Der alte Benutzer kann dann problemlos entfernt werden.

    MACaerer
     
    Balkenende und outlat gefällt das.
  5. outlat

    outlat Erdapfel

    Dabei seit:
    14.12.17
    Beiträge:
    5
    kann es sein, dass durch das neue update dieser trick nicht mehr funktioniert? ich bekomme es nicht hino_O

    habe das 2016er mbp mit siera 10.13.1
     
  6. outlat

    outlat Erdapfel

    Dabei seit:
    14.12.17
    Beiträge:
    5
    so sieht die eingabe aus. er startet dann ganz normal und ich muss wieder meine daten angeben
     

    Anhänge:

  7. MacAlzenau

    MacAlzenau Golden Noble

    Dabei seit:
    26.12.05
    Beiträge:
    20.432
    Halb OT: Bei längeren Aufenthalten fern von zuhause und wenn ich da viel fotografiere oder schreibe oder gar was geschäftlich machen muß, würde ich heute immer eine externe 2,5"-Platte als bootfähiges Backup mitnehmen. Nicht nur wegen solcher Fehlbedienungsexperimenten und nicht nur, weil natürlich immer die Möglichkeit besteht, daß die normale Platte mal spontan den Geist aufgibt, sondern auch, weil man ja außer Haus mit einem deutlich höheren Diebstahlsrisiko rechnen muß.

    Bevor du dich an Experimente wagst - solange du noch an deine Daten kommst und sie bearbeiten kannst und nur nichts neu installieren oder Einstellungen ändern, würde ich es im Zweifel lieber so lassen, wie es ist, nicht daß du noch mehr zerschießt. 10.13 (ist übrigens High Sierra, Sierra ist 10.12) ist durchaus noch recht buggy in manchen Beziehungen, und auch wenn es Sierra sein sollte, hat sich da das eine oder andere bei den Tricks und Kniffen geändert, die man aus früheren Versionen kennt.
     
    echo.park, Balkenende und outlat gefällt das.
  8. MACaerer

    MACaerer Manks Küchenapfel

    Dabei seit:
    23.05.11
    Beiträge:
    11.239
    Die Datei AppeSetupDone gibt es aber auch noch in High Sierra, also sollte man meinen dass der im Link beschriebene Workaround auch noch damit funktioniert. Kann es sein, dass du in dem Befehl rm /var/db/.AppleSetupDone zwischen …db/ und .Apple… ein Leerzeichen geschrieben hast? Wenn ja ist das falsch und der Befehl funktioniert natürlich nicht. In dem Screenshot ist das leider nicht eindeutig zu erkennen.

    MACaerer
     
    ains71, Balkenende und outlat gefällt das.
  9. outlat

    outlat Erdapfel

    Dabei seit:
    14.12.17
    Beiträge:
    5
    Hallejulia!

    Es funktioniert nun! Herzlichen Dank MACaerer! Auch an dich MacAlzenau.

    Ich habe den Slash nach -uw vergessen.
     
    saw, Balkenende und doc_holleday gefällt das.
  10. Cipri

    Cipri Erdapfel

    Dabei seit:
    09.05.18
    Beiträge:
    1
    Hallo Community,
    ich als Apple-Neuling habe den gleichen Fehler begangen wie outlat. Daraufhin bin ich auf diesen Beitrag im Forum gestoßen und habe dementsprechend die folgenden Schritte befolgt: https://blog.netways.de/2012/01/21/neuen-admin-account-am-mac-erstellen/ und hoffentlich korrekt eingegeben.

    Nun bootet mein MacBook schon seit über einer Stunde und der "Lade-Balken" ist vollständig geladen. Was soll ich nun tun?
     

    Anhänge:

  11. GunBound

    GunBound Baumanns Renette

    Dabei seit:
    23.06.05
    Beiträge:
    5.945
    Hallo!

    Funktioniert der sichere Systemstart (⇧ beim Start gedrückt halten und loslassen, sobald der Ladebalken sich beginnt zu füllen)?
    Ebenfalls (bzw. noch mehr) informativ: was wird angezeigt, wenn du mit ⌘R gedrückt gehalten startest (loslassen, wenn die weissen Textzeilen auf schwarzem Hintergrund erscheinen)? Dann sehen wir vielleicht, an welcher Stelle das System beim Start hängen bleibt.
     
  12. Mimi88

    Mimi88 Erdapfel

    Dabei seit:
    13.06.18
    Beiträge:
    1
    Hallo,

    Ich heiße Michaela und ich habe den gleichen Blödsinn wie Dominik aufgeführt. Kann ich diesen Tipp mit dem Einrichtungsmodus noch befolgen oder hat sich evtl schon wieder etwas geändert, dass das doch nicht funktioniert.
    Da ich mich mit solchen Sachen wirklich gaaaaar nicht auskenne, habe ich angst noch mehr kaputt zu machen :/
    Bitte um eure Hilfe!
    Danke!