1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

2 Websites zu bewerten // Aloa

Dieses Thema im Forum "Web-Programmierung" wurde erstellt von @pollo, 02.08.08.

  1. @pollo

    @pollo Raisin Rouge

    Dabei seit:
    03.08.06
    Beiträge:
    1.171
    Wie vielleicht einige bereits gelesen haben, bin ich relativ frisch im HTML, CSS, PHP Bereich. Die Seiten sind eigentlich nur zu Testzwecken errichtet worden, nachdem ich mich vielleicht 2 Tage mit HTML und CSS und ca. 3 mit PHP auseinandergesetzt habe.

    Die zweite Seite funktioniert nicht so wirklich im IE. Ich vermute ja stark, dass der IE generell Probleme mit meinem CSS hat (vor allem mit dem Mouseover in der NAVI). Außerdem "befürchte" ich, dass der IE die .PNG Transparenz nicht erkennt. Auch aus Gründen des Volumens werde ich da wohl auf GIF wechseln müssen.

    Aber nur fleißig kritisieren, ich kann nur lernen... ^^;)

    http://coverflow.de/red/
    - Im Internen Bereich habe ich eine Upload Funktion und Felder zum ändern des Contents geschrieben.

    http://coverflow.de/frank/
    - Vor allem der IE macht Probleme mit meiner Navigation und den PNG's
    - im FF und im Safari wird das Kontakt Formular im Austausch Probleme mit der breite des letzten Feldes (Breite)

    lg ich freue mich auf jeden Post... (glaub ich zumindest) :innocent:
     
  2. moc2001

    moc2001 Boskop

    Dabei seit:
    27.03.07
    Beiträge:
    208
    Die Seiten sehen doch gut gemacht aus !!

    Finde nur das Layout sehr eng und die Schriften teilweise einen Tick zu groß (zweite Seite Fließtext).
     
  3. C.Schwab

    C.Schwab Finkenwerder Herbstprinz

    Dabei seit:
    24.06.07
    Beiträge:
    470
    Insgesamt 5 Tage? Never...

    sehen gut aus die Seiten, weiter so.
     
  4. mschoening

    mschoening Gelbe Schleswiger Reinette

    Dabei seit:
    21.02.07
    Beiträge:
    1.764
    Hi,
    als kleiner Tipp. Dir fehlen bei beiden Seiten ein DOCTYPE! Das solltest du noch nachholen.

    Edit: Hier mal ein kompletter Header wie er mit DOCTYPE und allem anderen aussehen sollte:

    Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    
    <html lang="en" xml:lang="en" xmlns="http://www.w3.org/1999/xhtml">
    <head>
    	<title>Der Titel</title>
    	
    	<meta content="text/html; charset=utf-8" http-equiv="content-type" />
    	<meta content="Die Geilste Firma, AG 2008" name="copyright" />
    	<meta content="Wir stellen Spielzeug fuer Erwachsene her." name="description" />
    	<meta content="spielzeug, erwachsene, ding, dong" name="keywords" />
    	<meta content="index, follow" name="robots" />
    	
    	<link href ="favicon.ico" rel="shortcut icon" />
    	
    	<link href="#" media="projection, screen" rel="stylesheet" type="text/css" />
    </head>
    
    <body>
    </body>
    </html>
    
    LG,
    Max
     
    @pollo gefällt das.
  5. @pollo

    @pollo Raisin Rouge

    Dabei seit:
    03.08.06
    Beiträge:
    1.171
    Zu eurem Feedback

    - Super klasse für die schnelle Antwort, ich fand die Schrift auch etwas zu dick, ich habe mal einen pt drunter genommen, das Layout ist bewusst eng, da ich einfach keinen Text zum füllen hatte und 5x Lorem fand ich auch net spannend. Naja ich solte zumindest eine 1024 breite nehmen. Aber Danke für die Tricks.

    Ich habe vorher mit WYSIWYG-Editoren gearbeitet, ich fand das als sehr praktisch, wenn man aus dem Grafischen Bereich kommt (hier ein von mir CD) braucht man sich nicht groß von Photoshop umstellen, aber auf mich wurde geistig immer eingeprügelt den Code selbst zu schreiben. (Ich konnte noch nicht einmal die Schriftgröße valide ändern =( - peinlich. (meine ersten Versuche liefen über <font size="-1"></font>.

    Super Sache, ich habe die Sache mit dem DOCTYPE auch auf meiner to-do-Liste stehen, im Moment wälze ich mich durch Modernes Webdesign von Manuela Hoffmann. Ich hab deinen Beispielcode einfach mal kopiert und auf einer meiner Seiten eingefügt. Der W3 Validator gibt mir einen Fehler in line 9 heraus.

    Code:
    <meta content="text/html; charset=utf-8" http-equiv="content-type" />
    Vielleicht habe ich einen Tippfehler drin oder das falsche charset, ich bin aber noch etwas uninformiert was diese Sachen angeht. Ende nächste Woche habe ich das Buch durch und ich hoffe dann bin ich schlauer (zumindest was Standards im HTML / CSS / XHTML angeht.)

    _____________________

    Vielleicht dank erstmal, für das Lob zwischen den Zeilen. Weiß jemand von euch Profis wo mein Fehler auf der zweiten Seite im IE liegt? Ich vermute ja einfach mal...
    1. Schlechter code
    2. PNG und keine GIfs benutzt

    Bis dahin Grüße ^^ Man schreibt sich

    /* Content Ende */ :innocent:
     
    zackwinter gefällt das.
  6. Peitzi

    Peitzi Blutapfel

    Dabei seit:
    07.08.07
    Beiträge:
    2.595
    Ich kann jedem Anfänger nur dieses Buch empfehlen!
     
  7. @pollo

    @pollo Raisin Rouge

    Dabei seit:
    03.08.06
    Beiträge:
    1.171
    Ich habe einmal kurz drüber geschaut und war schon von der Aufmachung / Fülle an Informationen und der Relation zu einer kostenlosen Ausgabe sehr beeindruckt, meine nächste Lektüre. ^^

    lg
     
  8. mschoening

    mschoening Gelbe Schleswiger Reinette

    Dabei seit:
    21.02.07
    Beiträge:
    1.764
    Hi,
    wenn du den Header so kopiert hast wie ich ihn dir geschickt habe, dann sollte da eigentlich nichts mit dem charset falsch sein. Zu Anfang würde ich zum lernen auch durchaus immer den Strict DOCTYPE wählen (der verzeiht viel weniger):

    Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    
    etwas weniger strict ist dann der Transitional DOCTYPE:

    Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    
    Das Buch von Manuela kann ich dir sehr empfehlen und du solltest es von Anfang bis Ende einmal durcharbeiten. Sehr nützlich ist es später auch sich eigene Templates anzufertigen (Manuela bespicht das auch kurz). Meiner Meinung nach sind ihre Templates aber viel zu ausgearbeitet. Versuche es mal dich an schlichtere Grundkonstrukte zu halten.

    Was du dir auch noch mal anschauen kannst ist das CSS reset von Eric Meyers (bin ich kein großer Fan von aber hat auch seine guten Seiten).

    Außer Manuela Hoffmans Bücher (inzwischen 2, aber wenn du das jetzige ließt, ist das ältere unbedeutend) kann ich dir eigentlich nur amerikanische Authoren empfehlen:


    Bulletproof Web-Design von Dan Cederholm @Simplebits

    Web Standards Solutions von Dan Cederholm @ Simplebits


    und dann vielleicht noch vom Erfinder der Web-Standards (quasi) :p:


    Designing With Web Standards von Jefferey Zeldman @ Zeldmann und @ Happy Cog


    Da hast du dann noch einiges zu lesen :innocent:! Viel Spaß!
     
  9. mschoening

    mschoening Gelbe Schleswiger Reinette

    Dabei seit:
    21.02.07
    Beiträge:
    1.764
    Hi,
    ich habe mir nochmal die zweite angeschaut (coverflow.de/frank) und ich finde dein Navigations-Konstrukt (nenne wir es mal so) ein wenig eigenartig. Eigentlich sollte das so aussehen:

    Code:
    <ul id="nav">
        <li id="haupt"><a href="index.html" title="">Hauptseite</a></li>
        
        <li id="gal"><a href="galerie.html" title="">Galerie</a></li>
        
        <li id="imp"><a href="impressum.php" title="">Impressum</a></li>
    </ul>
    
    In deinem CSS Code setzt du vorraus das der IE ein :hover erkennt um das Hintergrundbild zu ändern. :hover wird vom IE nur bei Links (sprich <a />) erkannt. Das Browserübergreifend umzusetzen ist nur mit JavaScript möglich.

    Der Rest der Fehler bezieht sich nur auf die PNGs. Dazu gibt es einen PNG Fix. Gründlich durchlesen!

    EDIT: Du musst natürlich deine Dateien auch als utf-8 abspeichern! Was für einen Editor verwendest du?

    Mfg,
    Max
     
  10. kauan

    kauan Stina Lohmann

    Dabei seit:
    31.12.05
    Beiträge:
    1.043
    ie7-js macht, dass es auch mit Internet Explorer funktioniert.
     
  11. @pollo

    @pollo Raisin Rouge

    Dabei seit:
    03.08.06
    Beiträge:
    1.171
    Im Moment verwende ich Coda in der Trial Version File Encoding steht auf Automatic.... ich hoffe das ist Ok.
     
  12. kauan

    kauan Stina Lohmann

    Dabei seit:
    31.12.05
    Beiträge:
    1.043
    Ist es nicht, wenn du im Meta-Tag utf-8 angibst, musst du die Dateien auch explizit in utf-8 speichern.
     
  13. mschoening

    mschoening Gelbe Schleswiger Reinette

    Dabei seit:
    21.02.07
    Beiträge:
    1.764
    Das Browserübergreifend umzusetzen ist nur mit JavaScript möglich.

    Stell bei Coda mal auf:
    - Default encoding utf-8
    - Default line endings: unix

    LG,
    Max
     
  14. @pollo

    @pollo Raisin Rouge

    Dabei seit:
    03.08.06
    Beiträge:
    1.171
    Mit Js bin ich bis jetzt nur in Verbindung über "Lightbox2" gekommen, wenn ich jetzt die Transparenz und (viel wichtiger) den Hover benutzen möchte, muss ich den Code in meinen Head kopieren und [...]?

    Der IE7 Code
    Code:
    <!--[if lt IE 7]>
    <script src="http://ie7-js.googlecode.com/svn/version/2.0(beta3)/IE7.js" type="text/javascript"></script>
    <![endif]-->
    Ohje ich sollte das selbst auf jeden Fall nacharbeiten, aber wie wäre in dem Fall die Lösung?

    btw. die Dateien werden gerade ins utf8 Format gewandelt.
     
  15. kauan

    kauan Stina Lohmann

    Dabei seit:
    31.12.05
    Beiträge:
    1.043
    Das Vorgehen wäre ein anderes, man verwendet selbst CSS, bietet aber dann IE-Usern eine Alternative an, damit CSS dort auch korrekt funktioniert. Wie ich schonmal irgendwo geschrieben habe, wer klug genug ist, JS zu deaktivieren, ist auch klug genug, keinen Internet Explorer zu verwenden.
     
  16. @pollo

    @pollo Raisin Rouge

    Dabei seit:
    03.08.06
    Beiträge:
    1.171
    Alles klar ich habe meine Index umgestellt auf

    - utf-8
    - versucht mit js das Problem zu umgehen

    Inzwischen zeigt der mit transparente .PNG's wunderbar an. Auch die Seite ist im Center. Nur irgendwie verschiebt er die Nav leicht.

    edit: so sieht die Seite im IE7 aus (nur damit ihr eure X11 APPS nicht anschmeißen müsst)

    [​IMG]
     
  17. mschoening

    mschoening Gelbe Schleswiger Reinette

    Dabei seit:
    21.02.07
    Beiträge:
    1.764
    Du hast doch immer noch die leeren <ul /> drinn...
     
  18. @pollo

    @pollo Raisin Rouge

    Dabei seit:
    03.08.06
    Beiträge:
    1.171
    Weil es die Seite leicht verschiebt siehe Hier
     
  19. mschoening

    mschoening Gelbe Schleswiger Reinette

    Dabei seit:
    21.02.07
    Beiträge:
    1.764
    Ja natürlich. Du musst den CSS Code ja auch anpassen.
     
  20. @pollo

    @pollo Raisin Rouge

    Dabei seit:
    03.08.06
    Beiträge:
    1.171
    Ich werde mich heute Abend mal dran setzen. Vielleicht lösen sich dann auch die IE7 Probleme in Luft auf. Die <ul>'s sind auch nur so blöd, da ich mir das aus irgend einem Tutorial zum Thema SubNavi mit Bilder herausgesucht habe. Leider hat man in diesem Tutorial nicht erklärt wofür diese Ul und Menus da sind. Ich hab dann einfach so lange herumgebastelt bis mir die Optik und Logik gesagt haben was wo stehen muss. Offenbar war das nur ein Optischer Erfolg.

    Trotzdem danke ich werde mal schaun ob ich da jetzt irgendwie Hover Bilder auf die neuen Links bekomme.
     

Diese Seite empfehlen