1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Zugriffsrechte angepasst!?

Dieses Thema im Forum "macOS & OS X" wurde erstellt von chris_9_11, 14.05.09.

  1. chris_9_11

    chris_9_11 Fießers Erstling

    Dabei seit:
    01.09.05
    Beiträge:
    127
    Ich kann nicht mehr auf meine zweite interner und meine externe Festplatte zugreifen. Es ist ein Schloss dran und bei den Zugriffsrechten wird immer nur "Angepasst" angezeigt. Das Festplattentool gibt mir leider keine Möglichkeit die Zugriffsrechte zu reparieren.

    Nachdem ich meinen Benutzeraccount vom MacBook Pro auf den G5 (beide laufen unter den aktuellsten Leopardversionen) übertragen habe, hatte ich immer wieder Probleme mit den Zugriffsrechten. Deshalb habe ich kurzerhand bei alle Festplatten, internen wie externen, die Zugriffrechte geändert und die Änderungen auf alle Unterordner angewendet.

    Wie ihr euch denken könnt, war das keine so gute Idee. OS X ließ sich nicht mehr starten und nach mehreren Versuchen das alte System zu retten, musste ich OS X neu installieren. So weit kein größeres Problem. Das System startet wieder ohne Probleme und es sind auch noch alle Benutzer vorhanden.

    Aber wie löse ich oben genanntes Problem? Ich habe schon alle mögliche Foren durchsucht. Teilweise wird das Problem geschildert, aber keine Lösung geliefert.
     
  2. gbyte

    gbyte Gelbe Schleswiger Reinette

    Dabei seit:
    07.04.07
    Beiträge:
    1.750
    chris_9_11 gefällt das.
  3. salome

    salome Golden Noble

    Dabei seit:
    20.08.06
    Beiträge:
    23.757
    Ich habe mir mal für solche Fälle einen (anderen) Terminalbefehl aufgeschrieben:

    Code:
    sudo chflags nouchg 
    Der Leerraum am Ende ist wichtig.
    Dann ziehst du die Platte ins Terminalfenster und erst jetzt auf enter drücken.
    Dein Passwort wird verlangt (aber vermutlich beim Eintippen nicht angezeigt)
    Jetzt sollte das Schloss offen / weg sein.

    "chflags nouchg FILE" löscht das "nicht-ändern-flag" auf Dateien oder Ordnern.
    Aber verifiziert noch ein Frühaufsteher diese Zeile.
    Oder du vertraust diesem wiki
    salome
     
    chris_9_11 gefällt das.
  4. chris_9_11

    chris_9_11 Fießers Erstling

    Dabei seit:
    01.09.05
    Beiträge:
    127
    Super! Vielen Dank!

    So hat es funktioniert. Ich habe wie im Wiki beschrieben

    Code:
    sudo chflags -R nouchg 
    (das Leerzeichen am Ende ist wichtig) im Terminal eingegeben, die Festplatte reingezogen und mich dann ab- und wieder angemeldet. Danach konnte ich wieder manuell die Rechte vergeben.
     
  5. chris_9_11

    chris_9_11 Fießers Erstling

    Dabei seit:
    01.09.05
    Beiträge:
    127
    Dank Salomes Beitrag konnte ich mein Problem lösen. Meine genaue Vorgehensweise habe ich in einem anderen Thread ausgeführt, da sich dort auch andere mit dem Problem rumschlagen. Danke für eure Hilfe!
     

Diese Seite empfehlen