1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

You don't have permission to access

Dieses Thema im Forum "macOS & OS X" wurde erstellt von mewX, 28.01.09.

  1. mewX

    mewX Wohlschmecker aus Vierlanden

    Dabei seit:
    26.12.06
    Beiträge:
    241
    Hallo! Seit ein paar Tagen kann ich nicht mehr auf meinen lokalen Apache zugreifen. http://localhost/~Paul/ gibt mir einen 403 Forbidden-Fehler aus. Hab bereits verschiedene Dateien probiert und die Rechte überprüft, eigentlich müsste alles ok sein. Hab auch mal das Rechte-Reparieren-Tool vom Disk Utility laufen lassen und einen Neustart versucht, bringt nix. Ebenso in den Sharing-Einstellungen herumzuklicken hat keine Wirkung gezeigt. Hat vielleicht jemand von euch eine Idee? Was könnte da falsch laufen?
    Auch die /private/etc/Apache2/users/Paul.conf sieht aus wie eh und je.

    gruß

    Anhang: error.log
    Code:
    [Wed Jan 28 21:12:52 2009] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
    httpd: Could not reliably determine the server's fully qualified domain name, using 192.168.2.101 for ServerName
    [Wed Jan 28 21:12:52 2009] [notice] Digest: generating secret for digest authentication ...
    [Wed Jan 28 21:12:52 2009] [notice] Digest: done
    [Wed Jan 28 21:12:52 2009] [notice] Apache/2.2.9 (Unix) mod_ssl/2.2.9 OpenSSL/0.9.7l DAV/2 PHP/5.2.6 configured -- resuming normal operations
    [Wed Jan 28 21:13:05 2009] [error] [client ::1] (13)Permission denied: access to /~Paul/ denied
    
    Nachtrag: Was sagt mir das?
    Code:
    Pauls-Macbook:~ Paul$ /usr/sbin/httpd
    httpd: Could not reliably determine the server's fully qualified domain name, using 192.168.2.101 for ServerName
    (13)Permission denied: make_sock: could not bind to address [::]:80
    (13)Permission denied: make_sock: could not bind to address 0.0.0.0:80
    no listening sockets available, shutting down
    
    /edit: ok dafür brauchte ich ein sudo... bringt aber auch nix
     
    #1 mewX, 28.01.09
    Zuletzt bearbeitet: 28.01.09
  2. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Das zweite sagt, dass der Apache nicht starten kann, weil die Ports schon belegt sind. Scheinbar laufen bei dir verschiedene Installationen vom Apache. Wie versucht du den Webserver denn zu starten?
    Schau mal im Aktivitätsmonitor nach, ob vielleicht schon ein Webserver läuft.
    Wie startest du den Webserver denn?
     
  3. mewX

    mewX Wohlschmecker aus Vierlanden

    Dabei seit:
    26.12.06
    Beiträge:
    241
    Eiegntlich über die Sharing-Einstellungen. hatte gerade zum testen es übers Terminal gemacht.
    Mein Aktivitäts-Monitor zeigt mir 5 laufende Instanzen von httpd an... Wenn ich die beende, starten sie sich nach 10 Sekudnen automatisch neu ?!

    // http://ablage.ptec-media.de/uploads/Bild 4_910.png
     
  4. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Das ist normal. Es laufen immer mehrere Instanzen. Du kannst einmal den Webserver über Sharing beenden und schauen ob dann noch Instanzen laufen.
    Kannst du denn dir die Startseite anzeigen lassen wenn der Webserver läuft?
    Wie sind die Rechte vom Sites Verzeichnis? Einmal ein ls -a im Terminal eingeben wenn du das direkt gestartet hast.
     
  5. mewX

    mewX Wohlschmecker aus Vierlanden

    Dabei seit:
    26.12.06
    Beiträge:
    241
    Wenn ich das Sharing ausmache gehen die Prozesse weg.
    Die Startseite "Es klappt! Der Apache-Webserver..." funktioniert.
    Der -a Parameter macht garnix (?), sondern zeigt nur ganz normal die Liste der Dateien/Ordner an...

    Die Rechte für das SItes-Verzeichnis:
    [​IMG]
    (wobei ich den mittleren Eintrag auch nicht löschen kann (ja, ich habe auf das schloss geklickt vorher^^))
     
  6. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Der -a zeigt dir die Rechte mit an. Die Ausgabe sollte so aussehen.
    drwxr-xr-x+ 14 USER GRUPPE 476 20 Okt 03:04 Sites
    Versuche mal direkt eine Datei aufzurufen. Nicht das es verboten ist, das Verzeichnis Index anzuzeigen.
     
  7. mewX

    mewX Wohlschmecker aus Vierlanden

    Dabei seit:
    26.12.06
    Beiträge:
    241
    You don't have permission to access /~Paul/index.php on this server.

    -a gibt mir komischerweise nicht diese Ausgabe. Mein FTP-Programm sagt 775 (rwxrwxr-x). wenn ich andere rechte-einstellungen auf alle unterobjekte übertragen möchte, bricht das programm ab... Irgendwas ist da echt ganz schief... ;)
     
  8. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Ahhh, fu... mein Fehler. Da fehlt ein l. Also ls -la.
    Du kannst einmal versuchen, die Rechte von Hand für das Verzeichnis zurückzusetzen.
    Das Terminal starten:
    Code:
    chmod -R 755 Sites
    
    Danach kannst du mit ls -la Sites das noch einmal anzeigen lassen.
     
  9. mewX

    mewX Wohlschmecker aus Vierlanden

    Dabei seit:
    26.12.06
    Beiträge:
    241
    Was bedeutet das @?
    Code:
    drwxr-xr-x@ 121 Paul  Paul     4114 28 Jan 21:12 Sites
    
    /edit
    ah ok, bei ls -la@ kommt dann
    Code:
    drwxr-xr-x@ 121 Paul  Paul     4114 28 Jan 21:12 Sites
        com.apple.FinderInfo        32 
    
     
  10. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Das @ steht für erweiterte Attribute.
    Hat das ändern der Rechte was gebracht? Wenn nicht muss in der Config ein Fehler sein. Ich habe bei mir auch die 755 Rechte und es wird alles ohne Probleme angezeigt.
     
  11. mewX

    mewX Wohlschmecker aus Vierlanden

    Dabei seit:
    26.12.06
    Beiträge:
    241
    Nein funktioniert immer noch nicht.
    Was bedeutet den das erweiterete Attribut mit "com.apple.FidnerInfo"?
     
  12. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Lasse dir mal bitte die erweiterten Attribute anzeigen:
    xattr Sites/
     
  13. mewX

    mewX Wohlschmecker aus Vierlanden

    Dabei seit:
    26.12.06
    Beiträge:
    241
    Pauls-Macbook:~ Paul$ xattr Sites/
    com.apple.FinderInfo

    Kann ich dieses Attribut irgendwie löschen?
     
  14. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Das kannst du. Schaue einfach mal bei xattr -h nach. Warum das nicht geht ist komisch.
    haben die Dateien im Verzeichnis auch 755 Rechte? (also rwxr-xr-x).
     
  15. mewX

    mewX Wohlschmecker aus Vierlanden

    Dabei seit:
    26.12.06
    Beiträge:
    241
    -rwxr-xr-x 1 Paul Paul 1238 6 Sep 2007 index.html

    drwxr-xr-x+ 121 Paul Paul 4114 28 Jan 21:12 Sites

    Was heißt das +? ;) Und das d?
     
  16. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    d steht für Verzeichnis :)
     
  17. mewX

    mewX Wohlschmecker aus Vierlanden

    Dabei seit:
    26.12.06
    Beiträge:
    241
    Also hab mal testweise einen neuen Benutzer "test" erstellt, da ist das Siets Verezichnis auf
    drwxr-xr-x 5 test staff 170 29 Jan 21:15 Sites
    (ohne + und mit "staff")
     
  18. mewX

    mewX Wohlschmecker aus Vierlanden

    Dabei seit:
    26.12.06
    Beiträge:
    241
    Also das war irgendwas mit Einträgen in der Access Controll List, die ich nun entfernt habe. Gebracht hats aber nix.
     
  19. mewX

    mewX Wohlschmecker aus Vierlanden

    Dabei seit:
    26.12.06
    Beiträge:
    241
    HAB'S GESCHAFFT!
    Der Fehler war, dass das ~-Verezeichnis nicht "x" für Apache war.. Hab die Rechte auf 731 gesetzt, macht das Sinn? Das Verzeichnis sollte ja nicht lesbar sein für andere.
    Dennoch vielen Dank für die Hilfe!
     
  20. MacMark

    MacMark Biesterfelder Renette

    Dabei seit:
    01.01.05
    Beiträge:
    4.709

Diese Seite empfehlen