• Es gibt nach dem Softwareupdate eine Reihe von Änderungen und Neuerungen in unserem Forum. Genaueres dazu findet Ihr in dieser Ankündigung. Hinweise, Kritik, Anregungen, Lob und Tadel bitte hier diskutieren.

xdebug in High Sierra benutzen

mondy

Bismarckapfel
Mitglied seit
06.12.08
Beiträge
75
Hallo Zusammen,

vor Kurzem habe ich mein MacBook neu installiert.
Das Betriebssystem ist nun High Sierra (10.13)

Apple installiert einen Apache Server und PHP 7.1 mit.

Aber wie aktiviert man dort xdebug?

Ich habe in /etc eine php.ini erstellt, die auch geladen wird.
In der /etc/php.ini habe ich die folgenden Einstellungen hinterlegt:

[xdebug]
zend_extension="/usr/lib/php/extensions/no-debug-non-zts-20160303/xdebug.so"
xdebug.remote_enable=true
xdebug.remote_host=localhost
xdebug.remote_port=9000
xdebug.remote_handler=dbgp
xdebug.var_display_max_children=-1
xdebug.var_display_max_data=-1
xdebug.var_display_max_depth=-1

Nach einem Neustart wird aber dennoch kein xdebug geladen, obwohl die Datei im genannten Verzeichnis vorhanden ist.
Testweise habe ich in der gleichen php.ini memory_limit geändert, um zu sehen, ob sich dies auswirkt. Das hat geklappt.

Wie kann man das beheben?

Danke und Gruß,
Money
 

hillepille

Rheinischer Bohnapfel
Mitglied seit
19.07.09
Beiträge
2.427
Hi, bei mir klappt das mit den Einstellungen hier, einziger Unterschied ist in meinen Augen die 1 bei remote_enable. DIe restlichen Einstellungen (xdebug.var_display_...) nutze ich nicht. Vielleicht versuchst du es erst mal nur mit den 4 Einstellungen wie hier bei mir und schaust dann weiter.

zend_extension="/usr/lib/php/extensions/no-debug-non-zts-20160303/xdebug.so"
xdebug.remote_enable=1
xdebug.remote_host=localhost
xdebug.remote_port=9000
xdebug.remote_autostart=1