1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

XCode : scm , svn Frage

Dieses Thema im Forum "OS X-Developer" wurde erstellt von blutaermer, 12.06.06.

  1. blutaermer

    blutaermer Ingrid Marie

    Dabei seit:
    31.12.03
    Beiträge:
    273
    Hallo,

    egal wie oft ich auschecke, ich bekomme immer folgende Fehlermeldung (ob bei einem commit versuch via SCM oder direkt uber die Kommandozeile mit svn):

    svn: Working copy '/Users/*****/work/code/scheduling/libSynCore/build/libSynCore.build/libSynCore.pbxindex/strings.pbxstrings' is missing or not locked

    Sollte das kein bekannter Fehler sein: kann mir jemand vielleicht sagen, wie ich (meinetwegen auch auf die harte Tour) das build verzeichnis rausschmeisse? Ich mein das muss ja nicht wirklich mit in der versionskontrolle haengen.

    Mir ist es dabei egal, ob ich das Verzeichnis aus dem repository loesche oder in meinem Arbeitsverzeichnis.
     
  2. blutaermer

    blutaermer Ingrid Marie

    Dabei seit:
    31.12.03
    Beiträge:
    273
    so jetzt gehts. ich habe jetzt ein repository ohne build verzeichnis erstellt. bleibt nur noch die frage warums vorher nicht ging (trotz cleanup versuch etc.)
     
  3. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Stelle im Xcode besser generell ein, daß er NICHT im Projekt Ordner builden soll! Dann ersparst Du Dir solche Sachen und Dein SVN Server Admin wird es Dir danken.
    Gruß Pepi
     
  4. blutaermer

    blutaermer Ingrid Marie

    Dabei seit:
    31.12.03
    Beiträge:
    273
    ich bin der svn server admin ;) aber wie gesagt, jetzt wo das build verzeichnis nicht mehr im repository ist geht es ja. deinen tipp werde ich mir aber merken. danke!

    ich hab mal noch eine andere frage:
    nachdem das hier auf arbeit ja geklappt hat, habe ich gestern abend das repository zu hause ausgecheckt(ueber ssh / dsl anbindung), wollte dann in XCode weiterarbeiten - das ging aber nicht. dauernd svn warnmeldungen , dann habe ich SCM deaktiviert. naja ich denke mal es liegt daran, dass ich auf arbeit die schluesseluebergabe fuer ssh automatisiert habe zu hause nicht. ich weiss es aber nicht wirklich.
    hat jemand eine idee, wie man das handhaben kann?
     

Diese Seite empfehlen